Missing package


Steve N4IRS
 

The configuration info in that document can still be use. The better you actually understand what you are doing, the better you can adapt to updates.
The process to build a AllStar <-> digital bridge has become somewhat easier:

From a fresh install of a Debian based OS running as root (sudo -s)

apt update
apt upgrade -y
# if anything was installed then reboot
wget http://dvswitch.org/buster
chmod +x buster
./buster
# When finished:
apt install dvswitch-server
apt install allstar

Configure your AllStar node
Configure DVSwitch Server

Test your bridge.



On 4/16/22 19:08, Kevin Halton wrote:

Steve,

I do not see those directions in the document I have and used in numerous times in the past, maybe outdated at this point?


Kevin Halton
 

Steve,

I do not see those directions in the document I have and used in numerous times in the past, maybe outdated at this point?


Steve N4IRS
 

Kevin,
You partially installed the repositories for AllStarLink, not dvswitch.

For DVSwitch Server:
wget http://dvswitch.org/buster
chmod +x buster
./buster

When complete:
apt install dvswitch-server

Steve N4IRS

On 4/16/22 18:40, Kevin Halton wrote:

Running on a 25gb NVMe VM, 1 cpu, 1gb memory, and 2tb bandwidth in the cloud with Debian9

I ran  apt-get update prior to install 

just tried again and I get this error, not 100% it was not there prior and the old eyes failed me?

/etc/asterisk# apt-get update
Hit:1 http://security.debian.org/debian-security buster/updates InRelease
Hit:2 http://deb.debian.org/debian buster InRelease
Hit:3 http://deb.debian.org/debian buster-updates InRelease
Get:4 http://apt.allstarlink.org/repos/asl_builds buster InRelease [7,392 B]
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6A72C389B517460F
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://apt.allstarlink.org/repos/asl_builds buster InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6A72C389B517460F
W: Failed to fetch http://apt.allstarlink.org/repos/asl_builds/dists/buster/InRelease  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6A72C389B517460F
W: Some index files failed to download. They have been ignored, or old ones used instead.




Kevin Halton
 

Running on a 25gb NVMe VM, 1 cpu, 1gb memory, and 2tb bandwidth in the cloud with Debian9

I ran  apt-get update prior to install 

just tried again and I get this error, not 100% it was not there prior and the old eyes failed me?

/etc/asterisk# apt-get update
Hit:1 http://security.debian.org/debian-security buster/updates InRelease
Hit:2 http://deb.debian.org/debian buster InRelease
Hit:3 http://deb.debian.org/debian buster-updates InRelease
Get:4 http://apt.allstarlink.org/repos/asl_builds buster InRelease [7,392 B]
Err:4 http://apt.allstarlink.org/repos/asl_builds buster InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6A72C389B517460F
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://apt.allstarlink.org/repos/asl_builds buster InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6A72C389B517460F
W: Failed to fetch http://apt.allstarlink.org/repos/asl_builds/dists/buster/InRelease  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6A72C389B517460F
W: Some index files failed to download. They have been ignored, or old ones used instead.



Steve N4IRS
 

What hardware are you running?
What OS and version?

Please show what did before apt install.


Steve N4IRS

On 4/16/22 18:23, Kevin Halton wrote:

I am attempting to start up an ASL-DMR bridge to link to a private dmr talkgroup. I am stuck when I run apt-get install dvswitch -y, I get this error,;     
apt-get install dvswitch -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package dvswitch

I went back and rechecked the step by step directions but end up with the same error. 

Any suggestions?


Kevin Halton
 

I am attempting to start up an ASL-DMR bridge to link to a private dmr talkgroup. I am stuck when I run apt-get install dvswitch -y, I get this error,;     
apt-get install dvswitch -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package dvswitch

I went back and rechecked the step by step directions but end up with the same error. 

Any suggestions?