Date   

Re: IPSC_Bridge - hblink OB error

area51now@...
 

Cort, you where right on the money on your password call it's working good now........thank you very much

Bob


Re: hbmonitor3 available

Steve KC1AWV
 

To run it behind a secure page, you'll want to look at setting up a reverse proxy. I haven't tested this myself, so your mileage may vary.


On Wed, Aug 28, 2019, 6:19 PM KD2QIP Steve <kd2qip@...> wrote:
Just finished getting all the details finished and wanted to say a big thankyou for the updated code. I have it running on a micro server running Ubuntu supporting our club HBLink bridge. Now we can monitor what's happening and help members get connected. 
For me everything worked fine, had to manually pip3 the extra files from requirements.txt, but after that went like a dream.
I am looking at making the webpage link https because I would like to embed the page in an I-frame on the club website, let me know if this is a bad idea.
Again, big thank you.


Re: hbmonitor3 available

N2DH Steve
 

Just finished getting all the details finished and wanted to say a big thankyou for the updated code. I have it running on a micro server running Ubuntu supporting our club HBLink bridge. Now we can monitor what's happening and help members get connected. 
For me everything worked fine, had to manually pip3 the extra files from requirements.txt, but after that went like a dream.
I am looking at making the webpage link https because I would like to embed the page in an I-frame on the club website, let me know if this is a bad idea.
Again, big thank you.


Re: IPSC_Bridge - hblink OB error

area51now@...
 

Cort your right i just copied and pasted the passphrase, I would be amazing if just that simple!  I will report back

Thank you very much

Bob


Re: IPSC_Bridge - hblink OB error

Cort N0MJS <n0mjs@...>
 

Yes, a communication problem between you and BM regarding the passphrase, or you’re copying and pasting it and picking up non-printing characters – which does happen.

I recommend you completely delete the passphrase line in hblink.cfg (or whatever your file is named) and re-type it. Don’t paste it, type the whole line from scratch first deleting it. The whole line, including the space for it. If that doesn’t work, you need to ensure you and BM are using the same exact text.

HMAC is the message authentication hash used in messages with OBP. The hash isn’t correct on incoming packets and they’re being discarded.

On Aug 28, 2019, at 11:42 AM, area51now via Groups.Io <area51now@...> wrote:

I have the IPSC_Bridge<> hblink<>HBlink3 working great so I decided to add openbridge to BM , I already contacted them for the set. So far, I have been unable to get OB to pass BM traffic, when I watch the log I can see the below Error code continually scroll until the assigned TG stops being used. I next decided to try as a test to use OB to link 2 of my servers to see if I can get traffic between them and it worked fine, any idea what’s the cause of the error code is about? At this point I am at a loss.

INFO 2019-08-27 18:54:43,114 (OBP-1) OpenBridge HMAC failed, packet discarded - OPCODE: b'DMRD' DATA: b'DMRD#0\x11x\x00\x0c"\x00\x00\x0c\x1f\x02\xb8\xa14S\x04\xde\xe9\xef\x048\xa7\x9b\x9b\xe6\xc3\xc6\x07!p\xa9T\x11\x87Hl2\x85\xd7\xb0\x82\xa7u\x944\x8bNB' HMAC LENGTH: 20 HMAC: b'\x02\xea\x0eK/\x97\xfd$\x80`\xce\xba\xec\xc9\xabg\x13\x03\xfe\x98'
 
Thank you

Bob

Cort Buffington
785-865-7206


IPSC_Bridge - hblink OB error

area51now@...
 

I have the IPSC_Bridge<> hblink<>HBlink3 working great so I decided to add openbridge to BM , I already contacted them for the set. So far, I have been unable to get OB to pass BM traffic, when I watch the log I can see the below Error code continually scroll until the assigned TG stops being used. I next decided to try as a test to use OB to link 2 of my servers to see if I can get traffic between them and it worked fine, any idea what’s the cause of the error code is about? At this point I am at a loss.

INFO 2019-08-27 18:54:43,114 (OBP-1) OpenBridge HMAC failed, packet discarded - OPCODE: b'DMRD' DATA: b'DMRD#0\x11x\x00\x0c"\x00\x00\x0c\x1f\x02\xb8\xa14S\x04\xde\xe9\xef\x048\xa7\x9b\x9b\xe6\xc3\xc6\x07!p\xa9T\x11\x87Hl2\x85\xd7\xb0\x82\xa7u\x944\x8bNB' HMAC LENGTH: 20 HMAC: b'\x02\xea\x0eK/\x97\xfd$\x80`\xce\xba\xec\xc9\xabg\x13\x03\xfe\x98'

 
Thank you

Bob


Re: Error- Running HBlink3

va3czk@...
 

Getting same error from BM connection every minute

ERROR 2019-08-27 08:57:35,608 (BM3021) Received an invalid command in packet: b'52505453424b4e120577b0'

Here is my BM3021 parameters  

[BM3021]
MODE: PEER
ENABLED: True
LOOSE: True
EXPORT_AMBE: False
IP:
PORT: 54001
MASTER_IP: 158.69.203.89
MASTER_PORT: 62031
PASSPHRASE: passw0rd
CALLSIGN: VA3CZK
RADIO_ID: 3023......
RX_FREQ: 449000000
TX_FREQ: 444000000
TX_POWER: 25
COLORCODE: 1
SLOTS: 3
LATITUDE: 38.0000
LONGITUDE: -095.0000
HEIGHT: 75
LOCATION: Anywhere, USA
DESCRIPTION: This is a cool repeater
URL: www.w1abc.org
SOFTWARE_ID: 20170620
PACKAGE_ID: MMDVM_HBlink
GROUP_HANGTIME: 5
OPTIONS:
USE_ACL: True
SUB_ACL: DENY:1
TGID_TS1_ACL: PERMIT:ALL
TGID_TS2_ACL: PERMIT:ALL
 
 


Re: BM TG not opening on startup

Corey Dean N3FE <n3fe@...>
 

If you are using two timeslots and connecting as a client, you are only going to get each one for 15 minutes unless you make them static in the bm portal.

That is why openbridge is the perfered method of connecting so that you can do what you want with them.

BM now also doesn't require a static ip address.  THey can now ise a FQDN for connections.

If you want a Open Bridge connection you will need to email support@...

Corey  N3FE


Virus-free. www.avast.com


On Sun, Aug 25, 2019 at 2:53 PM Kevin Halton <KA1MXL@...> wrote:

Corey,

 

Connecting as a client

 

From: HBlink@DVSwitch.groups.io [mailto:HBlink@DVSwitch.groups.io] On Behalf Of Corey Dean N3FE
Sent: Sunday, August 25, 2019 1:33 PM
To: HBlink@dvswitch.groups.io
Subject: Re: [HBlink] BM TG not opening on startup

 

How are you connecting as a client or using openbridge? 

 

Corey  N3FE

 

Virus-free. www.avast.com

 

On Sun, Aug 25, 2019 at 1:13 PM Kevin Halton <KA1MXL@...> wrote:

Michael,

If I wanted to say add 10 Talkgroups would I add all of them to the options line? Or leave it blank and just key up tg to activate?


Re: (2) moto turbo repeaters via IPSC_Bridge

area51now@...
 
Edited

I was successful getting (2) mototrbo repeaters talking to each other via IPSC_Bridge  running 2 instances of dmrlink and hblink below is what I did . Just out of curiosity If I wanted to add a third or forth repeater would it require additional instances dmrlink and hblink running?

Moto rpt 1 -<->-- IPSC_Bridge<->hblink
                                                              <->HBlink-3
Moto rpt 2- <->-- IPSC_Bridge<->hblink

Thanks

Bob
KB6LED


Re: BM TG not opening on startup

Kevin Halton
 

Full duplex board 


On Aug 25, 2019, at 3:15 PM, Corey Dean N3FE <n3fe@...> wrote:

Single slot as a hotspot or full duplex like a repeater?

On Sun, Aug 25, 2019 at 2:53 PM Kevin Halton <KA1MXL@...> wrote:

Corey,

 

Connecting as a client

 

From: HBlink@DVSwitch.groups.io [mailto:HBlink@DVSwitch.groups.io] On Behalf Of Corey Dean N3FE
Sent: Sunday, August 25, 2019 1:33 PM
To: HBlink@dvswitch.groups.io
Subject: Re: [HBlink] BM TG not opening on startup

 

How are you connecting as a client or using openbridge? 

 

Corey  N3FE

 

Virus-free. www.avast.com

 

On Sun, Aug 25, 2019 at 1:13 PM Kevin Halton <KA1MXL@...> wrote:

Michael,

If I wanted to say add 10 Talkgroups would I add all of them to the options line? Or leave it blank and just key up tg to activate?


Re: BM TG not opening on startup

Corey Dean N3FE <n3fe@...>
 

Single slot as a hotspot or full duplex like a repeater?

On Sun, Aug 25, 2019 at 2:53 PM Kevin Halton <KA1MXL@...> wrote:

Corey,

 

Connecting as a client

 

From: HBlink@DVSwitch.groups.io [mailto:HBlink@DVSwitch.groups.io] On Behalf Of Corey Dean N3FE
Sent: Sunday, August 25, 2019 1:33 PM
To: HBlink@dvswitch.groups.io
Subject: Re: [HBlink] BM TG not opening on startup

 

How are you connecting as a client or using openbridge? 

 

Corey  N3FE

 

Virus-free. www.avast.com

 

On Sun, Aug 25, 2019 at 1:13 PM Kevin Halton <KA1MXL@...> wrote:

Michael,

If I wanted to say add 10 Talkgroups would I add all of them to the options line? Or leave it blank and just key up tg to activate?


Re: BM TG not opening on startup

Kevin Halton
 

Corey,

 

Connecting as a client

 

From: HBlink@DVSwitch.groups.io [mailto:HBlink@DVSwitch.groups.io] On Behalf Of Corey Dean N3FE
Sent: Sunday, August 25, 2019 1:33 PM
To: HBlink@dvswitch.groups.io
Subject: Re: [HBlink] BM TG not opening on startup

 

How are you connecting as a client or using openbridge? 

 

Corey  N3FE

 

Virus-free. www.avast.com

 

On Sun, Aug 25, 2019 at 1:13 PM Kevin Halton <KA1MXL@...> wrote:

Michael,

If I wanted to say add 10 Talkgroups would I add all of them to the options line? Or leave it blank and just key up tg to activate?


Re: BM TG not opening on startup

Corey Dean N3FE <n3fe@...>
 

How are you connecting as a client or using openbridge? 

Corey  N3FE

Virus-free. www.avast.com


On Sun, Aug 25, 2019 at 1:13 PM Kevin Halton <KA1MXL@...> wrote:
Michael,

If I wanted to say add 10 Talkgroups would I add all of them to the options line? Or leave it blank and just key up tg to activate?



Re: BM TG not opening on startup

Kevin Halton
 

Michael,

If I wanted to say add 10 Talkgroups would I add all of them to the options line? Or leave it blank and just key up tg to activate?



Re: Stuck with setting timer

Cort N0MJS <n0mjs@...>
 

This has been discussed on this list twice in as many weeks. The network side should be on all of the time. ‘ACTIVE': True, ‘TO_TYPE': NONE, ‘ON': [], ‘OFF': [], ‘RESET': []

This isn’t going to fix your immediate issue, but this will be the next problem you have.


The bridge configuration is correct for what you want to do. ‘ACTIVE’: False does disable on startup. The entire configuration file, the hblink.cfg, your MMDVM.INI and the log file from bridge.py in debug mode for the first 30 seconds after you start it up would be the minimum I need to dig any deeper for you.



On Aug 23, 2019, at 7:37 PM, Kevin Halton <KA1MXL@...> wrote:

Hmmm, Thought I tried that and it did not work. I have tried several different configurations and talkgroups still pass traffic thru hotspot. I have even tried this and traffic still coming thru without keying up. I have tried restarting 
Bridge.py and rebooting with negative results.
 
BM31466 is HBlink server
MASTERBM31466 is connection to BM.
 
And yes I have 31466 set as static on my selfcare page.
 
],
         'BM31466': [
            {'SYSTEM': 'BM31466', 'TS': 2, 'TGID': 31466, 'ACTIVE': False, 'TIMEOUT': 2, 'TO_TYPE': ' ON', 'ON': [31466,], 'OFF': [4000], 'RESET': []},
            {'SYSTEM': 'MASTER31466', 'TS': 2, 'TGID': 31466, 'ACTIVE': False, 'TIMEOUT': 2, 'TO_TYPE': ' ON','ON': [31466,], 'OFF': [4], 'RESET': []},
 
Any more suggestions greatly appreciated.
 
 
 
From: HBlink@DVSwitch.groups.io [mailto:HBlink@DVSwitch.groups.io] On Behalf Of area51now via Groups.Io
Sent: Friday, August 23, 2019 7:43 AM
To: HBlink@DVSwitch.groups.io
Subject: Re: [HBlink] Stuck with setting timer
 
I believe you want to look at the ACTIVE : True or False setting 

  'BM31466': [ 
            {'SYSTEM': 'BM31466', 'TS': 2, 'TGID': 31466, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': ' ON', 'ON': [31466,], 'OFF': [4000], 'RESET': []},
            {'SYSTEM': 'MASTER31466', 'TS': 2, 'TGID': 31466, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': ' NONE','ON': [31466,], 'OFF': [4], 'RESET': []},

Bob 


--
Cort Buffington
H: +1-785-813-1501
M: +1-785-865-7206






Re: Stuck with setting timer

Kevin Halton
 

Hmmm, Thought I tried that and it did not work. I have tried several different configurations and talkgroups still pass traffic thru hotspot. I have even tried this and traffic still coming thru without keying up. I have tried restarting

Bridge.py and rebooting with negative results.

 

BM31466 is HBlink server

MASTERBM31466 is connection to BM.

 

And yes I have 31466 set as static on my selfcare page.

 

],

         'BM31466': [

            {'SYSTEM': 'BM31466', 'TS': 2, 'TGID': 31466, 'ACTIVE': False, 'TIMEOUT': 2, 'TO_TYPE': ' ON', 'ON': [31466,], 'OFF': [4000], 'RESET': []},

            {'SYSTEM': 'MASTER31466', 'TS': 2, 'TGID': 31466, 'ACTIVE': False, 'TIMEOUT': 2, 'TO_TYPE': ' ON','ON': [31466,], 'OFF': [4], 'RESET': []},

 

Any more suggestions greatly appreciated.

 

 

 

From: HBlink@DVSwitch.groups.io [mailto:HBlink@DVSwitch.groups.io] On Behalf Of area51now via Groups.Io
Sent: Friday, August 23, 2019 7:43 AM
To: HBlink@DVSwitch.groups.io
Subject: Re: [HBlink] Stuck with setting timer

 

I believe you want to look at the ACTIVE : True or False setting

  'BM31466': [

            {'SYSTEM': 'BM31466', 'TS': 2, 'TGID': 31466, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': ' ON', 'ON': [31466,], 'OFF': [4000], 'RESET': []},

            {'SYSTEM': 'MASTER31466', 'TS': 2, 'TGID': 31466, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': ' NONE','ON': [31466,], 'OFF': [4], 'RESET': []},

Bob


Re: Stuck with setting timer

area51now@...
 

I believe you want to look at the ACTIVE : True or False setting

  'BM31466': [
            {'SYSTEM': 'BM31466', 'TS': 2, 'TGID': 31466, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': ' ON', 'ON': [31466,], 'OFF': [4000], 'RESET': []},
            {'SYSTEM': 'MASTER31466', 'TS': 2, 'TGID': 31466, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': ' NONE','ON': [31466,], 'OFF': [4], 'RESET': []},

Bob


Stuck with setting timer

Kevin Halton
 

I thought I understood the timers but obviously I do not. I am trying to have all the TG to be idle on startup until I key up that TG and then after 2 or 5 minutes without any local activity go idle again. Here is what I have entered. I tried restarting and also rebooting.

BM31466 is the local HBlink server
Master31466 is the link to BM 

],
         'BM31466': [
            {'SYSTEM': 'BM31466', 'TS': 2, 'TGID': 31466, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': ' ON', 'ON': [31466,], 'OFF': [4000], 'RESET': []},
            {'SYSTEM': 'MASTER31466', 'TS': 2, 'TGID': 31466, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': ' NONE','ON': [31466,], 'OFF': [4], 'RESET': []},

Any pointers as to what I am missing?


Re: hbmonitor3 available

Node750Tt
 

Steve

Yep, did it all.

As stated, I totally understands the various methods to run a program under Linux from boot. I found the error in my script, and now have it running fine at boot.
A simple space, why it was not calling on boot. 

I also tested the example given, and that too ran at boot ps ax | grep monitor.py

Keep up the great works guys, this is amazing stuff, for all with an open mind to learn.

node

   


Re: hbmonitor3 available

Steve N4IRS
 

Once you created the file:
did you put the file in /lib/systemd/system?
did you test the file with systemctl start filename?
did you check if the file was running with systemctl status filename?
did you enable the file with systemctl enable filename?

Steve N4IRS


On 8/18/19 6:21 AM, Node750Tt wrote:
Thanks Steve,

Not at all, your help is very valuable to us all, and greatly appreciated. Most, if not all, do this as hobbyist, and for the love and learning. On this site is a wealth of knowledgeable folks that shares their experiences. 

I do understand Linux very well, and I did make this exact service file, surprising with the same name, give it permissions and made it executable, and making it wait till all has been loaded, but it did not run on boot, hence why I asked if I was missing something in the python script, as to why it is not running on boot. My bad, should have explained myself better when I asked the question.

HBlink_bridge.py and my server both does run on boot, which I have done.

Will keep trying and see what is preventing the script from being called on boot.

2081 - 2100 of 2790