locked #hblink #support #closed #hblink #support #closed


Randy AA6RH
 

That would do it! Glad to hear it's working.

--R
--
Randy Hall AA6RH (not K7AGE, quit asking) 😁


Chris Whitam
 

Sure, my peer type was not changed from PEER to XLXPEER.  Quite a doh moment!


Kevin Halton
 

How about posting the fix so others having the issue can find it searching here.


Chris Whitam
 

Thank you to everyone that replied, especially Brett for getting me up and running.  Found a few minor configuration issues and once I was able to compare to a known working config I got it the Hblink to XLX interface working.


Doug - W4DBG
 

In HBLINK you just set this up:

[XLX-1]
MODE: XLXPEER
ENABLED: False
LOOSE: True
EXPORT_AMBE: False
IP:
PORT: 54002
MASTER_IP: 172.16.1.1
MASTER_PORT: 62030
PASSPHRASE: passw0rd
CALLSIGN: W1ABC
RADIO_ID: 312000
RX_FREQ: 449000000
TX_FREQ: 444000000
TX_POWER: 25
COLORCODE: 1
SLOTS: 1
LATITUDE: 38.0000
LONGITUDE: -095.0000
HEIGHT: 75
LOCATION: Anywhere, USA
DESCRIPTION: This is a cool repeater
URL: www.w1abc.org
SOFTWARE_ID: 20170620
PACKAGE_ID: MMDVM_HBlink
GROUP_HANGTIME: 5
XLXMODULE: 4004
USE_ACL: True
SUB_ACL: DENY:1
TGID_TS1_ACL: PERMIT:ALL
TGID_TS2_ACL: PERMIT:ALL

So in the above example it would connect to Module D (4004) of the XLX Reflector..

In your Rules File you would do this:

            {'SYSTEM': 'XLX-1',    'TS': 2, 'TGID': 9, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': 'NONE',  'ON': [9,], 'OFF': [404], 'RESET': []},


You use TGID 9 for calls on XLX.

So the .cfg file tells HBLINK to connect to "X" module and in this example it is D. The rules file tells traffic to pass on TG 9 which is required for HBLINK to pass the traffic.

I hope this helps.

Doug
W4DBG





On Tue, Feb 16, 2021 at 1:02 PM Chris Whitam <cwhitam@...> wrote:
Good Afternoon All.  I am using hblink to take a pair of MMDVM_Bridges and link them into an XLX server.  The only issue is I do not see a way to have hblink automatically connect to a particular module on the XLX reflector.  I know using MMDVM Options of XLX:4001 will auto connect to Module A, this does not work for HBlink.  Currently I have hblink taking audio in from the bridges on the correct talkgroup and sending audio to XLX on TG4100.  In theory this should route the audio to module A however it still will not auto link to the module.  Am I missing something simple?  Is there a way to do this?  I should add that I have the XLX server correctly configured as a peer stanza and HBlink does connect to the XLX server, and the XLX server shows HBlink as a connected node.  However it is shown with no module connected.  



--
Doug Gooden
troytrojan@...


Chris Whitam
 

Good Afternoon All.  I am using hblink to take a pair of MMDVM_Bridges and link them into an XLX server.  The only issue is I do not see a way to have hblink automatically connect to a particular module on the XLX reflector.  I know using MMDVM Options of XLX:4001 will auto connect to Module A, this does not work for HBlink.  Currently I have hblink taking audio in from the bridges on the correct talkgroup and sending audio to XLX on TG4100.  In theory this should route the audio to module A however it still will not auto link to the module.  Am I missing something simple?  Is there a way to do this?  I should add that I have the XLX server correctly configured as a peer stanza and HBlink does connect to the XLX server, and the XLX server shows HBlink as a connected node.  However it is shown with no module connected.