Topics

Echolink not linking in monitor mode (ASL Asterisk)


Brad McConahay - N8QQ
 

Not sure this is the right place since it's not directly related to bridging, but I am using ASL Asterisk with the repo hosted on dvswitch.org/ASL_Repoistory. Just let me know if this would be better somewhere else.

This is on an install based on the directions here, on Debian 9, both at Digital Ocean and Vultr:

https://wiki.allstarlink.org/wiki/ASL_FAQ#Can_ASL_be_installed_on_an_existing_Linux_install.2C_for_example_on_a_VM_running_Debian.3F

When trying to connect to an Echolink node in monitor mode, it just connects in regular transceive mode.

For instance, the following things are true...

# this links to an allstar node in monitor mode (rx_only), like normal
*CLI> rpt cmd 50004 ilink 2 45863 

# this links to an echolink node in tranceive mode rather than in monitor mode 
*CLI> rpt cmd 50004 ilink 2 3040065
I've tried it with echolink.conf settings from a working hamvoip-on-rpi node, but that doesn't change anything. It happens with any Echolink station or conference I've tried connecting to.

The only other thing I've found odd about it is that, everytime an Echolink connection is made, asterisk logs:

[Jul  7 21:37:35] ERROR[20026]: chan_echolink.c:2586 do_new_call: Cannot find DB entry for IP addr 
But it doesn't stop the connection.

Thought maybe it would be a known issue that hasn't been resolved yet, but I'm not finding anything via google. I know another station using DVSwitch with this same version of ASL who says the same thing is true for him.

Anybody have any info or ideas?

Thanks,

Brad N8QQ


Mike KB8JNM
 

To my current knowledge, (and things may have changed)

Under EchoLink RULES, 'ALL' EchoLink connections 'must be full-duplex'.

Monitor, under this rule,  is not permitted. I certainly had never made that work anyway.

*23xxxxxx is always *33xxxxxx

One method around this is to make a private ASL node to attach the echolink connection to and connect to that private node to your public node in monitor mode.

perhaps something has changed ? someone else may chime in with better answer? perhaps that helps.

...mike/kb8jnm


Brad McConahay - N8QQ
 

Thanks Mike, that does help. The private asl node workaround works great.

Brad N8QQ


Brad N8PC
 

EchoLink is Half Duplex not Full Duplex.