Topics

Allmon2 Trouble

Steaven Rogers
 

So I went through the config and installed Allmon2 on the Pi.  I can log in and out without issue.  It will not however display any node information....It just shows "Waiting...."   I have checked and rechecked the config files, but can not see what I am missing.  Username/password are correct in the manager.conf and the allmon.ini.php files.  I will be happy to post the file contents if needed.  This is on the LAN only, not open to the real world.

Ideas?
Steve

Mike KB8JNM
 

Well Steve,

The first couple of normal things I see when folks are having problems like this...

Make sure the admin password in manager.conf is not 'remarked out' and is not type error

check allmon.ini.php for password type error and the string is passwd=xxxxxx

check file permissions on manager.conf

is firewall permitting your access ?

hope that is some help.

...mike/kb8jnm

On 6/9/2019 10:46 PM, Steaven Rogers wrote:
So I went through the config and installed Allmon2 on the Pi.  I can log in and out without issue.  It will not however display any node information....It just shows "Waiting...."   I have checked and rechecked the config files, but can not see what I am missing.  Username/password are correct in the manager.conf and the allmon.ini.php files.  I will be happy to post the file contents if needed.  This is on the LAN only, not open to the real world.

Ideas?
Steve

Steaven Rogers
 

What should the file permissions on manager.conf be set at?
I assume that there should not be any issues with blocked ports since I am staying inside my local network.  I have not installed any firewall that I know of....Does ASL enable a firewall by default?  How would I check further for port issues?

Thanks
Steve

Steve KC1AWV
 
Edited

When allmon2 requests information from asterisk, you should see the following in the log

  == Parsing '/etc/asterisk/manager.conf': Found
  == Manager 'admin' logged on from 127.0.0.1

If you're seeing anything different, then check the username and password in allmon.ini.php and make sure the stanza in manager.conf has the same username and password.

Also, make sure to reload asterisk if you've made changes to any config files. I believe astres.sh exists on the Raspberry Pi distro which will restart it for you.

Steve KC1AWV

Scott Weis (KB2EAR)
 

Remember Allmon2 does not work with Microsoft browsers. Try chrome, safari or firefox

 

Here is what I get in Microsoft Edge:

 

 

And Chrome:

 

From: allstarlink@DVSwitch.groups.io [mailto:allstarlink@DVSwitch.groups.io] On Behalf Of Steaven Rogers
Sent: Sunday, June 9, 2019 10:46 PM
To: allstarlink@DVSwitch.groups.io
Subject: [allstarlink] Allmon2 Trouble

 

So I went through the config and installed Allmon2 on the Pi.  I can log in and out without issue.  It will not however display any node information....It just shows "Waiting...."   I have checked and rechecked the config files, but can not see what I am missing.  Username/password are correct in the manager.conf and the allmon.ini.php files.  I will be happy to post the file contents if needed.  This is on the LAN only, not open to the real world.

Ideas?
Steve