Re: Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR


Ray Harden
 

Responding to your request … 5 logs run without the  [  &  ], All Debugs @ 0 this time; keyed TYT-380 DMR radio on Brandmeister TG 3119 first, then a few seconds later the P25 – TG31900 mobile radio >> P25 repeater and its MMDVM-P25-Enabled TG31900 software.  There is a really impressive amount of setup to do this – I have probably missed something!

 

v/r

 

RayH    w0ray

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Tuesday, March 12, 2019 6:20 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

No debug. I need the 5 complete outputs from the 5 programs run in the foreground (no &) I need the complete output. The reason is the instruction are the same is because I never seem to get everything. The one time I did get what looked like the complete set of outputs, there were a number of issues with the config files used. By getting the foreground output I see the actual setting settings used I don't have to reference the config files. I'm more then happy to help but I can't do that with out waht I ask for.

This is exactly the procedure I use to troubleshoot when I build a bridge. This is how I find my mistakes.

Steve 

On 3/12/19 7:13 PM, Ray Harden wrote:

Respectfully, these instructions seem to be what you asked me to do earlier and just now I have sent these results.

My process was to open 5 terminals in downsized windows, pre-staging the specific commands, then returning to start each program starting with ./Reflector, then Gateway, the two - _DMR and _P25s, and last MMDVM_bridge.

Settle a couple of minutes, TX one DMR, then TX one P25.

Do you want DEBUG anywhere? We ran with all debugs @ 0 before.

I am happy to comply with your instructions and considering everyone's valuable time in process.

RayH   w0ray


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Steve N4IRS <szingman@...>
Sent: Tuesday, March 12, 2019 4:33:12 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

 

On 3/12/19 4:43 PM, Ray Harden wrote:

Mistaken “/etc/Analog_Bridge_P25.ini” was used which resulted in the erroneous Port entries, ambeMode -> DMR,  2 xxID -> 0 … very sorry for this error.

 

I have deleted the erroneous  xx_P25.ini to eliminate this stupid error.

 

New run with what are the corrected files is attached.  I believe this test reflects the proper port pairings.

 

I noticed that the details of the Analog_Bridge_xx.ini files are not printed this time and I don’t know why.

cd to the directory and just run AB with the ini file. no need to run it in the background. Just run multiple shells. I need that output from each program. It's the only way I know for sure the parameters being used.
Without it, I can go no further.

To be clear, I want each program run in the foreground. I want 1 transmission from DMR and 1 transmission from P25. Everything should be in the same time frame.

 

I am very well aware of the PortCross-Over assignments and have taken careful steps to check and reverify these critical specs. – never sure that everything lines up until I see things working.  I have printed the port assignments chart and understand the configuration.

 

Please accept my apology for the mistaken file.

 

RayH  w0ray

 

 

 

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Tuesday, March 12, 2019 1:07 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

From Analog_Bridge_DMR_Log
M: 2019-03-12 17:02:21.481 Setting [AMBE_AUDIO] server -> 127.0.0.1
M: 2019-03-12 17:02:14.944 Setting [AMBE_AUDIO] fromDMRPort -> 31000
M: 2019-03-12 17:02:14.944 Setting [AMBE_AUDIO] toDMRPort -> 31003

From MMDVM_Bridge_Log
M: 2019-03-12 17:02:30.724 DMR, Setting [DMR] Address -> 127.0.0.1
M: 2019-03-12 17:02:30.724 DMR, Setting [DMR] TXPort -> 31100
M: 2019-03-12 17:02:30.724 DMR, Setting [DMR] RXPort -> 31103

Analog_Bridge_DMR needs to point at the DMR ports in DVSwitch.ini. TX to RX RX to TX
You will have no communications between Analog_Bridge_DMR and MMDVM_Bridge until this is fixed.

From Analog_Bridge_DMR_Log
M: 2019-03-12 17:02:14.945 Setting [USRP] server -> 127.0.0.1
M: 2019-03-12 17:02:14.945 Setting [USRP] toASLPort -> 32001
M: 2019-03-12 17:02:14.945 Setting [USRP] fromASLPort -> 34001

From Analog_Bridge_P25_Log
M: 2019-03-12 17:02:21.481 Setting [AMBE_AUDIO] server -> 127.0.0.1
M: 2019-03-12 17:02:21.481 Setting [AMBE_AUDIO] fromDMRPort -> 31000
M: 2019-03-12 17:02:21.481 Setting [AMBE_AUDIO] toDMRPort -> 31003

Analog_Bridge_P25 needs to point at the P25 ports in DVSwitch.ini. TX to RX RX to TX
You will have no communications between Analog_Bridge_P25 and MMDVM_Bridge until this is fixed.

From Analog_Bridge_P25_Log
M: 2019-03-12 17:02:21.481 Setting [AMBE_AUDIO] ambeMode -> DMR

This should be P25 not DMR

On 3/12/2019 1:40 PM, Ray Harden wrote:

Version 2 ****  this should look a bit better with Reflector started first

     ___________________________________________________________

 

As requested, All DEBUGs are Off, MMDVM_Bridge, Analog_Bridge_DMR, Analog_Bridge_P25, P25Gateway, P25Reflector LOGS, Zipped.

 

One transmission from each radio. Capture results.

 

Many thanks for your efforts

 

RayH    w0ray

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 2:01 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

All off

On 3/6/2019 3:00 PM, Ray Harden wrote:

Debug on or off, all or which ones?


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Steve N4IRS <szingman@...>
Sent: Wednesday, March 6, 2019 1:40:35 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

OK, here is what I need.
Run MMDVM_Bridge Analog_Bridge_DMR Analog_Bridge_P25 P25Gateway all at the same time. Let everything startup and settle. Give me one transmission from a user with a DMR radio. The give me one transmission with a P25 radio. Capture the output from each program in a file then zip it up and send it.

On 3/6/2019 2:32 PM, Ray Harden wrote:

Sorry for the delay … took some time to delete the unwanted lines  … both files are close in time segments … I was already in the process before I saw your  message about Debug Off

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 11:28 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Turn off debug in each program.
Can you send actual text files?
I do see "No response from 31900, unlinking on the gateway.

 

 

 

 

 

Join main@DVSwitch.groups.io to automatically receive all group messages.