Re: AMBEserver on rPI for Analog_Bridge


Patrick Perdue
 

I did all the same stuff again a few hours later, with the ThumbDV connected to the Pi, and it works without break-ups this time. Don't know what changed. Oh well.

On 11/4/2019 9:27 PM, Steve N4IRS wrote:
I can tell you that both Mike and I have run a DV3000 on a remote Pi. Though only on a LAN on the same segment.

On 11/4/19 9:25 PM, Patrick Perdue wrote:
I did, and it was.

FWIW, I also tried the dongle on another x86 machine running Debian with the same results. I have not yet tried everything locally on that machine.


On 11/4/2019 9:23 PM, Steve N4IRS wrote:
Can I assume you verified on the machine with the DV3000, operation with AMBEtest4.py and the latency is 1?

Steve N4IRS

On 11/4/19 8:51 PM, Patrick Perdue wrote:
Got it working, but audio is extremely jittery (pretty much useless) between the remote AMBEserver and the Analog_Bridge. Latency is a very solid 3 MS across the internet between the box in my apartment and the server running DVSwitch. If I used BlueDV locally for DMR and D-STAR, all seems fine. I even tried it from my iPhone's hotspot, and it was good there, too.

I guess I can run DVSwitch locally, but was trying to avoid doing that.



On 11/3/2019 8:00 PM, Steve N4IRS wrote:
Patrick,
I would not suggest you use a powered hub. Plug the ThumbDV directly into the Pi.
The ThumbDV is very sensitive to power dips.
See this: <https://dvswitch.groups.io/g/main/message/315?p=,,,20,0,0,0::relevance,,DV3000U,20,2,0,5521534>

Fore USB latency:
As root:
cat /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
I expect it will return 16

Try this:
echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer

If that works, add:
echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
to /etc/rc.local before the last line (exit 0)

73, Steve N4IRS

On 11/3/19 7:47 PM, Patrick Perdue wrote:
Hi:

A while back, I saw something on this group to the affect of changing timing to make the ThumbDV+AMBEserver combo work better on a Raspberry Pi, but I can't find it now after searching the archives for an hour.

Note that I haven't set this up yet -- still waiting for dongles to arrive. They should be here tomorrow.

I have DVSwitch and ASL running in the cloud, and want to use AMBEserver on a remote Raspberry Pi 4 2GB instead of md380-emu. I'm using a 3.5A power supply on the Pi 4. I'd like to host two dongles for two different, completely unrelated connection points, each with it's own AMBEserver, of course. This is just a dongle host, and won't be running DVSwitch itself.

The Pi is running stock Raspbian.

What should be done in order to optimize things with this setup? Should I still use a powered USB hub, as some have suggested? What about timing?

Thanks and 73

KE4DYI










Join main@DVSwitch.groups.io to automatically receive all group messages.