Re: Brandmeister to XLX


Adrian Fewster <vk4tux@...>
 

Ernie, they may be symptoms associated at the time, but the red thumb, is just a failure of the database sync with the authenticated hash file that the server then verifies the Ip, and

set the thumb status ;

if ($CallingHome['Active']) {


$CallHomeNow = false;

$LastSync = 0;

$Hash = "";


if (!file_exists($CallingHome['HashFile'])) {

$Ressource = fopen($CallingHome['HashFile'], "w+");

if ($Ressource) {

$Hash = CreateCode(16);

@fwrite($Ressource, "<?php\n");

@fwrite($Ressource, "\n".'$Hash = "'.$Hash.'";');

@fwrite($Ressource, "\n\n".'?>');

@fflush($Ressource);

@fclose($Ressource);

@chmod($HashFile, 0777);

}

}

else {

require_once($CallingHome['HashFile']);

}


if (@file_exists($CallingHome['LastCallHomefile'])) {

if (@is_readable($CallingHome['LastCallHomefile'])) {

$tmp = @file($CallingHome['LastCallHomefile']);

if (isset($tmp[0])) {

$LastSync = $tmp[0];

}

unset($tmp);

}

}


if ($LastSync < (time() - $CallingHome['PushDelay'])) {

$CallHomeNow = true;

$Ressource = @fopen($CallingHome['LastCallHomefile'], "w+");

if ($Ressource) {

@fwrite($Ressource, time());

@fflush($Ressource);

@fclose($Ressource);

@chmod($HashFile, 0777);

}

}


if ($CallHomeNow || isset($_GET['callhome'])) {

$Reflector->SetCallingHome($CallingHome, $Hash);

$Reflector->ReadInterlinkFile();

$Reflector->PrepareInterlinkXML();

$Reflector->PrepareReflectorXML();

$Reflector->CallHome();

}


}

else {

$Hash = "";

}


Red thumb consequences are that hams can no longer connect, due to invalid or no hostfile information. There is no code
to detect the issue's below you name to trigger a red thumb. If the system is not running, then of course sync will not occur either.

Certainly it needs fixing asap.

In this case we suspect there is more than one dashboard installed, as the dashboard displayed error path does not match config.inc.php.

Adrian ... vk4tux

On 2/12/19 12:36 am, Ernie Gm7kbk wrote:
If I see a red thumb on my server it means there is something  wrong. Failed to start ambeserver. Ports not set. XLX not started properly. Taking a hard drive from another machine. XLX looks for the old IP address.
Looking for faults in xlx is for another forum.
Happy to help with MB as I've had most of problems that everyone has. I make sure both sides are working then fill in the puzzel.



Join main@DVSwitch.groups.io to automatically receive all group messages.