Re: Analog Bridge and DStar


Mike, AA9VI
 

OK, I moved the Dummy (repeater 2) to port 20011 and the Hotspot repeater (repeater 1) to port 20012.  Still, Dummy repeater will not relay any traffic if I use the IP address 127.0.0.1.  None.  If I use 192.168.1.10 or 0.0.0.0 it will relay the traffic.  I tried to change the USRP IP in DummyRepeaterThread.cpp to 192.168.1.10 and
$ make clean
$ ./configure  --with-ambeserver --with-stardv
$ make
$ sudo make install

then I reloaded asterisk with
$ sudo astres.sh

I even tried
$ export USRP_IP="10.1.1.2";export USRP_IP
$ export USRP_TXPORT=34001;export USRP_TXPORT
$ export USRP_RXPORT=32001;export USRP_RXPORT

Is the core of the problem that 127.0.0.1 does not work with the thumbDV?  let me clarify.. on the dummyrepeater GUI box that pops up has NO traffic showing up when I use that IP.  The transmit button does nothing.  I don't see any traffic from the hotspot repeater communicating with the dummy repeater.  This is what I mean when I say "does not work"

So, the workaround to use 192.168.1.10 seems to be a waste of time.

So, now what?  Any ideas? Day 14 and at least 40 hours of work later and we're 75% of the way there so I guess that is "some" progress.

Steve B. Can you post your rpt.conf file (or send it to me?) 
What other changes need to me made besides all of this?  (ANY changes to ANY files or ANY other dependencies required)
... and yes I did run the required_libs.sh from github and I have all of those requirements fulfilled.

I am running Debin 8 x64 if that adds to the mystery or not.

Join main@DVSwitch.groups.io to automatically receive all group messages.