Re: AMBE GPIO board #analog_bridge


Kevin Ku
 


2020년 2월 27일 (목) 19:54, Steve N4IRS <szingman@...>님이 작성:

Joe,
Analog_Bridge does support a Pi-Hat type of DV3000. Both Mike and a regularly run the NWDigital Pi-Hat DV3000. What parameter are you using to run AMBEtest4.py? It should be

AMBEtest4.py --error --verbose  -n --serial /dev/ttyAMA0

73, Steve N4IRS


On 2/27/20 1:26 AM, onetree9@... wrote:

Thank you for the great work of DVSwitch. I am trying to hook up my AMBE GPIO board which was made in Japan and similar to DV3000 GPIO board. It was working ok for AMBE server on RPI3B+ with the following setup:

          device port : /dev/ttyAMA0

          baudrate : 460800

 

It doesn't work for DVSwitch with the following setup(s) in Analog_Bridge.ini:

          device port : /dev/ttyAMA0

          baudrate : 460800   or   230400 (AMBEtest4.py showed this baudrate)

          serial : true

 

Interestingly, I get the different baudrate from the AMBEtest4.py on RPI3B+

Here is the result:

 

          Setting serial port

          Serial port parameters:

          Port name:      /dev/ttyAMA0

          Baudrate:       230400

          Byte size:      8

          Parity:         N

          Stop bits:      1

          Xon Xoff:       False

          RTS/CTS:        False

          DST/DTR:        False

          *********************

          Silent testing mode.....

          Error, AMBE header was corrupt

          Error, no reply from DV3000.  Command issued was: Reset DV3000

          Error, AMBE header was corrupt

          Error, no reply from DV3000.  Command issued was: Get Product ID

          Error, AMBE header was corrupt

          Error, no reply from DV3000.  Command issued was: Get Version

          Error, AMBE header was corrupt

          Error, no reply from DV3000.  Command issued was: Set DSTAR Mode

          Error, AMBE header was corrupt

          Error, no reply from DV3000.  Command issued was: Reset DV3000

          Error, AMBE header was corrupt

          Error, no reply from DV3000.  Command issued was: Set DMR Mode

          Error, AMBE header was corrupt

          Error, no reply from DV3000.  Command issued was: Decode AMBE

          Error, decode AMBE to PCM return no results

          Error, AMBE header was corrupt

          ..........

          ..........

 

Questions:

1. Does DVSwitch only support USB serial device ?

 

2. If it supports GPIO serial, is there other way of setup for GPIO device on Analog_Bridge.ini ?

 

73,

Joe, HL5KY.


Join main@DVSwitch.groups.io to automatically receive all group messages.