Re: Bang Head Here (mine, not yours)


kb3cs
 

not only is libcurl4 already installed, but there also is a libcurl3 installed:
libcurl3-gnutls/eoan,now 7.65.3-1ubuntu3 amd64 [installed]
gave your suggestion a whirl. here's what happened:
$ sudo dpkg -i asl-asterisk_1.01-20180226-6_i386.deb
Selecting previously unselected package asl-asterisk:i386.
(Reading database ... 522744 files and directories currently installed.)
Preparing to unpack asl-asterisk_1.01-20180226-6_i386.deb ...
Unpacking asl-asterisk:i386 (1.01-20180226-6) ...
dpkg: dependency problems prevent configuration of asl-asterisk:i386:
asl-asterisk:i386 depends on libcurl3.
asl-asterisk:i386 depends on libgsm1.
asl-asterisk:i386 depends on libidn11.
asl-asterisk:i386 depends on libiksemel3.
asl-asterisk:i386 depends on libncurses5.
asl-asterisk:i386 depends on libnewt0.52.
asl-asterisk:i386 depends on libpopt0.
asl-asterisk:i386 depends on libspeex1.

dpkg: error processing package asl-asterisk:i386 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
asl-asterisk:i386
and when trying the similar but more appropriate install matching my architecture:
$ sudo dpkg -i asl-asterisk_1.01-20180226-6_amd64.deb
(Reading database ... 523031 files and directories currently installed.)
Preparing to unpack asl-asterisk_1.01-20180226-6_amd64.deb ...
Unpacking asl-asterisk (1.01-20180226-6) over (1.01-20180226-6) ...
dpkg: dependency problems prevent configuration of asl-asterisk:
asl-asterisk depends on libcurl3; however:
Package libcurl3 is not installed.
asl-asterisk depends on libiksemel3; however:
Package libiksemel3 is not installed.

dpkg: error processing package asl-asterisk (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
asl-asterisk
more verbosity, but the same result as previously reported with output from 'apt'

Join main@DVSwitch.groups.io to automatically receive all group messages.