Re: ASL to P25 bridge #analog_bridge


Steve N4IRS
 

2 options I can see at this point.
1: Start with a fresh Stretch
    apt-get update
    apt-get upgrade
    apt-get install raspberrypi-kernel-headers -y
Verify you have headers matching the running kernel.
If so, install ASL.

2: Start with ASL 1.01

Steve

On 8/9/20 9:59 PM, Tom wrote:
Iroot@P25reflector:~ # apt-get install raspberrypi-kernel-headers -y
Reading package lists... Done
Building dependency tree        
Reading state information... Done
The following NEW packages will be installed:
  raspberrypi-kernel-headers
0 upgraded, 1 newly installed, 0 to remove and 86 not upgraded.
Need to get 0 B/16.7 MB of archives.
After this operation, 109 MB of additional disk space will be used.
Selecting previously unselected package raspberrypi-kernel-headers.
(Reading database ... 51098 files and directories currently installed.)
Preparing to unpack .../raspberrypi-kernel-headers_1.20190819~stretch-1_armhf.deb ...
Unpacking raspberrypi-kernel-headers (1.20190819~stretch-1) ...
Setting up raspberrypi-kernel-headers (1.20190819~stretch-1) ...
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.19.66+
Error! Bad return status for module build on kernel: 4.19.66+ (armv7l)
Consult /var/lib/dkms/asl-dahdi-linux/2.11.1/build/make.log for more information.
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.19.66-v7+
Error! Bad return status for module build on kernel: 4.19.66-v7+ (armv7l)
Consult /var/lib/dkms/asl-dahdi-linux/2.11.1/build/make.log for more information.
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.19.66-v7l+
Error! echo
Your kernel headers for kernel 4.19.66-v7l+ cannot be found at
/lib/modules/4.19.66-v7l+/build or /lib/modules/4.19.66-v7l+/source.

root@P25reflector:~ # uname -r
4.14.98-v7+

Join main@DVSwitch.groups.io to automatically receive all group messages.