Re: P25Gateway Inactivity Timeout Behavior


Steve N4IRS
 

Greg,
I ran a test here.

root@DVSwitch-Server:~# uname -a
Linux DVSwitch-Server 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) x86_64 GNU/Linux
root@DVSwitch-Server:~# dpkg --print-architecture
amd64
root@DVSwitch-Server:~# /opt/P25Gateway/P25Gateway -v
P25Gateway version 20200824

M: 2020-10-23 10:36:53.763 Starting P25Gateway-20200824
M: 2020-10-23 10:36:53.763 Linked at startup to reflector 10200
M: 2020-10-23 10:36:55.986 Unlinked from reflector 10200 by N4IRS
M: 2020-10-23 10:36:55.986 Linked to reflector 10400 by N4IRS
M: 2020-10-23 10:46:57.842 Linked to reflector 10200 due to inactivity

On 10/23/20 3:17 AM, Greg WB6ZSU wrote:
Over the past few days I’ve noticed a change in the way the Inactivity timeout works. I have my system configured with a Startup TG of 10400 and an Inactivity Timer of 10 minutes. The way I’m accustomed to this working is that if I changed talk groups to something other than 10400 (Startup) and there was inactivity on this new TG for more than 10 minutes, the system would revert back to 10400. This is not the way it is behaving today. I’m not exactly sure what TG is now used as the “Revert” TG.

I’ve looked at the P25Gateway log file and verified that even when operating on 10400, if there is more than 10 minutes of inactivity, I will be unlinked from 10400.

Is this a known current behavior, and if so, what does happen after the inactivity timer expires?


Thanks and 73,
Greg
WB6ZSU


Join main@DVSwitch.groups.io to automatically receive all group messages.