Re: Request for information


 

Hardware  is  Dell OptiPlex 380 - SFF - Core 2 Duo E7500 2.93 GHz

Running  Debian 8

 cat /sys/bus/usb-serial/devices/ttyUSB0/latency_timer     result  =   1

DV3000U running a DMR to AllStarLink gateway


Richard VE2DJE




Le 17/01/2018 à 09:24, David a écrit :
timer is 1
Pi 3 NWdigital dongle raspbian

On Wed, Jan 17, 2018 at 8:14 AM, Steve N4IRS <szingman@...> wrote:
We have been working on the next revision of Analog_Bridge. Along with adding features and refining settings, we are trying to squash bugs. While testing the NWDigital DV300u (ThumbDV) we encountered a problem with data transfer . Some of the packets were not being processed in the required window. The NWD DV3000u uses a FTDI chip to communicate with the host computer. Under Linux, or at least Debian the driver is the FTDI serial. On the machine under test, a older Dell 2950 with more then enough horsepower and no history of issues with USB, we were not getting data in a timely manner. There is a value that can be adjusted to resolve this. /sys/bus/usb-serial/devices/ttyUSB0/latency_timer. The default looks to be 16. The 2950 was set at 16. So far so good. Well, I have a machine running a full time DMR <---> D-Star bridge using two of the DV3000u. When I checked the latency_timer, it was set to 1. Huh? I know I did not change it.

I am asking everybody that is using a DV3000 and a FTDI chip to test with the device plugged in. As root: cat /sys/bus/usb-serial/devices/ttyUSB0/latency_timer. Please report the result here. We have multiple ways to set this to what we want, but for now, All I want to know is what hardware / software you are running and the value.

Thanks, Steve

 


Virus-free. www.avg.com

Join main@DVSwitch.groups.io to automatically receive all group messages.