Re: Hotspot Audio for C4FM Very loud and distorted.


Patrick Perdue
 

Are you running USRPGain and TLVGain at unity? I've found it helps a lot to turn TLVGain down quite a bit in Analog_Bridge.ini. TLV is the gain sent from analog to digital. This will reduce the gain to DMR from analog. More headroom isn't necessarily bad, though you'll find that audio to your Yaesu is probably still louder than with a DMR radio. I'm not a Yaesu-using person myself, though I did just order an FT70 to play with, so I don't know exactly why these differences in levels between DMR and C4FM radios are what they are when everyone is using the same codec. I'll let someone better qualified explain that.


Here's how I have my TLV gain set:

tlvAudio = AUDIO_USE_GAIN                  ; Analog -> Digital (AUDIO_UNITY, AUDIO_USE_GAIN, AUDIO_BPF)
tlvGain = 0.35                          ; Gain factor when tlvAudio = AUDIO_USE_GAIN (0.0 to 5.0) (1.0 = AUDIO_UNITY)


When playing with things a month or so ago, I was told that, on my bridge, digital to digital (person A on DMR radio and person B on a Yaesu) sounded OK, but audio from analog was too hot on C4FM, but OK on analog, so I turned down the TLVGain a little. I don't really know a better way to handle that situation. Note that in my case, DVSwitch is not involved in making the connection between DMR and YSF. I got the same results when using DVSwitch instead, though.


And for USRPGain, I'm using AGC, with the threshold a little higher than in the default configuration. This is personal preference, but I find it works pretty well on my bridge.

usrpAudio = AUDIO_USE_AGC                 ; Digital -> Analog (AUDIO_UNITY, AUDIO_USE_GAIN, AUDIO_USE_AGC)
usrpGain = 1.0                         ; Gain factor when usrpAudio = AUDIO_USE_GAIN (0.0 to 5.0) (1.0 = AUDIO_UNITY)
usrpAgc = -18,10,500


On 12/30/2020 12:54 AM, Frank C. D'Amato wrote:
I have DVswitch setup DMR>Analog. It pushes a DMR TG to my Hamvoip Allstar node (2 seperate Pi's).

When I talk on the analog radio, the audio sounds great coming out of my DMR radio connected to a Openspot (Both ver 1&2).

If I put my openspot modem to C4FM (to use my yaesu rado in DN mode), and connect to the TG that my DVswitch is transmitting to, the audio sounds very distorted and loud.

Anyone else have this problem?

Using the same setup C4FM to DMR on the openspots sound great on the yeasu radio, The problem is only there on the TG the DVswitch is pushing the analog audio to.

Join main@DVSwitch.groups.io to automatically receive all group messages.