Allstar systemctl issues


Steve Siesel [K4KSA]
 

Steve,

 

I have been having problems with ASL running in my Raspberry Pi 3B. I have a crontab to restart ASL overninght   00 00 * * *  systemctl restart asterisk.  So I have noticed:

 

·         CPU usage rises 12 hours after restart (not so high yet today)

·         When I do a systemctl restart asterisk it just stalls like the second graphic below.

 

Uname –a:

root@repeater:/usr/lib# uname -a

Linux repeater 5.4.51-v7-asl+ #1 SMP Sat Aug 29 13:44:27 EDT 2020 armv7l GNU/Linux

 

Asterisk –v:

AllStarLink Asterisk Version 1.01 2/13/2018 GIT Version c37af60

Copyright (C) 1999 - 2018 Digium, Inc. Jim Dixon, AllStarLink Inc. and others.

Created by Mark Spencer <markster@...>

Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.

This is free software, with components licensed under the GNU General Public

License version 2 and other licenses; you are welcome to redistribute it under

certain conditions. Type 'core show license' for details.

=========================================================================

Asterisk already running on /var/run/asterisk/asterisk.ctl.  Use 'asterisk -r' to connect.

 

Ps –aux:

 

 

 

 

Here is my asterisk.system file:

 

#/etc/systemd/system/asterisk.service

[Unit]

Description=AllStar Asterisk

Documentation=man:asterisk(8)

Wants=network.target

After=network-online.target

 

[Service]

Type=simple

StandardOutput=null

ExecStartPre=mkdir -p /run/asterisk

ExecStart=/usr/sbin/asterisk -g -f

ExecStop=/usr/sbin/asterisk -rx 'stop now'

ExecReload=/usr/sbin/asterisk -rx 'module reload'

 

# safe_asterisk emulation

Restart=always

RestartSec=10

 

[Install]

WantedBy=multi-user.target

 

 

Anything else you want to see from my system?

 

Join main@DVSwitch.groups.io to automatically receive all group messages.