Re: No audio from Windows DVSwitch dashboard


David J Taylor
 

On 17/05/2021 16:05, Steve N4IRS wrote:
Check the webproxy log in /var/log/dvswitch.
Steve,

Thanks for that suggestion. Two extracts below - the first seems to have a backwards time step, but it's from a couple of months back.

The second shows yesterday's tests (apparently using a server started an March-19) and apparently sending data (audio packets, I guess) correctly. Judging by the times in the log it seems that audio was being sent, and that my Web browser wasn't receiving or processing it until I ran the Python client once.

Unfortunately I didn't keep a careful note of the times! Oh, well!

21-03-19 11:03:12 - Websocket Proxy:
21-03-19 11:03:12 - =
21-03-19 14:15:46 - Version: 1.6.0
21-03-19 14:15:46 -
21-03-19 14:15:46 - WebSocket server ready on port 8080...
21-03-19 14:15:46 - PCM client is listening at port : 2222
21-03-19 14:15:46 - Server ip :0.0.0.0
21-03-19 14:15:46 - Server is IP4/IP6 : IPv4
21-05-17 10:41:16 - Remote client 192.168.0.8 connected. sending data...
21-05-17 10:41:16 - -------- CONNECTIONS --------
21-05-17 10:41:16 - Connected client: 192.168.0.8
21-05-17 10:41:16 - -----------------------------
21-05-17 10:41:35 - Remote client 192.168.0.8 disconnected
21-05-17 10:41:35 - -------- CONNECTIONS --------
21-05-17 10:41:35 - No connected clients
21-05-17 10:41:35 - -----------------------------
21-05-17 10:41:38 - Remote client 192.168.0.8 connected. sending data...
21-05-17 10:41:38 - -------- CONNECTIONS --------
21-05-17 10:41:38 - Connected client: 192.168.0.8
21-05-17 10:41:38 - -----------------------------
21-05-17 10:41:38 - Remote client 192.168.0.8 disconnected
21-05-17 10:41:38 - -------- CONNECTIONS --------
21-05-17 10:41:38 - No connected clients

73,
David GM8ARV
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@blueyonder.co.uk
Twitter: @gm8arv

Join main@DVSwitch.groups.io to automatically receive all group messages.