Date   

Re: Analog_Bridge failure to load

Chris WB4ULK
 

Think I may have it. LOL. Just figured out how to read the log.
Yeah.... I'm THAT slow.
It is complaining because I set the repeater ID to the same thing as the User ID.

THAAAAT would do it!

Chris


Re: Analog_Bridge failure to load

Mike Zingman - N4IRR
 

What does the Analog_Bridge log file show?


Re: Analog_Bridge failure to load

Chris WB4ULK
 

Yeah, if you look about half way up, I did a manual stop and start.
When I do a start, I get no feedback.

Chris


Re: Analog_Bridge failure to load

Chris Andrist, KC7WSU
 

Have you tried manually starting analog_bridge? I find that I get more info from this than the systemd status.

Regards,

Chris Andrist, KC7WSU
DMR-UTAH

On Jun 2, 2018, at 3:00 PM, Chris via Groups.Io <chood73@...> wrote:

Hey guys,
I working on another DMR ASL Bridge.
Everything was peachy until It wouldn't cross traffic.

I see that I have a failure on the Analog_Bridge startup

Here is what I have:

● analog_bridge.service - Analog_Bridge Service

   Loaded: loaded (/lib/systemd/system/analog_bridge.service; enabled; vendor preset: enabled)

   Active: activating (auto-restart) (Result: exit-code) since Sat 2018-06-02 16:55:09 EDT; 2s ago

  Process: 927 ExecStart=/opt/Analog_Bridge/Analog_Bridge /opt/Analog_Bridge/Analog_Bridge.ini (code=exited, status=1/FAILURE)

 Main PID: 927 (code=exited, status=1/FAILURE)

 

Jun 02 16:55:09 Test systemd[1]: analog_bridge.service: Main process exited, code=exited, status=1/FAILURE

Jun 02 16:55:09 Test systemd[1]: analog_bridge.service: Unit entered failed state.

Jun 02 16:55:09 Test systemd[1]: analog_bridge.service: Failed with result 'exit-code'.

repeater@Test://etc/asterisk$ sudo systemctl stop analog_bridge

repeater@Test://etc/asterisk$ sudo systemctl start analog_bridge

repeater@Test://etc/asterisk$ sudo systemctl status analog_bridge

● analog_bridge.service - Analog_Bridge Service

   Loaded: loaded (/lib/systemd/system/analog_bridge.service; enabled; vendor preset: enabled)

   Active: activating (auto-restart) (Result: exit-code) since Sat 2018-06-02 16:56:02 EDT; 1s ago

  Process: 972 ExecStart=/opt/Analog_Bridge/Analog_Bridge /opt/Analog_Bridge/Analog_Bridge.ini (code=exited, status=1/FAILURE)

 Main PID: 972 (code=exited, status=1/FAILURE)

 

Jun 02 16:56:02 Test systemd[1]: analog_bridge.service: Main process exited, code=exited, status=1/FAILURE

Jun 02 16:56:02 Test systemd[1]: analog_bridge.service: Unit entered failed state.

Jun 02 16:56:02 Test systemd[1]: analog_bridge.service: Failed with result 'exit-code'.

Any Ideas?

Chris
WB4ULK


Analog_Bridge failure to load

Chris WB4ULK
 

Hey guys,
I working on another DMR ASL Bridge.
Everything was peachy until It wouldn't cross traffic.

I see that I have a failure on the Analog_Bridge startup

Here is what I have:

● analog_bridge.service - Analog_Bridge Service

   Loaded: loaded (/lib/systemd/system/analog_bridge.service; enabled; vendor preset: enabled)

   Active: activating (auto-restart) (Result: exit-code) since Sat 2018-06-02 16:55:09 EDT; 2s ago

  Process: 927 ExecStart=/opt/Analog_Bridge/Analog_Bridge /opt/Analog_Bridge/Analog_Bridge.ini (code=exited, status=1/FAILURE)

 Main PID: 927 (code=exited, status=1/FAILURE)

 

Jun 02 16:55:09 Test systemd[1]: analog_bridge.service: Main process exited, code=exited, status=1/FAILURE

Jun 02 16:55:09 Test systemd[1]: analog_bridge.service: Unit entered failed state.

Jun 02 16:55:09 Test systemd[1]: analog_bridge.service: Failed with result 'exit-code'.

repeater@Test://etc/asterisk$ sudo systemctl stop analog_bridge

repeater@Test://etc/asterisk$ sudo systemctl start analog_bridge

repeater@Test://etc/asterisk$ sudo systemctl status analog_bridge

● analog_bridge.service - Analog_Bridge Service

   Loaded: loaded (/lib/systemd/system/analog_bridge.service; enabled; vendor preset: enabled)

   Active: activating (auto-restart) (Result: exit-code) since Sat 2018-06-02 16:56:02 EDT; 1s ago

  Process: 972 ExecStart=/opt/Analog_Bridge/Analog_Bridge /opt/Analog_Bridge/Analog_Bridge.ini (code=exited, status=1/FAILURE)

 Main PID: 972 (code=exited, status=1/FAILURE)

 

Jun 02 16:56:02 Test systemd[1]: analog_bridge.service: Main process exited, code=exited, status=1/FAILURE

Jun 02 16:56:02 Test systemd[1]: analog_bridge.service: Unit entered failed state.

Jun 02 16:56:02 Test systemd[1]: analog_bridge.service: Failed with result 'exit-code'.

Any Ideas?

Chris
WB4ULK


Re: I have missed some major step on install

Steve N4IRS
 

Also,
apt-get install p25reflector

On 06/02/2018 03:13 PM, Mike AE4ML wrote:
Good afternoon all,

Steve,
I'm doing a fresh install and I did the apt install dvswitch. I got Analog_Bridge , md380-emu and MMDVM_Bridge.

I don't have P25Gateway , P25 Parrot or P25 Reflector.  Is that a different install ?


Re: I have missed some major step on install

Mike AE4ML
 

Good afternoon all,

Steve,
I'm doing a fresh install and I did the apt install dvswitch. I got Analog_Bridge , md380-emu and MMDVM_Bridge.

I don't have P25Gateway , P25 Parrot or P25 Reflector.  Is that a different install ?


Re: List of ports to open for firewall rules

Chris WB4ULK
 

Thanks a lot!

Chris


Re: List of ports to open for firewall rules

Steve N4IRS
 

Don't block 62031 UDP out and you should be good. The datafile scripts also download via port 80. You do not need to open any inbound ports.

Steve

On 06/02/2018 12:15 PM, Chris via Groups.Io wrote:
My current installation is ASL and DMR.
I have all of the ports configured for ASL, but not sure which ones to keep open for Brandmeister.
I know they have a bunch of diff ports for diff repeaters ie.. Hytera vs Moto vs MMDVM, so I guess, I just need the list for an MMDVM to Brandmeister to add to my list.

Chris


Re: List of ports to open for firewall rules

Chris WB4ULK
 

My current installation is ASL and DMR.
I have all of the ports configured for ASL, but not sure which ones to keep open for Brandmeister.
I know they have a bunch of diff ports for diff repeaters ie.. Hytera vs Moto vs MMDVM, so I guess, I just need the list for an MMDVM to Brandmeister to add to my list.

Chris


Re: List of ports to open for firewall rules

Steve N4IRS
 

Chris,
I do not have a list but what ports to open would depend on what you are doing. ASL, DMR... ?

On 06/02/2018 12:11 PM, Chris via Groups.Io wrote:
Anyone have a down and dirty list for ports to add to your firewall rules?
I am tightening up my server since its open to the world and was wondering if someone has made a list, instead of having to go look at all of the config files to see which ports are being used.

Thanks,
Chris
WB4ULK


List of ports to open for firewall rules

Chris WB4ULK
 

Anyone have a down and dirty list for ports to add to your firewall rules?
I am tightening up my server since its open to the world and was wondering if someone has made a list, instead of having to go look at all of the config files to see which ports are being used.

Thanks,
Chris
WB4ULK


Re: Intermittent No Audio

Steve N4IRS
 

Will,
Since the data flows from ASL to MB through AB, it's good to tail both the AB and MB logs. You should see waht is happening in "real time"

Steve

On 06/01/2018 08:08 PM, WillieB wrote:
My bridge is working very well, however I do have one main problem.

Sometimes when one person stops talking and another person takes their turn, my hotspot transmits but there's no audio coming out. Then next time it drops and someone else starts talking I hear the audio. It may do this in about 1 out of 5 transmissions or so. It varies per person and AllStar node I'm connected to. I'm not sure if it's when they key up fast or what.

I can listen on the AllStar node and I hear the audio there, but not on DMR.

Anyone else having that problem? I was going to go check out the Analog_Bridge.ini file and see if there are any settings in there that might make sense changing but maybe someone can give me some ideas before I go poking around and changing things (after backing up the ini of course!).

I can also tail -f the 2 log files when it's happening and see if that gives me any clues to what might be going on.

-Will
KE4IAJ



Re: Updated DVSwitch repository available

Steve N4IRS
 

I have rebuilt under Jessie.
apt-get update
apt-get upgrade

On 06/01/2018 08:28 PM, Mike Swiatkowski via Groups.Io wrote:
Steve, FYI... Jessie does not natively support this version of GLIBCXX with latest distro upgrade.  I'm still working on the fix though you probably will figure it out a day before me.

sysop@debian8:/opt/MMDVM_Bridge$ strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_3.4.15
GLIBCXX_3.4.16
GLIBCXX_3.4.17
GLIBCXX_3.4.18
GLIBCXX_3.4.19
GLIBCXX_3.4.20
GLIBCXX_DEBUG_MESSAGE_LENGTH


Data file sources

Steve N4IRS
 
Edited


Re: Updated DVSwitch repository available

Steve N4IRS
 

I have to recompile all of the programs under Jessie. I've fixed Analog_Bridge. I need to do the rest. I'll post when they are done.

Steve

On 06/01/2018 08:13 PM, Mike Swiatkowski via Groups.Io wrote:
Thanks.  This seems to allow the binary and ini files to install.  But, when running mmdvm-bridge I get the following error:

sysop@debian8:/opt/MMDVM_Bridge$ sudo ./MMDVM_Bridge MMDVM_Bridge.ini
./MMDVM_Bridge: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./MMDVM_Bridge)

I'm working to resolve this.  apt-get upgrade and dist-upgrade won't fix it.  Googling the problem shows it is a common issue with Jessie.


Re: Updated DVSwitch repository available

Mike, AA9VI
 

Steve, FYI... Jessie does not natively support this version of GLIBCXX with latest distro upgrade.  I'm still working on the fix though you probably will figure it out a day before me.

sysop@debian8:/opt/MMDVM_Bridge$ strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_3.4.15
GLIBCXX_3.4.16
GLIBCXX_3.4.17
GLIBCXX_3.4.18
GLIBCXX_3.4.19
GLIBCXX_3.4.20
GLIBCXX_DEBUG_MESSAGE_LENGTH


Re: Updated DVSwitch repository available

Mike, AA9VI
 

Thanks.  This seems to allow the binary and ini files to install.  But, when running mmdvm-bridge I get the following error:

sysop@debian8:/opt/MMDVM_Bridge$ sudo ./MMDVM_Bridge MMDVM_Bridge.ini
./MMDVM_Bridge: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./MMDVM_Bridge)

I'm working to resolve this.  apt-get upgrade and dist-upgrade won't fix it.  Googling the problem shows it is a common issue with Jessie.


Intermittent No Audio

WillieB <will@...>
 

My bridge is working very well, however I do have one main problem.

Sometimes when one person stops talking and another person takes their turn, my hotspot transmits but there's no audio coming out. Then next time it drops and someone else starts talking I hear the audio. It may do this in about 1 out of 5 transmissions or so. It varies per person and AllStar node I'm connected to. I'm not sure if it's when they key up fast or what.

I can listen on the AllStar node and I hear the audio there, but not on DMR.

Anyone else having that problem? I was going to go check out the Analog_Bridge.ini file and see if there are any settings in there that might make sense changing but maybe someone can give me some ideas before I go poking around and changing things (after backing up the ini of course!).

I can also tail -f the 2 log files when it's happening and see if that gives me any clues to what might be going on.

-Will
KE4IAJ


Re: IPSC_Bridge & HB_Bridge etc. - ID Database

Steve N4IRS
 

The scripts installed by dvswitch-base do not download from DMR-MARC. There are at least 3 sources of subscriber data and 2 sources of repeater data. We will look at the possibility of a primary and a secondary DL so that we always have the best data. And of course, as soon as we do, it will change.

73, Steve N4IRS

On 06/01/2018 05:12 PM, Jon K1IMD wrote:
Hi Cort,
This is what I have... in a running copy...
# ID ALIAS CREATION
# Download
def build_aliases(_config, _logger):
#   if _config['ALIASES']['TRY_DOWNLOAD'] == True: # Disabled because DMR-MARC Servers NG
    if _config['ALIASES']['TRY_DOWNLOAD'] == False:
        # Try updating peer aliases file
        result = try_download(_config['ALIASES']['PATH'], _config['ALIASES']['PEER_FILE'], _config['ALIASES']['PEER_URL'], _config['ALIASES']['STALE_TIME'])
        _logger.info(result)
        # Try updating subscriber aliases file
        result = try_download(_config['ALIASES']['PATH'], _config['ALIASES']['SUBSCRIBER_FILE'], _config['ALIASES']['SUBSCRIBER_URL'], _config['ALIASES']['STALE_TIME'])
        _logger.info(result)

Really the question was an updated source for the .csv file  Which I think Peter M0NWI mentioned using radioid.net.  I will need to investigate.

from dmrlink.cfg and hblink.cfg
PEER_URL: http://www.dmr-marc.net/cgi-bin/trbo-database/datadump.cgi?table=repeaters&format=csv&header=0
SUBSCRIBER_URL: http://www.dmr-marc.net/cgi-bin/trbo-database/datadump.cgi?table=users&format=csv&header=0

Jon
K1IMD

On 6/1/2018 4:41 PM, Cort N0MJS wrote:
master branch code for dmrlink.py hasn’t been changed for 9 months. IPSC_Bridge hasn’t been changed for a year and both read the same. I might suggest that was a local change you have there, and not a repo issue. The magic of version control!

(starting line 106):

def build_aliases(_config, _logger):
    if _config['ALIASES']['TRY_DOWNLOAD'] == True:
        # Try updating peer aliases file
        result = try_download(_config['ALIASES']['PATH'], _config['ALIASES']['PEER_FILE'], _config['ALIASES']['PEER_URL'], _config['ALIASES']['STALE_TIME'])
        _logger.info(result)
        # Try updating subscriber aliases file
        result = try_download(_config['ALIASES']['PATH'], _config['ALIASES']['SUBSCRIBER_FILE'], _config['ALIASES']['SUBSCRIBER_URL'], _config['ALIASES']['STALE_TIME'])
        _logger.info(result)


On Jun 1, 2018, at 3:28 PM, Jon K1IMD <jon@...> wrote:

…snip

From dmrlink.py calling from dmrlink.cfg
# ID ALIAS CREATION
# Download
def build_aliases(_config, _logger):
#   if _config['ALIASES']['TRY_DOWNLOAD'] == True: # Disabled becuase DMR-MARC Servers NG
    if _config['ALIASES']['TRY_DOWNLOAD'] == False:

73
Jon
K1IMD

Cort Buffington
785-865-7206



7621 - 7640 of 9081