Date   

Re: Building up a network

Steve N4IRS
 

Anything in the DMRGateway log?

On 06/03/2018 11:58 AM, beni@... wrote:
Steve, thanks.

Attached herein hblink.cfg, and the Pi-Star's DMRGateway config section that connects to hblink is:


[DMR Network 3]
Enabled=1
Name=HBLink
Address=164.132.42.221
Port=8413
TGRewrite=2,11,2,11,1
Password=passiword
Location=0
Debug=0

PS. It is Pi-Star's own option, not added by me. The only thing I changed there are the IP, port and password.


Re: Building up a network

beni@...
 

Steve, thanks.

Attached herein hblink.cfg, and the Pi-Star's DMRGateway config section that connects to hblink is:


[DMR Network 3]
Enabled=1
Name=HBLink
Address=164.132.42.221
Port=8413
TGRewrite=2,11,2,11,1
Password=passiword
Location=0
Debug=0

PS. It is Pi-Star's own option, not added by me. The only thing I changed there are the IP, port and password.


Re: DMR to DSTAR

Steve N4IRS
 

DummyRepeater has been replaced with MMDVM_Bridge
D-Star <---> ircddbgateway <---> MMDVM_Bridge <---. Analog_Bridge <---> Analog_Bridge <---> MMDVM_Bridge <---> DMR

Steve

On 06/03/2018 11:47 AM, Mike Swiatkowski via Groups.Io wrote:
Is there a more simpler way to set up a transcode between a DStar REF and and DMR REF than by using the below method?
ircddbgw--> Dummyrepeater--> Analog Bridge --> ASL  <-- Analog_Bridge <-- DMR REF

I've see dummy repeater crash from time to time. Can you patch together two MMDVM instances to avoid Analog Bridge and ASL?

Mike, AA9VI


DMR to DSTAR

Mike, AA9VI
 

Is there a more simpler way to set up a transcode between a DStar REF and and DMR REF than by using the below method?
ircddbgw--> Dummyrepeater--> Analog Bridge --> ASL  <-- Analog_Bridge <-- DMR REF

I've see dummy repeater crash from time to time. Can you patch together two MMDVM instances to avoid Analog Bridge and ASL?

Mike, AA9VI


Re: Building up a network

Steve N4IRS
 

Ben,
Can you post your MASTER-1 stanza and the section of DMRGateway that is suppoed to be connecting to hblink?
Anything in the logs of dmrgateay or MMDVM?

Steve

On 06/03/2018 11:35 AM, beni@... wrote:
Setup HBLink on a vps, run it and it seems it runs ok.

also, configured two of the hotspots (Pi-Star) enabling DMRGateway, disabling BM and DMR+, enabling HBLink and configuring HBLink with the IP, port and password I setup on hblink configuration file.

But, the hotspots seems do not connect, when I run "hblink.py" I get the following:

root@vps523689:~# cd /home/debian/Downloads/HBlink ; python hblink.py
DEBUG 2018-06-03 17:22:15,858 Logging system started, anything from here on gets logged
INFO 2018-06-03 17:22:15,858 HBlink 'HBlink.py' (c) 2016 N0MJS & the K0USY Group - SYSTEM STARTING...
DEBUG 2018-06-03 17:22:15,859 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:15,860 MASTER instance created: MASTER-1, <__main__.HBSYSTEM instance at 0x7faa2581f8c0>
DEBUG 2018-06-03 17:22:20,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:25,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:30,865 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:35,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:40,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:45,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:50,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:55,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:00,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:05,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:10,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:15,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:20,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:25,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:30,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:35,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:40,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:45,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:50,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:55,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:00,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:05,865 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:10,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:15,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:20,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:25,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:30,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:35,860 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:40,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:45,860 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:50,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:55,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:25:00,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:25:05,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:25:10,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:25:15,864 (MASTER-1) Master maintenance loop started


and I do not see any connection messages from the hotspots trying to connect.

Anything you think I did wrong?


Re: Building up a network

beni@...
 

Setup HBLink on a vps, run it and it seems it runs ok.

also, configured two of the hotspots (Pi-Star) enabling DMRGateway, disabling BM and DMR+, enabling HBLink and configuring HBLink with the IP, port and password I setup on hblink configuration file.

But, the hotspots seems do not connect, when I run "hblink.py" I get the following:

root@vps523689:~# cd /home/debian/Downloads/HBlink ; python hblink.py
DEBUG 2018-06-03 17:22:15,858 Logging system started, anything from here on gets logged
INFO 2018-06-03 17:22:15,858 HBlink 'HBlink.py' (c) 2016 N0MJS & the K0USY Group - SYSTEM STARTING...
DEBUG 2018-06-03 17:22:15,859 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:15,860 MASTER instance created: MASTER-1, <__main__.HBSYSTEM instance at 0x7faa2581f8c0>
DEBUG 2018-06-03 17:22:20,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:25,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:30,865 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:35,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:40,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:45,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:50,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:22:55,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:00,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:05,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:10,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:15,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:20,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:25,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:30,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:35,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:40,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:45,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:50,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:23:55,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:00,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:05,865 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:10,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:15,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:20,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:25,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:30,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:35,860 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:40,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:45,860 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:50,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:24:55,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:25:00,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:25:05,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:25:10,864 (MASTER-1) Master maintenance loop started
DEBUG 2018-06-03 17:25:15,864 (MASTER-1) Master maintenance loop started


and I do not see any connection messages from the hotspots trying to connect.

Anything you think I did wrong?


Re: Building up a network

beni@...
 

Steve, thanks for the reply.

It is not that I do not want to connect to the "big" networks, but in my opinion (and I might be wrong, of course) it is best first they learn and adapt in a smaller scale, next they can connect to whatever network they want.

I am at the moment setting up a vps on Debian Stretch, then next HBLink.

Ben


Re: Building up a network

Steve N4IRS
 

Ben,
Welcome to the group. We understand not wanting to be part of the politics. I do not see any problem with waht you are trying to do and it certainly can be done with the programs of DVSwitch. I would star with HBlink on a computer that each HS can access (ping) That will get all the MMDVM based devices talking to each other. You can expand from there.

We are working on documentation and though it's slow going, we are getting there.

73, Steve N4IRS


On 06/03/2018 07:12 AM, beni@... wrote:
Hi there all and first of all thank you for the great tools; not only useful - but also interesting to learn.

Let me first give you some background information and next what I am trying to accomplish.

I live in a country - the "Black Sheep" of the HAM community in terms of digital - Albania. There are not too many HAMs in Albania, and even so mostly we operate in HF. In terms of Digital there is nothing - null - nil, and this is unacceptable to me, lol.

Now, I have some MMDVM hotspots (DVMega, Zumspot, Duplex MMDVM_HS), around 6 or 7 in total and I plan to distribute them (indeed for free) to HAMs around the country, so people can have at least a way to access DMR. Also some my own DMR HTs and some more I am trying to get form a good individual that is trying to help. Later on I was promised we would get two Mototrbo 1st gen repeaters (DR3000) from an organization, and in the meantime I am trying to build a home-brew MMDVD repeater with two GM300s that I have.

I would love to interconnect all those terminals in a network, and I want to do this without being part of the actual DMR Networks "political" games. My point is to incentivize HAMs in Albania and not making them part of the ongoing DMR Networks "war". I wont be around for long in Albania so the two months I got here I want to try to teach and incentivize HAMs - not lightning a fire. 

This is why I plan to use DVSwitch tools - first to learn and next interconnect to the whole worldwide DMR Network.

Tried to read most of the messages in here but I am still not very clear. Anyway I like experiments and I will start from HBLink right after I write this topic, and hope you understand when I ask questions from time to time if I don't find a solution.

In the meantime, if someone can help me with a rough - simple How to I would be very grateful.

Thanks in advance,

Ben


Building up a network

beni@...
 

Hi there all and first of all thank you for the great tools; not only useful - but also interesting to learn.

Let me first give you some background information and next what I am trying to accomplish.

I live in a country - the "Black Sheep" of the HAM community in terms of digital - Albania. There are not too many HAMs in Albania, and even so mostly we operate in HF. In terms of Digital there is nothing - null - nil, and this is unacceptable to me, lol.

Now, I have some MMDVM hotspots (DVMega, Zumspot, Duplex MMDVM_HS), around 6 or 7 in total and I plan to distribute them (indeed for free) to HAMs around the country, so people can have at least a way to access DMR. Also some my own DMR HTs and some more I am trying to get form a good individual that is trying to help. Later on I was promised we would get two Mototrbo 1st gen repeaters (DR3000) from an organization, and in the meantime I am trying to build a home-brew MMDVD repeater with two GM300s that I have.

I would love to interconnect all those terminals in a network, and I want to do this without being part of the actual DMR Networks "political" games. My point is to incentivize HAMs in Albania and not making them part of the ongoing DMR Networks "war". I wont be around for long in Albania so the two months I got here I want to try to teach and incentivize HAMs - not lightning a fire. 

This is why I plan to use DVSwitch tools - first to learn and next interconnect to the whole worldwide DMR Network.

Tried to read most of the messages in here but I am still not very clear. Anyway I like experiments and I will start from HBLink right after I write this topic, and hope you understand when I ask questions from time to time if I don't find a solution.

In the meantime, if someone can help me with a rough - simple How to I would be very grateful.

Thanks in advance,

Ben


Re: Updated DVSwitch repository available

Mike, AA9VI
 

Now working on Jessie.  Thanks Steve.

Mike


Re: Analog_Bridge failure to load

Chris WB4ULK
 

Think I may have it. LOL. Just figured out how to read the log.
Yeah.... I'm THAT slow.
It is complaining because I set the repeater ID to the same thing as the User ID.

THAAAAT would do it!

Chris


Re: Analog_Bridge failure to load

Mike Zingman - N4IRR
 

What does the Analog_Bridge log file show?


Re: Analog_Bridge failure to load

Chris WB4ULK
 

Yeah, if you look about half way up, I did a manual stop and start.
When I do a start, I get no feedback.

Chris


Re: Analog_Bridge failure to load

Chris Andrist, KC7WSU
 

Have you tried manually starting analog_bridge? I find that I get more info from this than the systemd status.

Regards,

Chris Andrist, KC7WSU
DMR-UTAH

On Jun 2, 2018, at 3:00 PM, Chris via Groups.Io <chood73@...> wrote:

Hey guys,
I working on another DMR ASL Bridge.
Everything was peachy until It wouldn't cross traffic.

I see that I have a failure on the Analog_Bridge startup

Here is what I have:

● analog_bridge.service - Analog_Bridge Service

   Loaded: loaded (/lib/systemd/system/analog_bridge.service; enabled; vendor preset: enabled)

   Active: activating (auto-restart) (Result: exit-code) since Sat 2018-06-02 16:55:09 EDT; 2s ago

  Process: 927 ExecStart=/opt/Analog_Bridge/Analog_Bridge /opt/Analog_Bridge/Analog_Bridge.ini (code=exited, status=1/FAILURE)

 Main PID: 927 (code=exited, status=1/FAILURE)

 

Jun 02 16:55:09 Test systemd[1]: analog_bridge.service: Main process exited, code=exited, status=1/FAILURE

Jun 02 16:55:09 Test systemd[1]: analog_bridge.service: Unit entered failed state.

Jun 02 16:55:09 Test systemd[1]: analog_bridge.service: Failed with result 'exit-code'.

repeater@Test://etc/asterisk$ sudo systemctl stop analog_bridge

repeater@Test://etc/asterisk$ sudo systemctl start analog_bridge

repeater@Test://etc/asterisk$ sudo systemctl status analog_bridge

● analog_bridge.service - Analog_Bridge Service

   Loaded: loaded (/lib/systemd/system/analog_bridge.service; enabled; vendor preset: enabled)

   Active: activating (auto-restart) (Result: exit-code) since Sat 2018-06-02 16:56:02 EDT; 1s ago

  Process: 972 ExecStart=/opt/Analog_Bridge/Analog_Bridge /opt/Analog_Bridge/Analog_Bridge.ini (code=exited, status=1/FAILURE)

 Main PID: 972 (code=exited, status=1/FAILURE)

 

Jun 02 16:56:02 Test systemd[1]: analog_bridge.service: Main process exited, code=exited, status=1/FAILURE

Jun 02 16:56:02 Test systemd[1]: analog_bridge.service: Unit entered failed state.

Jun 02 16:56:02 Test systemd[1]: analog_bridge.service: Failed with result 'exit-code'.

Any Ideas?

Chris
WB4ULK


Analog_Bridge failure to load

Chris WB4ULK
 

Hey guys,
I working on another DMR ASL Bridge.
Everything was peachy until It wouldn't cross traffic.

I see that I have a failure on the Analog_Bridge startup

Here is what I have:

● analog_bridge.service - Analog_Bridge Service

   Loaded: loaded (/lib/systemd/system/analog_bridge.service; enabled; vendor preset: enabled)

   Active: activating (auto-restart) (Result: exit-code) since Sat 2018-06-02 16:55:09 EDT; 2s ago

  Process: 927 ExecStart=/opt/Analog_Bridge/Analog_Bridge /opt/Analog_Bridge/Analog_Bridge.ini (code=exited, status=1/FAILURE)

 Main PID: 927 (code=exited, status=1/FAILURE)

 

Jun 02 16:55:09 Test systemd[1]: analog_bridge.service: Main process exited, code=exited, status=1/FAILURE

Jun 02 16:55:09 Test systemd[1]: analog_bridge.service: Unit entered failed state.

Jun 02 16:55:09 Test systemd[1]: analog_bridge.service: Failed with result 'exit-code'.

repeater@Test://etc/asterisk$ sudo systemctl stop analog_bridge

repeater@Test://etc/asterisk$ sudo systemctl start analog_bridge

repeater@Test://etc/asterisk$ sudo systemctl status analog_bridge

● analog_bridge.service - Analog_Bridge Service

   Loaded: loaded (/lib/systemd/system/analog_bridge.service; enabled; vendor preset: enabled)

   Active: activating (auto-restart) (Result: exit-code) since Sat 2018-06-02 16:56:02 EDT; 1s ago

  Process: 972 ExecStart=/opt/Analog_Bridge/Analog_Bridge /opt/Analog_Bridge/Analog_Bridge.ini (code=exited, status=1/FAILURE)

 Main PID: 972 (code=exited, status=1/FAILURE)

 

Jun 02 16:56:02 Test systemd[1]: analog_bridge.service: Main process exited, code=exited, status=1/FAILURE

Jun 02 16:56:02 Test systemd[1]: analog_bridge.service: Unit entered failed state.

Jun 02 16:56:02 Test systemd[1]: analog_bridge.service: Failed with result 'exit-code'.

Any Ideas?

Chris
WB4ULK


Re: I have missed some major step on install

Steve N4IRS
 

Also,
apt-get install p25reflector

On 06/02/2018 03:13 PM, Mike AE4ML wrote:
Good afternoon all,

Steve,
I'm doing a fresh install and I did the apt install dvswitch. I got Analog_Bridge , md380-emu and MMDVM_Bridge.

I don't have P25Gateway , P25 Parrot or P25 Reflector.  Is that a different install ?


Re: I have missed some major step on install

Mike AE4ML
 

Good afternoon all,

Steve,
I'm doing a fresh install and I did the apt install dvswitch. I got Analog_Bridge , md380-emu and MMDVM_Bridge.

I don't have P25Gateway , P25 Parrot or P25 Reflector.  Is that a different install ?


Re: List of ports to open for firewall rules

Chris WB4ULK
 

Thanks a lot!

Chris


Re: List of ports to open for firewall rules

Steve N4IRS
 

Don't block 62031 UDP out and you should be good. The datafile scripts also download via port 80. You do not need to open any inbound ports.

Steve

On 06/02/2018 12:15 PM, Chris via Groups.Io wrote:
My current installation is ASL and DMR.
I have all of the ports configured for ASL, but not sure which ones to keep open for Brandmeister.
I know they have a bunch of diff ports for diff repeaters ie.. Hytera vs Moto vs MMDVM, so I guess, I just need the list for an MMDVM to Brandmeister to add to my list.

Chris


Re: List of ports to open for firewall rules

Chris WB4ULK
 

My current installation is ASL and DMR.
I have all of the ports configured for ASL, but not sure which ones to keep open for Brandmeister.
I know they have a bunch of diff ports for diff repeaters ie.. Hytera vs Moto vs MMDVM, so I guess, I just need the list for an MMDVM to Brandmeister to add to my list.

Chris

8421 - 8440 of 9891