Date   

Re: Trying to set up Parrot

Cort N0MJS <n0mjs@...>
 

crickets…. is it ok now?

On Jul 3, 2018, at 9:52 PM, Cort N0MJS via Groups.Io <n0mjs@...> wrote:

All apps fixed in the master branch…. no promises I didn’t miss something. Been up since way early, and there’s a kitten crawling all over me while I’m working tonight.

On Jul 3, 2018, at 3:35 PM, rob297@... wrote:

[Edited Message Follows]

I am unable startup parrot.py.  New at this and have conference bridge already running.  Trying to run this in another directory seperate from main bridge.  Error below..  I know I am missing something but cant find it.  Please help.

INFO ID ALIAS MAPPER: 'peer_ids.csv' is current, not downloaded
INFO ID ALIAS MAPPER: 'subscriber_ids.csv' is current, not downloaded
INFO ID ALIAS MAPPER: peer_ids dictionary is available
INFO ID ALIAS MAPPER: subscriber_ids dictionary is available
INFO HBlink 'hb_parrot.py' (c) 2016 N0MJS & the K0USY Group - SYSTEM STARTING...
Traceback (most recent call last):
  File "hb_parrot.py", line 226, in <module>
    systems[system] = parrot(system, CONFIG, logger)
  File "hb_parrot.py", line 59, in __init__
    HBSYSTEM.__init__(self, _name, _config, _logger)
TypeError: __init__() takes exactly 5 arguments (4 given)


hblink.cfg

[Master]
MODE: MASTER
ENABLED: True
REPEAT: True
EXPORT_AMBE: False  
IP: 127.0.0.1
PORT: 54010
PASSPHRASE: Passw0rd
GROUP_HANGTIME: 5

[Parrot]
MODE: CLIENT
ENABLED: True
LOOSE: False
EXPORT_AMBE: False
IP:
PORT: 54025
MASTER_IP: 127.0.0.1
MASTER_PORT: 54010
PASSPHRASE: Passw0rd
CALLSIGN: XXXXXX
RADIO_ID: 314882403
RX_FREQ: 449000000
TX_FREQ: 444000000
TX_POWER: 25
COLORCODE: 1
SLOTS: 1
LATITUDE: 38.0000
LONGITUDE: -095.0000
HEIGHT: 75  
LOCATION: Houston,TX
DESCRIPTION: TARMA  
URL: www.rob297.com
SOFTWARE_ID: 20170620
PACKAGE_ID: MMDVM_HBlink
GROUP_HANGTIME: 5
OPTIONS:

--
Cort Buffington
H: +1-785-813-1501
M: +1-785-865-7206






--
Cort Buffington
H: +1-785-813-1501
M: +1-785-865-7206






Re: WiFi disabled in startup image

Steve N4IRS
 

Larry,
as root, run raspi-config select Localisation Options, then select Change Wi-fi Country.

73, Steve N4IRS

On 07/03/2018 09:30 PM, mothesmith@... wrote:
Today was the day to start the configuration process for bringing up a node to transit to and from DMR.  Regardless of which Raspberry PI I used, and after multiple SD card imaging I could not get the system to perform an update or upgrade using the wireless network. The initial image does as expected when the PI is connected directly to the router. After ruling out hardware issues. I concluded that the startup image simply could not connect wirelessly.  It was at this point that I discovered a statement in the boot process to the effect that 'WiFi is disabled unless a county code is present.'  So, am I on the right track? Does this statement mean anything at all? Does the system only reliably function when attached directly to the router? If not, what suggestions might there be for getting the system to function wirelessly?

Thank you,
Larry Moyer, K5IMO


WiFi disabled in startup image

mothesmith@...
 

Today was the day to start the configuration process for bringing up a node to transit to and from DMR.  Regardless of which Raspberry PI I used, and after multiple SD card imaging I could not get the system to perform an update or upgrade using the wireless network. The initial image does as expected when the PI is connected directly to the router. After ruling out hardware issues. I concluded that the startup image simply could not connect wirelessly.  It was at this point that I discovered a statement in the boot process to the effect that 'WiFi is disabled unless a county code is present.'  So, am I on the right track? Does this statement mean anything at all? Does the system only reliably function when attached directly to the router? If not, what suggestions might there be for getting the system to function wirelessly?

Thank you,
Larry Moyer, K5IMO


Re: Trying to set up Parrot

Cort N0MJS <n0mjs@...>
 

All apps fixed in the master branch…. no promises I didn’t miss something. Been up since way early, and there’s a kitten crawling all over me while I’m working tonight.

On Jul 3, 2018, at 3:35 PM, rob297@... wrote:

[Edited Message Follows]

I am unable startup parrot.py.  New at this and have conference bridge already running.  Trying to run this in another directory seperate from main bridge.  Error below..  I know I am missing something but cant find it.  Please help.

INFO ID ALIAS MAPPER: 'peer_ids.csv' is current, not downloaded
INFO ID ALIAS MAPPER: 'subscriber_ids.csv' is current, not downloaded
INFO ID ALIAS MAPPER: peer_ids dictionary is available
INFO ID ALIAS MAPPER: subscriber_ids dictionary is available
INFO HBlink 'hb_parrot.py' (c) 2016 N0MJS & the K0USY Group - SYSTEM STARTING...
Traceback (most recent call last):
  File "hb_parrot.py", line 226, in <module>
    systems[system] = parrot(system, CONFIG, logger)
  File "hb_parrot.py", line 59, in __init__
    HBSYSTEM.__init__(self, _name, _config, _logger)
TypeError: __init__() takes exactly 5 arguments (4 given)


hblink.cfg

[Master]
MODE: MASTER
ENABLED: True
REPEAT: True
EXPORT_AMBE: False  
IP: 127.0.0.1
PORT: 54010
PASSPHRASE: Passw0rd
GROUP_HANGTIME: 5

[Parrot]
MODE: CLIENT
ENABLED: True
LOOSE: False
EXPORT_AMBE: False
IP:
PORT: 54025
MASTER_IP: 127.0.0.1
MASTER_PORT: 54010
PASSPHRASE: Passw0rd
CALLSIGN: XXXXXX
RADIO_ID: 314882403
RX_FREQ: 449000000
TX_FREQ: 444000000
TX_POWER: 25
COLORCODE: 1
SLOTS: 1
LATITUDE: 38.0000
LONGITUDE: -095.0000
HEIGHT: 75  
LOCATION: Houston,TX
DESCRIPTION: TARMA  
URL: www.rob297.com
SOFTWARE_ID: 20170620
PACKAGE_ID: MMDVM_HBlink
GROUP_HANGTIME: 5
OPTIONS:

--
Cort Buffington
H: +1-785-813-1501
M: +1-785-865-7206






Re: Trying to set up Parrot

Cort N0MJS <n0mjs@...>
 

Yep – when I added socket based reporting to the master branch, I forgot to update several of the sample applications… Will be fixed tomorrow.

On Jul 3, 2018, at 5:14 PM, KB5PBM <rob297@...> wrote:

[Edited Message Follows]

Removed MASTER in hblink.cfg for parrot.py config.  It will run with the PARROT client disabled.  But I still get the same error with the client enabled.  The instance of confbridge.py  I added a master PARROT listening on 54010. and added rule for talkgroup 9990 to PARROT.  Netstat shows new Master (PARROT) is listening on port 54010.  I know I am missing something simple.  Could I be missing some modules?


--
Cort Buffington
H: +1-785-813-1501
M: +1-785-865-7206






Re: Trying to set up Parrot

KB5PBM
 

Made sure I am using master branch and re sync'd.  Same results.  My confbridge.py still work great!!


Re: Trying to set up Parrot

Cort N0MJS <n0mjs@...>
 

It’s something deep. The error you had indicates an internal class is being called incorrectly. This isn’t something an end-user can affect with configuration. I checked the current master and HB_Branches and see no issues.

I’d ask to make sure you’re on the master branch and up to date with it. If you can verify that and the problem persists, I will engage you on it – but we’ll need to take if off-list. We’ll be digging deep into the code and that’ll just be noise here.

On Jul 3, 2018, at 5:14 PM, KB5PBM <rob297@...> wrote:

Removed MASTER in hblink.cfg for parrot.py config.  It will run with the PARROT client disabled.  But I still get the same error with the client enabled.  The instance of confbridge.py  I added a master PARROT listening on 54010. and added rule for talkgroup 9990 to PARROT.  Netstat shows new Master (PARROT) is listening on port 54010.  I know I am missing something simple. 


--
Cort Buffington
H: +1-785-813-1501
M: +1-785-865-7206






Re: Trying to set up Parrot

KB5PBM
 
Edited

Removed MASTER in hblink.cfg for parrot.py config.  It will run with the PARROT client disabled.  But I still get the same error with the client enabled.  The instance of confbridge.py  I added a master PARROT listening on 54010. and added rule for talkgroup 9990 to PARROT.  Netstat shows new Master (PARROT) is listening on port 54010.  I know I am missing something simple.  Could I be missing some modules?


ThumbDV on Sale

 

The ThumbDV is on sale through July for $99.95
 


Re: Trying to set up Parrot

Steve N4IRS
 

Rob,
Since you already have confbridge running, I assume you have a rule for the TG you are going to assign to parrot. I think the parrot should be just a client. Try turning off the master and point the client at one of the masters in your confbridge. Think of it as a remote client. Also check your logging section and make sure the directory exists.

73, Steve N4IRS

On 07/03/2018 04:35 PM, rob297@... wrote:

[Edited Message Follows]

I am unable startup parrot.py.  New at this and have conference bridge already running.  Trying to run this in another directory seperate from main bridge.  Error below..  I know I am missing something but cant find it.  Please help.

INFO ID ALIAS MAPPER: 'peer_ids.csv' is current, not downloaded
INFO ID ALIAS MAPPER: 'subscriber_ids.csv' is current, not downloaded
INFO ID ALIAS MAPPER: peer_ids dictionary is available
INFO ID ALIAS MAPPER: subscriber_ids dictionary is available
INFO HBlink 'hb_parrot.py' (c) 2016 N0MJS & the K0USY Group - SYSTEM STARTING...
Traceback (most recent call last):
  File "hb_parrot.py", line 226, in <module>
    systems[system] = parrot(system, CONFIG, logger)
  File "hb_parrot.py", line 59, in __init__
    HBSYSTEM.__init__(self, _name, _config, _logger)
TypeError: __init__() takes exactly 5 arguments (4 given)


hblink.cfg

[Master]
MODE: MASTER
ENABLED: True
REPEAT: True
EXPORT_AMBE: False  
IP: 127.0.0.1
PORT: 54010
PASSPHRASE: Passw0rd
GROUP_HANGTIME: 5

[Parrot]
MODE: CLIENT
ENABLED: True
LOOSE: False
EXPORT_AMBE: False
IP:
PORT: 54025
MASTER_IP: 127.0.0.1
MASTER_PORT: 54010
PASSPHRASE: Passw0rd
CALLSIGN: XXXXXX
RADIO_ID: 314882403
RX_FREQ: 449000000
TX_FREQ: 444000000
TX_POWER: 25
COLORCODE: 1
SLOTS: 1
LATITUDE: 38.0000
LONGITUDE: -095.0000
HEIGHT: 75  
LOCATION: Houston,TX
DESCRIPTION: TARMA  
URL: www.rob297.com
SOFTWARE_ID: 20170620
PACKAGE_ID: MMDVM_HBlink
GROUP_HANGTIME: 5
OPTIONS:


Trying to set up Parrot

KB5PBM
 
Edited

I am unable startup parrot.py.  New at this and have conference bridge already running.  Trying to run this in another directory seperate from main bridge.  Error below..  I know I am missing something but cant find it.  Please help.

INFO ID ALIAS MAPPER: 'peer_ids.csv' is current, not downloaded
INFO ID ALIAS MAPPER: 'subscriber_ids.csv' is current, not downloaded
INFO ID ALIAS MAPPER: peer_ids dictionary is available
INFO ID ALIAS MAPPER: subscriber_ids dictionary is available
INFO HBlink 'hb_parrot.py' (c) 2016 N0MJS & the K0USY Group - SYSTEM STARTING...
Traceback (most recent call last):
  File "hb_parrot.py", line 226, in <module>
    systems[system] = parrot(system, CONFIG, logger)
  File "hb_parrot.py", line 59, in __init__
    HBSYSTEM.__init__(self, _name, _config, _logger)
TypeError: __init__() takes exactly 5 arguments (4 given)


hblink.cfg

[Master]
MODE: MASTER
ENABLED: True
REPEAT: True
EXPORT_AMBE: False  
IP: 127.0.0.1
PORT: 54010
PASSPHRASE: Passw0rd
GROUP_HANGTIME: 5

[Parrot]
MODE: CLIENT
ENABLED: True
LOOSE: False
EXPORT_AMBE: False
IP:
PORT: 54025
MASTER_IP: 127.0.0.1
MASTER_PORT: 54010
PASSPHRASE: Passw0rd
CALLSIGN: XXXXXX
RADIO_ID: 314882403
RX_FREQ: 449000000
TX_FREQ: 444000000
TX_POWER: 25
COLORCODE: 1
SLOTS: 1
LATITUDE: 38.0000
LONGITUDE: -095.0000
HEIGHT: 75  
LOCATION: Houston,TX
DESCRIPTION: TARMA  
URL: www.rob297.com
SOFTWARE_ID: 20170620
PACKAGE_ID: MMDVM_HBlink
GROUP_HANGTIME: 5
OPTIONS:


Re: Strange announcement after each keyup after about a day of running

Chris WB4ULK
 

I think that solved the issue. At least it did mine. It has been running just fine and endured very heavy traffic for about 4 hrs last night with all sorts of mixed modes.

Thanks Steve!

Chris


Re: Strange announcement after each keyup after about a day of running

Chris WB4ULK
 

That sounds great! I just looked at mine and the default was 500ms. lol
I just changed it to 2500ms and waiting for it to get registered with Allstar and give it a shot.

Again, THANKS!

Chris


Re: Strange announcement after each keyup after about a day of running

Steve N4IRS
 

Did some playing today. Thanks to everyone that helped. That strange announcement is the word "blocked" in English at a distorted level from BrandMeister.

The optional hang times in MMDVM_Bridge do nothing in this environment. That is why the default is to either set them to zero in MMDVM_Bridge.ini or leave out the tags altogether. They are a leftover and will disappear some day soon.

 In a ASL <-> DMR bridge, the value that is important is in Analog_Bridge.ini. In the [AMBE_AUDIO] stanza minTxTimeMS is the important value. As of now, the default as shipped is 2000 ms. This value is to guarantee that a analog to DMR signal is at least 2 seconds long. Why 2 seconds? There is a "loop detector" in BrandMeister (and only BrandMeister) that is supposed to automatically block a loop condition from a hot spot.

The loop detector looks for more then 4 short transmissions in a 60 second period. The loop detector define a short transmission as being 35 frames or less. This is about 2 seconds. As a safety measure please bump the value in Analog_Bridge.ini to 2500. I will push out a update to Analog_Bridge with the new default value and a minor update to MMDVM_Bridge that will report the number of frames sent.

73, Steve n4IRS


Re: Strange announcement after each keyup after about a day of running

Chris WB4ULK
 

She's back.


Re: Strange announcement after each keyup after about a day of running

Chris WB4ULK
 

Connected.


Re: Strange announcement after each keyup after about a day of running

Steve N4IRS
 

If you guys would reconnect to 2600 in transceive, the more noise the better. You will only go out on TG3166 and ASL 2600

On 7/2/2018 1:32 PM, Mike KB8JNM wrote:

I think the point I thought was obvious that perhaps is not that I was trying to make was that among any other activity you might be doing and telemetry issue could create that 'quick keying' block. And you are not likely to hear 'short telemetry' on the dmr side.

Perhaps I am dead wrong about that but I don't think so.

Perhaps everyone is missing that so I said it bluntly.


On 7/2/2018 1:02 PM, Kevin Halton wrote:
If you are getting the “blocked” message it takes approximately 60 minutes of no key ups to reset. 


On Jul 2, 2018, at 12:03 PM, Mike KB8JNM <groupio@...> wrote:

I think you need to wait some abount of time to be "UNFLAGGED"

If all is well.

Just my opinion.

...mike/kb8jnm


On 7/2/2018 11:32 AM, Chris WB4ULK via Groups.Io wrote:
I reconnected the Bridge node to my hub node. I keyed up over DMR no prob, but when I keyed up the analog side, she started her same ol' rigamarole. LOL




Re: Strange announcement after each keyup after about a day of running

Mike KB8JNM
 

I think the point I thought was obvious that perhaps is not that I was trying to make was that among any other activity you might be doing and telemetry issue could create that 'quick keying' block. And you are not likely to hear 'short telemetry' on the dmr side.

Perhaps I am dead wrong about that but I don't think so.

Perhaps everyone is missing that so I said it bluntly.


On 7/2/2018 1:02 PM, Kevin Halton wrote:
If you are getting the “blocked” message it takes approximately 60 minutes of no key ups to reset. 


On Jul 2, 2018, at 12:03 PM, Mike KB8JNM <groupio@...> wrote:

I think you need to wait some abount of time to be "UNFLAGGED"

If all is well.

Just my opinion.

...mike/kb8jnm


On 7/2/2018 11:32 AM, Chris WB4ULK via Groups.Io wrote:
I reconnected the Bridge node to my hub node. I keyed up over DMR no prob, but when I keyed up the analog side, she started her same ol' rigamarole. LOL



Re: Strange announcement after each keyup after about a day of running

Kevin Halton
 

If you are getting the “blocked” message it takes approximately 60 minutes of no key ups to reset. 


On Jul 2, 2018, at 12:03 PM, Mike KB8JNM <groupio@...> wrote:

I think you need to wait some abount of time to be "UNFLAGGED"

If all is well.

Just my opinion.

...mike/kb8jnm


On 7/2/2018 11:32 AM, Chris WB4ULK via Groups.Io wrote:
I reconnected the Bridge node to my hub node. I keyed up over DMR no prob, but when I keyed up the analog side, she started her same ol' rigamarole. LOL


Re: Strange announcement after each keyup after about a day of running

Chris WB4ULK
 

Interesting. I disconnected the bridge node from my hub node. Let it sit there for awhile, connected back up and it isn't doing it any more. The thing is, if it is my node being blocked by BM, won't it just get blocked again?

Chris

8321 - 8340 of 10078