Date   

Re: Corey's IP idea worked ..kind of...

Corey Dean N3FE <n3fe@...>
 

You will need to look on the wiki and find the password for the master.  Not all are the same.


On Jul 18, 2018, at 5:41 PM, mark rosenberg <4x1ks.mark@...> wrote:

Ok, so Corey's idea of using the ip of the server as the host server name worked a bit.  I was able to run the debug and got the result 

Logged into master successfully
Login to master has failed, retrying login...
Connection to the master has timed out, retrying connection
Closing DMR Network
Opening DMR Network
Sending Authorisation
Sending Configuration
Logged into master successfully
Login to the mater has failed, retrying login...

this repeats itself.  when I used the name "brandmeister-il.ddns.net"  it wouldn't login at all...with the ip address I got the above paragraph

thanks
 Mark


Re: C Bridge to P25 Reflector

Michael KD5DFB
 

SUCCESS! 

Once I removed the hb bridge and reconfigured the ports, it connected and tested audio sounds great! 

Steve, Thanks again! 



On Wed, Jul 18, 2018 at 4:14 PM, Steve N4IRS <szingman@...> wrote:
Joe,
There is a BIG error in the diagram. It should be:
cbridge <-> ipsc_bridge <-> Analog_Bridge_1 <-> Analog_bridge_2 <-> MMDVM_Bridge <-> P25Gateway <-> P25Reflector

HB_Bridge is not needed. That's what I get for copy and paste.

Steve

On 07/18/2018 03:03 PM, KD5DFB wrote:
All, I still need help with my bridge. I have voice traffic to hb bridge on the dmr side and p25 voice traffic to the analog bridge. Still struggling to understand how to get these 2 connected . 

As always, Thank you for your help Steve! 

On Tue, Jul 17, 2018 at 1:51 PM, Steve N4IRS <szingman@...> wrote:
##################################              ################################
# IPSC_Bridge configuration file #              #
HB_Bridge configuration file #           
##################################              ################################

[DEFAULTS]                                      [DEFAULTS]
gateway = 127.0.0.1                            
gateway = 127.0.0.1                             
fromGatewayPort = 31000                        
toGatewayPort = 31000
toGatewayPort = 31003                          
fromGatewayPort = 31003                          


The above assumes you are not using those port number somewhere else. If you are, make the unique.
example: change 31000 to 31999 change 31003 to 31993

On 7/17/2018 2:38 PM, KD5DFB wrote:
Steve, I really appreciate your help! My apologies, but, I just can see it. 

On Tue, Jul 17, 2018 at 12:57 PM, Steve N4IRS <szingman@...> wrote:
dmrlink.cfg and hblink.cfg define their respective network connections. IPSC_Bridge.cfg and HB_Bridge.cfg define their respective Partner connections.

On 7/17/2018 1:55 PM, KD5DFB wrote:
Okay, let me take a step back and break it down again. 

So, IPSC_Bridge uses both dmrlink.cfg and IPSC_bridge.cfg.  The dmrlink.cfg defines the connection to the cbridge and I see it connected on the control center. IPSC_Bridge.cfg defines the connection to HB_Bridge. Is that defined in the HB_Bridge.cfg or hblink.cfg?

On Tue, Jul 17, 2018 at 12:44 PM, Steve N4IRS <szingman@...> wrote:
No,
You can use the same port number twice. I try to use the default port numbers where possible. Since you can't use a port twice, you will have to change something. 

On 7/17/2018 1:38 PM, KD5DFB wrote:
Ok, so let me see if I got it correct. So basically all 3 of them use the same port numbers just changing the TX and RX? 

IPSC_Bridge.cfg                     HB_Bridge.cfg                  Analog_Bridge.ini
fromgateway: 31100              fromGateway: 31103         from: 31100
toGateway: 31103                  toGateway: 31100            to: 31103

On Tue, Jul 17, 2018 at 10:00 AM, Steve N4IRS <szingman@...> wrote:


On 7/17/2018 10:51 AM, KD5DFB wrote:
Okay, making progress! I am stumped on the last piece. 

I am trying to figure out the connection between ipsc_bridge and hb_bridge. 

On ipsc_bridge, I have the dmrlink.cfg connecting to the cbridge and can see traffic from the cbridge in the log. Does the ipsc_bridge.cfg connect to hb_bridge.cfg?
Yes

On the hb_bridge I am a little confused. Does the hb_bridge.cfg connect to analog_bridge? Does the ambe need to match what is in analog_bridge?
Just like connecting any of the partners, TX to RX and RX to TX (or words to that effect) Analog_Bridge [AMBE_AUDIO] stanza points to the values in the HB_Bridge [DEFAULTS] stanza.

[AMBE]
EXPORT_IP: 127.0.0.1
EXPORT_PORT: 1234
Ignore these


On Mon, Jul 16, 2018, 21:02 Steve N4IRS <szingman@...> wrote:
I like separate directories at first. Makes it easy to keep things visible. Yes, I uses systemd.
 

On 07/16/2018 09:55 PM, KD5DFB wrote:
Thank you! 

What is your recommendation on running 2 analog bridges? Do I make a new directory and copy the analog_bridge files into it? How can I run 2 at a time? Do I use systemctl? 

On Mon, Jul 16, 2018 at 8:47 PM, Steve N4IRS <szingman@...> wrote:
Walk through it one module at a time. You should see the traffic at each step.

On 07/16/2018 09:44 PM, KD5DFB wrote:
Success! Do I need to change anything else under [AMBE_AUDIO] for Analog_bridge_2?


I: 2018-07-17 01:39:11.007 Begin TX: src=3148242 rpt=0 dst=8207 slot=2 cc=0
D: 2018-07-17 01:39:12.824 End TX
I: 2018-07-17 01:39:21.690 Begin TX: src=3148242 rpt=0 dst=8207 slot=2 cc=0
D: 2018-07-17 01:39:23.327 End TX
I: 2018-07-17 01:39:25.043 Begin TX: src=3148242 rpt=0 dst=8207 slot=2 cc=0
D: 2018-07-17 01:39:25.594 End TX
I: 2018-07-17 01:39:39.947 Begin TX: src=3148242 rpt=0 dst=8207 slot=2 cc=0
D: 2018-07-17 01:39:44.125 End TX
 

On Mon, Jul 16, 2018 at 8:20 PM, Steve N4IRS <szingman@...> wrote:
You need to make sure the P25 TX and RX ports in DVSwitch.ini point to the proper ports in Analog_Bridge.ini

On 07/16/2018 09:15 PM, KD5DFB wrote:
Okay, trying to take this in small steps and not fry my noodle.

I am working from P25 reflector to c bridge. I have the p25 reflector up and running. I can see my voice traffic on the P25Gateway log and the MMDVM_Bridge log.

Is there anything else I need change in MMDVM_Bridge.ini? I have changed the following:

[General]
Callsign=KD5DFB
Id=314838

[P25]
Enable=1

[P25 Network]
Enable=1

On Analog_Bridge.ini

toASLPort = 32001 
fromASLPort = 34001  

Should I see any traffic if I tail the log or run it ./Analog_Bridge




On Mon, Jul 16, 2018 at 6:57 PM, Steve N4IRS <szingman@...> wrote:
IPSC_Bridge and HB_Bridge sub-class dmrlink and hblink. In other words, dmrlink and hblink are the network stack for IPSC_Bridge and HB_Bridge. So you configure hblink.cfg and hblink.cfg.
You will also need to install dmr_utils. Someday I hope IPSC_Bridge and HB_Bridge get merged into the master branches. One could only hope.

Steve N4IRS

On 07/16/2018 07:47 PM, KD5DFB wrote:
Okay, interesting... When I looked at the github under master they are not there. I had to change to branch to IPSC_bridge and HB-Bridge

So, When I look at the IPSC_Bridge.cfg. I only see this. How to I tell it to connect to the cbridge as a peer? 


# IPSC_Bridge configuration file #

##################################


# DEFAULTS - General settings. These values are

# inherited in each subsequent section (defined by section value).


[DEFAULTS]

gateway = 127.0.0.1 # IP address of Partner Application (HB_Bridge, Analog_Bridge)

fromGatewayPort = 31000 # Port IPSC_Bridge is listening on for data (IPSC_Bridge <--- Partner)

toGatewayPort = 31003 # Port Partner is listening on for data (IPSC_Bridge ---> Partner)


On Mon, Jul 16, 2018 at 6:32 PM, Steve N4IRS <szingman@...> wrote:
cbridge <-> ipsc_bridge <-> hb_Bridge <-> Analog_Bridge_1 <-> Analog_bridge_2 <-> MMDVM_Bridge <-> P25Gateway <-> P25Reflector

On 07/16/2018 07:29 PM, KD5DFB wrote:
All,

I am trying to setup a bridge between my C Bridge port and my P25 Reflector. When looking at older post I see reference to IPSC_Bridge and HB_bridge. Are those no longer applicable? Do I just use dmrlink and hb_bridge_all ? 

This is what I think it should be...

cbridge <-> dmrlink <-> hblink <-> hb_bridge_all <-> mb1 <-> ab1 <-> ab2 <-> mb2 <-> p25gateway <-> p25reflector

As of right now, I have dmrlink connect to the c bridge and when I tail the log, I can see traffic from dmr. Same on the other side. I have mb2 connectd thru the p25gateway to my p25 reflector. When I tail the log, I can see the p25 traffic. 

Just need some help between the cbridge and mb1 :-)

Michael KD5DFB




















Re: not connecting to Brandmeister still

mark rosenberg
 

I logged my rfshark openspot out of dmr and i was able to see the virtual mode on the brandmeister website ok.. i will try to finish it tomorrow...it's 0100 here...gn and thanks!


On Thu, Jul 19, 2018, 00:30 Steve N4IRS <szingman@...> wrote:
Mark,
Here is what I suggest:
Test with hblink.dvswitch.org That will tell you if you have your config correct.
I would think, and I can't speak for the US BM admins, You could run a quick test of connectivity to 3108.

Did you look at the wiki page I sent?

Steve

On 07/18/2018 05:24 PM, mark rosenberg wrote:
I tried 4251  and   brandmeister-il.ddns.net  

still getting the error  "cannot find address for host brandmeister-il.ddns.net"

If you have time for Teamviewer or some other way to get in to look at the files then let me know...I am usually near the computer.

73

Mark


problem solved more or less

mark rosenberg
 

my openspot sharkrf which was logged into DMR on the same network was messing up the MMDVM_Bridge attempts to stay logged into Brandmeister.

I switched the shark over to Dstart and now the Bridge is staying logged into Brandmeister.

Thanks

Mark


Corey's IP idea worked ..kind of...

mark rosenberg
 

Ok, so Corey's idea of using the ip of the server as the host server name worked a bit.  I was able to run the debug and got the result 

Logged into master successfully
Login to master has failed, retrying login...
Connection to the master has timed out, retrying connection
Closing DMR Network
Opening DMR Network
Sending Authorisation
Sending Configuration
Logged into master successfully
Login to the mater has failed, retrying login...

this repeats itself.  when I used the name "brandmeister-il.ddns.net"  it wouldn't login at all...with the ip address I got the above paragraph

thanks
 Mark


Re: not connecting to Brandmeister still

Corey Dean N3FE <n3fe@...>
 

I sent you the ip for it in an earlier email!  Did you try it?


On Jul 18, 2018, at 5:24 PM, mark rosenberg <4x1ks.mark@...> wrote:

I tried 4251  and   brandmeister-il.ddns.net  

still getting the error  "cannot find address for host brandmeister-il.ddns.net"

If you have time for Teamviewer or some other way to get in to look at the files then let me know...I am usually near the computer.

73

Mark


Re: not connecting to Brandmeister still

Steve N4IRS
 

Mark,
Here is what I suggest:
Test with hblink.dvswitch.org That will tell you if you have your config correct.
I would think, and I can't speak for the US BM admins, You could run a quick test of connectivity to 3108.

Did you look at the wiki page I sent?

Steve

On 07/18/2018 05:24 PM, mark rosenberg wrote:
I tried 4251  and   brandmeister-il.ddns.net  

still getting the error  "cannot find address for host brandmeister-il.ddns.net"

If you have time for Teamviewer or some other way to get in to look at the files then let me know...I am usually near the computer.

73

Mark


Re: not connecting to Brandmeister still

mark rosenberg
 

I tried 4251  and   brandmeister-il.ddns.net  

still getting the error  "cannot find address for host brandmeister-il.ddns.net"

If you have time for Teamviewer or some other way to get in to look at the files then let me know...I am usually near the computer.

73

Mark


Re: C Bridge to P25 Reflector

Michael KD5DFB
 

Thank you! I will change the files and test

Michael KD5DFB

On Wed, Jul 18, 2018 at 4:14 PM, Steve N4IRS <szingman@...> wrote:
Joe,
There is a BIG error in the diagram. It should be:
cbridge <-> ipsc_bridge <-> Analog_Bridge_1 <-> Analog_bridge_2 <-> MMDVM_Bridge <-> P25Gateway <-> P25Reflector

HB_Bridge is not needed. That's what I get for copy and paste.

Steve

On 07/18/2018 03:03 PM, KD5DFB wrote:
All, I still need help with my bridge. I have voice traffic to hb bridge on the dmr side and p25 voice traffic to the analog bridge. Still struggling to understand how to get these 2 connected . 

As always, Thank you for your help Steve! 

On Tue, Jul 17, 2018 at 1:51 PM, Steve N4IRS <szingman@...> wrote:
##################################              ################################
# IPSC_Bridge configuration file #              #
HB_Bridge configuration file #           
##################################              ################################

[DEFAULTS]                                      [DEFAULTS]
gateway = 127.0.0.1                            
gateway = 127.0.0.1                             
fromGatewayPort = 31000                        
toGatewayPort = 31000
toGatewayPort = 31003                          
fromGatewayPort = 31003                          


The above assumes you are not using those port number somewhere else. If you are, make the unique.
example: change 31000 to 31999 change 31003 to 31993

On 7/17/2018 2:38 PM, KD5DFB wrote:
Steve, I really appreciate your help! My apologies, but, I just can see it. 

On Tue, Jul 17, 2018 at 12:57 PM, Steve N4IRS <szingman@...> wrote:
dmrlink.cfg and hblink.cfg define their respective network connections. IPSC_Bridge.cfg and HB_Bridge.cfg define their respective Partner connections.

On 7/17/2018 1:55 PM, KD5DFB wrote:
Okay, let me take a step back and break it down again. 

So, IPSC_Bridge uses both dmrlink.cfg and IPSC_bridge.cfg.  The dmrlink.cfg defines the connection to the cbridge and I see it connected on the control center. IPSC_Bridge.cfg defines the connection to HB_Bridge. Is that defined in the HB_Bridge.cfg or hblink.cfg?

On Tue, Jul 17, 2018 at 12:44 PM, Steve N4IRS <szingman@...> wrote:
No,
You can use the same port number twice. I try to use the default port numbers where possible. Since you can't use a port twice, you will have to change something. 

On 7/17/2018 1:38 PM, KD5DFB wrote:
Ok, so let me see if I got it correct. So basically all 3 of them use the same port numbers just changing the TX and RX? 

IPSC_Bridge.cfg                     HB_Bridge.cfg                  Analog_Bridge.ini
fromgateway: 31100              fromGateway: 31103         from: 31100
toGateway: 31103                  toGateway: 31100            to: 31103

On Tue, Jul 17, 2018 at 10:00 AM, Steve N4IRS <szingman@...> wrote:


On 7/17/2018 10:51 AM, KD5DFB wrote:
Okay, making progress! I am stumped on the last piece. 

I am trying to figure out the connection between ipsc_bridge and hb_bridge. 

On ipsc_bridge, I have the dmrlink.cfg connecting to the cbridge and can see traffic from the cbridge in the log. Does the ipsc_bridge.cfg connect to hb_bridge.cfg?
Yes

On the hb_bridge I am a little confused. Does the hb_bridge.cfg connect to analog_bridge? Does the ambe need to match what is in analog_bridge?
Just like connecting any of the partners, TX to RX and RX to TX (or words to that effect) Analog_Bridge [AMBE_AUDIO] stanza points to the values in the HB_Bridge [DEFAULTS] stanza.

[AMBE]
EXPORT_IP: 127.0.0.1
EXPORT_PORT: 1234
Ignore these


On Mon, Jul 16, 2018, 21:02 Steve N4IRS <szingman@...> wrote:
I like separate directories at first. Makes it easy to keep things visible. Yes, I uses systemd.
 

On 07/16/2018 09:55 PM, KD5DFB wrote:
Thank you! 

What is your recommendation on running 2 analog bridges? Do I make a new directory and copy the analog_bridge files into it? How can I run 2 at a time? Do I use systemctl? 

On Mon, Jul 16, 2018 at 8:47 PM, Steve N4IRS <szingman@...> wrote:
Walk through it one module at a time. You should see the traffic at each step.

On 07/16/2018 09:44 PM, KD5DFB wrote:
Success! Do I need to change anything else under [AMBE_AUDIO] for Analog_bridge_2?


I: 2018-07-17 01:39:11.007 Begin TX: src=3148242 rpt=0 dst=8207 slot=2 cc=0
D: 2018-07-17 01:39:12.824 End TX
I: 2018-07-17 01:39:21.690 Begin TX: src=3148242 rpt=0 dst=8207 slot=2 cc=0
D: 2018-07-17 01:39:23.327 End TX
I: 2018-07-17 01:39:25.043 Begin TX: src=3148242 rpt=0 dst=8207 slot=2 cc=0
D: 2018-07-17 01:39:25.594 End TX
I: 2018-07-17 01:39:39.947 Begin TX: src=3148242 rpt=0 dst=8207 slot=2 cc=0
D: 2018-07-17 01:39:44.125 End TX
 

On Mon, Jul 16, 2018 at 8:20 PM, Steve N4IRS <szingman@...> wrote:
You need to make sure the P25 TX and RX ports in DVSwitch.ini point to the proper ports in Analog_Bridge.ini

On 07/16/2018 09:15 PM, KD5DFB wrote:
Okay, trying to take this in small steps and not fry my noodle.

I am working from P25 reflector to c bridge. I have the p25 reflector up and running. I can see my voice traffic on the P25Gateway log and the MMDVM_Bridge log.

Is there anything else I need change in MMDVM_Bridge.ini? I have changed the following:

[General]
Callsign=KD5DFB
Id=314838

[P25]
Enable=1

[P25 Network]
Enable=1

On Analog_Bridge.ini

toASLPort = 32001 
fromASLPort = 34001  

Should I see any traffic if I tail the log or run it ./Analog_Bridge




On Mon, Jul 16, 2018 at 6:57 PM, Steve N4IRS <szingman@...> wrote:
IPSC_Bridge and HB_Bridge sub-class dmrlink and hblink. In other words, dmrlink and hblink are the network stack for IPSC_Bridge and HB_Bridge. So you configure hblink.cfg and hblink.cfg.
You will also need to install dmr_utils. Someday I hope IPSC_Bridge and HB_Bridge get merged into the master branches. One could only hope.

Steve N4IRS

On 07/16/2018 07:47 PM, KD5DFB wrote:
Okay, interesting... When I looked at the github under master they are not there. I had to change to branch to IPSC_bridge and HB-Bridge

So, When I look at the IPSC_Bridge.cfg. I only see this. How to I tell it to connect to the cbridge as a peer? 


# IPSC_Bridge configuration file #

##################################


# DEFAULTS - General settings. These values are

# inherited in each subsequent section (defined by section value).


[DEFAULTS]

gateway = 127.0.0.1 # IP address of Partner Application (HB_Bridge, Analog_Bridge)

fromGatewayPort = 31000 # Port IPSC_Bridge is listening on for data (IPSC_Bridge <--- Partner)

toGatewayPort = 31003 # Port Partner is listening on for data (IPSC_Bridge ---> Partner)


On Mon, Jul 16, 2018 at 6:32 PM, Steve N4IRS <szingman@...> wrote:
cbridge <-> ipsc_bridge <-> hb_Bridge <-> Analog_Bridge_1 <-> Analog_bridge_2 <-> MMDVM_Bridge <-> P25Gateway <-> P25Reflector

On 07/16/2018 07:29 PM, KD5DFB wrote:
All,

I am trying to setup a bridge between my C Bridge port and my P25 Reflector. When looking at older post I see reference to IPSC_Bridge and HB_bridge. Are those no longer applicable? Do I just use dmrlink and hb_bridge_all ? 

This is what I think it should be...

cbridge <-> dmrlink <-> hblink <-> hb_bridge_all <-> mb1 <-> ab1 <-> ab2 <-> mb2 <-> p25gateway <-> p25reflector

As of right now, I have dmrlink connect to the c bridge and when I tail the log, I can see traffic from dmr. Same on the other side. I have mb2 connectd thru the p25gateway to my p25 reflector. When I tail the log, I can see the p25 traffic. 

Just need some help between the cbridge and mb1 :-)

Michael KD5DFB




















Re: C Bridge to P25 Reflector

Steve N4IRS
 

Joe,
There is a BIG error in the diagram. It should be:
cbridge <-> ipsc_bridge <-> Analog_Bridge_1 <-> Analog_bridge_2 <-> MMDVM_Bridge <-> P25Gateway <-> P25Reflector

HB_Bridge is not needed. That's what I get for copy and paste.

Steve

On 07/18/2018 03:03 PM, KD5DFB wrote:
All, I still need help with my bridge. I have voice traffic to hb bridge on the dmr side and p25 voice traffic to the analog bridge. Still struggling to understand how to get these 2 connected . 

As always, Thank you for your help Steve! 

On Tue, Jul 17, 2018 at 1:51 PM, Steve N4IRS <szingman@...> wrote:
##################################              ################################
# IPSC_Bridge configuration file #              #
HB_Bridge configuration file #           
##################################              ################################

[DEFAULTS]                                      [DEFAULTS]
gateway = 127.0.0.1                            
gateway = 127.0.0.1                             
fromGatewayPort = 31000                        
toGatewayPort = 31000
toGatewayPort = 31003                          
fromGatewayPort = 31003                          


The above assumes you are not using those port number somewhere else. If you are, make the unique.
example: change 31000 to 31999 change 31003 to 31993

On 7/17/2018 2:38 PM, KD5DFB wrote:
Steve, I really appreciate your help! My apologies, but, I just can see it. 

On Tue, Jul 17, 2018 at 12:57 PM, Steve N4IRS <szingman@...> wrote:
dmrlink.cfg and hblink.cfg define their respective network connections. IPSC_Bridge.cfg and HB_Bridge.cfg define their respective Partner connections.

On 7/17/2018 1:55 PM, KD5DFB wrote:
Okay, let me take a step back and break it down again. 

So, IPSC_Bridge uses both dmrlink.cfg and IPSC_bridge.cfg.  The dmrlink.cfg defines the connection to the cbridge and I see it connected on the control center. IPSC_Bridge.cfg defines the connection to HB_Bridge. Is that defined in the HB_Bridge.cfg or hblink.cfg?

On Tue, Jul 17, 2018 at 12:44 PM, Steve N4IRS <szingman@...> wrote:
No,
You can use the same port number twice. I try to use the default port numbers where possible. Since you can't use a port twice, you will have to change something. 

On 7/17/2018 1:38 PM, KD5DFB wrote:
Ok, so let me see if I got it correct. So basically all 3 of them use the same port numbers just changing the TX and RX? 

IPSC_Bridge.cfg                     HB_Bridge.cfg                  Analog_Bridge.ini
fromgateway: 31100              fromGateway: 31103         from: 31100
toGateway: 31103                  toGateway: 31100            to: 31103

On Tue, Jul 17, 2018 at 10:00 AM, Steve N4IRS <szingman@...> wrote:


On 7/17/2018 10:51 AM, KD5DFB wrote:
Okay, making progress! I am stumped on the last piece. 

I am trying to figure out the connection between ipsc_bridge and hb_bridge. 

On ipsc_bridge, I have the dmrlink.cfg connecting to the cbridge and can see traffic from the cbridge in the log. Does the ipsc_bridge.cfg connect to hb_bridge.cfg?
Yes

On the hb_bridge I am a little confused. Does the hb_bridge.cfg connect to analog_bridge? Does the ambe need to match what is in analog_bridge?
Just like connecting any of the partners, TX to RX and RX to TX (or words to that effect) Analog_Bridge [AMBE_AUDIO] stanza points to the values in the HB_Bridge [DEFAULTS] stanza.

[AMBE]
EXPORT_IP: 127.0.0.1
EXPORT_PORT: 1234
Ignore these


On Mon, Jul 16, 2018, 21:02 Steve N4IRS <szingman@...> wrote:
I like separate directories at first. Makes it easy to keep things visible. Yes, I uses systemd.
 

On 07/16/2018 09:55 PM, KD5DFB wrote:
Thank you! 

What is your recommendation on running 2 analog bridges? Do I make a new directory and copy the analog_bridge files into it? How can I run 2 at a time? Do I use systemctl? 

On Mon, Jul 16, 2018 at 8:47 PM, Steve N4IRS <szingman@...> wrote:
Walk through it one module at a time. You should see the traffic at each step.

On 07/16/2018 09:44 PM, KD5DFB wrote:
Success! Do I need to change anything else under [AMBE_AUDIO] for Analog_bridge_2?


I: 2018-07-17 01:39:11.007 Begin TX: src=3148242 rpt=0 dst=8207 slot=2 cc=0
D: 2018-07-17 01:39:12.824 End TX
I: 2018-07-17 01:39:21.690 Begin TX: src=3148242 rpt=0 dst=8207 slot=2 cc=0
D: 2018-07-17 01:39:23.327 End TX
I: 2018-07-17 01:39:25.043 Begin TX: src=3148242 rpt=0 dst=8207 slot=2 cc=0
D: 2018-07-17 01:39:25.594 End TX
I: 2018-07-17 01:39:39.947 Begin TX: src=3148242 rpt=0 dst=8207 slot=2 cc=0
D: 2018-07-17 01:39:44.125 End TX
 

On Mon, Jul 16, 2018 at 8:20 PM, Steve N4IRS <szingman@...> wrote:
You need to make sure the P25 TX and RX ports in DVSwitch.ini point to the proper ports in Analog_Bridge.ini

On 07/16/2018 09:15 PM, KD5DFB wrote:
Okay, trying to take this in small steps and not fry my noodle.

I am working from P25 reflector to c bridge. I have the p25 reflector up and running. I can see my voice traffic on the P25Gateway log and the MMDVM_Bridge log.

Is there anything else I need change in MMDVM_Bridge.ini? I have changed the following:

[General]
Callsign=KD5DFB
Id=314838

[P25]
Enable=1

[P25 Network]
Enable=1

On Analog_Bridge.ini

toASLPort = 32001 
fromASLPort = 34001  

Should I see any traffic if I tail the log or run it ./Analog_Bridge




On Mon, Jul 16, 2018 at 6:57 PM, Steve N4IRS <szingman@...> wrote:
IPSC_Bridge and HB_Bridge sub-class dmrlink and hblink. In other words, dmrlink and hblink are the network stack for IPSC_Bridge and HB_Bridge. So you configure hblink.cfg and hblink.cfg.
You will also need to install dmr_utils. Someday I hope IPSC_Bridge and HB_Bridge get merged into the master branches. One could only hope.

Steve N4IRS

On 07/16/2018 07:47 PM, KD5DFB wrote:
Okay, interesting... When I looked at the github under master they are not there. I had to change to branch to IPSC_bridge and HB-Bridge

So, When I look at the IPSC_Bridge.cfg. I only see this. How to I tell it to connect to the cbridge as a peer? 


# IPSC_Bridge configuration file #

##################################


# DEFAULTS - General settings. These values are

# inherited in each subsequent section (defined by section value).


[DEFAULTS]

gateway = 127.0.0.1 # IP address of Partner Application (HB_Bridge, Analog_Bridge)

fromGatewayPort = 31000 # Port IPSC_Bridge is listening on for data (IPSC_Bridge <--- Partner)

toGatewayPort = 31003 # Port Partner is listening on for data (IPSC_Bridge ---> Partner)


On Mon, Jul 16, 2018 at 6:32 PM, Steve N4IRS <szingman@...> wrote:
cbridge <-> ipsc_bridge <-> hb_Bridge <-> Analog_Bridge_1 <-> Analog_bridge_2 <-> MMDVM_Bridge <-> P25Gateway <-> P25Reflector

On 07/16/2018 07:29 PM, KD5DFB wrote:
All,

I am trying to setup a bridge between my C Bridge port and my P25 Reflector. When looking at older post I see reference to IPSC_Bridge and HB_bridge. Are those no longer applicable? Do I just use dmrlink and hb_bridge_all ? 

This is what I think it should be...

cbridge <-> dmrlink <-> hblink <-> hb_bridge_all <-> mb1 <-> ab1 <-> ab2 <-> mb2 <-> p25gateway <-> p25reflector

As of right now, I have dmrlink connect to the c bridge and when I tail the log, I can see traffic from dmr. Same on the other side. I have mb2 connectd thru the p25gateway to my p25 reflector. When I tail the log, I can see the p25 traffic. 

Just need some help between the cbridge and mb1 :-)

Michael KD5DFB



















Re: not connecting to Brandmeister still

Corey Dean N3FE <n3fe@...>
 

How about 109.226.57.187

On Wed, Jul 18, 2018 at 3:43 PM, mark rosenberg <4x1ks.mark@...> wrote:
e.g.   4251  or   4251.repeater.net  ?

On Wed, Jul 18, 2018, 22:41 Steve N4IRS <szingman@...> wrote:
You need to know the address or FQDN of you master.

On 7/18/2018 3:40 PM, mark rosenberg wrote:
No not sure...i can try removing that...

On Wed, Jul 18, 2018, 22:38 Steve N4IRS <szingman@...> wrote:
Are you sure it's .repeater.net?

On 7/18/2018 3:36 PM, mark rosenberg wrote:
4251 is the israel brandmeister master.

I am running this on a vurtl cloud so i use sudo to preface commands...not sure how to print or download the .ini file

I am happy to send you the file but need instructions on how to copy it from the cloud.

I can use any server...i have used 2042 in the past...that is amsterdam...but our 4251 master is pretty good

On Wed, Jul 18, 2018, 22:32 Steve N4IRS <szingman@...> wrote:
Take out the comments. They will cause problems. What is 4251.repeater.net?
To be honest, trying to work from a picture is a pain. Please post the actual file.


On 7/18/2018 3:25 PM, mark rosenberg wrote:
See attached pics

On Wed, Jul 18, 2018, 22:20 Steve N4IRS <szingman@...> wrote:
Show us your MMDVM_Bridge.ini

On 7/18/2018 3:05 PM, mark rosenberg wrote:
sure.  btw...I just ran the foreground status of the mmdvm bridge....like this.... sudo ./ MMDVM_Bridge MMDVM_Bridge.ini  and i am attaching a pic of the results...error 13...see attached.

Please send me an email to my 4x1ks.mark@...
address so I can set you up to SSH.  Tell me what you need to get in. 






Re: not connecting to Brandmeister still

Steve N4IRS
 

On 7/18/2018 3:43 PM, mark rosenberg wrote:
e.g.   4251  or   4251.repeater.net  ?

On Wed, Jul 18, 2018, 22:41 Steve N4IRS <szingman@...> wrote:
You need to know the address or FQDN of you master.

On 7/18/2018 3:40 PM, mark rosenberg wrote:
No not sure...i can try removing that...

On Wed, Jul 18, 2018, 22:38 Steve N4IRS <szingman@...> wrote:
Are you sure it's .repeater.net?

On 7/18/2018 3:36 PM, mark rosenberg wrote:
4251 is the israel brandmeister master.

I am running this on a vurtl cloud so i use sudo to preface commands...not sure how to print or download the .ini file

I am happy to send you the file but need instructions on how to copy it from the cloud.

I can use any server...i have used 2042 in the past...that is amsterdam...but our 4251 master is pretty good

On Wed, Jul 18, 2018, 22:32 Steve N4IRS <szingman@...> wrote:
Take out the comments. They will cause problems. What is 4251.repeater.net?
To be honest, trying to work from a picture is a pain. Please post the actual file.


On 7/18/2018 3:25 PM, mark rosenberg wrote:
See attached pics

On Wed, Jul 18, 2018, 22:20 Steve N4IRS <szingman@...> wrote:
Show us your MMDVM_Bridge.ini

On 7/18/2018 3:05 PM, mark rosenberg wrote:
sure.  btw...I just ran the foreground status of the mmdvm bridge....like this.... sudo ./ MMDVM_Bridge MMDVM_Bridge.ini  and i am attaching a pic of the results...error 13...see attached.

Please send me an email to my 4x1ks.mark@...
address so I can set you up to SSH.  Tell me what you need to get in. 






Re: not connecting to Brandmeister still

Corey Dean N3FE <n3fe@...>
 

repeater.net is owned by me and only used on the USA BM Masters.

Corey  N3FE

On Wed, Jul 18, 2018 at 3:36 PM, mark rosenberg <4x1ks.mark@...> wrote:
4251 is the israel brandmeister master.

I am running this on a vurtl cloud so i use sudo to preface commands...not sure how to print or download the .ini file

I am happy to send you the file but need instructions on how to copy it from the cloud.

I can use any server...i have used 2042 in the past...that is amsterdam...but our 4251 master is pretty good

On Wed, Jul 18, 2018, 22:32 Steve N4IRS <szingman@...> wrote:
Take out the comments. They will cause problems. What is 4251.repeater.net?
To be honest, trying to work from a picture is a pain. Please post the actual file.


On 7/18/2018 3:25 PM, mark rosenberg wrote:
See attached pics

On Wed, Jul 18, 2018, 22:20 Steve N4IRS <szingman@...> wrote:
Show us your MMDVM_Bridge.ini

On 7/18/2018 3:05 PM, mark rosenberg wrote:
sure.  btw...I just ran the foreground status of the mmdvm bridge....like this.... sudo ./ MMDVM_Bridge MMDVM_Bridge.ini  and i am attaching a pic of the results...error 13...see attached.

Please send me an email to my 4x1ks.mark@...
address so I can set you up to SSH.  Tell me what you need to get in. 




Re: not connecting to Brandmeister still

mark rosenberg
 

e.g.   4251  or   4251.repeater.net  ?


On Wed, Jul 18, 2018, 22:41 Steve N4IRS <szingman@...> wrote:
You need to know the address or FQDN of you master.

On 7/18/2018 3:40 PM, mark rosenberg wrote:
No not sure...i can try removing that...

On Wed, Jul 18, 2018, 22:38 Steve N4IRS <szingman@...> wrote:
Are you sure it's .repeater.net?

On 7/18/2018 3:36 PM, mark rosenberg wrote:
4251 is the israel brandmeister master.

I am running this on a vurtl cloud so i use sudo to preface commands...not sure how to print or download the .ini file

I am happy to send you the file but need instructions on how to copy it from the cloud.

I can use any server...i have used 2042 in the past...that is amsterdam...but our 4251 master is pretty good

On Wed, Jul 18, 2018, 22:32 Steve N4IRS <szingman@...> wrote:
Take out the comments. They will cause problems. What is 4251.repeater.net?
To be honest, trying to work from a picture is a pain. Please post the actual file.


On 7/18/2018 3:25 PM, mark rosenberg wrote:
See attached pics

On Wed, Jul 18, 2018, 22:20 Steve N4IRS <szingman@...> wrote:
Show us your MMDVM_Bridge.ini

On 7/18/2018 3:05 PM, mark rosenberg wrote:
sure.  btw...I just ran the foreground status of the mmdvm bridge....like this.... sudo ./ MMDVM_Bridge MMDVM_Bridge.ini  and i am attaching a pic of the results...error 13...see attached.

Please send me an email to my 4x1ks.mark@...
address so I can set you up to SSH.  Tell me what you need to get in. 





Re: not connecting to Brandmeister still

Steve N4IRS
 

You need to know the address or FQDN of you master.

On 7/18/2018 3:40 PM, mark rosenberg wrote:
No not sure...i can try removing that...

On Wed, Jul 18, 2018, 22:38 Steve N4IRS <szingman@...> wrote:
Are you sure it's .repeater.net?

On 7/18/2018 3:36 PM, mark rosenberg wrote:
4251 is the israel brandmeister master.

I am running this on a vurtl cloud so i use sudo to preface commands...not sure how to print or download the .ini file

I am happy to send you the file but need instructions on how to copy it from the cloud.

I can use any server...i have used 2042 in the past...that is amsterdam...but our 4251 master is pretty good

On Wed, Jul 18, 2018, 22:32 Steve N4IRS <szingman@...> wrote:
Take out the comments. They will cause problems. What is 4251.repeater.net?
To be honest, trying to work from a picture is a pain. Please post the actual file.


On 7/18/2018 3:25 PM, mark rosenberg wrote:
See attached pics

On Wed, Jul 18, 2018, 22:20 Steve N4IRS <szingman@...> wrote:
Show us your MMDVM_Bridge.ini

On 7/18/2018 3:05 PM, mark rosenberg wrote:
sure.  btw...I just ran the foreground status of the mmdvm bridge....like this.... sudo ./ MMDVM_Bridge MMDVM_Bridge.ini  and i am attaching a pic of the results...error 13...see attached.

Please send me an email to my 4x1ks.mark@...
address so I can set you up to SSH.  Tell me what you need to get in. 





Re: not connecting to Brandmeister still

mark rosenberg
 

No not sure...i can try removing that...


On Wed, Jul 18, 2018, 22:38 Steve N4IRS <szingman@...> wrote:
Are you sure it's .repeater.net?

On 7/18/2018 3:36 PM, mark rosenberg wrote:
4251 is the israel brandmeister master.

I am running this on a vurtl cloud so i use sudo to preface commands...not sure how to print or download the .ini file

I am happy to send you the file but need instructions on how to copy it from the cloud.

I can use any server...i have used 2042 in the past...that is amsterdam...but our 4251 master is pretty good

On Wed, Jul 18, 2018, 22:32 Steve N4IRS <szingman@...> wrote:
Take out the comments. They will cause problems. What is 4251.repeater.net?
To be honest, trying to work from a picture is a pain. Please post the actual file.


On 7/18/2018 3:25 PM, mark rosenberg wrote:
See attached pics

On Wed, Jul 18, 2018, 22:20 Steve N4IRS <szingman@...> wrote:
Show us your MMDVM_Bridge.ini

On 7/18/2018 3:05 PM, mark rosenberg wrote:
sure.  btw...I just ran the foreground status of the mmdvm bridge....like this.... sudo ./ MMDVM_Bridge MMDVM_Bridge.ini  and i am attaching a pic of the results...error 13...see attached.

Please send me an email to my 4x1ks.mark@...
address so I can set you up to SSH.  Tell me what you need to get in. 




Re: not connecting to Brandmeister still

Steve N4IRS
 

Are you sure it's .repeater.net?

On 7/18/2018 3:36 PM, mark rosenberg wrote:
4251 is the israel brandmeister master.

I am running this on a vurtl cloud so i use sudo to preface commands...not sure how to print or download the .ini file

I am happy to send you the file but need instructions on how to copy it from the cloud.

I can use any server...i have used 2042 in the past...that is amsterdam...but our 4251 master is pretty good

On Wed, Jul 18, 2018, 22:32 Steve N4IRS <szingman@...> wrote:
Take out the comments. They will cause problems. What is 4251.repeater.net?
To be honest, trying to work from a picture is a pain. Please post the actual file.


On 7/18/2018 3:25 PM, mark rosenberg wrote:
See attached pics

On Wed, Jul 18, 2018, 22:20 Steve N4IRS <szingman@...> wrote:
Show us your MMDVM_Bridge.ini

On 7/18/2018 3:05 PM, mark rosenberg wrote:
sure.  btw...I just ran the foreground status of the mmdvm bridge....like this.... sudo ./ MMDVM_Bridge MMDVM_Bridge.ini  and i am attaching a pic of the results...error 13...see attached.

Please send me an email to my 4x1ks.mark@...
address so I can set you up to SSH.  Tell me what you need to get in. 




Re: not connecting to Brandmeister still

mark rosenberg
 

4251 is the israel brandmeister master.

I am running this on a vurtl cloud so i use sudo to preface commands...not sure how to print or download the .ini file

I am happy to send you the file but need instructions on how to copy it from the cloud.

I can use any server...i have used 2042 in the past...that is amsterdam...but our 4251 master is pretty good

On Wed, Jul 18, 2018, 22:32 Steve N4IRS <szingman@...> wrote:
Take out the comments. They will cause problems. What is 4251.repeater.net?
To be honest, trying to work from a picture is a pain. Please post the actual file.


On 7/18/2018 3:25 PM, mark rosenberg wrote:
See attached pics

On Wed, Jul 18, 2018, 22:20 Steve N4IRS <szingman@...> wrote:
Show us your MMDVM_Bridge.ini

On 7/18/2018 3:05 PM, mark rosenberg wrote:
sure.  btw...I just ran the foreground status of the mmdvm bridge....like this.... sudo ./ MMDVM_Bridge MMDVM_Bridge.ini  and i am attaching a pic of the results...error 13...see attached.

Please send me an email to my 4x1ks.mark@...
address so I can set you up to SSH.  Tell me what you need to get in. 



Re: not connecting to Brandmeister still

Steve N4IRS
 

Take out the comments. They will cause problems. What is 4251.repeater.net?
To be honest, trying to work from a picture is a pain. Please post the actual file.


On 7/18/2018 3:25 PM, mark rosenberg wrote:
See attached pics

On Wed, Jul 18, 2018, 22:20 Steve N4IRS <szingman@...> wrote:
Show us your MMDVM_Bridge.ini

On 7/18/2018 3:05 PM, mark rosenberg wrote:
sure.  btw...I just ran the foreground status of the mmdvm bridge....like this.... sudo ./ MMDVM_Bridge MMDVM_Bridge.ini  and i am attaching a pic of the results...error 13...see attached.

Please send me an email to my 4x1ks.mark@...
address so I can set you up to SSH.  Tell me what you need to get in. 



Re: not connecting to Brandmeister still

mark rosenberg
 

See attached pics


On Wed, Jul 18, 2018, 22:20 Steve N4IRS <szingman@...> wrote:
Show us your MMDVM_Bridge.ini

On 7/18/2018 3:05 PM, mark rosenberg wrote:
sure.  btw...I just ran the foreground status of the mmdvm bridge....like this.... sudo ./ MMDVM_Bridge MMDVM_Bridge.ini  and i am attaching a pic of the results...error 13...see attached.

Please send me an email to my 4x1ks.mark@...
address so I can set you up to SSH.  Tell me what you need to get in. 

7941 - 7960 of 9820