Date   

Re: YSF Narrow to P25 Bridge with strange issue

Steve N4IRS
 

Jeff,
Try this for me as root:
cd to the directory containing MMDVM_Bridge
stop the MMDVM_Bridge service
mv MMDVM_Bridge MMDVM_Bridge.old
wget https://github.com/DVSwitch/MMDVM_Bridge/raw/master/bin/MMDVM_Bridge.amd64.test
mv MMDVM_Bridge.amd64.test MMDVM_Bridge
chmod +x MMDVM_Bridge
start the MMDVM_Bridge service
retest
Let us know the results.

Steve N4IRS


Re: YSF Narrow to P25 Bridge with strange issue

Jeff Scoville
 

Steve,

Result of running uname -a on the machine running MMDVM_Bridge was:

Linux ip-172-26-1-88 4.14.62-65.117.amzn1.x86_64 #1 SMP Fri Aug 10 20:03:52 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

--Jeff AE5ME


Re: YSF Narrow to P25 Bridge with strange issue

Steve N4IRS
 

Jeff,
Please show me the result of uname -a on the machine running MMDVM_Bridge.

Steve

On 4/8/2019 10:48 AM, Jeff Scoville via Groups.Io wrote:
And the complete Ubuntu version is 16.04.

--Jeff AE5ME


Re: BM to XLX via MMDVM_Bridge - Doc version 2.0

Steve KC1AWV
 

Does this create a bridge to DSTAR?
No. This document is to connect an XLX module to a Brandmeister Talkgroup. Brandmeister is a DMR network.

Should I build another Allstar node to add this to or could I do this on my current DMR bridge?
I don't know how your current bridge is configured. You're also discussing two different modes. D-Star and DMR are dissimilar modes, where D-Star is IMBE and DMR is AMBE. If the intention is to bridge a DMR network to D-Star, you will need to do some transcoding, which is out of scope for this document.

That being said, no you don't necessarily have to build another ASL node. You can run a second bridge for D-Star from the ASL node you currently have. A basic overview would be this:

D-Star <-> ASL <-> DMR

That setup will give you the following:

  • D-Star to Analog via ASL
  • D-Star to DMR using ASL to transcode
  • Analog to D-Star via ASL
  • Analog to DMR via ASL
  • DMR to Analog via ASL
  • DMR to D-Star using ASL to transcode
-- 
Steve Miller
KC1AWV


Re: BM to XLX via MMDVM_Bridge - Doc version 2.0

K4VL
 

I have a couple of questions about this. Does this create a bridge to DSTAR? I have a DMR bridge running now and linking to my server through Allstar. Should I build another Allstar node to add this to or could I do this on my current DMR bridge? I would be nice to have everything including my repeater running on one Pi but I will do what I need to do. My repeater controller is a Hamvoip build and my DMR bridge is an ASL build.


BM to XLX via MMDVM_Bridge - Doc version 2.0

Steve KC1AWV
 

Special thanks to Eric Dayrit and Doug Gooden for assistance in helping me refine this doc.

https://docs.google.com/document/d/1n17cx_9elLJoMmcQWM0_XOm2dicKdIC6ar_0S16904A

Revision 2.0 is a rewrite of the original document I created.
This revision is for showing how to use DMRGateway's TGRewrite function to allow the use of the "standard" XLX Talkgroup 6 and send that data to a BM Talkgroup of your choice, and vice versa.

The end result of the doc is this:

XLX***D <-> DMRGateway_XLX <-> MMDVM_Bridge_XLX <-> MMDVM_Bridge_BM <-> DMRGateway_BM <-> BM TG****


Two DMRGateways are needed, since the TGRewrite function is only provided by DMRGateway.

I'll try to format the doc a little better for viewing pleasure, but all the information that is needed should be there.

Steve KC1AWV


Re: YSF Narrow to P25 Bridge with strange issue

Jeff Scoville
 

And the complete Ubuntu version is 16.04.

--Jeff AE5ME


Re: YSF Narrow to P25 Bridge with strange issue

Jeff Scoville
 

Steve,

Everything EXCEPT the Analog bridges are running on Amazon Linux (Centos derivative).  The analog bridges are running on a separate Ubuntu 16 Amazon hosted machine.  The machines are connected by UDP ports 31100 31103 34100 34103 and firewalls have been opened on both ends.

The P25 gateway, P25 Reflector, and YSF Reflector have all worked well on Amazon Linux before the recent addition of the Analog bridges and MMDVM bridge.  When we ran MMDVM bridge as a direction connection between the P25 gateway and the YSF reflector, it passed the YSFW and P25 back and forth correctly and had correct callsigns on all stations, so it appears to be working correctly, even though it is being hosted on a Centos machine.

We added the Analog bridges and modified the MMDVM Bridge so that we could start passing YSFN to P25 and vice versa.  As I stated earlier, those were added on the additional Ubuntu machine.

Eventually all the Amazon Linux/Centos reflectors will be migrated to the Ubuntu machine, but we need to coordinate that properly so that the static IP is transferred at the same time to prevent a loss in service to the member hotspots.  In hindsight, should have started out on Ubuntu with the reflectors, considering some of the comments that Debian is the preferred platform for running the DVSwitch programs.

Thanks again for your help!

--Jeff AE5ME


Re: YSF Narrow to P25 Bridge with strange issue

Steve N4IRS
 

Jeff what architecture are you running? OS version?

Steve

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Jeff Scoville via Groups.Io <ae5me@...>
Sent: Sunday, April 7, 2019 11:00:28 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] YSF Narrow to P25 Bridge with strange issue
 
Additional info.  There appears to be no metadata going out on the YSF side of the analog bridge.  This came from the log:

 YSF, Begin TX: src=3140122 rpt=314012210 dst=31403 slot=1 cc=1 metadata=

--Jeff AE5ME


Re: YSF Narrow to P25 Bridge with strange issue

Jeff Scoville
 

Additional info.  There appears to be no metadata going out on the YSF side of the analog bridge.  This came from the log:

 YSF, Begin TX: src=3140122 rpt=314012210 dst=31403 slot=1 cc=1 metadata=

--Jeff AE5ME


YSF Narrow to P25 Bridge with strange issue

Jeff Scoville
 

Finally got a YSF Narrow to P25 bridge going using two Analog bridges to bridge the audio.  It is connecting a YSF Reflector to a P25 Reflector.

When I look at the YSF Reflector dashboard, P25 station callsigns come across fine.  Can connect a YSF Pi-star hotspot and hear traffic fine.

However, with an OPENSPOT connected to the YSF Reflector, it shows the callsign for all P25 traffic as N4IRR and with a encoding type of VW instead of DN.  In our system, we have a crossover bridge from YSF to Wires-X using an OPENSPOT that is on the same frequency as a local Wires-X node.  The Wires-X node will not pass the traffic from the YSF reflector to Wires-X for the P25 transcoded stations.  This behavior is odd as the MMDVM bridge is reporting the traffic as 72 bit AMBE, not 88 bit.  Don't know how the "VW" is entering into the mix on the OPENSPOT.

Stations on YSF or Wires-X travel through the YSF Reflector, analog bridge, and P25 reflector fine and are heard with the correct callsign on the P25 Reflector via a Pi-Star hotspot running P25 locally.  No change in callsign.

Any ideas what could be misconfigured?

--Jeff AE5ME


Re: Wave PTT subscription and DVSwitch config's #best_practices #dmrlink

 

Just wanted to see if anyone got this to work? We are trying to link one of our Local DMR repeaters over to Motorola's WAVE OnCloud system so we could have access to from our iPhones / TLK-100's.

Thanks in Advance!
-Ted/KE6YJC


dstar linkning

Kevin Halton
 

Is there anyone who has a good understanding of linkning dstar to DMRlink package? I need some help!_._,_._,_


Re: Error running Analog_bridge

David McGough
 

Another way to "just get it running" is to simply grab the libsndfile.*
library files from another AMD64 system, like debian. Make a
folder /mylibs and put the copied libs in /mylibs.

Then, from the bash prompt as root:

cp /etc/ld.so.conf /etc/ld.so.conf.save
echo /mylibs >> /etc/ld.so.conf
ldconfig

....That should do it....Not that I'm recommending a "nasty hack," but it
can get you going. Note that the first step is simply to make a backup of
the original file. Be careful with the /etc/ld.so.conf file. If it gets
damaged badly, your install may end up fried.


73, David KB4FXC

On Sun, 7 Apr 2019, Russell, KV4S wrote:

On AWS install Ubuntu 16 not 18. ASL and dvswitch seem to work fine.

On Sun, Apr 7, 2019, 10:27 AM Mike KB8JNM <groupio@midnighteng.com> wrote:

I don't know if you can make it work or not, but i can tell you that
version is based on centos.

While I have plenty of centos experience, app_rpt use to run on it (ACID),
I don't use it with app_rpt anymore as I stay on the beaten path so most
support issues are the same and likely 'known'.

Not familiar with AWS services and someone who does may chime in and point
you in the right direction.

But if you are willing to try different service I use and have validated
with it all...

https://wiki.allstarlink.org/wiki/ASL_DEBIAN-9_INSTALL_ON_VULTR


On 4/7/2019 11:09 AM, Jeff Scoville via Groups.Io wrote:

Result from cat /etc/*-release:

AME="cpe:/o:amazon:linux:2018.03:ga"
HOME_URL="http://aws.amazon.com/amazon-linux-ami/"
<http://aws.amazon.com/amazon-linux-ami/>
Amazon Linux AMI release 2018.03

As I stated in my post, I am running a AWS Linux. Looks like it's time to
spin up a Debian machine on AWS if there is no way to get the appropriate
shared libraries loaded to run.

--Jeff AE5ME





Re: Error running Analog_bridge

 

On AWS install Ubuntu 16 not 18. ASL and dvswitch seem to work fine.

On Sun, Apr 7, 2019, 10:27 AM Mike KB8JNM <groupio@...> wrote:

I don't know if you can make it work or not, but i can tell you that version is based on centos.

While I have plenty of centos experience, app_rpt use to run on it (ACID), I don't use it with app_rpt anymore as I stay on the beaten path so most support issues are the same and likely 'known'.

Not familiar with AWS services and someone who does may chime in and point you in the right direction.

But if you are willing to try different service I use and have validated with it all...

https://wiki.allstarlink.org/wiki/ASL_DEBIAN-9_INSTALL_ON_VULTR


On 4/7/2019 11:09 AM, Jeff Scoville via Groups.Io wrote:
Result from cat /etc/*-release:

AME="cpe:/o:amazon:linux:2018.03:ga"
Amazon Linux AMI release 2018.03

As I stated in my post, I am running a AWS Linux.  Looks like it's time to spin up a Debian machine on AWS if there is no way to get the appropriate shared libraries loaded to run.

--Jeff AE5ME


Re: Error running Analog_bridge

Mike KB8JNM
 

I don't know if you can make it work or not, but i can tell you that version is based on centos.

While I have plenty of centos experience, app_rpt use to run on it (ACID), I don't use it with app_rpt anymore as I stay on the beaten path so most support issues are the same and likely 'known'.

Not familiar with AWS services and someone who does may chime in and point you in the right direction.

But if you are willing to try different service I use and have validated with it all...

https://wiki.allstarlink.org/wiki/ASL_DEBIAN-9_INSTALL_ON_VULTR


On 4/7/2019 11:09 AM, Jeff Scoville via Groups.Io wrote:
Result from cat /etc/*-release:

AME="cpe:/o:amazon:linux:2018.03:ga"
Amazon Linux AMI release 2018.03

As I stated in my post, I am running a AWS Linux.  Looks like it's time to spin up a Debian machine on AWS if there is no way to get the appropriate shared libraries loaded to run.

--Jeff AE5ME


Re: Error running Analog_bridge

Jeff Scoville
 

Result from cat /etc/*-release:

AME="cpe:/o:amazon:linux:2018.03:ga"
HOME_URL="http://aws.amazon.com/amazon-linux-ami/"
Amazon Linux AMI release 2018.03

As I stated in my post, I am running a AWS Linux.  Looks like it's time to spin up a Debian machine on AWS if there is no way to get the appropriate shared libraries loaded to run.

--Jeff AE5ME


Re: Error running Analog_bridge

Mike KB8JNM
 

What full version of linux are you running.

cat /etc/*-release

It appears you are using 'centos'

You should be using 'Debian v9' to be par with the program.

Best advise is to stay on the beaten path, especially till you understand the software and setup.


On 4/7/2019 12:10 AM, Jeff Scoville via Groups.Io wrote:
Running Analog_Bridge AMD64 version, on AWS Linux, I get an error "error while loading shared libraries: libsndfile..........

Can't find libsndfile in yum for installing.  Is there a way to install the required library?

--Jeff AE5ME




Error running Analog_bridge

Jeff Scoville
 

Running Analog_Bridge AMD64 version, on AWS Linux, I get an error "error while loading shared libraries: libsndfile..........

Can't find libsndfile in yum for installing.  Is there a way to install the required library?

--Jeff AE5ME




Re: Bridging a P25Reflector and a YSFReflector?

Alec-N1AJW
 

that's an excellent idea.   Love it.  cant wait to see it work.   Thanks.

Alec
N1AJW

6221 - 6240 of 9925