Date   

Re: NOOB Setup-Configuration Help #analog_bridge #dmrlink

Chris K7AZ
 

I kinda knew I was missing something simple... that was it.. thank you.  :)



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Steve N4IRS <szingman@...>
Date: 7/30/19 06:11 (GMT-08:00)
To: main@dvswitch.groups.io
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

You should be in /opt/MMDVM_Bridge directory.

Sent via smoke signal (AT&T)


From: main@... <main@DVSwitch.groups.io> on behalf of Chris K7AZ via Groups.Io <kilo7alphazulu@...>
Sent: Tuesday, July 30, 2019 9:09:35 AM
To: main@DVSwitch.groups.io <main@DVSwitch.groups.io>
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge
 
I'm entering that at the root level and it just says: 
bash: ./MMDVM_Bridge: No such file or directory.

Maybe I'm at the wrong level?  



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Steve N4IRS <szingman@...>
Date: 7/30/19 02:32 (GMT-08:00)
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

It is the netx line in the document.

Time to test

Run MMDVM_Bridge in the foreground

./MMDVM_Bridge MMDVM_Bridge.ini

No, the ports do not need to be forwarded.


On 7/29/19 11:47 PM, Chris K7AZ via Groups.Io wrote:
I'm stuck at:
Time to test
Run MMDVM_Bridge in the foreground.  HOW?

Also, do ports 62031 and 62032 need to be forwarded? 

Thanks,
Chris K7AZ 



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: "Chris K7AZ via Groups.Io" <kilo7alphazulu@...>
Date: 7/29/19 08:45 (GMT-08:00)
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

Thanks Steve :)



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Steve N4IRS <szingman@...>
Date: 7/29/19 08:42 (GMT-08:00)
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

<https://docs.google.com/document/d/1eN50Csr29eAprBu7eKA0Bfa2XUcsXw5iktY1Ey-Qjkg/edit?usp=sharing>


Steve N4IRS


On 7/29/2019 11:34 AM, Chris K7AZ via Groups.Io wrote:
Seeking assistance setting up an ASL to DMR interface.  Platform is a private VM server.   I have an ASL node set up 29837 and I'm about 70% into the DMR transcoder part when things started to not cooperate.  TeamViewer available.
Evenings 6-8 PM CA time is best for me.    

Thank you,
Chris K7AZ 


Re: NOOB Setup-Configuration Help #analog_bridge #dmrlink

Steve N4IRS
 

You should be in /opt/MMDVM_Bridge directory.

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Chris K7AZ via Groups.Io <kilo7alphazulu@...>
Sent: Tuesday, July 30, 2019 9:09:35 AM
To: main@DVSwitch.groups.io <main@DVSwitch.groups.io>
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge
 
I'm entering that at the root level and it just says: 
bash: ./MMDVM_Bridge: No such file or directory.

Maybe I'm at the wrong level?  



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Steve N4IRS <szingman@...>
Date: 7/30/19 02:32 (GMT-08:00)
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

It is the netx line in the document.

Time to test

Run MMDVM_Bridge in the foreground

./MMDVM_Bridge MMDVM_Bridge.ini

No, the ports do not need to be forwarded.


On 7/29/19 11:47 PM, Chris K7AZ via Groups.Io wrote:
I'm stuck at:
Time to test
Run MMDVM_Bridge in the foreground.  HOW?

Also, do ports 62031 and 62032 need to be forwarded? 

Thanks,
Chris K7AZ 



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: "Chris K7AZ via Groups.Io" <kilo7alphazulu@...>
Date: 7/29/19 08:45 (GMT-08:00)
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

Thanks Steve :)



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Steve N4IRS <szingman@...>
Date: 7/29/19 08:42 (GMT-08:00)
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

<https://docs.google.com/document/d/1eN50Csr29eAprBu7eKA0Bfa2XUcsXw5iktY1Ey-Qjkg/edit?usp=sharing>


Steve N4IRS


On 7/29/2019 11:34 AM, Chris K7AZ via Groups.Io wrote:
Seeking assistance setting up an ASL to DMR interface.  Platform is a private VM server.   I have an ASL node set up 29837 and I'm about 70% into the DMR transcoder part when things started to not cooperate.  TeamViewer available.
Evenings 6-8 PM CA time is best for me.    

Thank you,
Chris K7AZ 


Re: NOOB Setup-Configuration Help #analog_bridge #dmrlink

Chris K7AZ
 

I'm entering that at the root level and it just says: 
bash: ./MMDVM_Bridge: No such file or directory.

Maybe I'm at the wrong level?  



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Steve N4IRS <szingman@...>
Date: 7/30/19 02:32 (GMT-08:00)
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

It is the netx line in the document.

Time to test

Run MMDVM_Bridge in the foreground

./MMDVM_Bridge MMDVM_Bridge.ini

No, the ports do not need to be forwarded.


On 7/29/19 11:47 PM, Chris K7AZ via Groups.Io wrote:
I'm stuck at:
Time to test
Run MMDVM_Bridge in the foreground.  HOW?

Also, do ports 62031 and 62032 need to be forwarded? 

Thanks,
Chris K7AZ 



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: "Chris K7AZ via Groups.Io" <kilo7alphazulu@...>
Date: 7/29/19 08:45 (GMT-08:00)
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

Thanks Steve :)



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Steve N4IRS <szingman@...>
Date: 7/29/19 08:42 (GMT-08:00)
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

<https://docs.google.com/document/d/1eN50Csr29eAprBu7eKA0Bfa2XUcsXw5iktY1Ey-Qjkg/edit?usp=sharing>


Steve N4IRS


On 7/29/2019 11:34 AM, Chris K7AZ via Groups.Io wrote:
Seeking assistance setting up an ASL to DMR interface.  Platform is a private VM server.   I have an ASL node set up 29837 and I'm about 70% into the DMR transcoder part when things started to not cooperate.  TeamViewer available.
Evenings 6-8 PM CA time is best for me.    

Thank you,
Chris K7AZ 


Re: HBmonitor and XLXPEERS support

Steve KC1AWV
 

I'm continuing work on HBmonitor3 - a Python 3 port of the original N0MJS HBmonitor.

The last bit that I worked on and seems to be hanging me up is dict.iteritems() is no longer in Python 3. According to some Google-foo and a Stack Overflow article, dict.items() in Python 3 does not have the same functionality that dict.iteritems() did.
view object isn't the same as iterator, so if you want to return an iterator in Py3.x, you could use iter(dictview)
This is the next hurdle. I'll be updating code as I have time available. If you want to collaborate on this effort with me, please submit code as a pull request on the github repository, found here: https://github.com/kc1awv/HBmonitor3

Steve KC1AWV


Re: NOOB Setup-Configuration Help #analog_bridge #dmrlink

Steve N4IRS
 

It is the netx line in the document.

Time to test

Run MMDVM_Bridge in the foreground

./MMDVM_Bridge MMDVM_Bridge.ini

No, the ports do not need to be forwarded.


On 7/29/19 11:47 PM, Chris K7AZ via Groups.Io wrote:
I'm stuck at:
Time to test
Run MMDVM_Bridge in the foreground.  HOW?

Also, do ports 62031 and 62032 need to be forwarded? 

Thanks,
Chris K7AZ 



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: "Chris K7AZ via Groups.Io" <kilo7alphazulu@...>
Date: 7/29/19 08:45 (GMT-08:00)
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

Thanks Steve :)



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Steve N4IRS <szingman@...>
Date: 7/29/19 08:42 (GMT-08:00)
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

<https://docs.google.com/document/d/1eN50Csr29eAprBu7eKA0Bfa2XUcsXw5iktY1Ey-Qjkg/edit?usp=sharing>


Steve N4IRS


On 7/29/2019 11:34 AM, Chris K7AZ via Groups.Io wrote:
Seeking assistance setting up an ASL to DMR interface.  Platform is a private VM server.   I have an ASL node set up 29837 and I'm about 70% into the DMR transcoder part when things started to not cooperate.  TeamViewer available.
Evenings 6-8 PM CA time is best for me.    

Thank you,
Chris K7AZ 


Re: NOOB Setup-Configuration Help #analog_bridge #dmrlink

Chris K7AZ
 

I'm stuck at:
Time to test
Run MMDVM_Bridge in the foreground.  HOW?

Also, do ports 62031 and 62032 need to be forwarded? 

Thanks,
Chris K7AZ 



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: "Chris K7AZ via Groups.Io" <kilo7alphazulu@...>
Date: 7/29/19 08:45 (GMT-08:00)
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

Thanks Steve :)



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Steve N4IRS <szingman@...>
Date: 7/29/19 08:42 (GMT-08:00)
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

<https://docs.google.com/document/d/1eN50Csr29eAprBu7eKA0Bfa2XUcsXw5iktY1Ey-Qjkg/edit?usp=sharing>


Steve N4IRS


On 7/29/2019 11:34 AM, Chris K7AZ via Groups.Io wrote:
Seeking assistance setting up an ASL to DMR interface.  Platform is a private VM server.   I have an ASL node set up 29837 and I'm about 70% into the DMR transcoder part when things started to not cooperate.  TeamViewer available.
Evenings 6-8 PM CA time is best for me.    

Thank you,
Chris K7AZ 


Re: NOOB Setup-Configuration Help #analog_bridge #dmrlink

Chris K7AZ
 

Thanks Steve :)



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Steve N4IRS <szingman@...>
Date: 7/29/19 08:42 (GMT-08:00)
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] NOOB Setup-Configuration Help #dmrlink #analog_bridge

<https://docs.google.com/document/d/1eN50Csr29eAprBu7eKA0Bfa2XUcsXw5iktY1Ey-Qjkg/edit?usp=sharing>


Steve N4IRS


On 7/29/2019 11:34 AM, Chris K7AZ via Groups.Io wrote:
Seeking assistance setting up an ASL to DMR interface.  Platform is a private VM server.   I have an ASL node set up 29837 and I'm about 70% into the DMR transcoder part when things started to not cooperate.  TeamViewer available.
Evenings 6-8 PM CA time is best for me.    

Thank you,
Chris K7AZ 


Re: NOOB Setup-Configuration Help #analog_bridge #dmrlink

Steve N4IRS
 

On 7/29/2019 11:34 AM, Chris K7AZ via Groups.Io wrote:
Seeking assistance setting up an ASL to DMR interface.  Platform is a private VM server.   I have an ASL node set up 29837 and I'm about 70% into the DMR transcoder part when things started to not cooperate.  TeamViewer available.
Evenings 6-8 PM CA time is best for me.    

Thank you,
Chris K7AZ 


NOOB Setup-Configuration Help #analog_bridge #dmrlink

Chris K7AZ
 

Seeking assistance setting up an ASL to DMR interface.  Platform is a private VM server.   I have an ASL node set up 29837 and I'm about 70% into the DMR transcoder part when things started to not cooperate.  TeamViewer available.
Evenings 6-8 PM CA time is best for me.    

Thank you,
Chris K7AZ 


Re: Help Needed Allstar Node running DVSwitch with DMR and Echolink Bridge Adding P25

Jeff Wood
 

Thanks again Steve, 

  I have been looking around the files and did find the P25 side and and ASL were using the same ports (I flipped) the P25 ports 
[USRP]
address = 127.0.0.1                   
txPort = 34001                          
rxPort = 32001                          

Now I have P25 Transmissions from P25 to ASL and DMR, but still nothing from ASL or DMR back to P25...
I am sure its a port still looking....


HBmonitor and XLXPEERS support

Dan K2IE
 

It is a beauty.  My XLXPEER now displays as expected.

 

Thanks!

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve KC1AWV
Sent: Sunday, July 28, 2019 18:37
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] HBmonitor and XLXPEERS support

 

New PR on github to fix a typo I overlooked on line 213. Also removed a \t at the end of the same line.

Also, porting from python 2 to 3 is breaking. Twisted gives a 500 response, Request did not return bytes, and "Bad request" when trying to view the page. Still working on these issues.

Steve KC1AWV


Re: HBmonitor and XLXPEERS support

Cort N0MJS <n0mjs@...>
 

Bytes objects were the biggest issue porting untils and HBlink. They’re frustrating.


On Jul 28, 2019, at 5:36 PM, Steve KC1AWV <smiller@...> wrote:

New PR on github to fix a typo I overlooked on line 213. Also removed a \t at the end of the same line.

Also, porting from python 2 to 3 is breaking. Twisted gives a 500 response, Request did not return bytes, and "Bad request" when trying to view the page. Still working on these issues.

Steve KC1AWV


Re: HBmonitor and XLXPEERS support

Joe Hussey
 



On Sun, Jul 28, 2019 at 6:37 PM Steve KC1AWV <smiller@...> wrote:
New PR on github to fix a typo I overlooked on line 213. Also removed a \t at the end of the same line.

Also, porting from python 2 to 3 is breaking. Twisted gives a 500 response, Request did not return bytes, and "Bad request" when trying to view the page. Still working on these issues.

Steve KC1AWV


Re: HBmonitor and XLXPEERS support

Steve KC1AWV
 

New PR on github to fix a typo I overlooked on line 213. Also removed a \t at the end of the same line.

Also, porting from python 2 to 3 is breaking. Twisted gives a 500 response, Request did not return bytes, and "Bad request" when trying to view the page. Still working on these issues.

Steve KC1AWV


Re: Help Needed Allstar Node running DVSwitch with DMR and Echolink Bridge Adding P25

Steve N4IRS
 

Jeff,
I assume you are feeding 2 ASL nodes, one for DMR and one for P25.
I assume you are running these 2 nodes on a single ASL server.
I assume you have the 2 nodes in your rpt.conf. Each have a entry for USRP as: rxchannel = USRP/127.0.0.1:34001:32001
If you look at the [USRP] stanza for each mode, you will see you are using the same UDP ports.

Steve N4IRS




On 7/28/19 12:58 PM, jeff@... wrote:
I would guess some ini files...



                       


Re: NXDN Dashboard

Jeff - WA3PNY
 

Hi Michael,

I don’t have the file but:
If you go to the dashboard web directory, you should see a directory: config - inside is config.php, edit that file with the same information that setup asks for.  

Worked for me.

Jeff

Jeffrey V. Bauer
6381 Mulberry Ln.
Macungie, PA 18062
WA3PNY
CCS-7 3142263
NXDN 504
Wires-X 18394/28394

On Jul 28, 2019, at 3:17 PM, Michael KD5DFB <mhebert1975@...> wrote:

I downloaded the NXDN Dashboard from https://github.com/N4IRS/MMDVM-Install/tree/master/NXDN/NXDNReflector-Dashboard.

When I try to set it up, the setup.php is missing. Anyone have the setup.php?


Re: NXDN Reflector

Jeff - WA3PNY
 

Hi Michael,

It is usually a directory permission error:

You might want to use:
ls -l
To see who owns the directory & permissions for the directory you are trying to write your log files.

I have routinely chown mmdvm:mmdvm filespec
and chmod 755 or something reasonable, and the error goes away. Hope this helps.

Jeff

Jeffrey V. Bauer
6381 Mulberry Ln.
Macungie, PA 18062
WA3PNY
CCS-7 3142263
NXDN 504
Wires-X 18394/28394

On Jul 28, 2019, at 3:14 PM, Michael KD5DFB <mhebert1975@...> wrote:

I am having problems trying to run NXDN Reflector. When I try to run it I keep getting the error "unable to open the log file"

In the ini file I have the following:

[Log]
# Logging levels, 0=No logging
DisplayLevel=1
FileLevel=0
FilePath= .
FileRoot=NXDNReflector

I can only get it to run with FileLevel=0
I have also changed Daemon=0


NXDN Dashboard

Michael KD5DFB
 

I downloaded the NXDN Dashboard from https://github.com/N4IRS/MMDVM-Install/tree/master/NXDN/NXDNReflector-Dashboard.

When I try to set it up, the setup.php is missing. Anyone have the setup.php?


NXDN Reflector

Michael KD5DFB
 

I am having problems trying to run NXDN Reflector. When I try to run it I keep getting the error "unable to open the log file"

In the ini file I have the following:

[Log]
# Logging levels, 0=No logging
DisplayLevel=1
FileLevel=0
FilePath= .
FileRoot=NXDNReflector

I can only get it to run with FileLevel=0
I have also changed Daemon=0


Re: Help Needed Allstar Node running DVSwitch with DMR and Echolink Bridge Adding P25

Jeff Wood
 
Edited

I would guess some ini files...

I have looked over these files, still not seeing where the issue is, P25 from the radio to the reflector shows on the screen as it is being received and it passes audio just normal to DMR ONLY not to Allstar.

DMR does not show on the screen that it is even being received on the P25 system side but does tx out to all-star and dmr but not P25....

4741 - 4760 of 9288