Date   

Re: DSTAR Registration Questions

Adrian Fewster <vk4tux@...>
 

How are you sending an echo request ? In D-Star #######E should be sent in urcall (#=space), &  ircddbgateway handles this locally, it does not go out beyond.

The ircddbgateway log will just show , eg ;

M: 2019-12-30 21:22:53: Received 5.7 secs of audio from VK4TUX   for echoing


On 31/12/19 6:44 am, Ed W8VT wrote:
Steve and Adrian,
Have an update. Keep getting interrupted but here is where we stand right now.
Manually updated the database (./dvswitch.sh update). Guess I should set up a cron job to do this on a regular basis?
Now my call shows rather than the DMR ID. Still get this though when trying to transmit:
M: 2019-12-30 20:23:14: Link command from W8VT   B to REF001 C issued via UR Call by W8VT    M: 2019-12-30 20:23:14: D-Plus reply is OKRWM: 2019-12-30 20:23:14: D-Plus ACK message received from REF001 CM: 2019-12-30 20:23:14: D-Plus link to REF001 C establishedM: 2019-12-30 20:23:15: USER: W8VT     NOT FOUND
Tried the E echo and no response, also called on several reflectors with no response, so get  the feeling no transmit.
Got to head out for now and won't be back until later this evening.
Really appreciate the assistance.

Ed W8VT


Re: DSTAR Registration Questions

Will - W4WWM <w4wwm@...>
 

Ed-W8VT

Restart your gateway as the quadnet server has a new IP.  That should clear up the NOT FOUND message.  If not send an email to admins@...


Will / W4WWM


On 12/30/2019 2:44 PM, Ed W8VT wrote:
Steve and Adrian,
Have an update. Keep getting interrupted but here is where we stand right now.
Manually updated the database (./dvswitch.sh update). Guess I should set up a cron job to do this on a regular basis?
Now my call shows rather than the DMR ID. Still get this though when trying to transmit:
M: 2019-12-30 20:23:14: Link command from W8VT   B to REF001 C issued via UR Call by W8VT    M: 2019-12-30 20:23:14: D-Plus reply is OKRWM: 2019-12-30 20:23:14: D-Plus ACK message received from REF001 CM: 2019-12-30 20:23:14: D-Plus link to REF001 C establishedM: 2019-12-30 20:23:15: USER: W8VT     NOT FOUND
Tried the E echo and no response, also called on several reflectors with no response, so get  the feeling no transmit.
Got to head out for now and won't be back until later this evening.
Really appreciate the assistance.

Ed W8VT


Re: DSTAR Registration Questions

Ed W8VT
 

Steve and Adrian,
Have an update. Keep getting interrupted but here is where we stand right now.
Manually updated the database (./dvswitch.sh update). Guess I should set up a cron job to do this on a regular basis?
Now my call shows rather than the DMR ID. Still get this though when trying to transmit:
M: 2019-12-30 20:23:14: Link command from W8VT   B to REF001 C issued via UR Call by W8VT    M: 2019-12-30 20:23:14: D-Plus reply is OKRWM: 2019-12-30 20:23:14: D-Plus ACK message received from REF001 CM: 2019-12-30 20:23:14: D-Plus link to REF001 C establishedM: 2019-12-30 20:23:15: USER: W8VT     NOT FOUND
Tried the E echo and no response, also called on several reflectors with no response, so get  the feeling no transmit.
Got to head out for now and won't be back until later this evening.
Really appreciate the assistance.

Ed W8VT


Re: Getting a Burp Voice Message through ASL <> DMR Bridge #mmdvm_bridge

Steve N4IRS
 

increase minTxTimeMS to between 2500 and 3000 in the [AMBE_Audio] stanza of Analog_Bridge.ini

On 12/30/19 3:06 PM, Jeff Lehman, N8ACL via Groups.Io wrote:

the message is probably "blocked" in a female voice. this means that your bridge has been blocked for an hour for too many keyups in a certain amount of time.

One thing that I found is to increase your tx timer. That might help to eliminate that. I don't have access to my system right this second, so I don't remember what a good setting is, but that will help. Maybe someone can suggest a good value.

Jeff

On 12/30/19 3:02 PM, Ted Lawrence via Groups.Io wrote:
Hi Folks!

I have 2 nodes running.   Node 505501 ASL<>DMR DV-Switch Bridge on one Raspberry Pi and Stand alone Node 505500 Raspberry Pi remote base UHF.

When the two nodes are linked,  I get what sounds like a  short voice message that sound line the word " burped " after the remote base courtesy tone. This happens when the remote base receives a siginal.   Can someone explain ? How do I stop this message behavior?

Sincerely,
Ted KD4EG
-- 
Jeff Lehman, N8ACL
E-mail: N8ACL@...
Hamshack Hotline: 4218

Webmaster
Hamilton County ARPSC
http://www.hamcoarpsc.org
E-mail: info@...
Phone: 513-452-6480


Re: Getting a Burp Voice Message through ASL <> DMR Bridge #mmdvm_bridge

Jeff Lehman, N8ACL
 

the message is probably "blocked" in a female voice. this means that your bridge has been blocked for an hour for too many keyups in a certain amount of time.

One thing that I found is to increase your tx timer. That might help to eliminate that. I don't have access to my system right this second, so I don't remember what a good setting is, but that will help. Maybe someone can suggest a good value.

Jeff

On 12/30/19 3:02 PM, Ted Lawrence via Groups.Io wrote:
Hi Folks!

I have 2 nodes running.   Node 505501 ASL<>DMR DV-Switch Bridge on one Raspberry Pi and Stand alone Node 505500 Raspberry Pi remote base UHF.

When the two nodes are linked,  I get what sounds like a  short voice message that sound line the word " burped " after the remote base courtesy tone. This happens when the remote base receives a siginal.   Can someone explain ? How do I stop this message behavior?

Sincerely,
Ted KD4EG
-- 
Jeff Lehman, N8ACL
E-mail: N8ACL@...
Hamshack Hotline: 4218

Webmaster
Hamilton County ARPSC
http://www.hamcoarpsc.org
E-mail: info@...
Phone: 513-452-6480


Getting a Burp Voice Message through ASL <> DMR Bridge #mmdvm_bridge

Ted Lawrence
 

Hi Folks!

I have 2 nodes running.   Node 505501 ASL<>DMR DV-Switch Bridge on one Raspberry Pi and Stand alone Node 505500 Raspberry Pi remote base UHF.

When the two nodes are linked,  I get what sounds like a  short voice message that sound line the word " burped " after the remote base courtesy tone. This happens when the remote base receives a siginal.   Can someone explain ? How do I stop this message behavior?

Sincerely,
Ted KD4EG


Re: DSTAR Registration Questions

Ed W8VT
 

Steve,
Well, think we may have found part of the problem, /var/lib/dvswitch/subscriber_ids.csv is an empty file, 0 bytes.
; The metadata below is used when ASL is the source since it does not have any concept of digital modesgatewayDmrId = 3154009                        ; ID to use when transmitting from Analog_BridgerepeaterID = 315400902                          ; ID of source repeatertxTg = 313938                                ; TG to use for all frames sent from Analog_Bridge -> xx_BridgetxTs = 2                                ; Slot to use for frames sent from Analog_Bridge -> xx_BridgecolorCode = 7                           ; Color Code to assign DMR frames
Above is what was being used in the original DMR Bridge.
Still mystified as to where this in the analog_bridge log is coming from:
I: 2019-12-30 17:00:54.887 Begin TX: src=3154017 rpt=0 dst=9 slot=2 cc=0 call=W8VT
Ed


Re: DSTAR Registration Questions

Adrian Fewster <vk4tux@...>
 

The system should be using it's DMR database to find and send W8VT to ircddbgateway ? ;

; Metadata management
exportMetadata = true                   ; Export metadata to USRP partner (transcode setups require this)
subscriberFile = /path/subscriber_ids.csv   ; DMR ID to callsign lookup data


You may have to check path and content of subscriber_ids.csv ? in ini's ?


On 31/12/19 1:55 am, Ed W8VT wrote:
Can now connect and receive fine. Listened to a lot  traffic on REF001C. Tried echo and apparently no transmit, Shows my call as connected in tje log and on their dashboard. When I attempt to transmit, this is via iaxRPT ASL and the bridge, I see this in the ircddbgateway log:
M: 2019-12-30 01:33:05: USER: 3154009  NOT FOUND
3154009 is one of my DMR IDs. I swear at one point in this adventure when I keyed saw my call and public IP listed as  unknown.

Another real mystery is this from the analog_bridge log:
I: 2019-12-30 15:16:58.435 Begin TX: src=3154017 rpt=0 dst=9 slot=2 cc=0 call=W8VT
315017 is my other DMR ID. Have no idea where this coming from. Have searched MMDVM_bridge.ini, analog_bridge.ini and dvswitch.ini. Think at one point may have tried it somewhere as a test but can not find it anywhere now.

The bridge is currently operational on DMR and can also be switched to YSF. Works great on these modes.

Ed W8VT
Still befuddled


Re: DSTAR Registration Questions

Steve N4IRS
 

Ed,
For D-Star transmit, MMDVM_Bridge is going to need to resolve your DMR ID to call sign.
Let's start with Analog_Bridge. What do you have for these?
[GENERAL]

; Metadata management
subscriberFile =
/var/lib/dvswitch/subscriber_ids.csv   ; DMR ID to callsign lookup data
exportMetadata = true                   ; Export metadata to USRP partner (transcode setups require this)

; Information for xx_Bridge (Where xx is MMDVM, Quantar, HB, IPSC)
[AMBE_AUDIO]
gatewayDmrId = 0                        ; ID to use when transmitting from Analog_Bridge
repeaterID = 0                          ; ID of source repeater


Let's verify AB can resolve your call sign

grep 3154009 /var/lib/dvswitch/subscriber_ids.csv

Steve



On 12/30/19 10:55 AM, Ed W8VT wrote:
Can now connect and receive fine. Listened to a lot  traffic on REF001C. Tried echo and apparently no transmit, Shows my call as connected in tje log and on their dashboard. When I attempt to transmit, this is via iaxRPT ASL and the bridge, I see this in the ircddbgateway log:
M: 2019-12-30 01:33:05: USER: 3154009  NOT FOUND
3154009 is one of my DMR IDs. I swear at one point in this adventure when I keyed saw my call and public IP listed as  unknown.

Another real mystery is this from the analog_bridge log:
I: 2019-12-30 15:16:58.435 Begin TX: src=3154017 rpt=0 dst=9 slot=2 cc=0 call=W8VT
315017 is my other DMR ID. Have no idea where this coming from. Have searched MMDVM_bridge.ini, analog_bridge.ini and dvswitch.ini. Think at one point may have tried it somewhere as a test but can not find it anywhere now.

The bridge is currently operational on DMR and can also be switched to YSF. Works great on these modes.

Ed W8VT
Still befuddled


Re: DSTAR Registration Questions

Ed W8VT
 

Can now connect and receive fine. Listened to a lot  traffic on REF001C. Tried echo and apparently no transmit, Shows my call as connected in tje log and on their dashboard. When I attempt to transmit, this is via iaxRPT ASL and the bridge, I see this in the ircddbgateway log:
M: 2019-12-30 01:33:05: USER: 3154009  NOT FOUND
3154009 is one of my DMR IDs. I swear at one point in this adventure when I keyed saw my call and public IP listed as  unknown.

Another real mystery is this from the analog_bridge log:
I: 2019-12-30 15:16:58.435 Begin TX: src=3154017 rpt=0 dst=9 slot=2 cc=0 call=W8VT
315017 is my other DMR ID. Have no idea where this coming from. Have searched MMDVM_bridge.ini, analog_bridge.ini and dvswitch.ini. Think at one point may have tried it somewhere as a test but can not find it anywhere now.

The bridge is currently operational on DMR and can also be switched to YSF. Works great on these modes.

Ed W8VT
Still befuddled


Re: DSTAR Registration Questions

Adrian Fewster <vk4tux@...>
 

The ircddbgateway log will indicate the nature of any issues, if you post it here, if so.



On 30/12/19 11:16 am, Ed W8VT wrote:
Thanks Adrian. Now that I know the registration looks OK, we'll do some more experimentation.

Really appreciate the assistance.

Ed W8VT


Re: DSTAR Registration Questions

Ed W8VT
 

Thanks Adrian. Now that I know the registration looks OK, we'll do some more experimentation.

Really appreciate the assistance.

Ed W8VT


Re: DSTAR Registration Questions

Adrian Fewster <vk4tux@...>
 

Ed your current status at USTRUST is ;

W8VT sync_mng Table Records (3 entries)
target_cs last_mod_time mod_date reg_date pc_hostname arearp_cs user_cs regist_rp_cs pc_ipaddr del_flg
W8VT 2019-12-24 18:44:03 2019-12-24 18:44:03.506387 2019-12-24 18:44:03.506387
REGIST A W8VT REGIST 0.0.0.0 OK
W8VT B 2019-12-24 22:28:10 2019-12-24 22:28:09.60761 2019-12-24 21:16:29.941764
REGIST A W8VT REGIST 0.0.0.0 DELETED
W8VT Z 2019-12-11 17:55:18 2019-12-11 17:55:18.179014 2019-12-11 17:55:18.179014 ACCESSPOINT W8VT Z W8VT REGIST 0.0.0.0 OK
W8VT unsync_mng table records (1 entries)
target_cs receive_time mod_date reg_date blacklist_flg
W8VT 1970-01-01 00:00:00 2019-12-11 17:55:18.179014 2019-12-11 17:55:18.179014 OK
W8VT sync_rip Table Records (1 entries)
user_cs regist_rp_cs last_mod_time mod_date reg_date start_ipaddr del_flg
W8VT REGIST 2019-12-11 17:22:05 2019-12-11 17:22:04.964139 2019-12-11 17:22:04.964139 10.209.79.8 OK
Mon Dec 30 01:00:48 UTC 2019


which means you can use W8VT  or W8VT###Z for dplus login in ircddbgateway config ;

<snip>

dplusEnabled=1
dplusMaxDongles=5
dplusLogin=W8VT

<snip>


In the USTRUST synced user list sent to Reflectors and gateways , and the Dplus database ;

[W8VT    ] [REGIST A]
[W8VT   Z] [W8VT   Z]

You exist, so you should be able to login to any dplus reflector or gateway with the dplus host file.

Adrian .. vk4tux





On 30/12/19 10:50 am, Ed W8VT wrote:
Would appreciate it if a DSTAR guru could answer a few questions about DSTAR registration. Do have my analog bridge at least working with DCS reflectors at this point.
Knew very little about DSTAR when I started this project. Had no idea there were all these multiple systems and registration. Thought I went through all the procedures to register but obviously have missed and / or screwed up something.
Queried my call on these sites:
https://wb1gof.dstargateway.org/cgi-bin/dstar-regcheck?callsign=W8VT
http://dstar.info/query.html
Not quite sure what it all means.

What a complex and convoluted system! HELP!

Ed W8VT
Old, confused and befuddled


DSTAR Registration Questions

Ed W8VT
 

Would appreciate it if a DSTAR guru could answer a few questions about DSTAR registration. Do have my analog bridge at least working with DCS reflectors at this point.
Knew very little about DSTAR when I started this project. Had no idea there were all these multiple systems and registration. Thought I went through all the procedures to register but obviously have missed and / or screwed up something.
Queried my call on these sites:
https://wb1gof.dstargateway.org/cgi-bin/dstar-regcheck?callsign=W8VT
http://dstar.info/query.html
Not quite sure what it all means.

What a complex and convoluted system! HELP!

Ed W8VT
Old, confused and befuddled


Re: Image needed

Vicente Segovia Gonzalez
 

El vie., 27 dic. 2019 a las 19:02, Brett KB5YZB via Groups.Io (<Brett.williams=sss.gov@groups.io>) escribió:
DV switch friends, I just upgraded from x86 CentOS to a PI 3. I installed hamviop however I want to have ALLstar/Echolink/DMR/Yeasu on one pi. Friend who is helping me install the bridges said to install the DV switch image instead of Hamvoip to make all this work. I looked for the link for an image (can't find) before sending this....sorry I'm sure its out there in DV switch land. Is there an image for all the above?

Thanks for the help!!!!

Brett
KB5YZB


Re: Hytera DMR Gateway

EA5GVK Joaquin
 

I have tried the hytera gw with the dmrgateway. AND IT WORKS PERFECTLY TO CONNECT TO BRANDMEISTER AND DMR +
BUT HBLINK HAS PROBLEMS:
If the TG of the HBLINK, in turn is linked to other systems, for example to an XLX, the audio in the direction of the HBLINK to XLX does not come out. However, in the sense of XLX to HBLINK, yes.
That is

HYTERA-GW -> DMRGATEWAY -> HBLINK - TGLINK TO XLX -> DOES NOT WORK.

AND HOWEVER TO THE CONTRARY IF

HBLINK-TG LINK TO XLX -> DMRGATEWAY -> HYTERA-GW -> WORK PERFECTLY.

CAN SOMEBODY HELP ME.


Re: ASL to YSF Question

Adrian Fewster <vk4tux@...>
 

It just disables the port = 0 instead of the address, various gateway connections with disabled local ports should not affect each other.

I just find the method produces the least debug complaints.

On 28/12/19 7:55 am, Eric Dayrit wrote:
Adrian,
Quick question? this local address/ port setup will not interfere to each other if I have 4 MMDVM Bridge instances running in one box?
Thanks, Eric


Re: ASL to YSF Question

Eric-K6KWB
 

Adrian,
Quick question? this local address/ port setup will not interfere to each other if I have 4 MMDVM Bridge instances running in one box?
Thanks, Eric


Re: ASL to YSF Question

Eric-K6KWB
 

thanks Adrian, noted.


Re: ASL to YSF Question

Adrian Fewster <vk4tux@...>
 

mmdvm_bridge.ini


I use ;


[System Fusion Network]
Enable=1
LocalAddress=127.0.0.1
LocalPort=0
GatewayAddress= ip or dns of your YSFreflector
GatewayPort=42000 port of your reflector
Debug=0

On 28/12/19 5:34 am, Eric Dayrit wrote:
mmdvm_bridge.ini
[System Fusion Network]
Enable=1
LocalAddress=0
LocalPort=3200
GatewayAddress= ip or dns of your YSFreflector
GatewayPort=42000 port of your reflector
Debug=0

4181 - 4200 of 9795