Date   

Re: ASL to P25 bridge #analog_bridge

Steve N4IRS
 

I need to see both logs from a fresh start to waiting for traffic. Do not truncate.

On 8/10/20 5:34 PM, Tom wrote:
root@P25reflector:/var/log/dvswitch # tail -f Analog_Bridge.log   
M: 2020-08-10 21:29:52.793 Connecting to DV3000 hardware......
W: 2020-08-10 21:29:53.800 DV3000 not found at 127.0.0.1:2460
I: 2020-08-10 21:29:54.706 Subscriber IDs loaded: 169853
I: 2020-08-10 21:29:54.706 Default extended metadata <K5TRA>
W: 2020-08-10 21:29:54.706 Using software MBE decoder version 1.2.3
W: 2020-08-10 21:29:54.706 Using software OP25 IMBE/AMBE vocoder
I: 2020-08-10 21:29:54.707 Sending to USRP clients at 127.0.0.1 on port(s) 32001
E: 2020-08-10 21:29:54.707 Can not bind port 42020, error code = 98 (Address already in use)
I: 2020-08-10 21:29:54.707 Starting TLV --> Analog_Bridge (decoder) --> USRP thread
I: 2020-08-10 21:29:54.707 Starting USRP --> Analog_Bridge (encoder) -> TLV thread

root@P25reflector:/var/log/mmdvm # tail -f MMDVM_Bridge-2020-08-10.log 
I: 2020-08-10 21:24:52.615 Loaded 169853 Ids to the DMR callsign lookup table
I: 2020-08-10 21:24:52.615 P25 RF Parameters
I: 2020-08-10 21:24:52.615 Started the DMR Id lookup reload thread
I: 2020-08-10 21:24:52.615     Id: 3148777
I: 2020-08-10 21:24:52.615     NAC: $293
I: 2020-08-10 21:24:52.615     UID Override: no
I: 2020-08-10 21:24:52.615     Self Only: no
I: 2020-08-10 21:24:52.615     Remote Gateway: no
I: 2020-08-10 21:24:52.615     Mode Hang: 10s
M: 2020-08-10 21:24:52.615 MMDVM_Bridge-20200309_V1.5.1 is running

Looks like AMBE audio port issue in AB. Should that be 34100, 34103 ?


Re: ASL to P25 bridge #analog_bridge

Tom
 

root@P25reflector:/var/log/dvswitch # tail -f Analog_Bridge.log   
M: 2020-08-10 21:29:52.793 Connecting to DV3000 hardware......
W: 2020-08-10 21:29:53.800 DV3000 not found at 127.0.0.1:2460
I: 2020-08-10 21:29:54.706 Subscriber IDs loaded: 169853
I: 2020-08-10 21:29:54.706 Default extended metadata <K5TRA>
W: 2020-08-10 21:29:54.706 Using software MBE decoder version 1.2.3
W: 2020-08-10 21:29:54.706 Using software OP25 IMBE/AMBE vocoder
I: 2020-08-10 21:29:54.707 Sending to USRP clients at 127.0.0.1 on port(s) 32001
E: 2020-08-10 21:29:54.707 Can not bind port 42020, error code = 98 (Address already in use)
I: 2020-08-10 21:29:54.707 Starting TLV --> Analog_Bridge (decoder) --> USRP thread
I: 2020-08-10 21:29:54.707 Starting USRP --> Analog_Bridge (encoder) -> TLV thread

root@P25reflector:/var/log/mmdvm # tail -f MMDVM_Bridge-2020-08-10.log 
I: 2020-08-10 21:24:52.615 Loaded 169853 Ids to the DMR callsign lookup table
I: 2020-08-10 21:24:52.615 P25 RF Parameters
I: 2020-08-10 21:24:52.615 Started the DMR Id lookup reload thread
I: 2020-08-10 21:24:52.615     Id: 3148777
I: 2020-08-10 21:24:52.615     NAC: $293
I: 2020-08-10 21:24:52.615     UID Override: no
I: 2020-08-10 21:24:52.615     Self Only: no
I: 2020-08-10 21:24:52.615     Remote Gateway: no
I: 2020-08-10 21:24:52.615     Mode Hang: 10s
M: 2020-08-10 21:24:52.615 MMDVM_Bridge-20200309_V1.5.1 is running

Looks like AMBE audio port issue in AB. Should that be 34100, 34103 ?


Re: ASL to P25 bridge #analog_bridge

Steve N4IRS
 

stop Analog_Bridge and MMDVM_Bridge. remove both logs. start Analog_Bridge and MMDVM_Bridge. Post both logs.


On 8/10/20 5:21 PM, Tom wrote:
Are these ports correct?
ASL (
USRP) 32001 RX,  34001 TX

AB
(USRP)  TX 32001, RX 34001
(AMBE AUDIO)  32010 TX , 42020 RX

MMDVM
(P25 network)  Gateway 42020, Local 32010

DVSwitch
(P25)   TX 34100,  RX 34103

P25Gateway
Repeater port 32010
Local port 42020
(Network)   Port = 42010
__________________________
Should I use my static LAN IP in all the ini files  (or loopback)?
 
The reflector on 10888 works; so why doesn't this gateway see it?

It's not clear at all where DVSwitch [P25] 34100, 34103  fits in (documentation)?

Only ASL talks to Analog_Bridge, then it breaks.

Thanks for your help 

Tom


Re: ASL to P25 bridge #analog_bridge

Tom
 

Are these ports correct?
ASL (
USRP) 32001 RX,  34001 TX

AB
(USRP)  TX 32001, RX 34001
(AMBE AUDIO)  32010 TX , 42020 RX

MMDVM
(P25 network)  Gateway 42020, Local 32010

DVSwitch
(P25)   TX 34100,  RX 34103

P25Gateway
Repeater port 32010
Local port 42020
(Network)   Port = 42010
__________________________
Should I use my static LAN IP in all the ini files  (or loopback)?
 
The reflector on 10888 works; so why doesn't this gateway see it?

It's not clear at all where DVSwitch [P25] 34100, 34103  fits in (documentation)?

Only ASL talks to Analog_Bridge, then it breaks.

Thanks for your help 

Tom


Re: ASL to P25 bridge #analog_bridge

Steve N4IRS
 

stop Analog_Bridge and MMDVM_Bridge. remove both logs. start Analog_Bridge and MMDVM_Bridge. Post both logs. 

On 8/10/20 4:25 PM, Tom wrote:
Steve,

systemctl status shows all services running (asl, analog_bridge, mmdvm, p25gateway, and p25reflector).

ASL talks to analog_bridge, and  p25reflector talks to the internet; but nothing else mutually communicates.

I believe I have all the ports set correctly.

Tom


Re: ASL to P25 bridge #analog_bridge

Tom
 

Steve,

systemctl status shows all services running (asl, analog_bridge, mmdvm, p25gateway, and p25reflector).

ASL talks to analog_bridge, and  p25reflector talks to the internet; but nothing else mutually communicates.

I believe I have all the ports set correctly.

Tom


Re: ASL to P25 bridge #analog_bridge

Tom
 

P25eflector works and ASL <-> Analog_Bridge  works; but that's all.
Tom


Re: ASL to P25 bridge #analog_bridge

Tom
 

Here are logs from MMDVM_Bridge, P25Gateway, and P25Reflector:

root@P25reflector:/var/log/mmdvm # tail -f MMDVM_Bridge-2020-08-10.log 
I: 2020-08-10 18:14:20.372 Loaded 169853 Ids to the DMR callsign lookup table
I: 2020-08-10 18:14:20.372 P25 RF Parameters
I: 2020-08-10 18:14:20.372 Started the DMR Id lookup reload thread
I: 2020-08-10 18:14:20.372     Id: 3148777
I: 2020-08-10 18:14:20.372     NAC: $293
I: 2020-08-10 18:14:20.372     UID Override: no
I: 2020-08-10 18:14:20.372     Self Only: no
I: 2020-08-10 18:14:20.372     Remote Gateway: no
I: 2020-08-10 18:14:20.372     Mode Hang: 10s
M: 2020-08-10 18:14:20.372 MMDVM_Bridge-20200309_V1.5.1 is running
^C
root@P25reflector:/var/log/mmdvm # tail -f P25Gateway-2020-08-10.log 
W: 2020-08-10 17:43:01.267 No response from 10888, unlinking
I: 2020-08-10 18:14:19.459 Opening P25 network connection
I: 2020-08-10 18:14:19.464 Opening P25 network connection
I: 2020-08-10 18:14:19.751 Loaded 13 P25 reflectors
I: 2020-08-10 18:14:19.751 Loaded P25 parrot (TG10)
I: 2020-08-10 18:14:20.223 Loaded 169853 Ids to the callsign lookup table
M: 2020-08-10 18:14:20.223 Starting P25Gateway-20180409
I: 2020-08-10 18:14:20.223 Started the DMR Id lookup reload thread
M: 2020-08-10 18:14:20.223 Linked at startup to reflector 10888
W: 2020-08-10 18:16:20.246 No response from 10888, unlinking
^C
root@P25reflector:/var/log/mmdvm # tail -f P25Reflector-2020-08-10.log 
M: 2020-08-10 18:54:20.263     K5TRA      (192.168.0.1:42010) 2/120
M: 2020-08-10 18:56:20.265 Currently linked repeaters:
M: 2020-08-10 18:56:20.265     K5TRA      (192.168.0.1:1088) 4/120
M: 2020-08-10 18:56:20.265     K5TRA      (192.168.0.1:42010) 2/120
M: 2020-08-10 18:56:54.179 Transmission started from K5TRA      (192.168.0.1:42010)
M: 2020-08-10 18:56:54.190 Transmission from K5TRA at K5TRA      to TG 10888
M: 2020-08-10 18:56:55.098 Received end of transmission
M: 2020-08-10 18:58:20.273 Currently linked repeaters:
M: 2020-08-10 18:58:20.273     K5TRA      (192.168.0.1:1088) 4/120
M: 2020-08-10 18:58:20.273     K5TRA      (192.168.0.1:42010) 2/120


Re: ASL to P25 bridge #analog_bridge

Tom
 

When I tail -f   /var/log/dvswitch/Analog_Bridge.log   I see PTT on and PTT off  response

In /var/log/mmdvm,  when I tail -f the MMDVM_Bridge log I don't see any responses from AB:

root@P25reflector:/var/log/mmdvm # tail -f MMDVM_Bridge-2020-08-10.log 
I: 2020-08-10 18:14:20.372 Loaded 169853 Ids to the DMR callsign lookup table
I: 2020-08-10 18:14:20.372 P25 RF Parameters
I: 2020-08-10 18:14:20.372 Started the DMR Id lookup reload thread
I: 2020-08-10 18:14:20.372     Id: 3148777
I: 2020-08-10 18:14:20.372     NAC: $293
I: 2020-08-10 18:14:20.372     UID Override: no
I: 2020-08-10 18:14:20.372     Self Only: no
I: 2020-08-10 18:14:20.372     Remote Gateway: no
I: 2020-08-10 18:14:20.372     Mode Hang: 10s
M: 2020-08-10 18:14:20.372 MMDVM_Bridge-20200309_V1.5.1 is running



Re: ASL to P25 bridge #analog_bridge

Steve N4IRS
 

One step at a time. Get AB talking to ASL. You should be able to see the traffic from ASL to AB.
This is an ASL <-> DMR document. The concepts are the same. It's old (needs updating) so toy will see toDMR etc but the concept is the same.
You:
ASL <-> AB <-> MB <-> P25Gateway

Document
<ASL <-> AB <-> MB

<https://dvswitch.groups.io/g/allstarlink/files/ASL%20to%20DMR%20Bridge.pdf>

On 8/10/2020 1:47 PM, Tom wrote:
Any tips on monitoring / verifying those data connections?


Re: ASL to P25 bridge #analog_bridge

Tom
 

Any tips on monitoring / verifying those data connections?


Re: ASL to P25 bridge #analog_bridge

Tom
 

reboot did it!  ASL is OK.

Now I'll work on the analog_bridge path to the reflector.

Thanks!  I'll keep you posted on progress.

Tom


Re: ASL to P25 bridge #analog_bridge

Tom
 

Yes, it looks like it is on the network. I checked the external nodes file on another box. 

The remaining problem is to get that file to get updates on this server. I'll try a reboot.


Re: ASL to P25 bridge #analog_bridge

Steve N4IRS
 

Do this as root so that you don't have to rebuild DAHDI again:
apt-mark hold raspberrypi-kernel-headers raspberrypi-kernel

You will then be able to do a apt-get update / apt-get upgrade without need ing to rebuild DAHDI.

Steve

On 8/10/2020 1:22 PM, Tom wrote:
It looks like ASL is running; but this node 46715 isn't in the external nodes list (not registered).  -- can't connect.


Re: ASL to P25 bridge #analog_bridge

Steve N4IRS
 

On 8/10/2020 1:22 PM, Tom wrote:
It looks like ASL is running; but this node 46715 isn't in the external nodes list (not registered).  -- can't connect.


Re: ASL to P25 bridge #analog_bridge

Steve N4IRS
 

Is 46715 the node you are working on now?

On 8/10/2020 1:22 PM, Tom wrote:
It looks like ASL is running; but this node 46715 isn't in the external nodes list (not registered).  -- can't connect.


Re: ASL to P25 bridge #analog_bridge

Tom
 

It looks like ASL is running; but this node 46715 isn't in the external nodes list (not registered).  -- can't connect.


Re: ASL to P25 bridge #analog_bridge

Tom
 

root@K5TRA_ASL_testserver:/etc/asterisk # dahdi_scan
[1]
active=yes
alarms=UNCONFIGURED
description=DAHDI_DUMMY/1 (source: HRtimer) 1
name=DAHDI_DUMMY/1
manufacturer=
devicetype=DAHDI Dummy Timing
location=
basechan=1
totchans=0
irq=0
root@K5TRA_ASL_testserver:/etc/asterisk # dahdi_test -c 10
Opened pseudo dahdi interface, measuring accuracy...
99.986% 99.944% 99.959% 99.958% 99.992% 99.993% 99.992% 99.993% 
99.991% 99.991% 
--- Results after 10 passes ---
Best: 99.993% -- Worst: 99.944% -- Average: 99.979834%
Cumulative Accuracy (not per pass): 99.980

chan_dahdi.conf was missing; but it's there now. 
simpleusb and usbradio are loaded in modules; but I will fix that (focused on dahdi now).


Re: ASL to P25 bridge #analog_bridge

Steve N4IRS
 

Show output:
dahdi_scan
dahdi_test -c 10

On 8/10/2020 12:59 PM, Tom wrote:
root@K5TRA_ASL_testserver:/usr/src # lsmod | grep dahdi
dahdi_dummy             3432  0
dahdi                 229497  1 dahdi_dummy
crc_ccitt               1771  1 dahdi


Re: ASL to P25 bridge #analog_bridge

Steve N4IRS
 

Do you have chan_dahdi.conf in /etc/asterisk?
Do you have simple usb and usbradio enabled on /etc/asterisk/modules?

On 8/10/2020 12:32 PM, Tom wrote:
.[Aug 10 11:21:52] ERROR[13888]: chan_dahdi.c:11711 setup_dahdi: Unable to load chan_dahdi.conf
...[Aug 10 11:21:52] NOTICE[13888]: chan_simpleusb.c:4242 load_module: Unable to load config simpleusb.conf
[Aug 10 11:21:52] NOTICE[13888]: chan_usbradio.c:5790 load_module: Unable to load config usbradio.conf

2221 - 2240 of 9151