Date   

Re: MMDVM log #mmdvm_bridge

David Martin
 

Hello Dimitri,

 

I have had good success (mostly) using a Nextion screen with MMDVM_Bridge. 

It works well on Receive but not at all on transmit. Transmit is not too much of a problem though as it’s only myself.

I am using NextionDriver 1.18 and a 3.5” basic screen. 

Initially there was no TXRx frequencies, CPU Temperature or location. But found ‘#define XTRA’ in NextionDriver.h to enable these.

 

I have only tested this on DMR so far

 

Are you trying to get the Transmit information to show?  If so I would be interested in what you come up with as a solution.

 

Regards  David VK3KQT.

 

 

 

 

 


From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Dimitri F5SWB
Sent: Tuesday, 6 October 2020 11:27 PM
To: main@DVSwitch.groups.io
Subject: [DVSwitch] MMDVM log #mmdvm_bridge

 

Hello, I need to parse the MMDVM log to get some informations to show on a Nextion screen ...
Regarding to the ini file :
[Log]

Logging levels, 0=No logging, 1=Debug, 2=Message, 3=Info, 4=Warning, 5=Error, 6=Fatal

DisplayLevel=1
FileLevel=2
FilePath=/var/log/mmdvm
FileRoot=MMDVM_Bridge

I would like to get only one file named mmdvm.log without the date like mmdvm.log for example ...

is there anything that I can do with the logging levels ?

If not, another way will be appreciated also.

Many thanks in advance !

Regards.
F5SWB Dimitri.


Virus-free. www.avast.com


#mmdvm_bridge log #mmdvm_bridge

Dimitri F5SWB
 

hello,

I'm working on a Application Programming Interface (api) to split the log of mmdvm_bridge.
# Logging levels, 0=No logging, 1=Debug, 2=Message, 3=Info, 4=Warning, 5=Error, 6=Fatal
DisplayLevel=1
FileLevel=2
FilePath=/var/log/mmdvm
FileRoot=MMDVM_Bridge
[Log]

the log is written like this : MMDVM_Bridge-2020-10-08 (for example).
is there a way to have only MMDVM_Bridge without the date -2020-10-08

Many thanks.

73"s F5SWB.


Passing Meetadata/Best Practice

 

Hi,

I've been running a multimode gateway using AllStar and DVSwitch for the
better part of 2 months.  Currently, on the digital side, I support DMR
(Brandmeister), D-STAR (My own XLX), YSF and P25. 

The system puts AllStar at the centre.  This was a deliberate decision,
to ensure that no matter the source and destination, there is never any
more than one (xMBE) transcoding cycle, regardless of source and
destination.  And in the case of YSF <--> DMR, no transcoding at all, as
I have a separate MMDVM_Bridge between those two modes.

Basically, I have an AllStar node which has 3 private nodes, each of
which is linked to a branch of digital systems - each branch uses a
different *MBE codec.  These private nodes are permanently linked to the
main node (and effectively each other) to form a complete system, so
I'll just discuss the private nodes to digital section.

There are 3 private nodes that link to the various digital systems. 
They are configured as follows:
1997 <--> Analog_Bridge <--> MMDVM_Bridge <-->  Brandmeister.
1998 <--> Analog_Bridge <--> MMDVM_Bridge <--> P25Gateway <--> P25Reflector
1999 <--> DummyRepeater <--> ircDDBGateway <--> XLX
Brandmeister <--> MMDVM_Bridge <--> YSFReflector

Note:  D-STAR is configured using the version of DummyRepeater patched
with USRP support.  DummyRepeater is used, so I can make use of a DV
Dongle (the original blue one) that I already had on hand to process the
DSAMBE audio.  Besides cost (and waste), delivery time uncertainties
were another reason not to order new hardware for the DSAMBE
processing.  Goods from overseas are taking an unpredictable amount of
time to get here from overseas (used to be 1-2 weeks from the US, can be
way more than a month now, due to COVID).

Everything is working well, with great audio between the different
modes, and it can be really difficult to tell where people are entering
the system, as other than D-STAR (quality is slightly less D-STAR to the
other modes), there's no easily noticed artifacts in the audio.

However, because AllStar is in the middle, I do lose the callsign/ID
metadata on most streams, with the only exception being between DMR and
YSF.  Since everyone IDs, and there's analog systems on the other side
of AllStar (I haven't elaborated, since the details aren't relevant to
this post), this is more of a cosmetic issue than a serious one, and I'm
happy to keep running things as they are, if there's no better solutions.

What I'm asking is if there's a better topology for such a gateway that
preserves audio quality?  Or is there a way somehow to pass metadata
between the digital links, while leaving the audio going via AllStar?


--
73 de Tony VK3JED/VK3IRL
http://vkradio.com


Re: ASL to DVSwitch Assistance

Neil k8it
 

Jay I think I might be able to help you with your project please send me your phone number in a direct email and I will call you to discuss.

Thanks 73 Neil Sablatzky K8IT

On 5 Oct 2020 13:00, "Jay" wrote:

My goal is to interface my Allstar to DVSWitch in a manner somewhat like the DVSWitch mobile app where I can change Modes and TG/Rooms/Reflectors from an analog radio keypad once connected to Allstar.  In my case a Allstar personnel Low Power Node at my residence or in the Mobile as a portable.

I can Interface DMR, YSF, etc as separate Private Nodes ok, but that is not my goal.  My DVSwitch configuration works well with the Mobile Client, but I want to use an Analog radio.

I would like to connect to my Allstar node, then through to DVSwitch and send DVSwitch commands, via either AllStar Commands, Funcitons or Macros (or send DVSwitch Commands directly) to switch mode and then TG, etc,   Talk, then disconnect.

I know others probably have this working fine, but after a lot of hours, I cannot wrap my head around the configuration and methodology.  I have tried a ton of things that almost work, but not really.  My Allstar node and DVSwitch are on separate Pi's at the moment for experimenting and  testing.  I have tried ASL and HamVOIP with the same results.

Thanks for any assistance.

jb  N4NQY

If any one has this working well and dont mind sharing their knowledge, you are free to post here or off groups.io and try my email call # arrl.net or QRZ address. I am pretty sure there are others stumped on this.  


--

jb   N4NQY


Re: 2nd DVSwitch server and port forwarding.

Bj DV8AWC
 

No, you will not have a problem running a 2nd server as long as the PORTS are different for each servers.


ASL to DVSwitch Assistance

Jay
 

My goal is to interface my Allstar to DVSWitch in a manner somewhat like the DVSWitch mobile app where I can change Modes and TG/Rooms/Reflectors from an analog radio keypad once connected to Allstar.  In my case a Allstar personnel Low Power Node at my residence or in the Mobile as a portable.

I can Interface DMR, YSF, etc as separate Private Nodes ok, but that is not my goal.  My DVSwitch configuration works well with the Mobile Client, but I want to use an Analog radio.

I would like to connect to my Allstar node, then through to DVSwitch and send DVSwitch commands, via either AllStar Commands, Funcitons or Macros (or send DVSwitch Commands directly) to switch mode and then TG, etc,   Talk, then disconnect.

I know others probably have this working fine, but after a lot of hours, I cannot wrap my head around the configuration and methodology.  I have tried a ton of things that almost work, but not really.  My Allstar node and DVSwitch are on separate Pi's at the moment for experimenting and  testing.  I have tried ASL and HamVOIP with the same results.

Thanks for any assistance.

jb  N4NQY

If any one has this working well and dont mind sharing their knowledge, you are free to post here or off groups.io and try my email call # arrl.net or QRZ address. I am pretty sure there are others stumped on this.  


--

jb   N4NQY


Re: Macro Result 256

Steve N4IRS
 

yes. Run the macro script from the command line to see the error.

On 10/5/20 5:40 AM, Derek William Haden wrote:

Could someone enlighten me was to what

"Macro Result 256"
means.

I know 0 means success I assume 256 is abject failure?



Macro Result 256

Derek William Haden <facebook@...>
 

Could someone enlighten me was to what

"Macro Result 256"
means.

I know 0 means success I assume 256 is abject failure?


Re: Repeater ID (0) cannot be the same as sibscriber ID (0)

Steve N4IRS
 

It means AD has seen traffic from repeater ID 0 or subscriber ID 0 (more likely) What hardware are you running and have you updated from github the MB and AB binaries?

Steve N4IRS

On 10/4/20 2:38 PM, Derek William Haden wrote:
Analog_Bridge.log shows this error.

Repeater ID (0) cannot be the same as sibscriber ID (0)

Could someone tell me what it means?


MMDVM_Bridge bug ???

David Young
 

Having a issue running a DVSwitch bridge from an FCS room to DMR.  Bridge is setup and working but in the MMDVM_Bridge log after every transmission to the MMDVM_Bridge from the FCS room through YSFGateway I receive an error message "Network watchdog has expired".
Also running other DVSwitch bridges, YSF, P25, and NXDN to the same DMR TG, and when this error occurs from the FCS bridge, it causes these other bridges to stay in listen mode as no TX OFF is passed through to them.
I am not sure this is a DVSwitch bug but I cannot find any other problem which is causing this network timeout error.
This network timeout error occurs on every FCS room Tx to the MMDVM_Bridge no matter how long or short the FCS transmission is.

Any help or ideas?
Thanks,
73, Dave
--
Dave WB6DTB


Re: DVSwitch-System-Builder 404 error

Steve N4IRS
 

./DVSwitch-System-Builder.sh
--2020-09-25 13:37:00--  http://dvswitch.org/install-dvswitch-repo
Resolving dvswitch.org (dvswitch.org)... 44.103.34.4
Connecting to dvswitch.org (dvswitch.org)|44.103.34.4|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 782
Saving to: ‘install-dvswitch-repo’

install-dvswitch-repo                                       100%[========================================================================================================================================>]     782  --.-KB/s    in 0s

2020-09-25 13:37:00 (4.73 MB/s) - ‘install-dvswitch-repo’ saved [782/782]

I'm testing it here on a remote RPi I don't want the whole script to execute because I am running it on the DVSwitch-Server RPi image which has all the programs already installed. So, I stopped the script (exit 0) after the wget from dvswitch.org. See below.

#!/usr/bin/env bash
set -o errexit

# N4IRS 02/10/2020

#################################################
#                                               #
#    Build a DVSwitch Server on a clean disk    #
#                                               #
#################################################

# Install DVSwitch Repository
cd /tmp

wget http://dvswitch.org/install-dvswitch-repo
chmod +x install-dvswitch-repo

exit 0


On 9/25/2020 1:32 PM, Derek William Haden wrote:

I can only report what I see happening.

This on 2 different computers.

The wget from github works, the wget from the script doesn't.



Re: DVSwitch-System-Builder 404 error

Derek William Haden <facebook@...>
 

I can only report what I see happening.

This on 2 different computers.

The wget from github works, the wget from the script doesn't.


Re: DVSwitch-System-Builder 404 error

Steve N4IRS
 

root@backup:~# wget http://dvswitch.org/install-dvswitch-repo
--2020-09-25 11:58:44--  http://dvswitch.org/install-dvswitch-repo
Resolving dvswitch.org (dvswitch.org)... 44.103.34.4
Connecting to dvswitch.org (dvswitch.org)|44.103.34.4|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 782
Saving to: ‘install-dvswitch-repo’

install-dvswitch-repo         100%[=================================================>]     782  --.-KB/s    in 0s

2020-09-25 11:58:44 (128 MB/s) - ‘install-dvswitch-repo’ saved [782/782]

root@backup:~# ls -la in*
-rw-r--r-- 1 root root 782 Jun 22  2018 install-dvswitch-repo


On 9/25/2020 11:54 AM, Derek William Haden wrote:
Error 404 occurs when I try to run the script ./DVSwitch-System-Builder.sh

Here's the reported error
---
./DVSwitch-System-Builder.sh
Resolving dvswitch.org (dvswitch.org)... 44.103.34.4
Connecting to dvswitch.org (dvswitch.org)|44.103.34.4|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2020-09-25 16:49:44 ERROR 404: Not Found.
------
If I try to run
wget http://dvswitch.org/install-dvswitch-repo   ### first line of the script
I get the error


Re: DVSwitch-System-Builder 404 error

Derek William Haden <facebook@...>
 

Error 404 occurs when I try to run the script ./DVSwitch-System-Builder.sh

Here's the reported error
---
./DVSwitch-System-Builder.sh
--2020-09-25 16:49:44--  http://dvswitch.org/install-dvswitch-repo
Resolving dvswitch.org (dvswitch.org)... 44.103.34.4
Connecting to dvswitch.org (dvswitch.org)|44.103.34.4|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2020-09-25 16:49:44 ERROR 404: Not Found.
------
If I try to run
wget http://dvswitch.org/install-dvswitch-repo   ### first line of the script
I get the error


Re: DVSwitch-System-Builder 404 error

Steve N4IRS
 



On 9/25/2020 10:13 AM, Derek William Haden wrote:root@dvswitch:
/# mkdir test
root@dvswitch:/# cd test

root@dvswitch:/test# wget https://github.com/DVSwitch/DVSwitch-System-Builder/archive/master.zip
--2020-09-25 10:05:39--  https://github.com/DVSwitch/DVSwitch-System-Builder/archive/master.zip
Resolving github.com (github.com)... 140.82.112.4
Connecting to github.com (github.com)|140.82.112.4|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://codeload.github.com/DVSwitch/DVSwitch-System-Builder/zip/master [following]
--2020-09-25 10:05:40--  https://codeload.github.com/DVSwitch/DVSwitch-System-Builder/zip/master
Resolving codeload.github.com (codeload.github.com)... 140.82.114.9
Connecting to codeload.github.com (codeload.github.com)|140.82.114.9|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/zip]
Saving to: ‘master.zip’

master.zip                                             [   <=>                                                                                                             ]   1.70M  2.89MB/s   in 0.6s

2020-09-25 10:05:40 (2.89 MB/s) - ‘master.zip’ saved [1781536]

root@dvswitch:/test# ls -la
total 1748
drwxr-xr-x  2 root root    4096 Sep 25 10:05 .
drwxr-xr-x 24 root root    4096 Sep 25 10:05 ..
-rw-r--r--  1 root root 1781536 Sep 25 10:05 master.zip

[Edited Message Follows]

Followed instructions
cd /tmp
wget 
https://github.com/DVSwitch/DVSwitch-System-Builder/archive/master.zip
cd /srv
unzip /tmp/master.zip
mv DVSwitch-System-Builder-master DVSwitch-System-Builder
cd DVSwitch-System-Builder
./DVSwitch-System-Builder.sh

404 error not found.
???



DVSwitch-System-Builder 404 error

Derek William Haden <facebook@...>
 
Edited

Followed instructions
cd /tmp
wget 
https://github.com/DVSwitch/DVSwitch-System-Builder/archive/master.zip
cd /srv
unzip /tmp/master.zip
mv DVSwitch-System-Builder-master DVSwitch-System-Builder
cd DVSwitch-System-Builder
./DVSwitch-System-Builder.sh

404 error not found.
???


Re: Talkover my talk groups

Derek William Haden <facebook@...>
 

Do you have port forwarding setup on the router?


Re: How do i connect my bridge on the TGIF network

Steve N4IRS
 

Edit this stanza in MMDVM_Bridge.ini

[DMR Network]
Address=hblink.dvswitch.org
Port=62031
Password=passw0rd


On 9/22/20 3:54 PM, Jeremy WX8NWS 3169368 wrote:
How do i connect my bridge on the TGIF network


How do i connect my bridge on the TGIF network

 

How do i connect my bridge on the TGIF network


Re: Anysecu / Inrico B01 BT Microphone

Jose - EA5SW
 

Sri. I post in the another group.

1841 - 1860 of 9072