Date   

Re: Problems Connecting

 

Here are the files.

Richard


Re: radioid.net URL update in dvswitch.sh

Steve N4IRS
 

FYI, this is the current version:
root@DVSwitch-Server:~# /opt/MMDVM_Bridge/dvswitch.sh -v
dvswitch.sh version 1.5.9


On 10/20/20 5:05 PM, k7wby@... wrote:
The complete version of how to update  dvwitch.sh with the correct urls to the RadioID.net database.

cd /opt/Analog_Bridge
ls -al (look for dvswitch.sh, if its not there then look in /opt/MMDVM_Bridge. If it's in MMDVM_Bridge then stop, you have the latest version.)
cp dvswitch.sh dvswitch.old (humor me and make a quick backup just for fun)
rm dvswitch.sh (delete the original version)
wget https://github.com/DVSwitch/MMDVM_Bridge/raw/master/dvswitch.sh
chmod +x dvswitch.sh (make it executable)
./dvswitch.sh update (if this runs and does not produce any errors then you're golden. if you get errors, then start at the beginning and try again.)

if all goes according to plan then
rm dvswitch.old 


Re: Problems Connecting

Steve N4IRS
 

Richard,
Without seeing the relevant sections of iax.conf and extensions.conf all I can say this is your clue:
[Oct 21 00:46:18] WARNING[2817]: app_rpt.c:21237 rpt_exec: Cannot find specified system node 1998


On 10/21/20 12:59 AM, RichardM wrote:
Hello

I am setting up DVSwitch to connect to an AllStar node in my house.  I can connect to it using IAXRPT on the PC, but when I try this with DVSwitch, it goes into a loop connecting and disconnecting. 

A friend looked into this and suggested that I post the following information. Can someone help us with this?

Richard

----

Message follows:

I have an Allstar node (Raspberry Pi 4) running HamVoip. I've done an update, so it's running all of the latest patches.

When I use DVSwitch to connect to my node (519980), the following error shows up in the Asterisk CLI log level 4. Note that if I have "autoload node" set to ON, the message repeats itself over and over until there is a crash.

Running DVSwitch 1.57 (130).

          Starting Asterisk client. Please type: exit<ENTER>
           when done and you will return to the admin menu.

Asterisk 1.4.23-pre.hamvoip-V1.6.2-10 app_rpt-0.327-06/01/2020, Copyright (C) 1999 - 2020 HamVoIP.org and others.
Created by Mark Spencer <markster@...>
Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type 'core show license' for details.
=========================================================================
Connected to Asterisk 1.4.23-pre.hamvoip-V1.6.2-10 app_rpt-0.327-06/01/2020 currently running on Richnode1 (pid = 2785)
Verbosity was 3 and is now 4
    -- Registered IAX2 'myphone-iaxrpt' (AUTHENTICATED) at 208.86.127.233:1025
    -- Accepting AUTHENTICATED call from 208.86.127.233:
       > requested format = unknown,
       > requested prefs = (slin|ulaw|adpcm),
       > actual format = ulaw,
       > host prefs = (ulaw),
       > priority = mine
    -- Executing [519980@phone-iaxrpt:1] Answer("IAX2/myphone-iaxrpt-314", "") in new stack
    -- Executing [519980@phone-iaxrpt:2] Playback("IAX2/myphone-iaxrpt-314", "rpt/node") in new stack
    -- <IAX2/myphone-iaxrpt-314> Playing 'rpt/node' (language 'en')
    -- Executing [519980@phone-iaxrpt:3] Playback("IAX2/myphone-iaxrpt-314", "digits/1") in new stack
    -- <IAX2/myphone-iaxrpt-314> Playing 'digits/1' (language 'en')
    -- Executing [519980@phone-iaxrpt:4] Playback("IAX2/myphone-iaxrpt-314", "digits/9") in new stack
    -- <IAX2/myphone-iaxrpt-314> Playing 'digits/9' (language 'en')
    -- Executing [519980@phone-iaxrpt:5] Playback("IAX2/myphone-iaxrpt-314", "digits/9") in new stack
    -- <IAX2/myphone-iaxrpt-314> Playing 'digits/9' (language 'en')
    -- Executing [519980@phone-iaxrpt:6] Playback("IAX2/myphone-iaxrpt-314", "digits/8") in new stack
    -- <IAX2/myphone-iaxrpt-314> Playing 'digits/8' (language 'en')
    -- Executing [519980@phone-iaxrpt:7] Set("IAX2/myphone-iaxrpt-314", "CALLERID(num)=0") in new stack
    -- Executing [519980@phone-iaxrpt:8] Rpt("IAX2/myphone-iaxrpt-314", "1998|P|KJ7PLR") in new stack
[Oct 21 00:46:18] WARNING[2817]: app_rpt.c:21237 rpt_exec: Cannot find specified system node 1998
  == Spawn extension (phone-iaxrpt, 519980, 8) exited non-zero on 'IAX2/myphone-iaxrpt-314'
    -- Hungup 'IAX2/myphone-iaxrpt-314'
Richnode1*CLI>


Problems Connecting

 

Hello

I am setting up DVSwitch to connect to an AllStar node in my house.  I can connect to it using IAXRPT on the PC, but when I try this with DVSwitch, it goes into a loop connecting and disconnecting. 

A friend looked into this and suggested that I post the following information. Can someone help us with this?

Richard

----

Message follows:

I have an Allstar node (Raspberry Pi 4) running HamVoip. I've done an update, so it's running all of the latest patches.

When I use DVSwitch to connect to my node (519980), the following error shows up in the Asterisk CLI log level 4. Note that if I have "autoload node" set to ON, the message repeats itself over and over until there is a crash.

Running DVSwitch 1.57 (130).

          Starting Asterisk client. Please type: exit<ENTER>
           when done and you will return to the admin menu.

Asterisk 1.4.23-pre.hamvoip-V1.6.2-10 app_rpt-0.327-06/01/2020, Copyright (C) 1999 - 2020 HamVoIP.org and others.
Created by Mark Spencer <markster@...>
Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type 'core show license' for details.
=========================================================================
Connected to Asterisk 1.4.23-pre.hamvoip-V1.6.2-10 app_rpt-0.327-06/01/2020 currently running on Richnode1 (pid = 2785)
Verbosity was 3 and is now 4
    -- Registered IAX2 'myphone-iaxrpt' (AUTHENTICATED) at 208.86.127.233:1025
    -- Accepting AUTHENTICATED call from 208.86.127.233:
       > requested format = unknown,
       > requested prefs = (slin|ulaw|adpcm),
       > actual format = ulaw,
       > host prefs = (ulaw),
       > priority = mine
    -- Executing [519980@phone-iaxrpt:1] Answer("IAX2/myphone-iaxrpt-314", "") in new stack
    -- Executing [519980@phone-iaxrpt:2] Playback("IAX2/myphone-iaxrpt-314", "rpt/node") in new stack
    -- <IAX2/myphone-iaxrpt-314> Playing 'rpt/node' (language 'en')
    -- Executing [519980@phone-iaxrpt:3] Playback("IAX2/myphone-iaxrpt-314", "digits/1") in new stack
    -- <IAX2/myphone-iaxrpt-314> Playing 'digits/1' (language 'en')
    -- Executing [519980@phone-iaxrpt:4] Playback("IAX2/myphone-iaxrpt-314", "digits/9") in new stack
    -- <IAX2/myphone-iaxrpt-314> Playing 'digits/9' (language 'en')
    -- Executing [519980@phone-iaxrpt:5] Playback("IAX2/myphone-iaxrpt-314", "digits/9") in new stack
    -- <IAX2/myphone-iaxrpt-314> Playing 'digits/9' (language 'en')
    -- Executing [519980@phone-iaxrpt:6] Playback("IAX2/myphone-iaxrpt-314", "digits/8") in new stack
    -- <IAX2/myphone-iaxrpt-314> Playing 'digits/8' (language 'en')
    -- Executing [519980@phone-iaxrpt:7] Set("IAX2/myphone-iaxrpt-314", "CALLERID(num)=0") in new stack
    -- Executing [519980@phone-iaxrpt:8] Rpt("IAX2/myphone-iaxrpt-314", "1998|P|KJ7PLR") in new stack
[Oct 21 00:46:18] WARNING[2817]: app_rpt.c:21237 rpt_exec: Cannot find specified system node 1998
  == Spawn extension (phone-iaxrpt, 519980, 8) exited non-zero on 'IAX2/myphone-iaxrpt-314'
    -- Hungup 'IAX2/myphone-iaxrpt-314'
Richnode1*CLI>


Re: radioid.net URL update in dvswitch.sh

k7wby@...
 

The complete version of how to update  dvwitch.sh with the correct urls to the RadioID.net database.

cd /opt/Analog_Bridge
ls -al (look for dvswitch.sh, if its not there then look in /opt/MMDVM_Bridge. If it's in MMDVM_Bridge then stop, you have the latest version.)
cp dvswitch.sh dvswitch.old (humor me and make a quick backup just for fun)
rm dvswitch.sh (delete the original version)
wget https://github.com/DVSwitch/MMDVM_Bridge/raw/master/dvswitch.sh
chmod +x dvswitch.sh (make it executable)
./dvswitch.sh update (if this runs and does not produce any errors then you're golden. if you get errors, then start at the beginning and try again.)

if all goes according to plan then
rm dvswitch.old 


Re: radioid.net URL update in dvswitch.sh

k7wby@...
 

don't forget to chmod +x dvswitch.sh


Re: Image for Raspberry pi3 with Debian 10 Buster with DVSWICTH SERVER, HBLINK3 AND HBMONITOR.

EA5GVK Joaquin
 

New DVLink Multilanguage Image Update V.9.9, via OTAP -Internet or download image also.
change log
http://ea5gvk-dmr.zigor.es/2020/10/09/actualizacion-imagen-dvlink-v-9-9-en-todas-sus-distribuciones/

Image available for Raspberry Pi-Zero, Pi 2/3/4, Virtual Box and Orange Pi PC.

https://www.youtube.com/watch?v=aRFSTSGzp8w&feature=emb_logo

Greetings and many thanks to Steve, Mike and all the members


Re: MMDVM log #mmdvm_bridge

Dimitri F5SWB
 

Hello david,

Yes, I have the informations on the screen in rx (network) and tx also.
The project with numeric feature is the following of this :
https://github.com/F8ASB/spotnik2hmi_V2

https://youtu.be/AAncUrFdAnY
To get the informations I'm using an application programming interface in javascript and a python script :



at this point of dev, I need to get the MMDVM_Bridge log without the date as MMDVM_Bridge-2020-10-09.log 
what I need is only MMDVM_Bridge.log ....

73's
F5SWB.


Re: MMDVM log #mmdvm_bridge

David Martin
 

Hello Dimitri,

 

I have had good success (mostly) using a Nextion screen with MMDVM_Bridge. 

It works well on Receive but not at all on transmit. Transmit is not too much of a problem though as it’s only myself.

I am using NextionDriver 1.18 and a 3.5” basic screen. 

Initially there was no TXRx frequencies, CPU Temperature or location. But found ‘#define XTRA’ in NextionDriver.h to enable these.

 

I have only tested this on DMR so far

 

Are you trying to get the Transmit information to show?  If so I would be interested in what you come up with as a solution.

 

Regards  David VK3KQT.

 

 

 

 

 


From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Dimitri F5SWB
Sent: Tuesday, 6 October 2020 11:27 PM
To: main@DVSwitch.groups.io
Subject: [DVSwitch] MMDVM log #mmdvm_bridge

 

Hello, I need to parse the MMDVM log to get some informations to show on a Nextion screen ...
Regarding to the ini file :
[Log]

Logging levels, 0=No logging, 1=Debug, 2=Message, 3=Info, 4=Warning, 5=Error, 6=Fatal

DisplayLevel=1
FileLevel=2
FilePath=/var/log/mmdvm
FileRoot=MMDVM_Bridge

I would like to get only one file named mmdvm.log without the date like mmdvm.log for example ...

is there anything that I can do with the logging levels ?

If not, another way will be appreciated also.

Many thanks in advance !

Regards.
F5SWB Dimitri.


Virus-free. www.avast.com


#mmdvm_bridge log #mmdvm_bridge

Dimitri F5SWB
 

hello,

I'm working on a Application Programming Interface (api) to split the log of mmdvm_bridge.
# Logging levels, 0=No logging, 1=Debug, 2=Message, 3=Info, 4=Warning, 5=Error, 6=Fatal
DisplayLevel=1
FileLevel=2
FilePath=/var/log/mmdvm
FileRoot=MMDVM_Bridge
[Log]

the log is written like this : MMDVM_Bridge-2020-10-08 (for example).
is there a way to have only MMDVM_Bridge without the date -2020-10-08

Many thanks.

73"s F5SWB.


Passing Meetadata/Best Practice

 

Hi,

I've been running a multimode gateway using AllStar and DVSwitch for the
better part of 2 months.  Currently, on the digital side, I support DMR
(Brandmeister), D-STAR (My own XLX), YSF and P25. 

The system puts AllStar at the centre.  This was a deliberate decision,
to ensure that no matter the source and destination, there is never any
more than one (xMBE) transcoding cycle, regardless of source and
destination.  And in the case of YSF <--> DMR, no transcoding at all, as
I have a separate MMDVM_Bridge between those two modes.

Basically, I have an AllStar node which has 3 private nodes, each of
which is linked to a branch of digital systems - each branch uses a
different *MBE codec.  These private nodes are permanently linked to the
main node (and effectively each other) to form a complete system, so
I'll just discuss the private nodes to digital section.

There are 3 private nodes that link to the various digital systems. 
They are configured as follows:
1997 <--> Analog_Bridge <--> MMDVM_Bridge <-->  Brandmeister.
1998 <--> Analog_Bridge <--> MMDVM_Bridge <--> P25Gateway <--> P25Reflector
1999 <--> DummyRepeater <--> ircDDBGateway <--> XLX
Brandmeister <--> MMDVM_Bridge <--> YSFReflector

Note:  D-STAR is configured using the version of DummyRepeater patched
with USRP support.  DummyRepeater is used, so I can make use of a DV
Dongle (the original blue one) that I already had on hand to process the
DSAMBE audio.  Besides cost (and waste), delivery time uncertainties
were another reason not to order new hardware for the DSAMBE
processing.  Goods from overseas are taking an unpredictable amount of
time to get here from overseas (used to be 1-2 weeks from the US, can be
way more than a month now, due to COVID).

Everything is working well, with great audio between the different
modes, and it can be really difficult to tell where people are entering
the system, as other than D-STAR (quality is slightly less D-STAR to the
other modes), there's no easily noticed artifacts in the audio.

However, because AllStar is in the middle, I do lose the callsign/ID
metadata on most streams, with the only exception being between DMR and
YSF.  Since everyone IDs, and there's analog systems on the other side
of AllStar (I haven't elaborated, since the details aren't relevant to
this post), this is more of a cosmetic issue than a serious one, and I'm
happy to keep running things as they are, if there's no better solutions.

What I'm asking is if there's a better topology for such a gateway that
preserves audio quality?  Or is there a way somehow to pass metadata
between the digital links, while leaving the audio going via AllStar?


--
73 de Tony VK3JED/VK3IRL
http://vkradio.com


Re: ASL to DVSwitch Assistance

Neil k8it
 

Jay I think I might be able to help you with your project please send me your phone number in a direct email and I will call you to discuss.

Thanks 73 Neil Sablatzky K8IT

On 5 Oct 2020 13:00, "Jay" wrote:

My goal is to interface my Allstar to DVSWitch in a manner somewhat like the DVSWitch mobile app where I can change Modes and TG/Rooms/Reflectors from an analog radio keypad once connected to Allstar.  In my case a Allstar personnel Low Power Node at my residence or in the Mobile as a portable.

I can Interface DMR, YSF, etc as separate Private Nodes ok, but that is not my goal.  My DVSwitch configuration works well with the Mobile Client, but I want to use an Analog radio.

I would like to connect to my Allstar node, then through to DVSwitch and send DVSwitch commands, via either AllStar Commands, Funcitons or Macros (or send DVSwitch Commands directly) to switch mode and then TG, etc,   Talk, then disconnect.

I know others probably have this working fine, but after a lot of hours, I cannot wrap my head around the configuration and methodology.  I have tried a ton of things that almost work, but not really.  My Allstar node and DVSwitch are on separate Pi's at the moment for experimenting and  testing.  I have tried ASL and HamVOIP with the same results.

Thanks for any assistance.

jb  N4NQY

If any one has this working well and dont mind sharing their knowledge, you are free to post here or off groups.io and try my email call # arrl.net or QRZ address. I am pretty sure there are others stumped on this.  


--

jb   N4NQY


Re: 2nd DVSwitch server and port forwarding.

Bj DV8AWC
 

No, you will not have a problem running a 2nd server as long as the PORTS are different for each servers.


ASL to DVSwitch Assistance

Jay
 

My goal is to interface my Allstar to DVSWitch in a manner somewhat like the DVSWitch mobile app where I can change Modes and TG/Rooms/Reflectors from an analog radio keypad once connected to Allstar.  In my case a Allstar personnel Low Power Node at my residence or in the Mobile as a portable.

I can Interface DMR, YSF, etc as separate Private Nodes ok, but that is not my goal.  My DVSwitch configuration works well with the Mobile Client, but I want to use an Analog radio.

I would like to connect to my Allstar node, then through to DVSwitch and send DVSwitch commands, via either AllStar Commands, Funcitons or Macros (or send DVSwitch Commands directly) to switch mode and then TG, etc,   Talk, then disconnect.

I know others probably have this working fine, but after a lot of hours, I cannot wrap my head around the configuration and methodology.  I have tried a ton of things that almost work, but not really.  My Allstar node and DVSwitch are on separate Pi's at the moment for experimenting and  testing.  I have tried ASL and HamVOIP with the same results.

Thanks for any assistance.

jb  N4NQY

If any one has this working well and dont mind sharing their knowledge, you are free to post here or off groups.io and try my email call # arrl.net or QRZ address. I am pretty sure there are others stumped on this.  


--

jb   N4NQY


Re: Macro Result 256

Steve N4IRS
 

yes. Run the macro script from the command line to see the error.

On 10/5/20 5:40 AM, Derek William Haden wrote:

Could someone enlighten me was to what

"Macro Result 256"
means.

I know 0 means success I assume 256 is abject failure?



Macro Result 256

Derek William Haden <facebook@...>
 

Could someone enlighten me was to what

"Macro Result 256"
means.

I know 0 means success I assume 256 is abject failure?


Re: Repeater ID (0) cannot be the same as sibscriber ID (0)

Steve N4IRS
 

It means AD has seen traffic from repeater ID 0 or subscriber ID 0 (more likely) What hardware are you running and have you updated from github the MB and AB binaries?

Steve N4IRS

On 10/4/20 2:38 PM, Derek William Haden wrote:
Analog_Bridge.log shows this error.

Repeater ID (0) cannot be the same as sibscriber ID (0)

Could someone tell me what it means?


MMDVM_Bridge bug ???

David Young
 

Having a issue running a DVSwitch bridge from an FCS room to DMR.  Bridge is setup and working but in the MMDVM_Bridge log after every transmission to the MMDVM_Bridge from the FCS room through YSFGateway I receive an error message "Network watchdog has expired".
Also running other DVSwitch bridges, YSF, P25, and NXDN to the same DMR TG, and when this error occurs from the FCS bridge, it causes these other bridges to stay in listen mode as no TX OFF is passed through to them.
I am not sure this is a DVSwitch bug but I cannot find any other problem which is causing this network timeout error.
This network timeout error occurs on every FCS room Tx to the MMDVM_Bridge no matter how long or short the FCS transmission is.

Any help or ideas?
Thanks,
73, Dave
--
Dave WB6DTB


Re: DVSwitch-System-Builder 404 error

Steve N4IRS
 

./DVSwitch-System-Builder.sh
--2020-09-25 13:37:00--  http://dvswitch.org/install-dvswitch-repo
Resolving dvswitch.org (dvswitch.org)... 44.103.34.4
Connecting to dvswitch.org (dvswitch.org)|44.103.34.4|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 782
Saving to: ‘install-dvswitch-repo’

install-dvswitch-repo                                       100%[========================================================================================================================================>]     782  --.-KB/s    in 0s

2020-09-25 13:37:00 (4.73 MB/s) - ‘install-dvswitch-repo’ saved [782/782]

I'm testing it here on a remote RPi I don't want the whole script to execute because I am running it on the DVSwitch-Server RPi image which has all the programs already installed. So, I stopped the script (exit 0) after the wget from dvswitch.org. See below.

#!/usr/bin/env bash
set -o errexit

# N4IRS 02/10/2020

#################################################
#                                               #
#    Build a DVSwitch Server on a clean disk    #
#                                               #
#################################################

# Install DVSwitch Repository
cd /tmp

wget http://dvswitch.org/install-dvswitch-repo
chmod +x install-dvswitch-repo

exit 0


On 9/25/2020 1:32 PM, Derek William Haden wrote:

I can only report what I see happening.

This on 2 different computers.

The wget from github works, the wget from the script doesn't.



Re: DVSwitch-System-Builder 404 error

Derek William Haden <facebook@...>
 

I can only report what I see happening.

This on 2 different computers.

The wget from github works, the wget from the script doesn't.

2581 - 2600 of 9820