Date   

Re: YSF > ASL using XLXd reflector

k7wby@...
 

Steve, thanks for the repsonse. My first attempt was without the gateway using only MB, which as you say, works. I wasn't able to do YSF Passthrough but I knew G4KLX's YSFGateway could do it. I've managed to get that up and running now and all is good.  This is all an experiment to see what I might do if my back haul failed. I needed a fail over that I can bring up remotely via ssh. This will get the job done. DVSwitch is quite versatile and I thank you for streamlining it for us.


Re: One TG in Analog Bridge

Steve N4IRS
 

dvswitch.sh tune 9

On 10/27/20 7:23 PM, Aaron Groover wrote:

Is there a way to just set a basic TG for example “9” and be able to talk on what static TG we are on either on the BM or TGIF selfcare dash? Or do we have to constantly change it and restart analog bridge?

 

 

 

--

 

Thank You,

 

Aaron Groover

(610) 379 6148

K3ALG@...

agroover@...

 

The content of this email is confidential and intended for the recipient specified in message only. It is strictly forbidden to share any part of this message with any third party, without a written consent of the sender. If you received this message by mistake, please reply to this message and follow with its deletion, so that we can ensure such a mistake does not occur in the future.

 



One TG in Analog Bridge

Aaron Groover
 

Is there a way to just set a basic TG for example “9” and be able to talk on what static TG we are on either on the BM or TGIF selfcare dash? Or do we have to constantly change it and restart analog bridge?

 

 

 

--

 

Thank You,

 

Aaron Groover

(610) 379 6148

K3ALG@...

agroover@...

 

The content of this email is confidential and intended for the recipient specified in message only. It is strictly forbidden to share any part of this message with any third party, without a written consent of the sender. If you received this message by mistake, please reply to this message and follow with its deletion, so that we can ensure such a mistake does not occur in the future.

 


Re: YSF > ASL using XLXd reflector

Steve N4IRS
 

Are you connecting to a DMR or YSF XLX connection? MB can connect directly to a YSF reflector without need for YSFGateway or to a XLX DMR reflector.

On 10/27/20 4:41 PM, k7wby@... wrote:
Hi folks, so I have MB > XLXd and the xlx dashboard shows the connection as a Repeater/Node of K7wBY B and the channel is blank. I tried adding Options=XLX:4008 to see if it would come up on Channel H but that didn't seem to work. I suspect that I'm going to need to run YSFGateway and then point MB to the gateway.


YSF > ASL using XLXd reflector

k7wby@...
 

Hi folks, so I have MB > XLXd and the xlx dashboard shows the connection as a Repeater/Node of K7wBY B and the channel is blank. I tried adding Options=XLX:4008 to see if it would come up on Channel H but that didn't seem to work. I suspect that I'm going to need to run YSFGateway and then point MB to the gateway.


Re: Some basic dv switch questions, hoping you can help

Steve N4IRS
 

Huh?

On 10/26/2020 2:47 PM, lee kasen wrote:
Get a pi i use the pi3b and an mmdvm hat (Google it) then www. pi-star. Co. Uk.(no spaces)  youtube or ham radio concepts (seting up a mmdvm) and have fun. You may want to get a dmr radio tyt md 380 is the one i have. (learn how to work code plug) hope that gets you started 

On Sat, Oct 24, 2020, 17:12 Jed Barton <jedbarton@...> wrote:
Hey guys,

Jed.n1jbc here.  So, i'm brand new to this dvswitch thing, and
honestly it seems pretty cool.
So, the furthest i've gotten with it, is hooking it up to my allstar
node, using a network radio.  I'm using an Inrico t-320 network radio,
and have dvswitch installed on it, and am connecting it to my allstar
node.  It works great.
Now it's time to expand it further.  I've been told that i can run
dmr, and other digital modes if i put a pi together.  So i'm at that
point where i want to go to that next step.  What do i need to do?
I'm going to have a lot of questions here.

Cheers,

Jed







Re: Some basic dv switch questions, hoping you can help

lee kasen
 

Get a pi i use the pi3b and an mmdvm hat (Google it) then www. pi-star. Co. Uk.(no spaces)  youtube or ham radio concepts (seting up a mmdvm) and have fun. You may want to get a dmr radio tyt md 380 is the one i have. (learn how to work code plug) hope that gets you started 


On Sat, Oct 24, 2020, 17:12 Jed Barton <jedbarton@...> wrote:
Hey guys,

Jed.n1jbc here.  So, i'm brand new to this dvswitch thing, and
honestly it seems pretty cool.
So, the furthest i've gotten with it, is hooking it up to my allstar
node, using a network radio.  I'm using an Inrico t-320 network radio,
and have dvswitch installed on it, and am connecting it to my allstar
node.  It works great.
Now it's time to expand it further.  I've been told that i can run
dmr, and other digital modes if i put a pi together.  So i'm at that
point where i want to go to that next step.  What do i need to do?
I'm going to have a lot of questions here.

Cheers,

Jed






Re: M17 Support #mmdvm_bridge

Steve N4IRS
 

Thanks.
Mike and I talked about supporting CW, but maybe not MCW. ;)

Steve

On 10/26/2020 10:54 AM, k7wby@... wrote:
Good plan Steve, with over 75 digital modes currently available it would be an insane project to try to accommodate them all. 


Re: M17 Support #mmdvm_bridge

k7wby@...
 

Good plan Steve, with over 75 digital modes currently available it would be an insane project to try to accommodate them all. 


Re: M17 Support #mmdvm_bridge

Steve N4IRS
 

Maybe in the future. We will see if it really gets any use.

On 10/26/2020 8:49 AM, Roby IV3JDV wrote:

Hi Steve, are you planning to support the new M17 protocol?


Roby IV3JDV



M17 Support #mmdvm_bridge

Roby IV3JDV
 

Hi Steve, are you planning to support the new M17 protocol?


Roby IV3JDV


Re: Some basic dv switch questions, hoping you can help

Steve N4IRS
 

Jed,
Welcome. Glad you are enjoying using DVSwitch Mobile (DVSM) with Allstar. For what you are asking, you have a couple of choices:

1: Setup a separate Pi for you to use the Digital modes with DVSM.
2: Add the digital modes to your existing AllStar node.

No matter what you choose, I'm going to tell you to wait at least a week to do anything other the gather hardware.
1: is the best option If you have a spare Pi.
2: give you the best overall flexibility but may be more complex to setup depending on how you want things to work.

We are one week away from release of DVSwitch Server. The server image runs on a Raspberry Pi and allows you to setup a server with very little trouble.
We have not tested adding DVSwitch Server to an existing AllStar node. It SHOULD work, but we need to test before recommending.

That having been said, we have 2 subgroups you should consider joining.
1: <https://dvswitch.groups.io/g/allstarlink> Discussion of bridging AllStar to the digital world
2: <https://dvswitch.groups.io/g/Mobile> Discussion of all things DVSM

73, Steve N4IRS

On 10/24/20 10:39 AM, Jed Barton wrote:
Hey guys,

Jed.n1jbc here. So, i'm brand new to this dvswitch thing, and
honestly it seems pretty cool.
So, the furthest i've gotten with it, is hooking it up to my allstar
node, using a network radio. I'm using an Inrico t-320 network radio,
and have dvswitch installed on it, and am connecting it to my allstar
node. It works great.
Now it's time to expand it further. I've been told that i can run
dmr, and other digital modes if i put a pi together. So i'm at that
point where i want to go to that next step. What do i need to do?
I'm going to have a lot of questions here.

Cheers,

Jed




Some basic dv switch questions, hoping you can help

Jed Barton <jedbarton@...>
 

Hey guys,

Jed.n1jbc here. So, i'm brand new to this dvswitch thing, and
honestly it seems pretty cool.
So, the furthest i've gotten with it, is hooking it up to my allstar
node, using a network radio. I'm using an Inrico t-320 network radio,
and have dvswitch installed on it, and am connecting it to my allstar
node. It works great.
Now it's time to expand it further. I've been told that i can run
dmr, and other digital modes if i put a pi together. So i'm at that
point where i want to go to that next step. What do i need to do?
I'm going to have a lot of questions here.

Cheers,

Jed


Re: P25Gateway Inactivity Timeout Behavior

Steve N4IRS
 

Happy Halloween....

On 10/23/2020 2:08 PM, Greg WB6ZSU wrote:
Thanks Steve. I’ll wait for the new image. As you said, it will be “Just two weeks”. 😀


Greg
WB6ZSU


On Oct 23, 2020, at 10:50 AM, Steve N4IRS <szingman@...> wrote:

When the new image is released and you have access to the site, then yes I suggest you install the new image. If nothing else it will allow safer updates.

On 10/23/2020 1:47 PM, Greg WB6ZSU wrote:
Steve,

I tried restarting both Pi’s and this seems to have corrected the issue.

Do you think it is still a good idea to update the files to the latest version, or is there really no big advantage?  One of the installs is on a mountaintop, and I’m a little hesitant to do a remote upgrade. I’m using this strictly for P25, utilizing Quantar Bridge.


Greg
WB6ZSU
 
On Oct 23, 2020, at 7:59 AM, Steve N4IRS <szingman@...> wrote:

I see no reason it would change. It's just that I tested with the current version as shown in the included logs so I know it's working. As far as I know it always worked that way.

On 10/23/2020 10:58 AM, Greg WB6ZSU wrote:
Steve,

I will try doing this later.

Can you think of why this would have changed all the sudden?  I have two installations which are now behaving this way.

I only realized this because the past few days I was noticing there hasn’t been much chatter on the TG. Also, when I keyed my radio, I would get the “Pacific” annunciation which was an indication that the talkgroup had changed. That’s when I started doing some digging.

Greg
WB6ZSU


On Oct 23, 2020, at 7:49 AM, Steve N4IRS <szingman@...> wrote:

Greg,
You might just get away with replacing the binary.

systemctl stop p25gateway
cd /opt/P25Gateway
mv P25Gateway P25Gateway.old
 wget https://github.com/DVSwitch/P25Gateway/raw/master/bin/P25Gateway.armhf
mv P25Gateway.armhf P25Gateway
chmod +x P25Gateway
systemctl start p25gateway

To go "all the way" you will want to replace the binary, the ini and the audio directory from this: <https://github.com/DVSwitch/P25Gateway/archive/master.zip>


Steve N4IRS

On 10/23/2020 10:41 AM, Greg WB6ZSU wrote:
Steve,

Here are my results (you can see this is a pretty old install):


root@raspberrypi:/home/pi# uname -a
Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux
root@raspberrypi:/home/pi# dpkg --print-architecture
armhf
root@raspberrypi:/home/pi# /opt/P25Gateway/P25Gateway -v
P25Gateway version 20180409
root@raspberrypi:/home/pi#


Greg
WB6ZSU



On Oct 23, 2020, at 2:47 AM, Steve N4IRS <szingman@...> wrote:

Greg,
Please run the following as root:
uname -a
dpkg --print-architecture
/opt/P25Gateway/P25Gateway -v

Steve N4IRS



On 10/23/20 3:17 AM, Greg WB6ZSU wrote:
Over the past few days I’ve noticed a change in the way the Inactivity timeout works.  I have my system configured with a Startup TG of 10400 and an Inactivity Timer of 10 minutes.  The way I’m accustomed to this working is that if I changed talk groups to something other than 10400 (Startup) and there was inactivity on this new TG for more than 10 minutes, the system would revert back to 10400. This is not the way it is behaving today. I’m not exactly sure what TG is now used as the “Revert” TG.

I’ve looked at the P25Gateway log file and verified that even when operating on 10400, if there is more than 10 minutes of inactivity, I will be unlinked from 10400.

Is this a known current behavior, and if so, what does happen after the inactivity timer expires?


Thanks and 73,
Greg
WB6ZSU


















Re: P25Gateway Inactivity Timeout Behavior

Greg WB6ZSU
 

Thanks Steve. I’ll wait for the new image. As you said, it will be “Just two weeks”. 😀


Greg
WB6ZSU


On Oct 23, 2020, at 10:50 AM, Steve N4IRS <szingman@...> wrote:

When the new image is released and you have access to the site, then yes I suggest you install the new image. If nothing else it will allow safer updates.

On 10/23/2020 1:47 PM, Greg WB6ZSU wrote:
Steve,

I tried restarting both Pi’s and this seems to have corrected the issue.

Do you think it is still a good idea to update the files to the latest version, or is there really no big advantage?  One of the installs is on a mountaintop, and I’m a little hesitant to do a remote upgrade. I’m using this strictly for P25, utilizing Quantar Bridge.


Greg
WB6ZSU
 
On Oct 23, 2020, at 7:59 AM, Steve N4IRS <szingman@...> wrote:

I see no reason it would change. It's just that I tested with the current version as shown in the included logs so I know it's working. As far as I know it always worked that way.

On 10/23/2020 10:58 AM, Greg WB6ZSU wrote:
Steve,

I will try doing this later.

Can you think of why this would have changed all the sudden?  I have two installations which are now behaving this way.

I only realized this because the past few days I was noticing there hasn’t been much chatter on the TG. Also, when I keyed my radio, I would get the “Pacific” annunciation which was an indication that the talkgroup had changed. That’s when I started doing some digging.

Greg
WB6ZSU


On Oct 23, 2020, at 7:49 AM, Steve N4IRS <szingman@...> wrote:

Greg,
You might just get away with replacing the binary.

systemctl stop p25gateway
cd /opt/P25Gateway
mv P25Gateway P25Gateway.old
 wget https://github.com/DVSwitch/P25Gateway/raw/master/bin/P25Gateway.armhf
mv P25Gateway.armhf P25Gateway
chmod +x P25Gateway
systemctl start p25gateway

To go "all the way" you will want to replace the binary, the ini and the audio directory from this: <https://github.com/DVSwitch/P25Gateway/archive/master.zip>


Steve N4IRS

On 10/23/2020 10:41 AM, Greg WB6ZSU wrote:
Steve,

Here are my results (you can see this is a pretty old install):


root@raspberrypi:/home/pi# uname -a
Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux
root@raspberrypi:/home/pi# dpkg --print-architecture
armhf
root@raspberrypi:/home/pi# /opt/P25Gateway/P25Gateway -v
P25Gateway version 20180409
root@raspberrypi:/home/pi#


Greg
WB6ZSU



On Oct 23, 2020, at 2:47 AM, Steve N4IRS <szingman@...> wrote:

Greg,
Please run the following as root:
uname -a
dpkg --print-architecture
/opt/P25Gateway/P25Gateway -v

Steve N4IRS



On 10/23/20 3:17 AM, Greg WB6ZSU wrote:
Over the past few days I’ve noticed a change in the way the Inactivity timeout works.  I have my system configured with a Startup TG of 10400 and an Inactivity Timer of 10 minutes.  The way I’m accustomed to this working is that if I changed talk groups to something other than 10400 (Startup) and there was inactivity on this new TG for more than 10 minutes, the system would revert back to 10400. This is not the way it is behaving today. I’m not exactly sure what TG is now used as the “Revert” TG.

I’ve looked at the P25Gateway log file and verified that even when operating on 10400, if there is more than 10 minutes of inactivity, I will be unlinked from 10400.

Is this a known current behavior, and if so, what does happen after the inactivity timer expires?


Thanks and 73,
Greg
WB6ZSU

















Re: P25Gateway Inactivity Timeout Behavior

Steve N4IRS
 

When the new image is released and you have access to the site, then yes I suggest you install the new image. If nothing else it will allow safer updates.

On 10/23/2020 1:47 PM, Greg WB6ZSU wrote:
Steve,

I tried restarting both Pi’s and this seems to have corrected the issue.

Do you think it is still a good idea to update the files to the latest version, or is there really no big advantage?  One of the installs is on a mountaintop, and I’m a little hesitant to do a remote upgrade. I’m using this strictly for P25, utilizing Quantar Bridge.


Greg
WB6ZSU
 
On Oct 23, 2020, at 7:59 AM, Steve N4IRS <szingman@...> wrote:

I see no reason it would change. It's just that I tested with the current version as shown in the included logs so I know it's working. As far as I know it always worked that way.

On 10/23/2020 10:58 AM, Greg WB6ZSU wrote:
Steve,

I will try doing this later.

Can you think of why this would have changed all the sudden?  I have two installations which are now behaving this way.

I only realized this because the past few days I was noticing there hasn’t been much chatter on the TG. Also, when I keyed my radio, I would get the “Pacific” annunciation which was an indication that the talkgroup had changed. That’s when I started doing some digging.

Greg
WB6ZSU


On Oct 23, 2020, at 7:49 AM, Steve N4IRS <szingman@...> wrote:

Greg,
You might just get away with replacing the binary.

systemctl stop p25gateway
cd /opt/P25Gateway
mv P25Gateway P25Gateway.old
 wget https://github.com/DVSwitch/P25Gateway/raw/master/bin/P25Gateway.armhf
mv P25Gateway.armhf P25Gateway
chmod +x P25Gateway
systemctl start p25gateway

To go "all the way" you will want to replace the binary, the ini and the audio directory from this: <https://github.com/DVSwitch/P25Gateway/archive/master.zip>


Steve N4IRS

On 10/23/2020 10:41 AM, Greg WB6ZSU wrote:
Steve,

Here are my results (you can see this is a pretty old install):


root@raspberrypi:/home/pi# uname -a
Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux
root@raspberrypi:/home/pi# dpkg --print-architecture
armhf
root@raspberrypi:/home/pi# /opt/P25Gateway/P25Gateway -v
P25Gateway version 20180409
root@raspberrypi:/home/pi#


Greg
WB6ZSU



On Oct 23, 2020, at 2:47 AM, Steve N4IRS <szingman@...> wrote:

Greg,
Please run the following as root:
uname -a
dpkg --print-architecture
/opt/P25Gateway/P25Gateway -v

Steve N4IRS



On 10/23/20 3:17 AM, Greg WB6ZSU wrote:
Over the past few days I’ve noticed a change in the way the Inactivity timeout works.  I have my system configured with a Startup TG of 10400 and an Inactivity Timer of 10 minutes.  The way I’m accustomed to this working is that if I changed talk groups to something other than 10400 (Startup) and there was inactivity on this new TG for more than 10 minutes, the system would revert back to 10400. This is not the way it is behaving today. I’m not exactly sure what TG is now used as the “Revert” TG.

I’ve looked at the P25Gateway log file and verified that even when operating on 10400, if there is more than 10 minutes of inactivity, I will be unlinked from 10400.

Is this a known current behavior, and if so, what does happen after the inactivity timer expires?


Thanks and 73,
Greg
WB6ZSU
















Re: P25Gateway Inactivity Timeout Behavior

Steve N4IRS
 

If it works don't fix it.

On 10/23/2020 1:47 PM, Greg WB6ZSU wrote:
Steve,

I tried restarting both Pi’s and this seems to have corrected the issue.

Do you think it is still a good idea to update the files to the latest version, or is there really no big advantage?  One of the installs is on a mountaintop, and I’m a little hesitant to do a remote upgrade. I’m using this strictly for P25, utilizing Quantar Bridge.


Greg
WB6ZSU
 
On Oct 23, 2020, at 7:59 AM, Steve N4IRS <szingman@...> wrote:

I see no reason it would change. It's just that I tested with the current version as shown in the included logs so I know it's working. As far as I know it always worked that way.

On 10/23/2020 10:58 AM, Greg WB6ZSU wrote:
Steve,

I will try doing this later.

Can you think of why this would have changed all the sudden?  I have two installations which are now behaving this way.

I only realized this because the past few days I was noticing there hasn’t been much chatter on the TG. Also, when I keyed my radio, I would get the “Pacific” annunciation which was an indication that the talkgroup had changed. That’s when I started doing some digging.

Greg
WB6ZSU


On Oct 23, 2020, at 7:49 AM, Steve N4IRS <szingman@...> wrote:

Greg,
You might just get away with replacing the binary.

systemctl stop p25gateway
cd /opt/P25Gateway
mv P25Gateway P25Gateway.old
 wget https://github.com/DVSwitch/P25Gateway/raw/master/bin/P25Gateway.armhf
mv P25Gateway.armhf P25Gateway
chmod +x P25Gateway
systemctl start p25gateway

To go "all the way" you will want to replace the binary, the ini and the audio directory from this: <https://github.com/DVSwitch/P25Gateway/archive/master.zip>


Steve N4IRS

On 10/23/2020 10:41 AM, Greg WB6ZSU wrote:
Steve,

Here are my results (you can see this is a pretty old install):


root@raspberrypi:/home/pi# uname -a
Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux
root@raspberrypi:/home/pi# dpkg --print-architecture
armhf
root@raspberrypi:/home/pi# /opt/P25Gateway/P25Gateway -v
P25Gateway version 20180409
root@raspberrypi:/home/pi#


Greg
WB6ZSU



On Oct 23, 2020, at 2:47 AM, Steve N4IRS <szingman@...> wrote:

Greg,
Please run the following as root:
uname -a
dpkg --print-architecture
/opt/P25Gateway/P25Gateway -v

Steve N4IRS



On 10/23/20 3:17 AM, Greg WB6ZSU wrote:
Over the past few days I’ve noticed a change in the way the Inactivity timeout works.  I have my system configured with a Startup TG of 10400 and an Inactivity Timer of 10 minutes.  The way I’m accustomed to this working is that if I changed talk groups to something other than 10400 (Startup) and there was inactivity on this new TG for more than 10 minutes, the system would revert back to 10400. This is not the way it is behaving today. I’m not exactly sure what TG is now used as the “Revert” TG.

I’ve looked at the P25Gateway log file and verified that even when operating on 10400, if there is more than 10 minutes of inactivity, I will be unlinked from 10400.

Is this a known current behavior, and if so, what does happen after the inactivity timer expires?


Thanks and 73,
Greg
WB6ZSU
















Re: P25Gateway Inactivity Timeout Behavior

Greg WB6ZSU
 

Steve,

I tried restarting both Pi’s and this seems to have corrected the issue.

Do you think it is still a good idea to update the files to the latest version, or is there really no big advantage?  One of the installs is on a mountaintop, and I’m a little hesitant to do a remote upgrade. I’m using this strictly for P25, utilizing Quantar Bridge.


Greg
WB6ZSU
 

On Oct 23, 2020, at 7:59 AM, Steve N4IRS <szingman@...> wrote:

I see no reason it would change. It's just that I tested with the current version as shown in the included logs so I know it's working. As far as I know it always worked that way.

On 10/23/2020 10:58 AM, Greg WB6ZSU wrote:
Steve,

I will try doing this later.

Can you think of why this would have changed all the sudden?  I have two installations which are now behaving this way.

I only realized this because the past few days I was noticing there hasn’t been much chatter on the TG. Also, when I keyed my radio, I would get the “Pacific” annunciation which was an indication that the talkgroup had changed. That’s when I started doing some digging.

Greg
WB6ZSU


On Oct 23, 2020, at 7:49 AM, Steve N4IRS <szingman@...> wrote:

Greg,
You might just get away with replacing the binary.

systemctl stop p25gateway
cd /opt/P25Gateway
mv P25Gateway P25Gateway.old
 wget https://github.com/DVSwitch/P25Gateway/raw/master/bin/P25Gateway.armhf
mv P25Gateway.armhf P25Gateway
chmod +x P25Gateway
systemctl start p25gateway

To go "all the way" you will want to replace the binary, the ini and the audio directory from this: <https://github.com/DVSwitch/P25Gateway/archive/master.zip>


Steve N4IRS

On 10/23/2020 10:41 AM, Greg WB6ZSU wrote:
Steve,

Here are my results (you can see this is a pretty old install):


root@raspberrypi:/home/pi# uname -a
Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux
root@raspberrypi:/home/pi# dpkg --print-architecture
armhf
root@raspberrypi:/home/pi# /opt/P25Gateway/P25Gateway -v
P25Gateway version 20180409
root@raspberrypi:/home/pi#


Greg
WB6ZSU



On Oct 23, 2020, at 2:47 AM, Steve N4IRS <szingman@...> wrote:

Greg,
Please run the following as root:
uname -a
dpkg --print-architecture
/opt/P25Gateway/P25Gateway -v

Steve N4IRS



On 10/23/20 3:17 AM, Greg WB6ZSU wrote:
Over the past few days I’ve noticed a change in the way the Inactivity timeout works.  I have my system configured with a Startup TG of 10400 and an Inactivity Timer of 10 minutes.  The way I’m accustomed to this working is that if I changed talk groups to something other than 10400 (Startup) and there was inactivity on this new TG for more than 10 minutes, the system would revert back to 10400. This is not the way it is behaving today. I’m not exactly sure what TG is now used as the “Revert” TG.

I’ve looked at the P25Gateway log file and verified that even when operating on 10400, if there is more than 10 minutes of inactivity, I will be unlinked from 10400.

Is this a known current behavior, and if so, what does happen after the inactivity timer expires?


Thanks and 73,
Greg
WB6ZSU















Re: DVSwitch Server Raspberry Pi Image

Tito Lopez - YN1OB
 

Looks AWESOME!!! thanks for all the goodies you guys work on. You all should be inducted to the HAM Radio Hall of Fame!!!!
Cant wait to install the dashboard, I tried installing but no packages yet.... Cool  Stuff


Re: P25Gateway Inactivity Timeout Behavior

Greg WB6ZSU
 

Very strange.

This is an example of what I observed last night:

M: 2020-10-23 04:29:32.253 Linked to reflector 10400 by WB6ZSU
M: 2020-10-23 04:39:34.361 Unlinking from 10400 due to inactivity
I: 2020-10-23 05:21:18.507 Loaded 18 P25 reflectors
I: 2020-10-23 05:21:18.507 Loaded P25 parrot (TG10)
M: 2020-10-23 06:06:00.120 Linked to reflector 10400 by WB6ZSU
M: 2020-10-23 06:16:00.802 Unlinking from 10400 due to inactivity



On Oct 23, 2020, at 7:59 AM, Steve N4IRS <szingman@...> wrote:

I see no reason it would change. It's just that I tested with the current version as shown in the included logs so I know it's working. As far as I know it always worked that way.

On 10/23/2020 10:58 AM, Greg WB6ZSU wrote:
Steve,

I will try doing this later.

Can you think of why this would have changed all the sudden?  I have two installations which are now behaving this way.

I only realized this because the past few days I was noticing there hasn’t been much chatter on the TG. Also, when I keyed my radio, I would get the “Pacific” annunciation which was an indication that the talkgroup had changed. That’s when I started doing some digging.

Greg
WB6ZSU


On Oct 23, 2020, at 7:49 AM, Steve N4IRS <szingman@...> wrote:

Greg,
You might just get away with replacing the binary.

systemctl stop p25gateway
cd /opt/P25Gateway
mv P25Gateway P25Gateway.old
 wget https://github.com/DVSwitch/P25Gateway/raw/master/bin/P25Gateway.armhf
mv P25Gateway.armhf P25Gateway
chmod +x P25Gateway
systemctl start p25gateway

To go "all the way" you will want to replace the binary, the ini and the audio directory from this: <https://github.com/DVSwitch/P25Gateway/archive/master.zip>


Steve N4IRS

On 10/23/2020 10:41 AM, Greg WB6ZSU wrote:
Steve,

Here are my results (you can see this is a pretty old install):


root@raspberrypi:/home/pi# uname -a
Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux
root@raspberrypi:/home/pi# dpkg --print-architecture
armhf
root@raspberrypi:/home/pi# /opt/P25Gateway/P25Gateway -v
P25Gateway version 20180409
root@raspberrypi:/home/pi#


Greg
WB6ZSU



On Oct 23, 2020, at 2:47 AM, Steve N4IRS <szingman@...> wrote:

Greg,
Please run the following as root:
uname -a
dpkg --print-architecture
/opt/P25Gateway/P25Gateway -v

Steve N4IRS



On 10/23/20 3:17 AM, Greg WB6ZSU wrote:
Over the past few days I’ve noticed a change in the way the Inactivity timeout works.  I have my system configured with a Startup TG of 10400 and an Inactivity Timer of 10 minutes.  The way I’m accustomed to this working is that if I changed talk groups to something other than 10400 (Startup) and there was inactivity on this new TG for more than 10 minutes, the system would revert back to 10400. This is not the way it is behaving today. I’m not exactly sure what TG is now used as the “Revert” TG.

I’ve looked at the P25Gateway log file and verified that even when operating on 10400, if there is more than 10 minutes of inactivity, I will be unlinked from 10400.

Is this a known current behavior, and if so, what does happen after the inactivity timer expires?


Thanks and 73,
Greg
WB6ZSU














2241 - 2260 of 9532