Date   

Re: DVSwitch Dashboard Web Port

Steve N4IRS
 

Joe,
Interesting that webproxy was not running when it was showing with netstat.
As far as upgrading nodejs, you might look at: <https://github.com/nodesource/distributions>

curl -sL https://deb.nodesource.com/setup_15.x | sudo -E bash -
sudo apt-get install -y nodejs

I used it to upgrade a install of Stretch.

Glad you have it working.

Steve

On 12/9/20 10:28 PM, Joe, WB3IHY wrote:

Okay...problem (finally) solved.  Turns out that the problem was (probably) not related to changing the dashboard web port.  Documenting my experience so that others may benefit.

Steve, your suggestion to check for webproxy log started me on the trail: THERE WASN'T ONE! Which meant that the service wasn't running at all.

I then tried running the following command manually: sudo /usr/bin/node /opt/Web_Proxy/proxy.js 8080 2222 which generated a SyntaxError: "Unexpected token "Const { Exit }"

Much Googling told me earlier versions of node.js would do that.  Found out that, somehow, I had version (gasp) 4 installed for some reason! My other instances were running 8.10.0, so that had to be the culprit.  Much more Googling told me how to update it to the latest version (15.4.0 as of this writing):

First, install npm: sudo apt-get install npm
Then install n, a node version manager: sudo npm install -g n
Then install the latest version of node: sudo n latest
If the installer changed the path from what's specified in the webproxy service call, change it back with "PATH=$PATH"
Verify that node was truly updated with: node -v
Try running the service manually: sudo /usr/bin/node /opt/Web_Proxy/proxy.js 8080 2222
If you still get the same error, you might have to forcibly copy the newer binary to where the webproxy expects it to be: sudo cp /usr/local/n/versions/node/15.4.0/bin/node /usr/bin/node
Try running the service manually again.  If you get a "cannot find module "ws" " error, then do this: cd /opt/Web_Proxy/ and then install the ws module with sudo npm install ws
Try running the service manually again.  It should now run with no errors.  Control C out of it.  You're almost done.
Finally, start the service properly: sudo systemctl start webproxy.service

Voila: RX Monitor audio AT LAST!



Re: DVSwitch Dashboard Web Port

Joe, WB3IHY
 

Okay...problem (finally) solved.  Turns out that the problem was (probably) not related to changing the dashboard web port.  Documenting my experience so that others may benefit.

Steve, your suggestion to check for webproxy log started me on the trail: THERE WASN'T ONE! Which meant that the service wasn't running at all.

I then tried running the following command manually: sudo /usr/bin/node /opt/Web_Proxy/proxy.js 8080 2222 which generated a SyntaxError: "Unexpected token "Const { Exit }"

Much Googling told me earlier versions of node.js would do that.  Found out that, somehow, I had version (gasp) 4 installed for some reason! My other instances were running 8.10.0, so that had to be the culprit.  Much more Googling told me how to update it to the latest version (15.4.0 as of this writing):

First, install npm: sudo apt-get install npm
Then install n, a node version manager: sudo npm install -g n
Then install the latest version of node: sudo n latest
If the installer changed the path from what's specified in the webproxy service call, change it back with "PATH=$PATH"
Verify that node was truly updated with: node -v
Try running the service manually: sudo /usr/bin/node /opt/Web_Proxy/proxy.js 8080 2222
If you still get the same error, you might have to forcibly copy the newer binary to where the webproxy expects it to be: sudo cp /usr/local/n/versions/node/15.4.0/bin/node /usr/bin/node
Try running the service manually again.  If you get a "cannot find module "ws" " error, then do this: cd /opt/Web_Proxy/ and then install the ws module with sudo npm install ws
Try running the service manually again.  It should now run with no errors.  Control C out of it.  You're almost done.
Finally, start the service properly: sudo systemctl start webproxy.service

Voila: RX Monitor audio AT LAST!


Re: digital transmit overtime

Steve N4IRS
 

Patrick,
Which TOT are you adjusting? Are you adjusting the TOT on the USRP node or the ASL TX? The TOT controls the TX not the RX. Just a thought.

Steve

On 12/9/20 5:55 AM, Patrick Perdue wrote:
Hi Steve:

Thanks. Yeah, I thought it should work the same as any other channel driver, so I changed it to a ridiculously low number (10000), and transmissions over 10 seconds across the bridge still passed after rpt reload, at least from digital to analog. I didn't test in the other direction.






Re: DVSwitch Dashboard Web Port

Steve N4IRS
 

Is lightttpd running?
systemctl status lighttpd and/or
ps ax | grep lighttpd

On 12/9/20 1:06 PM, Joe, WB3IHY wrote:
On the two working DVSwitch installations, netstat -tnap shows the following line:

tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      1376/node

Which is, I assume, the RX Monitor doing its thing.

On the one where I switched lighttpd to port 8888, there is nothing listed with port 8080 anywhere.

Is that what you're looking for or do you need me to post the entire output? If the latter, then I'd need to (ahem) redact a few things in it for security reasons, HI HI.



On the one where I switched the lighttpd port, there is nothing with port 8080 listed.


Re: MMDVM to MMDVM connections ?

Steve N4IRS
 

Agreed, why bother? If what you are trying to do is create a private DMR TG, you can use HBlink to create a DMR Master. Insert it where you have internet on your diagram.

On 12/9/20 5:47 PM, Gerry Filby wrote:
Hi Folks,

Is it possible to have a private connection using MMDV/Analog_Bridge ?

Analog HT1 <> AllStar1 <> Analog_Bridge <> MMDVM_Bridge <> [Internet] <> MMDV_Bridge <> Analog_Bridge <> AllStar2 <> HT2

("Why bother ?" - what's the point of going through the digital mode - just go AllStar to AllStar ?)

Or would one have to use a temporary Talk Group ?

Best,
Gerry.
W6WNG


Re: Using DVSwitch to access DMR+/Phoenix

Steve N4IRS
 

Please post your tune string.

On 12/9/20 8:11 AM, G4WXN@... wrote:
That works, but when I drop the transmission, the voice announcement "Linked to 4440" repeats, cutting off the first few seconds of incoming signals.

--
Derek

G4WXN


Re: DVSwitch Dashboard - DMR Master Information

Steve N4IRS
 

Make sure you have done a update / upgrade. and retest.

On 12/9/20 7:31 AM, g8ptn@... wrote:

Hi,
A minor observation on the DVSwitch Dashboard.

I have noticed that the “DMR Master” information keeps disappearing. Everything is still working as expected and DVSwitch is connected to the DMR server.

Switching between servers in the “dvs” control panel restores the dialog information.

 

 

PS. Keep up the great work on DVSwitch. Even using the software vocoder, for DMR the audio on both transmit and receive is excellent.

Regards,

Dave (G8PTN)



Version information below.


Software:
dvswitch.sh version 1.6.0
Analog_Bridge version 1.6.0
MMDVM_Bridge version 20201129_V1.6.2 git #89f8998
P25Gateway version 20200824
NXDNGateway version 20200824
YSFGateway version 20200908

 

Hardware:
Raspberry Pi 3 Model B



DVSwitch Dashboard - DMR Master Information

g8ptn@...
 

Hi,
A minor observation on the DVSwitch Dashboard.

I have noticed that the “DMR Master” information keeps disappearing. Everything is still working as expected and DVSwitch is connected to the DMR server.

Switching between servers in the “dvs” control panel restores the dialog information.

 

 

PS. Keep up the great work on DVSwitch. Even using the software vocoder, for DMR the audio on both transmit and receive is excellent.

Regards,

Dave (G8PTN)



Version information below.


Software:
dvswitch.sh version 1.6.0
Analog_Bridge version 1.6.0
MMDVM_Bridge version 20201129_V1.6.2 git #89f8998
P25Gateway version 20200824
NXDNGateway version 20200824
YSFGateway version 20200908

 

Hardware:
Raspberry Pi 3 Model B


Re: DVSwitch Dashboard Web Port

Steve N4IRS
 

This is what I see on server.dvswitch.org when I set lighttpd to port 88:

tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      14654/node         
tcp        0      0 0.0.0.0:88              0.0.0.0:*               LISTEN      20288/lighttpd     


On 12/9/20 8:27 AM, Joe, WB3IHY wrote:
Personally, I selected port 88 (after looking at the raw page and noticing that port 8080 was mentioned for RX Monitor) to avoid the obvious conflict there.

Also made sure nothing else was grabbing port 8080 on the machine.


Re: MMDVM to MMDVM connections ?

Patrick Perdue
 

The cheap and easy solution would be to just use a personal CCS7 ID as a group call for all participants (not exactly private), or just anything that isn't being used and won't make people mad, on a public network. Not sure how private calls work with DVSwitch, not something I've ever cared to try.

That, or set up an HBlink or some other DMR master server somewhere and directly connect to that.

It's very common, especially on Brandmeister, for people to make group calls on personal ID's to connect, I've noticed.


On 12/9/2020 5:47 PM, Gerry Filby wrote:

Hi Folks,

Is it possible to have a private connection using MMDV/Analog_Bridge ?

Analog HT1 <> AllStar1 <> Analog_Bridge <> MMDVM_Bridge <> [Internet] <> MMDV_Bridge <> Analog_Bridge <> AllStar2 <> HT2

("Why bother ?" - what's the point of going through the digital mode - just go AllStar to AllStar ?)

Or would one have to use a temporary Talk Group ?

Best,
Gerry.
W6WNG


MMDVM to MMDVM connections ?

Gerry Filby
 

Hi Folks,

Is it possible to have a private connection using MMDV/Analog_Bridge ?

Analog HT1 <> AllStar1 <> Analog_Bridge <> MMDVM_Bridge <> [Internet] <> MMDV_Bridge <> Analog_Bridge <> AllStar2 <> HT2

("Why bother ?" - what's the point of going through the digital mode - just go AllStar to AllStar ?)

Or would one have to use a temporary Talk Group ?

Best,
Gerry.
W6WNG


Re: DVSwitch Dashboard Web Port

Steve N4IRS
 

On the non working node, try systemctl restart webproxy.

Check netstat

Look at /var/log/dvswitch/webroxy

 

From: Joe, WB3IHY
Sent: Wednesday, December 9, 2020 1:06 PM
To: main@dvswitch.groups.io
Subject: Re: [DVSwitch] DVSwitch Dashboard Web Port

 

On the two working DVSwitch installations, netstat -tnap shows the following line:

tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      1376/node

Which is, I assume, the RX Monitor doing its thing.

On the one where I switched lighttpd to port 8888, there is nothing listed with port 8080 anywhere.

Is that what you're looking for or do you need me to post the entire output? If the latter, then I'd need to (ahem) redact a few things in it for security reasons, HI HI.



On the one where I switched the lighttpd port, there is nothing with port 8080 listed.

 


Re: DVSwitch Dashboard Web Port

Joe, WB3IHY
 

On the two working DVSwitch installations, netstat -tnap shows the following line:

tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      1376/node

Which is, I assume, the RX Monitor doing its thing.

On the one where I switched lighttpd to port 8888, there is nothing listed with port 8080 anywhere.

Is that what you're looking for or do you need me to post the entire output? If the latter, then I'd need to (ahem) redact a few things in it for security reasons, HI HI.



On the one where I switched the lighttpd port, there is nothing with port 8080 listed.


Re: DVSwitch Dashboard Web Port

Steve N4IRS
 

What does netstat -tnap show as root?

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Joe, WB3IHY <groupsdotio@...>
Sent: Wednesday, December 9, 2020 9:02:54 AM
To: main@DVSwitch.groups.io <main@DVSwitch.groups.io>
Subject: Re: [DVSwitch] DVSwitch Dashboard Web Port
 
Okay.  Changed it to port 8888.  No difference in the RX Monitor problem.


Re: DVSwitch Dashboard Web Port

Joe, WB3IHY
 

Okay.  Changed it to port 8888.  No difference in the RX Monitor problem.


Re: DVSwitch Dashboard Web Port

Mike Zingman - N4IRR
 

That port is in the  privileged range. Please use a port number > 1000


Re: DVSwitch Dashboard Web Port

Joe, WB3IHY
 

Personally, I selected port 88 (after looking at the raw page and noticing that port 8080 was mentioned for RX Monitor) to avoid the obvious conflict there.

Also made sure nothing else was grabbing port 8080 on the machine.


Can client macros commands be pushed to the client.

G4WXN@...
 
Edited

Is it possible to PUSH the user definable dropdown macro commands on DVSM?

If not possible to Push these, can the defaults be changed somehow?


--
Derek

G4WXN


Re: Using DVSwitch to access DMR+/Phoenix

G4WXN@...
 

That works, but when I drop the transmission, the voice announcement "Linked to 4440" repeats, cutting off the first few seconds of incoming signals.

--
Derek

G4WXN


DVSwitch Server Multi Access

IZ1XBB - Pier Paolo
 

Hi everybody!

May I have some infos and instructions to develope a multi access function on my DVSwitch Server?

Thank You for help!


1401 - 1420 of 9087