Date   

Re: Dashboard no Workie

Steve N4IRS
 

show me apt-get update

On 12/28/20 10:27 AM, William KC3CPO wrote:

Do you want to continue? [Y/n] y

(Reading database ... 87525 files and directories currently installed.)

Preparing to unpack .../dvswitch-menu_1.6.1-20201220-113_all.deb ...

Unpacking dvswitch-menu (1.6.1-20201220-113) ...

dpkg: error processing archive /var/cache/apt/archives/dvswitch-menu_1.6.1-20201220-113_all.deb (--unpack):

 trying to overwrite '/usr/local/dvs/init_config.sh', which is also in package dvswitch-base 1.5-20200427-21

Errors were encountered while processing:

 /var/cache/apt/archives/dvswitch-menu_1.6.1-20201220-113_all.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)



Re: Restarting DVSwitch Services

g8ptn@...
 
Edited

Hi Steve, 

Thanks again for the quick response.

All understood. The tune method is effectively what happens when switching via the DVSM App. When switching using this method the MMDVM_Bridge.ini DMR Address path does not get updated.

When switching the server from the DVSwitch “dvs” menu option, the  MMDVM_Bridge.ini DMR Address path does get updated.

Regards,
  Dave

 


Re: Dashboard no Workie

William WY7WL
 

Do you want to continue? [Y/n] y

(Reading database ... 87525 files and directories currently installed.)

Preparing to unpack .../dvswitch-menu_1.6.1-20201220-113_all.deb ...

Unpacking dvswitch-menu (1.6.1-20201220-113) ...

dpkg: error processing archive /var/cache/apt/archives/dvswitch-menu_1.6.1-20201220-113_all.deb (--unpack):

 trying to overwrite '/usr/local/dvs/init_config.sh', which is also in package dvswitch-base 1.5-20200427-21

Errors were encountered while processing:

 /var/cache/apt/archives/dvswitch-menu_1.6.1-20201220-113_all.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)


Re: Dashboard no Workie

Steve N4IRS
 

apt --fix-broken install

On 12/28/20 10:22 AM, William KC3CPO wrote:
hummm... well that install is fighting me... (I'm a pretty basic cmd line user) 

root@ASLDVSwitch:/etc# apt install nodejs

Reading package lists... Done

Building dependency tree       

Reading state information... Done

You might want to run 'apt --fix-broken install' to correct these.

The following packages have unmet dependencies:

 dvswitch-server : Depends: dvswitch-menu but it is not going to be installed

 node-ws : Depends: nodejs-abi-46

 nodejs : Conflicts: nodejs-dev

 nodejs-dev : Depends: nodejs (= 4.8.2~dfsg-1) but 10.23.0-1nodesource1 is to be installed

E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution)



Re: Dashboard no Workie

William WY7WL
 

hummm... well that install is fighting me... (I'm a pretty basic cmd line user) 

root@ASLDVSwitch:/etc# apt install nodejs

Reading package lists... Done

Building dependency tree       

Reading state information... Done

You might want to run 'apt --fix-broken install' to correct these.

The following packages have unmet dependencies:

 dvswitch-server : Depends: dvswitch-menu but it is not going to be installed

 node-ws : Depends: nodejs-abi-46

 nodejs : Conflicts: nodejs-dev

 nodejs-dev : Depends: nodejs (= 4.8.2~dfsg-1) but 10.23.0-1nodesource1 is to be installed

E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution)


Re: Dashboard no Workie

Steve N4IRS
 

On 12/28/20 10:01 AM, William KC3CPO wrote:
debian 9 stretch


Re: Dashboard no Workie

William WY7WL
 

debian 9 stretch


Re: Dashboard no Workie

Steve N4IRS
 

What version of Debian?

On 12/28/20 9:59 AM, William KC3CPO wrote:

root@ASLDVSwitch:/opt/Web_Proxy# /usr/bin/nodejs proxy.js 88 2222

/opt/Web_Proxy/proxy.js:12

const { exit } = require('process');

      ^

 

SyntaxError: Unexpected token {

    at exports.runInThisContext (vm.js:53:16)

    at Module._compile (module.js:373:25)

    at Object.Module._extensions..js (module.js:416:10)

    at Module.load (module.js:343:32)

    at Function.Module._load (module.js:300:12)

    at Function.Module.runMain (module.js:441:10)

    at startup (node.js:140:18)

    at node.js:1043:3



Re: Dashboard no Workie

William WY7WL
 

root@ASLDVSwitch:/opt/Web_Proxy# /usr/bin/nodejs proxy.js 88 2222

/opt/Web_Proxy/proxy.js:12

const { exit } = require('process');

      ^

 

SyntaxError: Unexpected token {

    at exports.runInThisContext (vm.js:53:16)

    at Module._compile (module.js:373:25)

    at Object.Module._extensions..js (module.js:416:10)

    at Module.load (module.js:343:32)

    at Function.Module._load (module.js:300:12)

    at Function.Module.runMain (module.js:441:10)

    at startup (node.js:140:18)

    at node.js:1043:3


Re: Dashboard no Workie

Steve N4IRS
 

try:
/usr/bin/nodejs proxy.js 88 2222

On 12/28/20 9:52 AM, William KC3CPO wrote:
Well... Looks like I have it installed... In Web_Proxy I have proxy.js but nothing to include the port 88

root@ASLDVSwitch:/opt/Web_Proxy# apt-get install nodejs node-ws

Reading package lists... Done

Building dependency tree       

Reading state information... Done

node-ws is already the newest version (1.1.0+ds1.e6ddaae4-3+deb9u1).

node-ws set to manually installed.

nodejs is already the newest version (4.8.2~dfsg-1).

You might want to run 'apt --fix-broken install' to correct these.

The following packages have unmet dependencies:

 dvswitch-server : Depends: dvswitch-menu but it is not going to be installed

E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

root@ASLDVSwitch:/opt/Web_Proxy# ls

proxy.js

 



Re: Dashboard no Workie

William WY7WL
 

Well... Looks like I have it installed... In Web_Proxy I have proxy.js but nothing to include the port 88

root@ASLDVSwitch:/opt/Web_Proxy# apt-get install nodejs node-ws

Reading package lists... Done

Building dependency tree       

Reading state information... Done

node-ws is already the newest version (1.1.0+ds1.e6ddaae4-3+deb9u1).

node-ws set to manually installed.

nodejs is already the newest version (4.8.2~dfsg-1).

You might want to run 'apt --fix-broken install' to correct these.

The following packages have unmet dependencies:

 dvswitch-server : Depends: dvswitch-menu but it is not going to be installed

E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

root@ASLDVSwitch:/opt/Web_Proxy# ls

proxy.js

 


Re: Dashboard no Workie

Steve N4IRS
 

SO, you removed nodejs somehow. Assuming you are running Buster:
apt-get install nodejs node-ws

On 12/28/20 9:42 AM, William KC3CPO wrote:
On Mon, Dec 28, 2020 at 06:41 AM, Steve N4IRS wrote:
/usr/bin/node proxy.js 88 2222

bash: /usr/bin/node: No such file or directory



Re: Dashboard no Workie

William WY7WL
 

On Mon, Dec 28, 2020 at 06:41 AM, Steve N4IRS wrote:
/usr/bin/node proxy.js 88 2222

bash: /usr/bin/node: No such file or directory


Re: Dashboard no Workie

Steve N4IRS
 

cd /opt/Web_Proxy
/usr/bin/node proxy.js 88 2222


What do you get?

On 12/28/20 9:39 AM, William KC3CPO wrote:
Ok Thanks! Any ideas on this one now?? haha

root@ASLDVSwitch:/home/admin# systemctl status webproxy

● webproxy.service - Web Proxy Service

   Loaded: loaded (/lib/systemd/system/webproxy.service; enabled; vendor preset: enabled)

   Active: activating (auto-restart) (Result: exit-code) since Mon 2020-12-28 07:38:01 MST; 1s ago

  Process: 1750 ExecStart=/usr/bin/node /opt/Web_Proxy/proxy.js 88 2222 (code=exited, status=203/EXEC)

  Process: 1747 ExecStartPre=/bin/sh -c echo "Starting Web Proxy: [`date +%T.%3N`]" >> /var/log/netcheck (code=exited, status=0/SUCCESS)

 Main PID: 1750 (code=exited, status=203/EXEC)

 

Dec 28 07:38:01 ASLDVSwitch.local systemd[1]: webproxy.service: Main process exited, code=exited, status=203/EXEC

Dec 28 07:38:01 ASLDVSwitch.local systemd[1]: webproxy.service: Unit entered failed state.

Dec 28 07:38:01 ASLDVSwitch.local systemd[1]: webproxy.service: Failed with result 'exit-code'.



Re: Dashboard no Workie

William WY7WL
 

Ok Thanks! Any ideas on this one now?? haha

root@ASLDVSwitch:/home/admin# systemctl status webproxy

● webproxy.service - Web Proxy Service

   Loaded: loaded (/lib/systemd/system/webproxy.service; enabled; vendor preset: enabled)

   Active: activating (auto-restart) (Result: exit-code) since Mon 2020-12-28 07:38:01 MST; 1s ago

  Process: 1750 ExecStart=/usr/bin/node /opt/Web_Proxy/proxy.js 88 2222 (code=exited, status=203/EXEC)

  Process: 1747 ExecStartPre=/bin/sh -c echo "Starting Web Proxy: [`date +%T.%3N`]" >> /var/log/netcheck (code=exited, status=0/SUCCESS)

 Main PID: 1750 (code=exited, status=203/EXEC)

 

Dec 28 07:38:01 ASLDVSwitch.local systemd[1]: webproxy.service: Main process exited, code=exited, status=203/EXEC

Dec 28 07:38:01 ASLDVSwitch.local systemd[1]: webproxy.service: Unit entered failed state.

Dec 28 07:38:01 ASLDVSwitch.local systemd[1]: webproxy.service: Failed with result 'exit-code'.


Re: Dashboard no Workie

Steve N4IRS
 

If you modify a config file for a apt package, in this case lightttpd, then on upgrade, apt will ask if you want to keep your file or use the config file included in the apt package.

On 12/28/20 9:12 AM, William KC3CPO wrote:
Ah, so the file was there just named.... lighttpd.conf.dpkg-new 

Changed name and running now.



Re: Dashboard no Workie

William WY7WL
 

Ah, so the file was there just named.... lighttpd.conf.dpkg-new 

Changed name and running now.


Re: Dashboard no Workie

Steve N4IRS
 

server.modules = (
    "mod_indexfile",
    "mod_access",
    "mod_alias",
    "mod_redirect",
)

server.document-root        = "/var/www/html"
server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
server.errorlog             = "/var/log/lighttpd/error.log"
server.pid-file             = "/var/run/lighttpd.pid"
server.username             = "www-data"
server.groupname            = "www-data"
server.port                 = 80

# strict parsing and normalization of URL for consistency and security
# https://redmine.lighttpd.net/projects/lighttpd/wiki/Server_http-parseoptsDetails
# (might need to explicitly set "url-path-2f-decode" = "disable"
#  if a specific application is encoding URLs inside url-path)
server.http-parseopts = (
  "header-strict"           => "enable",# default
  "host-strict"             => "enable",# default
  "host-normalize"          => "enable",# default
  "url-normalize-unreserved"=> "enable",# recommended highly
  "url-normalize-required"  => "enable",# recommended
  "url-ctrls-reject"        => "enable",# recommended
  "url-path-2f-decode"      => "enable",# recommended highly (unless breaks app)
 #"url-path-2f-reject"      => "enable",
  "url-path-dotseg-remove"  => "enable",# recommended highly (unless breaks app)
 #"url-path-dotseg-reject"  => "enable",
 #"url-query-20-plus"       => "enable",# consistency in query string
)

index-file.names            = ( "index.php", "index.html" )
url.access-deny             = ( "~", ".inc" )
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

compress.cache-dir          = "/var/cache/lighttpd/compress/"
compress.filetype           = ( "application/javascript", "text/css", "text/html", "text/plain" )

# default listening port for IPv6 falls back to the IPv4 port
# include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell "/usr/share/lighttpd/create-mime.conf.pl"
include "/etc/lighttpd/conf-enabled/*.conf"

#server.compat-module-load   = "disable"
server.modules += (
    "mod_compress",
    "mod_dirlisting",
    "mod_staticfile",
)


On 12/28/20 9:03 AM, William KC3CPO wrote:
Is there a quick way to rebuild lighttpd?

I'm back to revisit this problem (on a different server now). 

lighttpd status tells failed to start and I've noticed the conf file under /etc/lighttpd/lighttpd.conf is missing. 

Thanks for any help, 

Will


Re: Dashboard no Workie

William WY7WL
 

Is there a quick way to rebuild lighttpd?

I'm back to revisit this problem (on a different server now). 

lighttpd status tells failed to start and I've noticed the conf file under /etc/lighttpd/lighttpd.conf is missing. 

Thanks for any help, 

Will


Re: Restarting DVSwitch Services

Steve N4IRS
 

Dave,
There are two ways to switch servers:
1: edit MMDVM_Bridge.ini and restart MMDVM_Bridge
2: With a tune command: "password@server:port:options"
   
TGIF = "passw0rd@...:62031"
Brandmeister = "passw0rd@...:62031"
DMR_PLUS = "passw0rd@...:55555:StartRef=4649;RelinkTime=60;UserLink=1"

Hope this helps,
Steve N4IRS


On 12/28/20 6:56 AM, g8ptn@... wrote:

Hi Steve, 

After investigating further, the issue only occurs when switching server using the DVSM App.

Switching server in the “dvs” menu updates the MMDVM_Bridge.ini file with the selected address, but not when making the selection using DVSM App.

Regards,

   Dave


1821 - 1840 of 9820