Date   

Re: Hotspot Audio for C4FM Very loud and distorted.

Patrick Perdue
 

Are you running USRPGain and TLVGain at unity? I've found it helps a lot to turn TLVGain down quite a bit in Analog_Bridge.ini. TLV is the gain sent from analog to digital. This will reduce the gain to DMR from analog. More headroom isn't necessarily bad, though you'll find that audio to your Yaesu is probably still louder than with a DMR radio. I'm not a Yaesu-using person myself, though I did just order an FT70 to play with, so I don't know exactly why these differences in levels between DMR and C4FM radios are what they are when everyone is using the same codec. I'll let someone better qualified explain that.


Here's how I have my TLV gain set:

tlvAudio = AUDIO_USE_GAIN                  ; Analog -> Digital (AUDIO_UNITY, AUDIO_USE_GAIN, AUDIO_BPF)
tlvGain = 0.35                          ; Gain factor when tlvAudio = AUDIO_USE_GAIN (0.0 to 5.0) (1.0 = AUDIO_UNITY)


When playing with things a month or so ago, I was told that, on my bridge, digital to digital (person A on DMR radio and person B on a Yaesu) sounded OK, but audio from analog was too hot on C4FM, but OK on analog, so I turned down the TLVGain a little. I don't really know a better way to handle that situation. Note that in my case, DVSwitch is not involved in making the connection between DMR and YSF. I got the same results when using DVSwitch instead, though.


And for USRPGain, I'm using AGC, with the threshold a little higher than in the default configuration. This is personal preference, but I find it works pretty well on my bridge.

usrpAudio = AUDIO_USE_AGC                 ; Digital -> Analog (AUDIO_UNITY, AUDIO_USE_GAIN, AUDIO_USE_AGC)
usrpGain = 1.0                         ; Gain factor when usrpAudio = AUDIO_USE_GAIN (0.0 to 5.0) (1.0 = AUDIO_UNITY)
usrpAgc = -18,10,500


On 12/30/2020 12:54 AM, Frank C. D'Amato wrote:
I have DVswitch setup DMR>Analog. It pushes a DMR TG to my Hamvoip Allstar node (2 seperate Pi's).

When I talk on the analog radio, the audio sounds great coming out of my DMR radio connected to a Openspot (Both ver 1&2).

If I put my openspot modem to C4FM (to use my yaesu rado in DN mode), and connect to the TG that my DVswitch is transmitting to, the audio sounds very distorted and loud.

Anyone else have this problem?

Using the same setup C4FM to DMR on the openspots sound great on the yeasu radio, The problem is only there on the TG the DVswitch is pushing the analog audio to.


Hotspot Audio for C4FM Very loud and distorted.

Frank C. D'Amato - KB2MXV
 

I have DVswitch setup DMR>Analog. It pushes a DMR TG to my Hamvoip Allstar node (2 seperate Pi's).

When I talk on the analog radio, the audio sounds great coming out of my DMR radio connected to a Openspot (Both ver 1&2).

If I put my openspot modem to C4FM (to use my yaesu rado in DN mode), and connect to the TG that my DVswitch is transmitting to, the audio sounds very distorted and loud.

Anyone else have this problem?

Using the same setup C4FM to DMR on the openspots sound great on the yeasu radio, The problem is only there on the TG the DVswitch is pushing the analog audio to.


Re: Bridge

Steve N4IRS
 

If it's keying, it should also sending audio. Check your Vocoders and maybe the audio levels in your AB.ini If sending in one direction and not another, I expect a port issue in that direction.
 

On 12/28/20 10:57 PM, ibjosh1985@... wrote:
i do see where dmr does key up p25  and p25 does not key up dmr  that much i do know

even when dmr key's up p25 no audio is being routed


Re: Bridge

Joshua Johnson - KC5JMJ
 

i do see where dmr does key up p25  and p25 does not key up dmr  that much i do know

even when dmr key's up p25 no audio is being routed


Re: Bridge

Steve N4IRS
 

It's not just about errors. It's about following the data through. Does data enter a component? Does the data leave the component...

On 12/28/20 10:47 PM, ibjosh1985@... wrote:
ok i'm not seeing any error's in the logs


Re: Bridge

Joshua Johnson - KC5JMJ
 

ok i'm not seeing any error's in the logs


Re: Bridge

Steve N4IRS
 

I run everything in the foreground while testing. Once all works, I have it all start at boot.

On 12/28/20 10:20 PM, ibjosh1985@... wrote:
ok does the MMDVM start up auto or do i launch it manual making sure i do have everything running


Re: Bridge

Joshua Johnson - KC5JMJ
 

ok does the MMDVM start up auto or do i launch it manual making sure i do have everything running


Re: Bridge

Steve N4IRS
 

Follow the data through the logs. Send one short transmission and follow it.

On 12/28/20 9:52 PM, ibjosh1985@... wrote:
here is a copy of the logs


Re: Bridge

Joshua Johnson - KC5JMJ
 

here is a copy of the logs


Re: Bridge

Steve N4IRS
 

Te questions are what you should be asking yourself as you troubleshoot.

On 12/28/20 9:47 PM, ibjosh1985@... wrote:
M: 2020-12-29 02:46:42.808 Currently linked repeaters:
M: 2020-12-29 02:46:42.809     KC5JMJ    : 240.58.230.191:24226 0/120
M: 2020-12-29 02:46:42.809     KC5JMJ    : 240.58.230.191:6820 2/120


the KC5FDO is no longer listed as linked repeaters


Re: Bridge

Joshua Johnson - KC5JMJ
 

M: 2020-12-29 02:46:42.808 Currently linked repeaters:
M: 2020-12-29 02:46:42.809     KC5JMJ    : 240.58.230.191:24226 0/120
M: 2020-12-29 02:46:42.809     KC5JMJ    : 240.58.230.191:6820 2/120


the KC5FDO is no longer listed as linked repeaters


Re: Bridge

Joshua Johnson - KC5JMJ
 

http://bridge.kc5jmj.com

P25 : 31337
DMR BM TG : 311995


Re: Bridge

Steve N4IRS
 

Like I said, follow the data. Since you are testing DMR to P25.
Is MMDVM_Bridge logging into the Master?
Do you see the data when a DMR user keys in the MB log?
Do you see the data in the AB_DMR log?
Do you see the data in the AB_P25 log?
Do you see the P25 data transmitting from MB?
Is the P25Gateway logged into the P25 Reflector?

The LAST thing you care about is the dashboard.
Follow the data.

On 12/28/20 9:38 PM, ibjosh1985@... wrote:
ok i see on the dashboard now when i key dmr it says tx p25 but no audio so i did get that far


Re: Bridge

Joshua Johnson - KC5JMJ
 

ok i see on the dashboard now when i key dmr it says tx p25 but no audio so i did get that far


Re: Bridge

Steve N4IRS
 

Watch the logs as you transmit on one side of the bridge, follow the data through the bridge.

On 12/28/20 9:24 PM, ibjosh1985@... wrote:
ok it shows the linked but no audio passing and when keying up p25 it does not show up in the dashboard


Re: Bridge

Joshua Johnson - KC5JMJ
 

ok it shows the linked but no audio passing and when keying up p25 it does not show up in the dashboard


Re: Bridge

Steve N4IRS
 

Yes,
The services read the config files at boot.

On 12/28/20 9:00 PM, ibjosh1985@... wrote:
ok so editing each dedicated analog_bridge file for the mode's so after editing do i need to reboot the server


Re: Bridge

Joshua Johnson - KC5JMJ
 

ok so editing each dedicated analog_bridge file for the mode's so after editing do i need to reboot the server


Re: Bridge

Steve N4IRS
 

Analog_Bridge

On 12/28/20 8:53 PM, ibjosh1985@... wrote:
ok so where do i edit the AMBE_AUDIO  ports at

1861 - 1880 of 9891