Date   

Re: Unable to locate package dvswitch-server

Steve N4IRS
 

Steve,
I see this:
Hit:1 http://dvswitch.org/ASL_Repository stretch InRelease
Which tells me something attempted to install a older version of AllStar
edit the file /etc/apt/sources.list.d/

change all occurrences of stretch to buster
apt update
apt install dvswitch-server

On 2/15/2021 12:01 PM, Steve, N9VW wrote:
Steve,
I have a fresh, updated version of Buster. I installed everything per the above directions and get the following:

pi@raspberrypi:~ $ wget http://dvswitch.org/buster
--2021-02-15 08:57:35--  http://dvswitch.org/buster
Resolving dvswitch.org (dvswitch.org)... 44.103.34.4
Connecting to dvswitch.org (dvswitch.org)|44.103.34.4|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1831 (1.8K)
Saving to: ‘buster’

buster                                  100%[===============================================================================>]   1.79K  --.-KB/s    in 0s

2021-02-15 08:57:35 (29.4 MB/s) - ‘buster’ saved [1831/1831]

pi@raspberrypi:~ $ sudo -s
root@raspberrypi:/home/pi# ls
Bookshelf  buster  Desktop  Documents  Downloads  Music  Pictures  Public  Templates  Videos
root@raspberrypi:/home/pi# chmod +x buster
root@raspberrypi:/home/pi# ./buster
The Repository file already exists, exiting
root@raspberrypi:/home/pi# apt-get update
Hit:1 http://dvswitch.org/ASL_Repository stretch InRelease
Get:2 http://packages.microsoft.com/repos/code stable InRelease [10.4 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:4 http://archive.raspberrypi.org/debian buster InRelease [32.8 kB]
Get:5 http://packages.microsoft.com/repos/code stable/main arm64 Packages [13.9 kB]
Get:6 http://packages.microsoft.com/repos/code stable/main amd64 Packages [13.2 kB]
Get:7 http://packages.microsoft.com/repos/code stable/main armhf Packages [13.7 kB]
Get:8 http://archive.raspberrypi.org/debian buster/main armhf Packages [364 kB]
Fetched 463 kB in 3s (152 kB/s)
Reading package lists... Done
root@raspberrypi:/home/pi# apt-get install dvswitch-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package dvswitch-server
root@raspberrypi:/home/pi#
root@raspberrypi:/home/pi#
root@raspberrypi:/home/pi# uname -a
Linux raspberrypi 5.10.11-v7+ #1399 SMP Thu Jan 28 12:06:05 GMT 2021 armv7l GNU/Linux
root@raspberrypi:/home/pi#

What am I missing???

All I am really wanting to do is IPSC <-> Analog_Bridge <-> DV3000 <-> icecast (or similar streaming service)

73 de Steve, N9VW


Re: Unable to locate package dvswitch-server

Steve, N9VW
 

Steve,
I have a fresh, updated version of Buster. I installed everything per the above directions and get the following:

pi@raspberrypi:~ $ wget http://dvswitch.org/buster
--2021-02-15 08:57:35--  http://dvswitch.org/buster
Resolving dvswitch.org (dvswitch.org)... 44.103.34.4
Connecting to dvswitch.org (dvswitch.org)|44.103.34.4|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1831 (1.8K)
Saving to: ‘buster’

buster                                  100%[===============================================================================>]   1.79K  --.-KB/s    in 0s

2021-02-15 08:57:35 (29.4 MB/s) - ‘buster’ saved [1831/1831]

pi@raspberrypi:~ $ sudo -s
root@raspberrypi:/home/pi# ls
Bookshelf  buster  Desktop  Documents  Downloads  Music  Pictures  Public  Templates  Videos
root@raspberrypi:/home/pi# chmod +x buster
root@raspberrypi:/home/pi# ./buster
The Repository file already exists, exiting
root@raspberrypi:/home/pi# apt-get update
Hit:1 http://dvswitch.org/ASL_Repository stretch InRelease
Get:2 http://packages.microsoft.com/repos/code stable InRelease [10.4 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:4 http://archive.raspberrypi.org/debian buster InRelease [32.8 kB]
Get:5 http://packages.microsoft.com/repos/code stable/main arm64 Packages [13.9 kB]
Get:6 http://packages.microsoft.com/repos/code stable/main amd64 Packages [13.2 kB]
Get:7 http://packages.microsoft.com/repos/code stable/main armhf Packages [13.7 kB]
Get:8 http://archive.raspberrypi.org/debian buster/main armhf Packages [364 kB]
Fetched 463 kB in 3s (152 kB/s)
Reading package lists... Done
root@raspberrypi:/home/pi# apt-get install dvswitch-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package dvswitch-server
root@raspberrypi:/home/pi#
root@raspberrypi:/home/pi#
root@raspberrypi:/home/pi# uname -a
Linux raspberrypi 5.10.11-v7+ #1399 SMP Thu Jan 28 12:06:05 GMT 2021 armv7l GNU/Linux
root@raspberrypi:/home/pi#

What am I missing???

All I am really wanting to do is IPSC <-> Analog_Bridge <-> DV3000 <-> icecast (or similar streaming service)

73 de Steve, N9VW


Second instances

Steve Siesel [K4KSA]
 

To have second instances of AB, MB, md380-emu, Do you just copy the directories to where you want the second instances? Then modify and rename the existing .service files? This is to send to Broadcasify


Re: Unable to locate package dvswitch-server

David - W9DWH
 

Upgrading to Buster worked.  It's up and running now.  Thanks for the help Steve.  It's much appreciated!


Re: Unable to locate package dvswitch-server

Steve N4IRS
 

I am going to bed at 11:00 Eastern
If you hit a error, stop and ask. Much less frustration that way.

Steve N4IRS

On 2/14/21 9:48 PM, David - W9DWH/4 via groups.io wrote:
Virmach.


Re: Unable to locate package dvswitch-server

Steve N4IRS
 

1: Install Linux Debian 9 X86 64 Minimal Latest V2
2: apt update
3: apt upgrade
4: reboot
5: edit /etc/apt/sources.list
    Change all occurrences of stretch to buster
    cd /etc/apt
     grep stretch * -r
     You should have no hits
6: apt update
7: apt dist-upgrade
8 apt autoremove
9: reboot
 


On 2/14/21 9:52 PM, David - W9DWH/4 via groups.io wrote:
It's worth a try.  What's getting frustrating is I have an Allstar Node set up with autopatch/reverse patch, and several other advanced features, and something as simple as this is giving me fits.


Re: Unable to locate package dvswitch-server

David - W9DWH
 

It's worth a try.  What's getting frustrating is I have an Allstar Node set up with autopatch/reverse patch, and several other advanced features, and something as simple as this is giving me fits.


Re: Unable to locate package dvswitch-server

Steve N4IRS
 

As am I. OK, I can tell you how to upgrade their Debian 9 to Buster.

On 2/14/21 9:48 PM, David - W9DWH/4 via groups.io wrote:
Virmach.


Re: Unable to locate package dvswitch-server

David - W9DWH
 

Virmach.


Re: Unable to locate package dvswitch-server

Steve N4IRS
 

What provider are you using?

On 2/14/21 9:44 PM, David - W9DWH/4 via groups.io wrote:
Best I can tell.  It's not there anymore though as I wiped the OS again trying to find one that will work.  I added the repos that someone else mentioned, and it didn't throw as many errors, but it did still throw some errors.


Re: Unable to locate package dvswitch-server

David - W9DWH
 

Best I can tell.  It's not there anymore though as I wiped the OS again trying to find one that will work.  I added the repos that someone else mentioned, and it didn't throw as many errors, but it did still throw some errors.


Re: Unable to locate package dvswitch-server

Steve N4IRS
 

Let me see if I understand. It installed but dvs did not run?

On 2/14/21 9:39 PM, David - W9DWH/4 via groups.io wrote:
I had to go back to Ubuntu as Buster wasn't one of my choices (newest available to me was Debian 8 and it threw the same errors as earlier).  The DVS command would not run after installation.  As I mentioned I found some documentation on setting it up the old way but the documentation wasn't complete. I couldn't find how to add more DMR networks other than Brandmeister.  If you still have the old documentation laying around the old way is the way I prefer to do it as this point.  I had it and running and minutes where I've spent hours this way and haven't gotten anywhere.  


Re: Unable to locate package dvswitch-server

David - W9DWH
 

I had to go back to Ubuntu as Buster wasn't one of my choices (newest available to me was Debian 8 and it threw the same errors as earlier).  The DVS command would not run after installation.  As I mentioned I found some documentation on setting it up the old way but the documentation wasn't complete. I couldn't find how to add more DMR networks other than Brandmeister.  If you still have the old documentation laying around the old way is the way I prefer to do it as this point.  I had it and running and minutes where I've spent hours this way and haven't gotten anywhere.  


Re: Unable to locate package dvswitch-server

Steve N4IRS
 

What OS did you choose? What error are you getting.

On 2/14/21 8:50 PM, David - W9DWH/4 via groups.io wrote:
I give up. This is not an easier way of doing it. I don't want to run out of allowed OS reinstalls.  Can someone please point me toward the complete documentation on how to do this the hard way?  The way where we have to install it package by package and then manually edit the files using a text editor?  I actually had it working on Brandmeister this way but I couldn't find the documentation on how to also add additional DMR networks.  I thought this might be a faster way of doing it but it's not. 


Re: Unable to locate package dvswitch-server

David - W9DWH
 
Edited

I give up. This is not an easier way of doing it. I don't want to run out of allowed OS reinstalls.  Can someone please point me toward the complete documentation on how to do this the hard way?  The way where we have to install it package by package and then manually edit the files using a text editor?  I actually had it working on Brandmeister this way but I couldn't find the documentation on how to also add additional DMR networks.  I thought this might be a faster way of doing it but it's not.  I've been working on it since my last reply.  I probably could have already had it configured the old way.


Re: DVSwitch dashboard not populating

David Young
 

Ok, thanks, I'll give this a try, else I'll do a clean install.
--
Dave WB6DTB


Re: Unable to locate package dvswitch-server

Mike KB8JNM
 

I finished already after the repo correction

On 2/14/2021 7:13 PM, Steve N4IRS wrote:
OK,
I suggest you start with the stock netinstall ISO from Debian. <https://cdimage.debian.org/debian-cd/current/amd64/iso-cd/debian-10.8.0-amd64-netinst.iso>

On 2/14/21 7:04 PM, Mike KB8JNM wrote:

You are right, mine was buster iso w/asl script


On 2/14/2021 6:36 PM, Steve N4IRS wrote:
The amd64 asl ISO is stretch, not buster.

On 2/14/21 6:28 PM, Mike KB8JNM wrote:

For anyone else's benefit,

I was missing source repo list

/etc/apt/sources.list

This is what it should read:

deb http://deb.debian.org/debian buster main contrib non-free
deb-src http://deb.debian.org/debian buster main contrib non-free

deb http://security.debian.org/debian-security buster/updates main contrib
deb-src http://security.debian.org/debian-security buster/updates main contrib

Installed just fine after fix


I would note that my install came from amd64 asl iso.


On 2/14/2021 6:13 PM, Steve N4IRS wrote:
<https://packages.debian.org/buster/net-tools>

On 2/14/21 6:04 PM, Mike KB8JNM wrote:

So, on a new attempt,

After : ./buster

E: Package 'net-tools' has no installation candidate

On 2/14/2021 3:18 PM, Mike KB8JNM wrote:

The following packages have been kept back:
  openssh-client openssh-server openssh-sftp-server ssh
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

On 2/14/2021 3:17 PM, Mike KB8JNM wrote:

Originally, it left me with 9

I installed them manually, all but 3

ssh client and server and one other network package.

On 2/14/2021 3:16 PM, Steve N4IRS wrote:
are you saying that apt upgrade does not install updates?

On 2/14/21 3:14 PM, Mike KB8JNM wrote:

That is where it takes system updates but can not install them all.

I'm pretty sure that is what the other fella was having a issue with but can't speak to that if it was not buster

On 2/14/2021 3:12 PM, Steve N4IRS wrote:
OK,
step one:
Make sure your existing system is up to date.
apt update
apt upgrade

What is wrong there?

On 2/14/21 3:10 PM, Mike KB8JNM wrote:

No, back up a step, I talking system.

apt update

apt apgrade

On 2/14/2021 3:08 PM, Steve N4IRS wrote:
That script is the first step. It adds the buster repo.

On 2/14/21 3:06 PM, Mike KB8JNM wrote:

The issue was not with the install script.

Never got that far.

The issue was updated repository's that are broken.

On 2/14/2021 3:05 PM, Steve N4IRS wrote:
This is the buster script:

#!/usr/bin/env bash
set -o errexit

# N4IRS 10/25/2020

#################################################
#                                               #
#    Add DVSwitch Repository and gpg key        #
#                                               #
#################################################

if [[ $(/usr/bin/id -u) -ne 0 ]]; then
    echo "Not running as root"
    echo "either run as root or with sudo"
    exit
fi

distribution=buster

# INSTALL gnupg needed for gpg.key
[ ! -x "/usr/bin/gpg" ] && apt-get install gnupg -y

# Add the backport repository, if needed to install monit
if [ $(apt-cache policy monit | grep -c "Candidate: (none)") -eq 1 ] ; then
        # add repository
        printf "%s\n" "deb http://ftp.de.debian.org/debian buster-backports main" | tee /etc/apt/sources.list.d/buster-backports.list
fi

# INSTALL netstat needed by dvswitch.sh
[ ! -x "/bin/netstat" ] && apt-get install net-tools -y

# Check for rc.local and create if not found.
FILE="/etc/rc.local"
        if [ ! -f "$FILE" ] ; then
        echo '#!/bin/sh -e' > $FILE
        echo '' >> $FILE
        echo 'exit 0' >> $FILE
       chmod +x $FILE
        fi

# Are the repos installed
# Should this test for buster too?
if [ -f /etc/apt/sources.list.d/dvswitch.list ]
then
    echo "The Repository file already exists, exiting"
    exit 0
fi

# Install the key and add the repo
wget -O - http://dvswitch.org/DVSwitch_Repository/dvswitch.gpg.key | apt-key add -
echo "# Official DVSwitch repository" >/etc/apt/sources.list.d/dvswitch.list
echo "deb http://dvswitch.org/DVSwitch_Repository $distribution hamradio" >>/etc/apt/sources.list.d/dvswitch.list
echo "#" >>/etc/apt/sources.list.d/dvswitch.list

apt-get update

# print the installed repositories
echo "Installed repositories:"
apt-cache policy | grep http | awk '{print $2 $3}' | sort -u

I don't see any way it would install a pointer to http://dvswitch.org/ASL_Repository stretch


On 2/14/21 3:00 PM, Mike KB8JNM wrote:

I have the same issue with Buster

I was able to manually update packages until ssh-client/server and one other related

Stopped till I have time to fool with it again.

On 2/14/2021 2:48 PM, Steve N4IRS wrote:
I assume you mean this:

wget http://dvswitch.org/buster
sudo chmod +x buster
sudo ./buster
sudo apt-get update
sudo apt-get install dvswitch-server

The buster script would have either added the buster repository or told you that it was already installed.

Check /etc/apt/sources.list.d/allstarlink.list

deb http://dvswitch.org/DVSwitch_Repository buster hamradio

Then:
apt-get update
apt-get install dvswitch-server


Steve N4IRS



On 2/14/21 2:40 PM, David - W9DWH/4 via groups.io wrote:
http://dvswitch.org/DVSwitch_install.pdf









Re: Unable to locate package dvswitch-server

Steve N4IRS
 

OK,
I suggest you start with the stock netinstall ISO from Debian. <https://cdimage.debian.org/debian-cd/current/amd64/iso-cd/debian-10.8.0-amd64-netinst.iso>

On 2/14/21 7:04 PM, Mike KB8JNM wrote:

You are right, mine was buster iso w/asl script


On 2/14/2021 6:36 PM, Steve N4IRS wrote:
The amd64 asl ISO is stretch, not buster.

On 2/14/21 6:28 PM, Mike KB8JNM wrote:

For anyone else's benefit,

I was missing source repo list

/etc/apt/sources.list

This is what it should read:

deb http://deb.debian.org/debian buster main contrib non-free
deb-src http://deb.debian.org/debian buster main contrib non-free

deb http://security.debian.org/debian-security buster/updates main contrib
deb-src http://security.debian.org/debian-security buster/updates main contrib

Installed just fine after fix


I would note that my install came from amd64 asl iso.


On 2/14/2021 6:13 PM, Steve N4IRS wrote:
<https://packages.debian.org/buster/net-tools>

On 2/14/21 6:04 PM, Mike KB8JNM wrote:

So, on a new attempt,

After : ./buster

E: Package 'net-tools' has no installation candidate

On 2/14/2021 3:18 PM, Mike KB8JNM wrote:

The following packages have been kept back:
  openssh-client openssh-server openssh-sftp-server ssh
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

On 2/14/2021 3:17 PM, Mike KB8JNM wrote:

Originally, it left me with 9

I installed them manually, all but 3

ssh client and server and one other network package.

On 2/14/2021 3:16 PM, Steve N4IRS wrote:
are you saying that apt upgrade does not install updates?

On 2/14/21 3:14 PM, Mike KB8JNM wrote:

That is where it takes system updates but can not install them all.

I'm pretty sure that is what the other fella was having a issue with but can't speak to that if it was not buster

On 2/14/2021 3:12 PM, Steve N4IRS wrote:
OK,
step one:
Make sure your existing system is up to date.
apt update
apt upgrade

What is wrong there?

On 2/14/21 3:10 PM, Mike KB8JNM wrote:

No, back up a step, I talking system.

apt update

apt apgrade

On 2/14/2021 3:08 PM, Steve N4IRS wrote:
That script is the first step. It adds the buster repo.

On 2/14/21 3:06 PM, Mike KB8JNM wrote:

The issue was not with the install script.

Never got that far.

The issue was updated repository's that are broken.

On 2/14/2021 3:05 PM, Steve N4IRS wrote:
This is the buster script:

#!/usr/bin/env bash
set -o errexit

# N4IRS 10/25/2020

#################################################
#                                               #
#    Add DVSwitch Repository and gpg key        #
#                                               #
#################################################

if [[ $(/usr/bin/id -u) -ne 0 ]]; then
    echo "Not running as root"
    echo "either run as root or with sudo"
    exit
fi

distribution=buster

# INSTALL gnupg needed for gpg.key
[ ! -x "/usr/bin/gpg" ] && apt-get install gnupg -y

# Add the backport repository, if needed to install monit
if [ $(apt-cache policy monit | grep -c "Candidate: (none)") -eq 1 ] ; then
        # add repository
        printf "%s\n" "deb http://ftp.de.debian.org/debian buster-backports main" | tee /etc/apt/sources.list.d/buster-backports.list
fi

# INSTALL netstat needed by dvswitch.sh
[ ! -x "/bin/netstat" ] && apt-get install net-tools -y

# Check for rc.local and create if not found.
FILE="/etc/rc.local"
        if [ ! -f "$FILE" ] ; then
        echo '#!/bin/sh -e' > $FILE
        echo '' >> $FILE
        echo 'exit 0' >> $FILE
       chmod +x $FILE
        fi

# Are the repos installed
# Should this test for buster too?
if [ -f /etc/apt/sources.list.d/dvswitch.list ]
then
    echo "The Repository file already exists, exiting"
    exit 0
fi

# Install the key and add the repo
wget -O - http://dvswitch.org/DVSwitch_Repository/dvswitch.gpg.key | apt-key add -
echo "# Official DVSwitch repository" >/etc/apt/sources.list.d/dvswitch.list
echo "deb http://dvswitch.org/DVSwitch_Repository $distribution hamradio" >>/etc/apt/sources.list.d/dvswitch.list
echo "#" >>/etc/apt/sources.list.d/dvswitch.list

apt-get update

# print the installed repositories
echo "Installed repositories:"
apt-cache policy | grep http | awk '{print $2 $3}' | sort -u

I don't see any way it would install a pointer to http://dvswitch.org/ASL_Repository stretch


On 2/14/21 3:00 PM, Mike KB8JNM wrote:

I have the same issue with Buster

I was able to manually update packages until ssh-client/server and one other related

Stopped till I have time to fool with it again.

On 2/14/2021 2:48 PM, Steve N4IRS wrote:
I assume you mean this:

wget http://dvswitch.org/buster
sudo chmod +x buster
sudo ./buster
sudo apt-get update
sudo apt-get install dvswitch-server

The buster script would have either added the buster repository or told you that it was already installed.

Check /etc/apt/sources.list.d/allstarlink.list

deb http://dvswitch.org/DVSwitch_Repository buster hamradio

Then:
apt-get update
apt-get install dvswitch-server


Steve N4IRS



On 2/14/21 2:40 PM, David - W9DWH/4 via groups.io wrote:
http://dvswitch.org/DVSwitch_install.pdf









Re: Unable to locate package dvswitch-server

Mike KB8JNM
 

You are right, mine was buster iso w/asl script


On 2/14/2021 6:36 PM, Steve N4IRS wrote:
The amd64 asl ISO is stretch, not buster.

On 2/14/21 6:28 PM, Mike KB8JNM wrote:

For anyone else's benefit,

I was missing source repo list

/etc/apt/sources.list

This is what it should read:

deb http://deb.debian.org/debian buster main contrib non-free
deb-src http://deb.debian.org/debian buster main contrib non-free

deb http://security.debian.org/debian-security buster/updates main contrib
deb-src http://security.debian.org/debian-security buster/updates main contrib

Installed just fine after fix


I would note that my install came from amd64 asl iso.


On 2/14/2021 6:13 PM, Steve N4IRS wrote:
<https://packages.debian.org/buster/net-tools>

On 2/14/21 6:04 PM, Mike KB8JNM wrote:

So, on a new attempt,

After : ./buster

E: Package 'net-tools' has no installation candidate

On 2/14/2021 3:18 PM, Mike KB8JNM wrote:

The following packages have been kept back:
  openssh-client openssh-server openssh-sftp-server ssh
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

On 2/14/2021 3:17 PM, Mike KB8JNM wrote:

Originally, it left me with 9

I installed them manually, all but 3

ssh client and server and one other network package.

On 2/14/2021 3:16 PM, Steve N4IRS wrote:
are you saying that apt upgrade does not install updates?

On 2/14/21 3:14 PM, Mike KB8JNM wrote:

That is where it takes system updates but can not install them all.

I'm pretty sure that is what the other fella was having a issue with but can't speak to that if it was not buster

On 2/14/2021 3:12 PM, Steve N4IRS wrote:
OK,
step one:
Make sure your existing system is up to date.
apt update
apt upgrade

What is wrong there?

On 2/14/21 3:10 PM, Mike KB8JNM wrote:

No, back up a step, I talking system.

apt update

apt apgrade

On 2/14/2021 3:08 PM, Steve N4IRS wrote:
That script is the first step. It adds the buster repo.

On 2/14/21 3:06 PM, Mike KB8JNM wrote:

The issue was not with the install script.

Never got that far.

The issue was updated repository's that are broken.

On 2/14/2021 3:05 PM, Steve N4IRS wrote:
This is the buster script:

#!/usr/bin/env bash
set -o errexit

# N4IRS 10/25/2020

#################################################
#                                               #
#    Add DVSwitch Repository and gpg key        #
#                                               #
#################################################

if [[ $(/usr/bin/id -u) -ne 0 ]]; then
    echo "Not running as root"
    echo "either run as root or with sudo"
    exit
fi

distribution=buster

# INSTALL gnupg needed for gpg.key
[ ! -x "/usr/bin/gpg" ] && apt-get install gnupg -y

# Add the backport repository, if needed to install monit
if [ $(apt-cache policy monit | grep -c "Candidate: (none)") -eq 1 ] ; then
        # add repository
        printf "%s\n" "deb http://ftp.de.debian.org/debian buster-backports main" | tee /etc/apt/sources.list.d/buster-backports.list
fi

# INSTALL netstat needed by dvswitch.sh
[ ! -x "/bin/netstat" ] && apt-get install net-tools -y

# Check for rc.local and create if not found.
FILE="/etc/rc.local"
        if [ ! -f "$FILE" ] ; then
        echo '#!/bin/sh -e' > $FILE
        echo '' >> $FILE
        echo 'exit 0' >> $FILE
       chmod +x $FILE
        fi

# Are the repos installed
# Should this test for buster too?
if [ -f /etc/apt/sources.list.d/dvswitch.list ]
then
    echo "The Repository file already exists, exiting"
    exit 0
fi

# Install the key and add the repo
wget -O - http://dvswitch.org/DVSwitch_Repository/dvswitch.gpg.key | apt-key add -
echo "# Official DVSwitch repository" >/etc/apt/sources.list.d/dvswitch.list
echo "deb http://dvswitch.org/DVSwitch_Repository $distribution hamradio" >>/etc/apt/sources.list.d/dvswitch.list
echo "#" >>/etc/apt/sources.list.d/dvswitch.list

apt-get update

# print the installed repositories
echo "Installed repositories:"
apt-cache policy | grep http | awk '{print $2 $3}' | sort -u

I don't see any way it would install a pointer to http://dvswitch.org/ASL_Repository stretch


On 2/14/21 3:00 PM, Mike KB8JNM wrote:

I have the same issue with Buster

I was able to manually update packages until ssh-client/server and one other related

Stopped till I have time to fool with it again.

On 2/14/2021 2:48 PM, Steve N4IRS wrote:
I assume you mean this:

wget http://dvswitch.org/buster
sudo chmod +x buster
sudo ./buster
sudo apt-get update
sudo apt-get install dvswitch-server

The buster script would have either added the buster repository or told you that it was already installed.

Check /etc/apt/sources.list.d/allstarlink.list

deb http://dvswitch.org/DVSwitch_Repository buster hamradio

Then:
apt-get update
apt-get install dvswitch-server


Steve N4IRS



On 2/14/21 2:40 PM, David - W9DWH/4 via groups.io wrote:
http://dvswitch.org/DVSwitch_install.pdf








Re: Unable to locate package dvswitch-server

Steve N4IRS
 

This is from a install using the ASL amd64 ISO:

Linux repeater 4.9.0-14-amd64 #1 SMP Debian 4.9.246-2 (2020-12-17) x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sun Feb 14 18:51:04 2021

repeater@repeater:~$ uname -a
Linux repeater 4.9.0-14-amd64 #1 SMP Debian 4.9.246-2 (2020-12-17) x86_64 GNU/Linux

repeater@repeater:~$ cat /etc/debian_version
9.13

repeater@repeater:~$ cat /etc/issue.net
Debian GNU/Linux 9

repeater@repeater:~$ cat /etc/apt/sources.list
#

# deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official Multi-architecture amd64/i386 NETINST #1 20171209-13:49]/ stretch contrib main non-free

#deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official Multi-architecture amd64/i386 NETINST #1 20171209-13:49]/ stretch contrib main non-free

deb http://http.us.debian.org/debian stretch main non-free contrib
deb-src http://http.us.debian.org/debian stretch main non-free contrib

deb http://dvswitch.org/ASL_Repository stretch hamradio

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://http.us.debian.org/debian stretch-updates main contrib non-free
deb-src http://http.us.debian.org/debian stretch-updates main contrib non-free
repeater@repeater:~$


On 2/14/21 6:28 PM, Mike KB8JNM wrote:

For anyone else's benefit,

I was missing source repo list

/etc/apt/sources.list

This is what it should read:

deb http://deb.debian.org/debian buster main contrib non-free
deb-src http://deb.debian.org/debian buster main contrib non-free

deb http://security.debian.org/debian-security buster/updates main contrib
deb-src http://security.debian.org/debian-security buster/updates main contrib

Installed just fine after fix


I would note that my install came from amd64 asl iso.


On 2/14/2021 6:13 PM, Steve N4IRS wrote:
<https://packages.debian.org/buster/net-tools>

On 2/14/21 6:04 PM, Mike KB8JNM wrote:

So, on a new attempt,

After : ./buster

E: Package 'net-tools' has no installation candidate

On 2/14/2021 3:18 PM, Mike KB8JNM wrote:

The following packages have been kept back:
  openssh-client openssh-server openssh-sftp-server ssh
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

On 2/14/2021 3:17 PM, Mike KB8JNM wrote:

Originally, it left me with 9

I installed them manually, all but 3

ssh client and server and one other network package.

On 2/14/2021 3:16 PM, Steve N4IRS wrote:
are you saying that apt upgrade does not install updates?

On 2/14/21 3:14 PM, Mike KB8JNM wrote:

That is where it takes system updates but can not install them all.

I'm pretty sure that is what the other fella was having a issue with but can't speak to that if it was not buster

On 2/14/2021 3:12 PM, Steve N4IRS wrote:
OK,
step one:
Make sure your existing system is up to date.
apt update
apt upgrade

What is wrong there?

On 2/14/21 3:10 PM, Mike KB8JNM wrote:

No, back up a step, I talking system.

apt update

apt apgrade

On 2/14/2021 3:08 PM, Steve N4IRS wrote:
That script is the first step. It adds the buster repo.

On 2/14/21 3:06 PM, Mike KB8JNM wrote:

The issue was not with the install script.

Never got that far.

The issue was updated repository's that are broken.

On 2/14/2021 3:05 PM, Steve N4IRS wrote:
This is the buster script:

#!/usr/bin/env bash
set -o errexit

# N4IRS 10/25/2020

#################################################
#                                               #
#    Add DVSwitch Repository and gpg key        #
#                                               #
#################################################

if [[ $(/usr/bin/id -u) -ne 0 ]]; then
    echo "Not running as root"
    echo "either run as root or with sudo"
    exit
fi

distribution=buster

# INSTALL gnupg needed for gpg.key
[ ! -x "/usr/bin/gpg" ] && apt-get install gnupg -y

# Add the backport repository, if needed to install monit
if [ $(apt-cache policy monit | grep -c "Candidate: (none)") -eq 1 ] ; then
        # add repository
        printf "%s\n" "deb http://ftp.de.debian.org/debian buster-backports main" | tee /etc/apt/sources.list.d/buster-backports.list
fi

# INSTALL netstat needed by dvswitch.sh
[ ! -x "/bin/netstat" ] && apt-get install net-tools -y

# Check for rc.local and create if not found.
FILE="/etc/rc.local"
        if [ ! -f "$FILE" ] ; then
        echo '#!/bin/sh -e' > $FILE
        echo '' >> $FILE
        echo 'exit 0' >> $FILE
       chmod +x $FILE
        fi

# Are the repos installed
# Should this test for buster too?
if [ -f /etc/apt/sources.list.d/dvswitch.list ]
then
    echo "The Repository file already exists, exiting"
    exit 0
fi

# Install the key and add the repo
wget -O - http://dvswitch.org/DVSwitch_Repository/dvswitch.gpg.key | apt-key add -
echo "# Official DVSwitch repository" >/etc/apt/sources.list.d/dvswitch.list
echo "deb http://dvswitch.org/DVSwitch_Repository $distribution hamradio" >>/etc/apt/sources.list.d/dvswitch.list
echo "#" >>/etc/apt/sources.list.d/dvswitch.list

apt-get update

# print the installed repositories
echo "Installed repositories:"
apt-cache policy | grep http | awk '{print $2 $3}' | sort -u

I don't see any way it would install a pointer to http://dvswitch.org/ASL_Repository stretch


On 2/14/21 3:00 PM, Mike KB8JNM wrote:

I have the same issue with Buster

I was able to manually update packages until ssh-client/server and one other related

Stopped till I have time to fool with it again.

On 2/14/2021 2:48 PM, Steve N4IRS wrote:
I assume you mean this:

wget http://dvswitch.org/buster
sudo chmod +x buster
sudo ./buster
sudo apt-get update
sudo apt-get install dvswitch-server

The buster script would have either added the buster repository or told you that it was already installed.

Check /etc/apt/sources.list.d/allstarlink.list

deb http://dvswitch.org/DVSwitch_Repository buster hamradio

Then:
apt-get update
apt-get install dvswitch-server


Steve N4IRS



On 2/14/21 2:40 PM, David - W9DWH/4 via groups.io wrote:
http://dvswitch.org/DVSwitch_install.pdf







661 - 680 of 9215