Date   

Re: HBLink Parrot Settings

Cort N0MJS <n0mjs@...>
 

Maybe you could send your configuration files and I could check them.


On Mar 18, 2018, at 12:56 PM, kbluetkemeier via Groups.Io <kbluetkemeier@...> wrote:

[Edited Message Follows]

Today I try it, but its killed :-(


root@Pi:~/HBlink# ./hb_confbridge.py
DEBUG 2018-03-18 18:58:50,896 Logging system started, anything from here on gets logged
INFO 2018-03-18 18:58:50,897 ID ALIAS MAPPER: 'peer_ids.csv' is current, not downloaded
INFO 2018-03-18 18:58:50,898 ID ALIAS MAPPER: 'subscriber_ids.csv' is current, not downloaded
INFO 2018-03-18 18:58:50,899 ID ALIAS MAPPER: peer_ids dictionary is available
INFO 2018-03-18 18:58:51,781 ID ALIAS MAPPER: subscriber_ids dictionary is available
INFO 2018-03-18 18:58:51,784 ID ALIAS MAPPER: talkgroup_ids dictionary is available
INFO 2018-03-18 18:58:51,786 Routing bridges file found and bridges imported
INFO 2018-03-18 18:58:51,787 ACL file found, importing entries. This will take about 1.5 seconds per 1 million IDs
Killed


maybe you can write step by step ?
How i activate the Parrot in the cofig? I find only the way to start the hb_parrot.py but when I defined two Master on the hblink.cfg and I start the confbridge.py or hblink.py he say the ports a used (its correct!)

thank you
Do1KBL, Kim


Re: HBLink Parrot Settings

Kim-Benjamin Lütkemeier
 
Edited

Today I try it, but its killed :-(


root@Pi:~/HBlink# ./hb_confbridge.py
DEBUG 2018-03-18 18:58:50,896 Logging system started, anything from here on gets logged
INFO 2018-03-18 18:58:50,897 ID ALIAS MAPPER: 'peer_ids.csv' is current, not downloaded
INFO 2018-03-18 18:58:50,898 ID ALIAS MAPPER: 'subscriber_ids.csv' is current, not downloaded
INFO 2018-03-18 18:58:50,899 ID ALIAS MAPPER: peer_ids dictionary is available
INFO 2018-03-18 18:58:51,781 ID ALIAS MAPPER: subscriber_ids dictionary is available
INFO 2018-03-18 18:58:51,784 ID ALIAS MAPPER: talkgroup_ids dictionary is available
INFO 2018-03-18 18:58:51,786 Routing bridges file found and bridges imported
INFO 2018-03-18 18:58:51,787 ACL file found, importing entries. This will take about 1.5 seconds per 1 million IDs
Killed


maybe you can write step by step ?
How i activate the Parrot in the cofig? I find only the way to start the hb_parrot.py but when I defined two Master on the hblink.cfg and I start the confbridge.py or hblink.py he say the ports a used (its correct!)

thank you
Do1KBL, Kim


Re: HBLink Parrot Settings

Cort N0MJS <n0mjs@...>
 

I think you bay be confused about how the pieces work.

If you’re running confbridge.py and hb_parrot.py, there is no need to run hblink.py on it’s own. 

On Mar 17, 2018, at 1:45 PM, kbluetkemeier via Groups.Io <kbluetkemeier@...> wrote:

I test today but I have no funktion

I Create one Master (Globale Master) here are connecting the MMDVM Hotspots Port 54000 (Start hblink.py)
Than I Create a snd Master (Parrot Master) with the port 54004 (start: hb_parrot.py)

On the first globale Master hblink.cfg I have two client

client-1 connect to the Gloable Master
client-2 connect to the Parrot Master

on the hb_confbridge_rules i write:

BRIDGES = {
    'HBlink': [
            {'SYSTEM': 'client-1',       'TS': 2, 'TGID': 9990, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': 'NONE', 'ON': [], 'OFF': []},
            {'SYSTEM': 'client-2',       'TS': 2, 'TGID': 9990, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': 'NONE', 'ON': [], 'OFF': []},
        ]
}

I start the hb_confbridge.py he write me over one million he need 1.5 seconds an thats all.

But no communication between Globale Master and Parrot Master :-(



--
Cort Buffington
H: +1-785-813-1501
M: +1-785-865-7206






Re: HBLink Parrot Settings

Kim-Benjamin Lütkemeier
 

I test today but I have no funktion

I Create one Master (Globale Master) here are connecting the MMDVM Hotspots Port 54000 (Start hblink.py)
Than I Create a snd Master (Parrot Master) with the port 54004 (start: hb_parrot.py)

On the first globale Master hblink.cfg I have two client

client-1 connect to the Gloable Master
client-2 connect to the Parrot Master

on the hb_confbridge_rules i write:

BRIDGES = {
    'HBlink': [
            {'SYSTEM': 'client-1',       'TS': 2, 'TGID': 9990, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': 'NONE', 'ON': [], 'OFF': []},
            {'SYSTEM': 'client-2',       'TS': 2, 'TGID': 9990, 'ACTIVE': True, 'TIMEOUT': 2, 'TO_TYPE': 'NONE', 'ON': [], 'OFF': []},
        ]
}

I start the hb_confbridge.py he write me over one million he need 1.5 seconds an thats all.

But no communication between Globale Master and Parrot Master :-(



HBLink Parrot Settings

Kim-Benjamin Lütkemeier
 

Hello,
I have one Question. How i can configurate a HBLink master with Parrot in TG9990

I start hb_parrot.py and he repeat everythink.

Normal I have the Master on hblink.cfg on this master my frinds are connected with DVMega or openspot. its working without problem.
Now i will activate the Parrot in this network. When he made a group call to 9990 the Parrot will repeat. On all other groups he do nothing.

But I dont understand how i can made it.

Anyone can help me?

73,
Do1KBL


dmr_utils update

Cort N0MJS <n0mjs@...>
 

Folks,

DMR-MARC is changing their database API to only support json format. To this point, dmr_utils has used csv. The next update I push to dmr_utils will be a fix for this. I’m testing it now, expect the push in the next couple of days.

Cort Buffington
785-865-7206


Re: NEW to HBlink and python

Steve N4IRS
 

No, the parrot is not installed by default, you will have to configure it. See the config for your options on how to run it.

Steve

On 3/16/2018 9:28 AM, Guillaume Larouche wrote:
Problem was VPS issue...a put new image of debian jessy and all is running now...

Time to play with HBlink

STeve, is the parrot is running per default?  in the csv it look like to be set on TG 9998, an not private call...it is the case ?


Re: NEW to HBlink and python

Guillaume Larouche
 

Problem was VPS issue...a put new image of debian jessy and all is running now...

Time to play with HBlink

STeve, is the parrot is running per default?  in the csv it look like to be set on TG 9998, an not private call...it is the case ?


Re: NEW to HBlink and python

Guillaume Larouche
 

On Tue, Mar 13, 2018 at 06:22 pm, Steve N4IRS wrote:
I suggest you check your DNS (ping http://pypi.python.org

Hi Steve, sorry for the delay,

I juste cheked on my VPS and for an unknow reason...the VPS can't reach pyton.org.  VPS is in a big data center... will check and let you know.

I will try locally on a RPI .

Thank for your help


Re: ASL>DStar noise problem

Steve N4IRS
 

Cool,
Sorry for the initial misinformation. I should have gone back and revised that. I know that making DummyRepeater run headless etc is a pain. We will be replacing it with a MUCH simpler solution. Mike and I are discussing it at least once a day.

Steve

On 3/15/2018 9:12 AM, G7RPG - Peter Kendall wrote:

BINGO!

That fixed it, thanks Steve.

Its running under ESX and added an 'HD audio' device.

73
Peter


On 15/03/18 12:56, Steve N4IRS wrote:
OK, I may have to go back and find that message and edit it. DO you have a real sound device available in those pulldowns? If so select it. If not, can you add a simple sound device like a CM1xx and select it?

Steve

On 3/15/2018 8:53 AM, G7RPG - Peter Kendall wrote:

Hi Steve,

Yes, followed your instructions from a previous post.

Peter


On 15/03/18 12:47, Steve N4IRS wrote:
Peter,
I'm pulling this off the top of my head. Do you have the sound device in Dummy Repeater using snd-dummy?

73, Steve

On 3/15/2018 7:59 AM, G7RPG - Peter Kendall wrote:
Hi All,

I've got my Allstar node connected to DStar (DCS005E) using the dvswitch
modified version of dummy repeater.

All seems to be working well apart from a digital burst of noise that is
heard on DStar at the end of a transmission coming from ASL.

I've recorded an example here: https://www.youtube.com/watch?v=APkGjoLxKPk

I wonder if anyone has any suggestions or has come across this before?

73
Peter
G7RPG














Re: ASL>DStar noise problem

G7RPG - Peter Kendall
 

BINGO!

That fixed it, thanks Steve.

Its running under ESX and added an 'HD audio' device.

73
Peter


On 15/03/18 12:56, Steve N4IRS wrote:
OK, I may have to go back and find that message and edit it. DO you have a real sound device available in those pulldowns? If so select it. If not, can you add a simple sound device like a CM1xx and select it?

Steve

On 3/15/2018 8:53 AM, G7RPG - Peter Kendall wrote:

Hi Steve,

Yes, followed your instructions from a previous post.

Peter


On 15/03/18 12:47, Steve N4IRS wrote:
Peter,
I'm pulling this off the top of my head. Do you have the sound device in Dummy Repeater using snd-dummy?

73, Steve

On 3/15/2018 7:59 AM, G7RPG - Peter Kendall wrote:
Hi All,

I've got my Allstar node connected to DStar (DCS005E) using the dvswitch
modified version of dummy repeater.

All seems to be working well apart from a digital burst of noise that is
heard on DStar at the end of a transmission coming from ASL.

I've recorded an example here: https://www.youtube.com/watch?v=APkGjoLxKPk

I wonder if anyone has any suggestions or has come across this before?

73
Peter
G7RPG













Re: ASL>DStar noise problem

G7RPG - Peter Kendall
 

OK - I'll give that a try and report back.


On 15/03/18 12:56, Steve N4IRS wrote:
OK, I may have to go back and find that message and edit it. DO you have a real sound device available in those pulldowns? If so select it. If not, can you add a simple sound device like a CM1xx and select it?

Steve

On 3/15/2018 8:53 AM, G7RPG - Peter Kendall wrote:

Hi Steve,

Yes, followed your instructions from a previous post.

Peter


On 15/03/18 12:47, Steve N4IRS wrote:
Peter,
I'm pulling this off the top of my head. Do you have the sound device in Dummy Repeater using snd-dummy?

73, Steve

On 3/15/2018 7:59 AM, G7RPG - Peter Kendall wrote:
Hi All,

I've got my Allstar node connected to DStar (DCS005E) using the dvswitch
modified version of dummy repeater.

All seems to be working well apart from a digital burst of noise that is
heard on DStar at the end of a transmission coming from ASL.

I've recorded an example here: https://www.youtube.com/watch?v=APkGjoLxKPk

I wonder if anyone has any suggestions or has come across this before?

73
Peter
G7RPG













Re: ASL>DStar noise problem

Steve N4IRS
 

OK, I may have to go back and find that message and edit it. DO you have a real sound device available in those pulldowns? If so select it. If not, can you add a simple sound device like a CM1xx and select it?

Steve

On 3/15/2018 8:53 AM, G7RPG - Peter Kendall wrote:

Hi Steve,

Yes, followed your instructions from a previous post.

Peter


On 15/03/18 12:47, Steve N4IRS wrote:
Peter,
I'm pulling this off the top of my head. Do you have the sound device in Dummy Repeater using snd-dummy?

73, Steve

On 3/15/2018 7:59 AM, G7RPG - Peter Kendall wrote:
Hi All,

I've got my Allstar node connected to DStar (DCS005E) using the dvswitch
modified version of dummy repeater.

All seems to be working well apart from a digital burst of noise that is
heard on DStar at the end of a transmission coming from ASL.

I've recorded an example here: https://www.youtube.com/watch?v=APkGjoLxKPk

I wonder if anyone has any suggestions or has come across this before?

73
Peter
G7RPG












Re: ASL>DStar noise problem

G7RPG - Peter Kendall
 

Hi Steve,

Yes, followed your instructions from a previous post.

Peter


On 15/03/18 12:47, Steve N4IRS wrote:
Peter,
I'm pulling this off the top of my head. Do you have the sound device in Dummy Repeater using snd-dummy?

73, Steve

On 3/15/2018 7:59 AM, G7RPG - Peter Kendall wrote:
Hi All,

I've got my Allstar node connected to DStar (DCS005E) using the dvswitch
modified version of dummy repeater.

All seems to be working well apart from a digital burst of noise that is
heard on DStar at the end of a transmission coming from ASL.

I've recorded an example here: https://www.youtube.com/watch?v=APkGjoLxKPk

I wonder if anyone has any suggestions or has come across this before?

73
Peter
G7RPG











Re: ASL>DStar noise problem

Steve N4IRS
 

Peter,
I'm pulling this off the top of my head. Do you have the sound device in Dummy Repeater using snd-dummy?

73, Steve

On 3/15/2018 7:59 AM, G7RPG - Peter Kendall wrote:
Hi All,

I've got my Allstar node connected to DStar (DCS005E) using the dvswitch
modified version of dummy repeater.

All seems to be working well apart from a digital burst of noise that is
heard on DStar at the end of a transmission coming from ASL.

I've recorded an example here: https://www.youtube.com/watch?v=APkGjoLxKPk

I wonder if anyone has any suggestions or has come across this before?

73
Peter
G7RPG



ASL>DStar noise problem

G7RPG - Peter Kendall
 

Hi All,

I've got my Allstar node connected to DStar (DCS005E) using the dvswitch
modified version of dummy repeater.

All seems to be working well apart from a digital burst of noise that is
heard on DStar at the end of a transmission coming from ASL.

I've recorded an example here: https://www.youtube.com/watch?v=APkGjoLxKPk

I wonder if anyone has any suggestions or has come across this before?

73
Peter
G7RPG


Re: NEW to HBlink and python

Steve N4IRS
 

Guillaume,
I just ran the install.sh script on Raspbian Stretch without error. I suggest you check your DNS (ping http://pypi.python.org) I would also make sure your other packages are up to date. (apt-get update ; apt-get upgrade)
Both suggestions are rather simplistic. Maybe someone else can weigh in.

73, Steve N4IRS

On 03/13/2018 09:07 PM, Guillaume Larouche wrote:
Hi steve,

i got this error trying to install dmr_utils 

Downloading/unpacking bitarray (from dmr-utils==0.1.8)
  Cannot fetch index base URL http://pypi.python.org/simple/
  Could not find any downloads that satisfy the requirement bitarray (from dmr-utils==0.1.8)
No distributions at all found for bitarray (from dmr-utils==0.1.8)
Storing complete log in /root/.pip/pip.log


Guillaume


Re: NEW to HBlink and python

Guillaume Larouche
 

Hi steve,

i got this error trying to install dmr_utils 

Downloading/unpacking bitarray (from dmr-utils==0.1.8)
  Cannot fetch index base URL http://pypi.python.org/simple/
  Could not find any downloads that satisfy the requirement bitarray (from dmr-utils==0.1.8)
No distributions at all found for bitarray (from dmr-utils==0.1.8)
Storing complete log in /root/.pip/pip.log


Guillaume


Re: NEW to HBlink and python

Steve N4IRS
 

Make sure you also installed dmr_utils https://github.com/n0mjs710/dmr_utils
Run the install.sh script.

73, Steve N4IRS


NEW to HBlink and python

Guillaume Larouche
 

Hello group,

i am quite active in dmr and a want to explore HBlink but my skill are limited in Python use..

I run python 2.7 in raspbian and also on a debian machine and on each one when i try to load hblink.py i got this :

Traceback (most recent call last):
  File "./hblink.py", line 38, in <module>
    from bitstring import BitArray
ImportError: No module named bitstring
root@vps174118:/HBlink#


I try to install python-bitarray with no luck...

Newbies need your help please :)

Guillaume

9001 - 9020 of 9882