Date   

Re: Cannot connect to DVswitch - Android 11 - cannot see back chevron from Accounts

Steve N4IRS
 

Davis,
Sorry I was looking at the actual menu, not the rest of the Android screen.
swipe right below the choices to return to the dialer screen.

Steve

On 3/20/21 6:33 AM, David J Taylor via groups.io wrote:
On 20/03/2021 10:09, Steve N4IRS wrote:
David,
I see no difference between your Accounts tab and mine. What am I not
seeing?

Steve N4IRS
Steve,

I'm missing the three icons at the bottom of the screen (from the User Guide), the three vertical lines, the rounded rectangle, and the left-facing chevron.  These look like an earlier version of Android.

I'm just trying to follow the instructions which state:

  "Save and return to the Dialer screen by pressing the back arrow (<) button." -

73,
David GM8ARV


Re: Cannot connect to DVswitch - Android 11 - cannot see back chevron from Accounts

David J Taylor
 

On 20/03/2021 10:09, Steve N4IRS wrote:
David,
I see no difference between your Accounts tab and mine. What am I not
seeing?
Steve N4IRS
Steve,

I'm missing the three icons at the bottom of the screen (from the User Guide), the three vertical lines, the rounded rectangle, and the left-facing chevron. These look like an earlier version of Android.

I'm just trying to follow the instructions which state:

"Save and return to the Dialer screen by pressing the back arrow (<) button." -

73,
David GM8ARV
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@blueyonder.co.uk
Twitter: @gm8arv


Re: Cannot connect to DVswitch - Android 11 - cannot see back chevron from Accounts

Steve N4IRS
 

David,
I see no difference between your Accounts tab and mine. What am I not seeing?

Steve N4IRS

On 3/20/21 6:04 AM, David J Taylor via groups.io wrote:
On 20/03/2021 08:24, Ernie Gm7kbk wrote:
Very bottom right of your android phone. The symbol looks like <
Thanks, Ernie.  I know what the symbol looks like, and there is a screen-shot in the User Guide showing its location, but it is not present on my phone as you can see from my screen-shot.

Google Pixel 5, OS: Android 11, update 05-Mar-2021.

Cheers,
David


Re: Cannot connect to DVswitch - Android 11 - cannot see back chevron from Accounts

David J Taylor
 

On 20/03/2021 08:24, Ernie Gm7kbk wrote:
Very bottom right of your android phone. The symbol looks like <
Thanks, Ernie. I know what the symbol looks like, and there is a screen-shot in the User Guide showing its location, but it is not present on my phone as you can see from my screen-shot.

Google Pixel 5, OS: Android 11, update 05-Mar-2021.

Cheers,
David
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@blueyonder.co.uk
Twitter: @gm8arv


Re: Cannot connect to DVswitch - Android 11 - cannot see back chevron from Accounts

 

Very bottom right of your android phone. The symbol looks like <


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of David J Taylor via groups.io <david-taylor@...>
Sent: Saturday, March 20, 2021 8:10:59 AM
To: main@DVSwitch.groups.io <main@DVSwitch.groups.io>
Subject: Re: [DVSwitch] Cannot connect to DVswitch - Android 11 - cannot see back chevron from Accounts
 
Phone now connecting after DMR frequencies issue corrected.  Missing
chevron still missing, though.

David
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@...
Twitter: @gm8arv






Re: Cannot connect to DVswitch - Android 11 - cannot see back chevron from Accounts

David J Taylor
 

Phone now connecting after DMR frequencies issue corrected. Missing chevron still missing, though.

David
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@blueyonder.co.uk
Twitter: @gm8arv


Re: Brandmeister UK connection lost?

David J Taylor
 

On 19/03/2021 17:26, Steve N4IRS wrote:
Your HS ID is what is used to login to BM. Make sure the frequencies in
the info section are simplex not split.
[Info]
RXFrequency=224940000
TXFrequency=224940000
On 19/03/2021 17:52, Corey Dean N3FE wrote:
Have you made that if you are running dmo that you have both
frequencies the same as discussed in other emails?

Steve, Corey, thanks, both. Yes, that was the issue. As there's no RF in my DVSwitch I hadn't appreciated that there would even be any frequencies involved in my configuration. Sorry I mentally mis-filed the earlier [Special] posting. Perhaps the midnight UTC stop /might/ have been a clue.

David GM8ARV
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@blueyonder.co.uk
Twitter: @gm8arv


Re: Brandmeister UK connection lost?

Corey Dean N3FE
 

Have you made that if you are running dmo that you have both frequencies the same as discussed in other emails?

On Mar 19, 2021, at 1:20 PM, David J Taylor via groups.io <david-taylor=blueyonder.co.uk@groups.io> wrote:

On 19/03/2021 16:53, Steve N4IRS wrote:
Check /opt/MMDVM_Bridge/MMDVM_Bridge.ini for plain text password.
Thanks, Steve. That looks OK:

~~~~~~~~~~~~~~~~~~~~~~~~~
Enable=1
Address=51.68.220.36
Port=62031
Jitter=360
Local=62032
Password=************
# for DMR+ see https://github.com/DVSwitch/MMDVM_Bridge/blob/master/DOC/DMRplus$
# for XLX the syntax is: Options=XLX:4009
# Options=
Slot1=0
Slot2=1
~~~~~~~~~~~~~~~~~~~~~~~~~

What looks strange to me is the ID:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[General]
Callsign=GM8ARV
Id=235410106
Timeout=180
Duplex=0
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

My ID doesn't have the 06 at the end, that's the hotspot ID. In fact, I can't find my plain ID anywhere?

73,
David GM8ARV
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@blueyonder.co.uk
Twitter: @gm8arv



Re: Brandmeister UK connection lost?

Steve N4IRS
 

Your HS ID is what is used to login to BM. Make sure the frequencies in the info section are simplex not split.


[Info]
RXFrequency=224940000
TXFrequency=224940000

On 3/19/2021 1:18 PM, David J Taylor via groups.io wrote:
On 19/03/2021 16:53, Steve N4IRS wrote:
Check /opt/MMDVM_Bridge/MMDVM_Bridge.ini for plain text password.
Thanks, Steve.  That looks OK:

~~~~~~~~~~~~~~~~~~~~~~~~~
Enable=1
Address=51.68.220.36
Port=62031
Jitter=360
Local=62032
Password=************
# for DMR+ see https://github.com/DVSwitch/MMDVM_Bridge/blob/master/DOC/DMRplus$
# for XLX the syntax is: Options=XLX:4009
# Options=
Slot1=0
Slot2=1
~~~~~~~~~~~~~~~~~~~~~~~~~

What looks strange to me is the ID:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[General]
Callsign=GM8ARV
Id=235410106
Timeout=180
Duplex=0
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

My ID doesn't have the 06 at the end, that's the hotspot ID.  In fact, I can't find my plain ID anywhere?

73,
David GM8ARV


Re: Brandmeister UK connection lost?

David J Taylor
 

On 19/03/2021 16:53, Steve N4IRS wrote:
Check /opt/MMDVM_Bridge/MMDVM_Bridge.ini for plain text password.
Thanks, Steve. That looks OK:

~~~~~~~~~~~~~~~~~~~~~~~~~
Enable=1
Address=51.68.220.36
Port=62031
Jitter=360
Local=62032
Password=************
# for DMR+ see https://github.com/DVSwitch/MMDVM_Bridge/blob/master/DOC/DMRplus$
# for XLX the syntax is: Options=XLX:4009
# Options=
Slot1=0
Slot2=1
~~~~~~~~~~~~~~~~~~~~~~~~~

What looks strange to me is the ID:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[General]
Callsign=GM8ARV
Id=235410106
Timeout=180
Duplex=0
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

My ID doesn't have the 06 at the end, that's the hotspot ID. In fact, I can't find my plain ID anywhere?

73,
David GM8ARV
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@blueyonder.co.uk
Twitter: @gm8arv


Re: Brandmeister UK connection lost?

Steve N4IRS
 

Check /opt/MMDVM_Bridge/MMDVM_Bridge.ini for plain text password.

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of David J Taylor via groups.io <david-taylor@...>
Sent: Friday, March 19, 2021 12:48:45 PM
To: DVSwitch groups.io <DVSwitch@groups.io>
Subject: [DVSwitch] Brandmeister UK connection lost?
 
I presume it's just me, but after 23:29 UTC last night my DVSwitch
appears not to connect to Brandmeister.  The status display shows: DMR
Master: Not Connected, but the Networks panel shows DMR Net in Green.

I've used the update option, checked that the personal DMR password is
correct (although it would be nice to see that in plain text in a file
somewhere), and I'm assuming that the IP for Brandmeister UK hasn't
changed (two other hotspots still connect correctly).  The RPT ID is
correct with the correct two digit suffix.

Unsure how to go about diagnosing this...

Thanks,
David
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@...
Twitter: @gm8arv






Brandmeister UK connection lost?

David J Taylor
 

I presume it's just me, but after 23:29 UTC last night my DVSwitch appears not to connect to Brandmeister. The status display shows: DMR Master: Not Connected, but the Networks panel shows DMR Net in Green.

I've used the update option, checked that the personal DMR password is correct (although it would be nice to see that in plain text in a file somewhere), and I'm assuming that the IP for Brandmeister UK hasn't changed (two other hotspots still connect correctly). The RPT ID is correct with the correct two digit suffix.

Unsure how to go about diagnosing this...

Thanks,
David
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@blueyonder.co.uk
Twitter: @gm8arv


Cannot connect to DVswitch - Android 11 - cannot see back chevron from Accounts

David J Taylor
 

It's been a day of issue!

This sounds like a silly question to me, but I can't connect to my DVswitch server from my Android 11 phone. The instructions point to a left-facing chevron at the bottom of the accounts screen, but I don't have that (most recent app installed).

So when I go back to the Dialler screen, there's nothing in the top entry box (except "Unregistered") and no way for me to connect to my server. I can connect from the PC app.

What might I be missing?

Thanks,
David GM8ARV
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@blueyonder.co.uk
Twitter: @gm8arv


Re: Analog_Reflector VPS

Steve N4IRS
 

Peter,
From what I see, you are not going to want to tune or steer either side of the bridge. What I mean is that your bridge will always be connected to TG 31085 and AllStar 45479.
So this is how it lays out:
Right now you have:
AllStar <-> Analog_Bridge
This is how it's going to look:
AllStar <-> Analog_Reflector <-> Analog_Bridge

So,
apt update
apt upgrade
If any updates applied, reboot
Verify all is still working
Stop Analog_Bridge and AllStar
apt install analog-reflector
edit Analog_Bridge.ini (I would back it up first)
[USRP]
txPort = 31001                          ; Transmit USRP to Analog_Reflector
rxPort = 31001                          ; Listen for USRP frames from Analog_Reflector

cd /opt/Analog_Reflector
edit Analog_Reflector.json (I would back it up first)
{
  "nodeName":"DVSwitch",
  "dmrID":"1234567",
  "abAddress": "127.0.0.1",
  "usrpTxPort": "31001",
  "usrpRxPort": "31001",
  "mobilePort": "12345",
  "wsPort": "443",
  "keyDir": "./ssl/",
  "siteroot": "./arRoot",
  "logFileName": "/var/log/dvswitch/Analog_Reflector.log",
  "logLevel": "2",
  "disallowUnknownClients": false,
  "brokerURL": "mqtt://localhost:1883",
  "rightsMask": "4",
  "autoMute": true,
  "clientDebugMode": false,
  "clientModes": ["Intercom", "DMR", "STFU", "DSTAR|D-Star", "NXDN", "P25", "YSF", "ASL|AllStar"],
  "bridges": {
    "asl": [
      {"node" : "1999", "address" : "127.0.0.1", "rxPort" : "34001", "txPort" : "32001", "rights" : 3, "amiUserName" : "admin", "amiSecret" : "llcgi"}
    ],
    "ab" : [
      {"name" : "DMR",    "address" : "127.0.0.1", "rxPort" : "51100", "txPort" : "51103", "rights" : 1},
      {"name" : "D-Star", "address" : "127.0.0.1", "rxPort" : "52100", "txPort" : "52103", "rights" : 1},
      {"name" : "NXDN",   "address" : "127.0.0.1", "rxPort" : "53100", "txPort" : "53103", "rights" : 1},
      {"name" : "P25",    "address" : "127.0.0.1", "rxPort" : "54100", "txPort" : "54103", "rights" : 1},
      {"name" : "YSF",    "address" : "127.0.0.1", "rxPort" : "55100", "txPort" : "55103", "rights" : 1}
    ]
  }
}

I have bolded the things you want to edit You should not have to edit anything else.
You should know the values you want to replace Node number, DMR ID etc.
Change "autoMute": true, to "autoMute": false,

There are minimum changes you need to make. Once you have things working, you can tweak this to better reflect you system.

cd /opt/Analog_Reflector
./Analog_Reflector user YourCallSign YourDMRID YourDMRID+SSID YourSecretPassword 11
Mine would look like this:
./Analog_Reflector user N4IRS 3112138 311213899 BigSecret 11

cd /opt/Analog_Reflector/ssl
./mkcerts.sh

If you have any errors along the way, stop and ask.
cd /opt/Analog_Reflector
./Analog_Reflector -f Analog_Reflector.json

See any bad words? errors? OK, good.
Control C
systemctl start analog_reflector
You should now be able to point a web browser at https://InternetVail.Dyndns.org
Login with your callsign and password.


Steve N4IRS
   

On 3/18/2021 9:51 AM, Peter Buckley via groups.io wrote:
Yes, Steve - trying to add Analog_Reflector to working Allstar 45479 <----> DMR Gateway  BM/TG 31085

Browser page for Gateway Here:     http://InternetVail.Dyndns.org:8888

-pete


Re: Cloud based Dstar Ambe Server Audio Quality

Tom Corcoran
 

Hello Ken,

were you using client (pyUC/DVSM/hUC) from home or remote?
--
Tom VE3NY


Re: DTMF

 

Bravo. Will be welcomed for the
MMDVM FMGateway that Jonathan just released.
It is using USRP interface to ASL

Richard
VE2DJE

Le jeu. 18 mars 2021 8 h 51 a.m., Danny Lloyd <danny@...> a écrit :
I am testing changes to chan_usrp to allow it to decode dtmf.  The results are good.  I will get a pull request out soon.

Danny/KB4MDD


Re: Analog_Reflector VPS

Peter Buckley
 

Yes, Steve - trying to add Analog_Reflector to working Allstar 45479 <----> DMR Gateway  BM/TG 31085

Browser page for Gateway Here:     http://InternetVail.Dyndns.org:8888

-pete


Re: DTMF

Danny Lloyd
 

I am testing changes to chan_usrp to allow it to decode dtmf.  The results are good.  I will get a pull request out soon.

Danny/KB4MDD


Re: PLease suggest a place to ask about DMR packet structures

Randy AA6RH
 

Check out the OpenDV groups.io forum. Johnathan Naylor, who wrote MMDVM is on that forum and similar questions have been posed there. He's fairly well versed on DMR specs, though I don't know the extent to which he has experience with Hytera.

--R
--
Randy Hall AA6RH (not K7AGE, quit asking) 😁


Re: Cloud based Dstar Ambe Server Audio Quality

Ken, K6EFJ
 

Version 1.3
I just did a test pointing the Rpi 3 Dvswitch server (on fiber to home) to the internal ip # of Zum Ambe Server. Dstar was crytal clear. Thinking maybe UDP packet loss.

901 - 920 of 9795