Date   

Re: All-star to dmr bridge #analog_bridge

Komkit Listisard
 

Roger, have you try making TXFrequency and RXFrequency the same without an offset?

73, Kit


Re: I'm stumped....

Roger Davies
 

Thanks Jorge. Made a difference.
Here's what I get when I run systemsctl start stfu (lowcase):

dvswitch@dvswitch-server:~ $ systemctl start stfu
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to start 'stfu.service'.
Authenticating as: ,,, (dvswitch)
Password:
==== AUTHENTICATION COMPLETE ===

Does this look right? Do I need to enter my password to run it?
Also, after running it, the mode changes right back to DMR when I choose STFU mode.
I think I'm getting closer.....


Re: I'm stumped....

Jorge (George)
 

systemsctl start stfu (lowcase)


Re: I'm stumped....

Roger Davies
 

Hi Steve,
Thanks for you patience. I appreciate your help. Thought I'd give this a go on my own to learn.
I've been trying to get STFU to work, but I must be missing something. When I select STFU as a mode, it changes right back to DMR.
Here what I've done so far:
1. Ran apt update and apt install stfu
2. Edited  DVSwitch.ini STFU section:
[STFU]                          ; Brandmeister Open DMR Terminal (ODMRT) Protocol
BMAddress = 3102.repeater.net   ; Brandmeister ODMRT server address
BMPort = 54006                  ; Brandmeister ODMRT port
BMPassword = XXXXX       ; Your Brandmeister password
Address = 127.0.0.1             ; Address to send AMBE TLV frames to (export)
txPort  = 36100                 ; Port to send AMBE TLV frames to (export)
rxPort  = 36103                 ; Port to listen on (import)
UserID  = 3149001             ; Your DMR ID + SSID (I did not add SSID)
TalkerAlias = N0CALL Name City  ; Max 27 characters
StartTG = 3149                  ; Startup talk group
LogLevel = 3                    ; STFU log level (0=No logging, 1=Debug, 2=Message, 3=Info, 4=Warning, 5=Error)

3. Here is my STFU.log:
I: 2021-08-23 19:06:55.733 STFU is starting
I: 2021-08-23 19:06:55.734 Connecting to STFU server at address: 3102.repeater.net:54006
I: 2021-08-23 19:06:56.009 Successful connection to BM server at ip address:
I: 2021-08-23 19:18:20.166 Signal 15 received, exiting STFU
I: 2021-08-23 19:18:20.166 exitApp
M: 2021-08-23 19:18:26.263 DMR, Setting [STFU] BMAddress -> 3102.repeater.net
M: 2021-08-23 19:18:26.264 DMR, Setting [STFU] BMPort -> 54006
M: 2021-08-23 19:18:26.264 DMR, Setting [STFU] BMPassword -> XXXXXX
M: 2021-08-23 19:18:26.264 DMR, Setting [STFU] Address -> 127.0.0.1
M: 2021-08-23 19:18:26.264 DMR, Setting [STFU] txPort -> 36100
M: 2021-08-23 19:18:26.264 DMR, Setting [STFU] rxPort -> 36103
M: 2021-08-23 19:18:26.264 DMR, Setting [STFU] UserID -> 3149001
M: 2021-08-23 19:18:26.264 DMR, Setting [STFU] TalkerAlias -> N0CALL Name City (could this be my problem?)
M: 2021-08-23 19:18:26.264 DMR, Setting [STFU] StartTG -> 3149
M: 2021-08-23 19:18:26.264 DMR, Setting [STFU] LogLevel -> 3
I: 2021-08-23 19:18:26.264 STFU Version 0.3.3
I: 2021-08-23 19:18:26.264 Copyright (C) 2021 DVSwitch, INAD.
I: 2021-08-23 19:18:26.264 Created by Mike N4IRR and Steve N4IRS
I: 2021-08-23 19:18:26.264 STFU comes with ABSOLUTELY NO WARRANTY
I: 2021-08-23 19:18:26.264
I: 2021-08-23 19:18:26.264 This software is for use on amateur radio networks only,
I: 2021-08-23 19:18:26.264 it is to be used for educational purposes only. Its use on
I: 2021-08-23 19:18:26.264 commercial networks is strictly prohibited.
I: 2021-08-23 19:18:26.264
I: 2021-08-23 19:18:26.264 STFU is starting
I: 2021-08-23 19:18:26.265 Connecting to STFU server at address: 3102.repeater.net:54006
I: 2021-08-23 19:18:26.525 Successful connection to BM server at ip address:
I: 2021-08-23 19:38:33.164 DMR, ODMR Begin Tx: src = 3149170, dst = 3149 (GROUP)
I: 2021-08-23 19:38:39.740 DMR, ODMR End Tx:DMR frame count was 111 frames
 

3. When I run sudo systemctl start STFU, I get Failed to start STFU.service: Unit STFU.service not found.

Thanks again for your help,
Roger N6DVZ


Re: server hacked

Kevin Halton
 

Yes


Re: I'm stumped....

Robert Rodriguez
 

I had a similar problem connecting to the weekly 3142 net from my ClearNode- tried a Canadian server and could hear them
Ok but couldn’t transmit. I’m not familiar with STFU; would that break the normal operation of the ClearNode?


Re: I'm stumped....

David - W9DWH
 

That's the same name of the file that I used.


Re: I'm stumped....

Roger Davies
 
Edited

David,
What is the name of the log file is the one you posted above?
I looked at MMDVM_Bridge-2021-08-22.log and it looks different.


Re: I'm stumped....

Roger Davies
 

David, 
I was able to connect to the Mexico master. I checked for my info on the master list and I showed up there.
I'll take a look at setting the password again.
Thanks


Re: I'm stumped....

David - W9DWH
 

Well at least they admitted blocking it now where the first time they told me nothing had changed.on their end recently. 

Roger, yes I'm using the same password. You might want to go into your BM selfcare settings and set your password again and then go through the initial setup on DVS again.


Re: I'm stumped....

Steve N4IRS
 

Yes, The password works. Check your MMDVM_Bridge log in /var/log/mmdvm

On 8/22/21 6:56 PM, Roger Davies wrote:
Thanks Steve. I'll take your advice on posting about DVS on Telegram.
I connected to Parrot, using master 3104 and Parrot works. Still no luck on our state TG 3149.
How do I go about using/setup STFU?

David,
I tried the Mexico master and had no luck there. Do you use the same password as you do for BM?
Thanks


Re: I'm stumped....

Roger Davies
 
Edited

Thanks Steve. I'll take your advice on posting about DVS on Telegram.
I connected to Parrot, using master 3104 and Parrot works. Still no luck on our state TG 3149.
How do I go about using/setup STFU?

David,
I tried the Mexico master and had no luck there. Do you use the same password as you do for a US master?
Thanks


Re: I'm stumped....

David - W9DWH
 

Thank you.  I will have to study that as it's the first I've heard of it.  I'm a relative newcomer to DVS.  In the meantime I've got it working again on Mexico's master.  It wouldn't work with Canada's Master either.  I appreciate you figuring out what was going on and offering us some work arounds. 


Re: I'm stumped....

Steve N4IRS
 

STFU is Simple Terminal Feature Update. It is a alternate method of connecting to BM. It can replace MMDVM_Bridge for connecting to BM.

On 8/22/21 6:16 PM, David - W9DWH via groups.io wrote:
I normally know what STFU is but I don't think that's the way you meant it so would you elaborate please?


Re: I'm stumped....

David - W9DWH
 

I normally know what STFU is but I don't think that's the way you meant it so would you elaborate please?


Re: I'm stumped....

Steve N4IRS
 

I really suggest you stop posting on Telegram. You will get no support.


On 8/22/21 5:52 PM, David - W9DWH via groups.io wrote:
3166, 3167 and parrot all work.  Tried 3118 and 3121 again and they do not.


Re: I'm stumped....

Steve N4IRS
 

BM US is blocking the statewide TGs Use a non US server or swap out MMDVM_Bridge for STFU

On 8/22/21 5:52 PM, David - W9DWH via groups.io wrote:
3166, 3167 and parrot all work.  Tried 3118 and 3121 again and they do not.


Re: I'm stumped....

David - W9DWH
 

3166, 3167 and parrot all work.  Tried 3118 and 3121 again and they do not.


Re: server hacked

Steve Siesel [K4KSA]
 

Your hacked server was on Vultr as well?

On Aug 22, 2021, at 5:46 PM, Kevin Halton <Khalton@...> wrote:



Steve, it is on Vultr. Running deb10, seems like I am missing a step or two?

 

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve Siesel [K4KSA]
Sent: Sunday, August 22, 2021 5:10 PM
To: main@dvswitch.groups.io
Subject: Re: [DVSwitch] server hacked

 

What was you pervious host server? I have seen strange activity on Nfoservers..

 

Steve..



On Aug 22, 2021, at 5:06 PM, Kevin Halton <KA1MXL@...> wrote:

Well  what a great day it has been. Woke up this morning and found that my DVS server was hacked over night. I dumped that server and installed a new one on Vultr. I followed the instructions I had used on the prior install and nothing seems to work.

These are the directions I followed 
wget http://dvswitch.org/buster
 sudo chmod +x buster
 sudo ./buster
 sudo apt-get update
 sudo apt-get install dvswitch-server
Once the install is complete, reboot the server.Enter "dvs" (no quotes) in a terminal window to start the dvswitch menu system.

I logged into server and went thru each option. I am using a T320 network radio to connect, which on the surface appears that I do connect. I cannot access dashboard, when I enter commands via radio I get no feedback, I hear no audio.

I have attempted this more times then I can count and end up with the same result. I am 99.99% positive it is "OE" but am stumped.

I have included log files in hope maybe someone sees what I am missing. Any help is greatly appreciated.


<Analog_Bridge.log>

<MMDVM_Bridge-2021-08-22.log>


Re: I'm stumped....

Steve N4IRS
 

Try 3166, 3167 or parrot

On 8/22/21 5:22 PM, David - W9DWH via groups.io wrote:
Mine will work on 31211 but that's the only one I've found so far. 

241 - 260 of 9925