Date   

Dashboard is not swown correcty

Pietro Schimmenti (IU2 DLC)
 

Hi all, i hope in your help :-)
Well i installed the server with the Raspberry image and no problem at all. It'up&running. I also have a relatively powe VPS with Ubuntu 20.04.
Primarly i use it for my projects so the conf. is nginx primarly. 
I installed the dvswitch server on it. Fortunately no problem. dvs starts at first shot and all services is up and running despite the lighttpd was installed there are no issues with the nginx and also ports are correctly configured server side and on the firewall/nat.
Well what happens? All run smoothly except the dashboard. If i connect on port 80 (but i tried even other ports) i can see only the header and the RX button.
It is so strange...even the sound is working but the dashboard is totally missing no error shown.
Worst is for the monitoring that does not answer on default port.
Connecting to port 8080 a message say "upgrade required", then i upgraded googling that "piece" that seemed not update. Fortunatelly i made a snapshot of the vps , i don't lost nothing but that upgrade crashed both lightd and nginx so for sure was not the right solution.
Does someone of you have/had same issues?
I hope i was clear in explaining all because i would like a working solution if it exist. It is a production server so i don't want to play with it unless somo fix/workaround will solve the issue.
To be honest it's not crucial for me because the dvswitch works good so the dashboard give me just the plus of seeing qrz people on my server but nothing more.
Neither the monitoring is crucial due the server is fully monitored already with the cloud tools. So it's just to finish the job nothing more ...and understand how come.
Thanks in advance,
Pietro IU2DLC.


Re: kf7eel / hbnet

Doug - W4DBG
 

Eric,

I think I have answered his questions off group. 

Thanks!

Doug
W4DBG





On Tue, Dec 21, 2021 at 6:01 PM Eric - KF7EEL <kf7eel@...> wrote:
Hi Patrick,

Documentation is something that is lacking, and something that I have been working on. See the Wiki for what little documentation exists at the moment. As I get more time, more of the pages will start to contain helpful information. Time is a precious commodity between multiple jobs and family. Send me an email off list, and I will be happy to help you get set up. This will also help me find/fix/address issues that may come up, improving documentation.

Thanks,
Eric - KF7EEL

--
Doug Gooden
troytrojan@...


Re: kf7eel / hbnet

Eric - KF7EEL
 

Hi Patrick,

Documentation is something that is lacking, and something that I have been working on. See the Wiki for what little documentation exists at the moment. As I get more time, more of the pages will start to contain helpful information. Time is a precious commodity between multiple jobs and family. Send me an email off list, and I will be happy to help you get set up. This will also help me find/fix/address issues that may come up, improving documentation.

Thanks,
Eric - KF7EEL


Re: Audio adjustment DVS

David k7iou
 

It’s fixed, just did some testing on the system with several on the RF analog side and the DMR audio was great. I chose the 5.0 setting because kv4s recommended it on his setup webpage and previously we tried raising to 2.0 without hardly a bump.
thanks Steve
73 de k7iou 


Re: Audio adjustment DVS

David k7iou
 

Figured out what you meant by comments, (….) in the code. Lol
set gain DMR —->analog usrpGain=5.0
we will see how it works when we get a couple stations on RF.
thanks de k7iou 


Re: Audio adjustment DVS

Steve N4IRS
 

Yes, read the comments.

On 12/20/21 3:48 PM, David k7iou wrote:
We would need to change where circled?
thanks


Re: Audio adjustment DVS

David k7iou
 

We would need to change where circled?
thanks


Re: Audio adjustment DVS

David k7iou
 
Edited

Hi Steve, this is what he sees when he ssh into CN.
/opt/Analog_Bridge/Analog_Bridge.ini
and it looks like this now:  

[USRP]
address = 127.0.0.1                     ; IP address of USRP partner (Allstar/Asterisk or another Analog_Bridge)
txPort = 32001                          ; Transmit USRP frames on this port
rxPort = 34001                          ; Listen for USRP frames on this port
usrpAudio = AUDIO_USE_GAIN                 ; Digital -> Analog (AUDIO_UNITY, AUDIO_USE_GAIN, AUDIO_USE_AGC)
usrpGain = 1.0                         ; Gain factor when usrpAudio = AUDIO_USE_GAIN (0.0 to 5.0) (1.0 = AUDIO_UNITY)
usrpAgc = -20,10,100                    ; Set the agc threshold (db), slope (db) and decay (ms)
tlvAudio = AUDIO_USE_GAIN                  ; Analog -> Digital (AUDIO_UNITY, AUDIO_USE_GAIN, AUDIO_BPF)
tlvGain = 1.0                          ; Gain factor when tlvAudio = AUDIO_USE_GAIN (0.0 to 5.0) (1.0 = AUDIO_UNITY)

 

can you highlight the actual adjustment so we can perform an increase of 3 dB change? He knows how to change and write the file.
Thanks and regards de k7iou 


Help getting DVSwitch and DVSwitch Mobile to work please

Mike Jensen (ZL4IA)
 

I have done the Server and Client setups from DVSwitch Installation and User Guide Version 1.61.

As far as I can tell I have it right, but not quite ...

The DVS Mobile - I long press A then B selecting my options.
Then the SEND button.
Nothing appears to happen though, and I can[t hear any received audio from and modes.

I can login to the Server and have set it up as per DVSwitch Installation and User Guide Version 1.61.

The server and client are connected according to the client.

So, any tips for a newbie please hihi!

Thanks
Mike
ZL4IA
mikejensencomputing@...


Re: Audio adjustment DVS

Steve N4IRS
 

usrpGain = 1.10                         ; Gain factor when usrpAudio = AUDIO_USE_GAIN (0.0 to 5.0) (1.0 = AUDIO_UNITY)

On 12/19/21 10:52 AM, nh6bf via groups.io wrote:
On my Clearnode, the Analog-Bridge.ini file already has AUDIO_USE_GAIN in both sections.  Being familiar with the WD7F setup, I get the DMR audio just fine... But...on occasions I do get breaks in the audio or no audio.  So, not sure what is going on...  Also, the CN has fail safe backups, so if you mess up some ini files, it writes it back to default...Smart Guy!!!


Re: Audio adjustment DVS

nh6bf
 
Edited

On my Clearnode, the Analog-Bridge.ini file already has AUDIO_USE_GAIN in both sections.  Being familiar with the setup, I get the DMR audio just fine... But...on occasions I do get breaks in the audio or no audio.  So, not sure what is going on...  Also, the CN has fail safe backups, so if you mess up some ini files, it writes it back to default...Smart Guy!!!


Re: Audio adjustment DVS

Steve N4IRS
 

/opt/Analog_Bridge/Analog_Bridge.ini

[USRP]
usrpAudio = AUDIO_UNITY                 ; Digital -> Analog (AUDIO_UNITY, AUDIO_USE_GAIN, AUDIO_USE_AGC)
usrpGain = 1.10                         ; Gain factor when usrpAudio = AUDIO_USE_GAIN (0.0 to 5.0) (1.0 = AUDIO_UNITY)
usrpAGC = -20,10,100                    ; Set the agc threshold (db), slope (db) and decay (ms)

tlvAudio = AUDIO_UNITY                  ; Analog -> Digital (AUDIO_UNITY, AUDIO_USE_GAIN, AUDIO_BPF)
tlvGain = 0.35                          ; Gain factor when tlvAudio = AUDIO_USE_GAIN (0.0 to 5.0) (1.0 = AUDIO_UNITY)


On 12/18/21 12:33 PM, David k7iou wrote:
Hello, we are stumped where to adjust the audio, (DMR to analog).
It’s great coming from the analog repeater side to DMR but from DMR to analog it’s in the dirt and needs to be raised. We are connecting the Clear node to the EchoLink on the repeater system and don’t want to adjust EL on the repeater because it’s balanced correctly.

Also we are all reeling from the recent passing 12/16 of one of our (leaders, father to many) hams in the group who helped set this up and we did his last call on the system last night.

I’m not on site so I’d have to relay the information and help them walk through the adjustment.

It would be greatly appreciated if you could display step by step because we are still learning-dummies…..

Regards de David k7iou

 MMDVM_Bridge and Analog_Bridge 
ClearNode software distribution. We are currently supporting DMR, P25, System Fusion YFS Reflectors, FCS Rooms and NXDN Reflectors. 


Audio adjustment DVS

David k7iou
 

Hello, we are stumped where to adjust the audio, (DMR to analog).
It’s great coming from the analog repeater side to DMR but from DMR to analog it’s in the dirt and needs to be raised. We are connecting the Clear node to the EchoLink on the repeater system and don’t want to adjust EL on the repeater because it’s balanced correctly.

Also we are all reeling from the recent passing 12/16 of one of our (leaders, father to many) hams in the group who helped set this up and we did his last call on the system last night.

I’m not on site so I’d have to relay the information and help them walk through the adjustment.

It would be greatly appreciated if you could display step by step because we are still learning-dummies…..

Regards de David k7iou

MMDVM_Bridge and Analog_Bridge 
ClearNode software distribution. We are currently supporting DMR, P25, System Fusion YFS Reflectors, FCS Rooms and NXDN Reflectors. 


kf7eel / hbnet

Patrick Johnson
 

Trying to get this installed, seems like awesome dmr software. I would like it to use with unit to unit calling.

There is absolutely no install information, is it possible for someone to spend 5 min to explain how to install it? I’ve been at it 8 hours and I am not new to linux. Frustration level 5000


Re: What is an ISPC2 Server?

DO1KBL, Kim
 

Maybe you can have a look with Mike if it is easy to include the private call function in IPSC_Bridge and HB_Bridge or if it is more complicated.

The Main Server is a HBlink3 system and the hb_bridge connected as peer with the hblink3 server.

This would be nice if it also works.


Lessons Learned for those building Multimode Repeaters

Jim - K6JM
 

I converted a D-STAR repeater to MultiMode and have documented what I learned.  Biggest takeaway was that some Motorola repeaters are not appropriate to use as the radios for MMDVM if DMR will be enabled.  My hope is to help others avoid my mistakes.

https://www.k6jm.com/wp/mmdvm-lessons-learned/

    Jim – K6JM




Avast logo

This email has been checked for viruses by Avast antivirus software.
www.avast.com



Transmit problem using DVS

John-EA5JAV
 

DVSwitch was working fine upto a couple weeks ago on DMR, now when I PTT nothing gets transmitted, yet when I Tx via e.g. Droidstar then retry via DVSwitch then works fine. I have tried different BM servers, have latest updates etc, any ideas please? Thanks, John. EA5JAV 


Re: Good morning to all

Mike AE4ML
 

will do , 
Thanks 


Re: What is an ISPC2 Server?

Steve N4IRS
 

Yes

On 12/14/2021 9:05 AM, DO1KBL, Kim via groups.io wrote:
Thank you Steve.
Mike is also reading Here?

Von meinem iPhone gesendet

Am 14.12.2021 um 15:01 schrieb Steve N4IRS <szingman@...>:

Randy has accepted the pull request so the change to dmr_utils is now in their repo. We will be updating pypi so that the change are available via pip.


Re: What is an ISPC2 Server?

DO1KBL, Kim
 

Thank you Steve.
Mike is also reading Here?

Von meinem iPhone gesendet

Am 14.12.2021 um 15:01 schrieb Steve N4IRS <szingman@...>:

Randy has accepted the pull request so the change to dmr_utils is now in their repo. We will be updating pypi so that the change are available via pip.

201 - 220 of 10177