Date   

Re: Voice Announcements for .sh functions

Tom Corcoran
 

👍
--
Tom VE3NY


Re: Voice Announcements for .sh functions

Steve N4IRS
 

Mike and I have discussed it and you may see it at some point in the future. It's on the ever growing stack of "round toits"

Steve

On 8/20/20 10:35 PM, Tom Corcoran wrote:
In the same way that BM Disconnect announces "Not Connected", is there a way to announce ".sh" functions like shutdown.sh  routine? 

It would be great for mobile operation.

tnx ... Tom VE3NY
--
Tom VE3NY


Voice Announcements for .sh functions

Tom Corcoran
 

In the same way that BM Disconnect announces "Not Connected", is there a way to announce ".sh" functions like shutdown.sh  routine? 

It would be great for mobile operation.

tnx ... Tom VE3NY
--
Tom VE3NY


Re: P25 to DMR issue

 

I had entirely too many instances of AB_P25 and AB_DMR running. 
All shutdown now, I will kill MMDVM_Bridge then start everything fresh.
Thank you for spending so much of your valuable time on this.
It is appreciated. Hope to meet you in person some time, lunch will be on me.
I'll let you know how this starts up.
I did find a couple of typos in the bridge.sh script to start it.


Re: P25 to DMR issue

Steve N4IRS
 

So,
your port conflict is with one of your AB instances. Your P25 AB should be listening on 34103 and transmitting on 34100.


On 8/20/20 6:56 PM, Don WB5EKU wrote:



Looks like its running !


Re: P25 to DMR issue

 




Looks like its running !


Re: P25 to DMR issue

Steve N4IRS
 

Now run MMDVM_Bridge ./MMDVM_Bridge and capture output.


On 8/20/20 5:35 PM, Don WB5EKU wrote:
Killed the Refledtor and Gateway



Re: P25 to DMR issue

 

Killed the Refledtor and Gateway


Re: P25 to DMR issue

 



Now nothing running. 


Re: P25 to DMR issue

 

killing all P25Reflector


Re: P25 to DMR issue

 

Installed net-tools on the system:


Re: P25 to DMR issue

 

No netstat on my system!


Re: P25 to DMR issue

Steve N4IRS
 

Don,
Let's make sure you have both Analog_Bridges stopped.
ps ax | grep Analog
With both ABs stopped and MMDVM_Bridge stopped.
netstat -unap

Steve

On 8/20/20 4:03 PM, Don WB5EKU wrote:
Had to do it in 2 pieces, the location is not duplicated in the real one, just on my copy.







Re: P25 to DMR issue

 

Had to do it in 2 pieces, the location is not duplicated in the real one, just on my copy.






Re: P25 to DMR issue

Steve N4IRS
 

OK, so no, you don't have QB running. Do this as root:
stop both Analog_Bridges
stop MMDVM_Bridge
cd /opt/MMDVM_Bridge
./MMDVM_Bridge MMDVM_Bridge.ini
capture the TOTAL output and post it.

Steve

On 8/20/2020 3:43 PM, Don WB5EKU wrote:
Looks like it is!



Re: P25 to DMR issue

 

Looks like it is!


Re: P25 to DMR issue

Steve N4IRS
 

Ah, do you have Quantar Bridge running?
ps ax | grep Quantar

On 8/20/2020 3:16 PM, Don WB5EKU wrote:
Steve,
Thanks, I made the changes ... but..
I guess that I am missing something very obvious and don't see it OR I am dense!

I now get the can't open RXport 34100 which changed from 34103 when I changed it per your email.

I am still unsure how or where DVSwitch.ini is called or what calls it.

Don
WB5EKU


Re: P25 to DMR issue

Steve N4IRS
 

Nothing calls DVSwitch.ini it configures the TLV IO ports for each mode of MMDVM_Bridge.
Did you edit Analog_Bridge.ini or DVSwitch.ini?

On 8/20/2020 3:16 PM, Don WB5EKU wrote:
Steve,
Thanks, I made the changes ... but..
I guess that I am missing something very obvious and don't see it OR I am dense!

I now get the can't open RXport 34100 which changed from 34103 when I changed it per your email.

I am still unsure how or where DVSwitch.ini is called or what calls it.

Don
WB5EKU


Re: P25 to DMR issue

 

Steve,
Thanks, I made the changes ... but..
I guess that I am missing something very obvious and don't see it OR I am dense!

I now get the can't open RXport 34100 which changed from 34103 when I changed it per your email.

I am still unsure how or where DVSwitch.ini is called or what calls it.

Don
WB5EKU


Re: P25 to DMR issue

Steve N4IRS
 

Don, This is what you have now:

AB_DMR                  DVSwitch.ini
[AMBE_AUDIO]            [DMR]
address = 127.0.0.1 <-> Address = 127.0.0.1
txPort = 31103 <------> RXPort = 31103
rxPort = 31100 <------> TXPort = 31100
ambeMode = DMR

                                                AB_P25
                       
[P25]                   [AMBE_AUDIO]
                        Address = 127.0.0.1 <-> address = 127.0.0.1
                        TXPort = 34100 <------> rxPort = 31100 <<<<<<< Error!
                        RXPort = 34103 <------> txPort = 31100 <<<<<<< Error!

I have highlighted the error above. Your connection from MMDVM_Bridge (DvSwitch.ini) is using the wrong ports. They can't communicate.
It should look like this:
AB_DMR                  DVSwitch.ini
[AMBE_AUDIO]            [DMR]
address = 127.0.0.1 <-> Address = 127.0.0.1
txPort = 31103 <------> RXPort = 31103
rxPort = 31100 <------> TXPort = 31100
ambeMode = DMR

                                                AB_P25
                        [P25]                   [AMBE_AUDIO]
                        Address = 127.0.0.1 <-> address = 127.0.0.1
                        TXPort = 34100 <------> rxPort = 34100
                        RXPort = 34103 <------> txPort = 34103

Steve, N4IRS

Steve,
Sorry I had to run out yesterday and thought I sent this to you.

I think I missed DVSWwitch!  Is it started prior to MMDVM_Bridge?

WB5EKU

2781 - 2800 of 9814