Date   

Re: Switching to Phoenix at command line

Derek William Haden <facebook@...>
 

Thank you, I have now got the script working.

Not sure what AFAI refers too?


Re: Switching to Phoenix at command line

Ian
 

Just to point you in the right direction ,,
DMR+  is port 5555  and password  is PASSWORD .
AFAI remember.
 
G0TJH 
 
 
 
 

-------Original Message-------
 
Date: 07/15/20 11:56:28
Subject: Re: [DVSwitch] Switching to Phoenix at command line
 

So I think I went off on the wrong track, what I need to connect to is

DMR+ not Phoenix, sorry real new to DMR.

In the script I have to change to BM this command is implemented

/opt/Analog_Bridge/dvswitch.sh tune passw0rd@...:62031

What I am looking for is a similar command but to switch to DMR+

As always appreciate support and time and effort involved.

 


Re: Switching to Phoenix at command line

Derek William Haden <facebook@...>
 

So I think I went off on the wrong track, what I need to connect to is

DMR+ not Phoenix, sorry real new to DMR.

In the script I have to change to BM this command is implemented

/opt/Analog_Bridge/dvswitch.sh tune passw0rd@...:62031

What I am looking for is a similar command but to switch to DMR+

As always appreciate support and time and effort involved.


Re: Switching to Phoenix at command line

Derek William Haden <facebook@...>
 

Thanks Steve, I'll give it a try.

I am assuming Enable needs to be 1?


On Tue, Jul 14, 2020 at 09:40 AM, Steve N4IRS wrote:
[DMR Network]
Enable=0
Address=hblink.dvswitch.org
Port=62031
Jitter=360
Local=62032
Password=passw0rd
# for DMR+ see https://github.com/DVSwitch/MMDVM_Bridge/blob/master/DOC/DMRplus_startup_options.md
# for XLX the syntax is: Options=XLX:4009
# Options=
Slot1=0
Slot2=1
Debug=0


Re: Switching to Phoenix at command line

Steve N4IRS
 

From what I can Google, you will need the login for that network. I am guessing when I say, put the login info in MMDVM_Bridge.ini

[DMR Network]
Enable=0
Address=hblink.dvswitch.org
Port=62031
Jitter=360
Local=62032
Password=passw0rd
# for DMR+ see https://github.com/DVSwitch/MMDVM_Bridge/blob/master/DOC/DMRplus_startup_options.md
# for XLX the syntax is: Options=XLX:4009
# Options=
Slot1=0
Slot2=1
Debug=0

Steve N4IRS

On 7/14/2020 12:05 PM, Derek William Haden wrote:

Well connect to the DMR phoenix network.

If in DMR mode I believe that *D from DVswitch mobile switches to Phoenix.

I have some scripts installed that were written by WA3LXD I beleive, these switch between DStar, DMR TGIF, DMR BM, and YSF, and load up a customised TG list for each mode.

I want to add Phoenix to the scripts so they switch to that system. All my local Repeaters are on Phoenix, if they were on BM I wouldn't need this.



Re: Switching to Phoenix at command line

Derek William Haden <facebook@...>
 

Well connect to the DMR phoenix network.

If in DMR mode I believe that *D from DVswitch mobile switches to Phoenix.

I have some scripts installed that were written by WA3LXD I beleive, these switch between DStar, DMR TGIF, DMR BM, and YSF, and load up a customised TG list for each mode.

I want to add Phoenix to the scripts so they switch to that system. All my local Repeaters are on Phoenix, if they were on BM I wouldn't need this.


Re: Switching to Phoenix at command line

Steve N4IRS
 

I don't know anything about Phoenix. Tell us what you are trying to do.

Steve N4IRS

On 7/14/2020 6:21 AM, Derek William Haden wrote:

what would be the command or sequence of commands to Switch to Phoenix at the command line?

I have looked in the Wiki but don't see it



Switching to Phoenix at command line

Derek William Haden <facebook@...>
 

what would be the command or sequence of commands to Switch to Phoenix at the command line?

I have looked in the Wiki but don't see it


Re: enabling an AMBE dongle

Derek William Haden <facebook@...>
 

OK understood.

Thanks again.


Re: DVSwitch Dashboard

Jason - WY7JT
 

There is a bug in the code of the page. What works for me is when it shows someone transmitting, I hit reload and then the rest of the page loads.

Jason - WY7JT

On Mon, Jul 13, 2020 at 8:22 AM Stavros Papas via groups.io <sv2hwl=yahoo.gr@groups.io> wrote:
I have problem with Dashboard.
I have copy the files from Download folder to Webroot /var/www/html 
where I have Problem I don’t know.


Re: DVSwitch Dashboard

Stavros Papas
 

I have problem with Dashboard.
I have copy the files from Download folder to Webroot /var/www/html 
where I have Problem I don’t know.


Re: enabling an AMBE dongle

Steve N4IRS
 

No.
true = on
false = off

On 7/12/20 2:27 PM, Derek William Haden wrote:
So could I just rem the lines out?


Re: enabling an AMBE dongle

Derek William Haden <facebook@...>
 

So could I just rem the lines out?


Re: enabling an AMBE dongle

Steve N4IRS
 

decoderFallBack = true ; You can turn this off

useEmulator = true ; You can turn this off

emulatorAddress = 127.0.0.1:2500 ; this does not matter if use emulator is off

On 7/11/20 12:19 PM, Derek William Haden wrote:

I have now installed ambeserver and all seems to be working ok.

There are some settings in the Analog_Bridge.ini file that confuse me.

Do I need to change anything here?
---------------------------------------

decoderFallBack = true

useEmulator = true

emulatorAddress = 127.0.0.1:2500
-------------------------------------
Or lease as default?



Re: enabling an AMBE dongle

Derek William Haden <facebook@...>
 

I have now installed ambeserver and all seems to be working ok.

There are some settings in the Analog_Bridge.ini file that confuse me.

Do I need to change anything here?
---------------------------------------

decoderFallBack = true

useEmulator = true

emulatorAddress = 127.0.0.1:2500
-------------------------------------
Or lease as default?


Re: enabling an AMBE dongle

Derek William Haden <facebook@...>
 

I have now installed ambeserver, and now have it working fine.

The dongle (DVmega version).

My question now is about this section of Analog_Bridge.ini file

-----------------------------------

decoderFallBack = true

useEmulator = true

emulatorAddress = 127.0.0.1:2500

------------------------===

Do I have to change these settings when using the ambeserver, or will it simply use the dongle and ignore these settings?


Re: Error, DVSwitch.ini file not found.. But it's right there?!

sigmazgfx@...
 

So now the new battle will be to get ircddbgateway into arch ... 


Some ini files missing after installing on Rpi

Derek William Haden <facebook@...>
 

I have just installed dvswitch on a Rpi following the instructions in DVSM_02_17_2020.pdf

All went well till it came to editing
YSFGateway.ini
Quantar_Bridge.ini 
ircddbgateway
none of which existed, so I made my own in the appropriate folders.

also the systemctl service files for these services did not exist either.

Is there a resource I can download them from?

Also the ini files for NXDN P25 were also not there, however I won't be running those so that is not an problem.

 


Re: Error, DVSwitch.ini file not found.. But it's right there?!

sigmazgfx@...
 

Whoops that was my fault..
Here we go
[root@AllstarNode MMDVM_Bridge]# ./dvswitch.sh getEnabledModes
Enabled Modes: DMR D-Star




Re: Error, DVSwitch.ini file not found.. But it's right there?!

sigmazgfx@...
 
Edited

Ok... so I moved the comments down a line on the TXPort and RXPort lines.. it appears that for some reason it doesnt honor the ; comment delimiter

anyway, ran it again and this is what we see..

parseIniFile "$DVSWITCH_INI" "$_MODE" "TXPort"
++ parseIniFile /opt/MMDVM_Bridge/DVSwitch.ini DSTAR TXPort
++ python -
+ _MBTX=32100
parseIniFile "$DVSWITCH_INI" "$_MODE" "RXPort"
++ parseIniFile /opt/MMDVM_Bridge/DVSwitch.ini DSTAR RXPort
++ python -
+ _MBRX=32103
+ '[' '!' -z 32100 ']'
+ sendMessage 'Setting mode to DSTAR'
+ '[' -z 'Setting mode to DSTAR' ']'
+ remoteControlCommand 'message=Setting mode to DSTAR'
+ '[' '!' -z '' ']'
+ PYTHON_ARG='message=Setting mode to DSTAR'
+ python -
+ setAmbeMode DSTAR
+ '[' 1 -eq 0 ']'
+ remoteControlCommand ambeMode=DSTAR
+ '[' '!' -z '' ']'
+ PYTHON_ARG=ambeMode=DSTAR
+ python -
+ setTLVTxPort 32103
+ '[' 1 -eq 0 ']'
+ remoteControlCommand txport=32103
+ '[' '!' -z '' ']'
+ PYTHON_ARG=txport=32103
+ python -
+ setTLVRxPort 32100
+ '[' 1 -eq 0 ']'
+ remoteControlCommand rxport=32100
+ '[' '!' -z '' ']'
+ PYTHON_ARG=rxport=32100
+ python -
+ sleep 1
getTLVPort
++ getTLVPort
++ getABInfoValue tlv rx_port
getABInfoFileName
+++ getABInfoFileName
+++ '[' -z '' ']'
ls -t /tmp/ABInfo_*.json 2>/dev/null | head -1
++++ ls -t /tmp/ABInfo_34001.json
++++ head -1
+++ declare _json_file=/tmp/ABInfo_34001.json
+++ echo /tmp/ABInfo_34001.json
++ declare _json_file=/tmp/ABInfo_34001.json
++ python -
+ TLV_PORT=32100
+ getInfo
+ '[' 0 -eq 0 ']'
+ remoteControlCommand info
+ '[' '!' -z '' ']'
+ PYTHON_ARG=info
+ python -
exit $_ERRORCODE
+ exit 0

./dvswitch.sh mode DSTAR

But .. getEnabledModes is angry now.. 
 
[root@AllstarNode MMDVM_Bridge]# ./dvswitch.sh getEnabledModes
./dvswitch.sh: line 894: configparser: command not found
./dvswitch.sh: line 896: configparser: command not found
./dvswitch.sh: line 898: [: ==: unary operator expected
./dvswitch.sh: line 894: configparser: command not found
./dvswitch.sh: line 896: configparser: command not found
./dvswitch.sh: line 898: [: ==: unary operator expected
./dvswitch.sh: line 894: configparser: command not found
./dvswitch.sh: line 896: configparser: command not found
./dvswitch.sh: line 898: [: ==: unary operator expected
./dvswitch.sh: line 894: configparser: command not found
./dvswitch.sh: line 896: configparser: command not found
./dvswitch.sh: line 898: [: ==: unary operator expected
./dvswitch.sh: line 894: configparser: command not found
./dvswitch.sh: line 896: configparser: command not found
./dvswitch.sh: line 898: [: ==: unary operator expected
 

3021 - 3040 of 9820