Date   

Re: mmdvmb.service in amd64?

Tom Corcoran
 

I can graze on winscp, but please ... where is file?
--
Tom VE3NY


Re: Dvswitch software not running on Odroid N2

Steve N4IRS
 

I now have a board that will do aarch64 (arm64) I bought a RPi4 and I'm running Ubuntu 19.10 on it.
I have pushed MMDVM_Bridge.arm64 and Analog_Bridge.arm64 to GitHub.
I will build the other support programs over the next few days. The ONLY testing I did was to make sure the executables ran. I will be doing full testing as I build the support programs.

73, Steve N4IRS 


Re: mmdvmb.service in amd64?

jim.lathan@...
 

Try the command in terminal, if it returns without go for it

On Fri, Nov 29, 2019 at 5:17 PM Tom Corcoran <tcorcoran@...> wrote:
tnx for speedy response .

so, instead of my macro ending with "restart mmdvmb.service" should I use "restart MMDVM_Bridge" ?
--
Tom VE3NY


Re: mmdvmb.service in amd64?

Steve N4IRS
 

No,
No the file is mmdvm_bridge.service

On 11/29/2019 5:17 PM, Tom Corcoran wrote:
tnx for speedy response .

so, instead of my macro ending with "restart mmdvmb.service" should I use "restart MMDVM_Bridge" ?
--
Tom VE3NY


Re: mmdvmb.service in amd64?

Tom Corcoran
 

tnx for speedy response .

so, instead of my macro ending with "restart mmdvmb.service" should I use "restart MMDVM_Bridge" ?
--
Tom VE3NY


Re: mmdvmb.service in amd64?

Steve N4IRS
 

No, mmdvm_bridge.service expects the file be named MMDVM_Bridge

n 11/29/19 5:05 PM, Tom Corcoran wrote:

I am trying to install macros in my cloud instance of DVS. Is there an equivalent (but different name) file in amd64 version for mmdvmb.service?
--
Tom VE3NY


mmdvmb.service in amd64?

Tom Corcoran
 

I am trying to install macros in my cloud instance of DVS. Is there an equivalent (but different name) file in amd64 version for mmdvmb.service?
--
Tom VE3NY


Re: DMRlink.cfg #dmrlink #best_practices

Alex IK7SEC
 

At my system works whith only one instance, but  i don't need strange or specific way to stream voice flow, at the moment all tg\ts are used at same way in all repeaters\hotspot, bau at the moment i havo only one repaters and some hostspost on line. 


Re: ASL to DMR Bridge how to on Raspberry Pi Audio Quality Lost

Ted Lawrence
 

On Thu, Nov 28, 2019 at 11:07 AM, Steve N4IRS wrote:
AB.ini
Thank you Steve! I made the change.  Thanks a bunch for the help!  Enjoy your day!

Ted


Re: ASL to DMR Bridge how to on Raspberry Pi Audio Quality Lost

Steve N4IRS
 

Looks like you are not using the emulator. Make sure it's running and enabled in AB.ini

Sent by smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Ted Lawrence via Groups.Io <tedlaw2@...>
Sent: Thursday, November 28, 2019 1:47:32 PM
To: main@DVSwitch.groups.io <main@DVSwitch.groups.io>
Subject: [DVSwitch] ASL to DMR Bridge how to on Raspberry Pi Audio Quality Lost
 
Greetings folks!

Got new node up and running on Raspberry Pi 3, seemed successful and sounded great. Then I enabled WiFI, then back to ethernet cable trying to  troubleshooting what has changed.  No joy, Now I have lost audio quality DMR to ASL.  Not sure what may have changed?  See anything strange here:

I: 2019-11-28 18:43:22.230 Analog Bridge is starting

M: 2019-11-28 18:43:22.230 Setting [GENERAL] logLevel -> 2

M: 2019-11-28 18:43:22.230 Setting [GENERAL] exportMetadata -> true

M: 2019-11-28 18:43:22.230 Setting [GENERAL] subscriberFile -> /var/lib/dvswitch/subscriber_ids.csv

M: 2019-11-28 18:43:22.230 Setting [GENERAL] decoderFallBack -> true

M: 2019-11-28 18:43:22.230 Setting [GENERAL] useEmulator -> false

M: 2019-11-28 18:43:22.230 Setting [GENERAL] emulatorAddress -> 127.0.0.1:2470

M: 2019-11-28 18:43:22.230 Setting [GENERAL] outputAudioDevice -> /dev/null

M: 2019-11-28 18:43:22.231 Setting [GENERAL] inputAudioDevice -> /dev/null

M: 2019-11-28 18:43:22.231 Setting [GENERAL] useMicrophone -> false

M: 2019-11-28 18:43:22.231 Setting [GENERAL] useVox -> false

M: 2019-11-28 18:43:22.231 Setting [GENERAL] voxDecay -> 2

M: 2019-11-28 18:43:22.231 Setting [GENERAL] voxTrigger -> 200

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] server -> 127.0.0.1

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] fromDMRPort -> 31100

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] toDMRPort -> 31103

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] ambeMode -> DMR

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] minTxTimeMS -> 2000

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] gatewayDmrId -> 3151317

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] repeaterID -> 315131703

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] txTg -> 315136

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] txTs -> 2

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] colorCode -> 1

M: 2019-11-28 18:43:22.231 Setting [USRP] server -> 127.0.0.1

M: 2019-11-28 18:43:22.231 Setting [USRP] toASLPort -> 32001

M: 2019-11-28 18:43:22.231 Setting [USRP] fromASLPort -> 34001

M: 2019-11-28 18:43:22.232 Setting [USRP] aslAudio -> AUDIO_UNITY

M: 2019-11-28 18:43:22.232 Setting [USRP] agcGain -> -20

M: 2019-11-28 18:43:22.232 Setting [USRP] dmrAudio -> AUDIO_UNITY

M: 2019-11-28 18:43:22.232 Setting [USRP] dmrGain -> 0.37

M: 2019-11-28 18:43:22.232 Setting [DV3000] server -> 127.0.0.1

M: 2019-11-28 18:43:22.232 Setting [DV3000] port -> 2460

W: 2019-11-28 18:43:22.232 ioctl reset error 

W: 2019-11-28 18:43:22.232 ioctl speed error 

W: 2019-11-28 18:43:22.232 ioctl stereo error 

W: 2019-11-28 18:43:22.232 ioctl setfmt error 

M: 2019-11-28 18:43:22.232 Audio In/Out Device: /dev/null

I: 2019-11-28 18:43:22.232 Open UDP listener on 127.0.0.1:31100

I: 2019-11-28 18:43:22.232 Open USRP on 127.0.0.1:32001

M: 2019-11-28 18:43:22.232 Connecting to DV3000 hardware......

W: 2019-11-28 18:43:23.241 DV3000 not found at 127.0.0.1:2460


Thanks,
Ted
KD4EG


ASL to DMR Bridge how to on Raspberry Pi Audio Quality Lost

Ted Lawrence
 

Greetings folks!

Got new node up and running on Raspberry Pi 3, seemed successful and sounded great. Then I enabled WiFI, then back to ethernet cable trying to  troubleshooting what has changed.  No joy, Now I have lost audio quality DMR to ASL.  Not sure what may have changed?  See anything strange here:

I: 2019-11-28 18:43:22.230 Analog Bridge is starting

M: 2019-11-28 18:43:22.230 Setting [GENERAL] logLevel -> 2

M: 2019-11-28 18:43:22.230 Setting [GENERAL] exportMetadata -> true

M: 2019-11-28 18:43:22.230 Setting [GENERAL] subscriberFile -> /var/lib/dvswitch/subscriber_ids.csv

M: 2019-11-28 18:43:22.230 Setting [GENERAL] decoderFallBack -> true

M: 2019-11-28 18:43:22.230 Setting [GENERAL] useEmulator -> false

M: 2019-11-28 18:43:22.230 Setting [GENERAL] emulatorAddress -> 127.0.0.1:2470

M: 2019-11-28 18:43:22.230 Setting [GENERAL] outputAudioDevice -> /dev/null

M: 2019-11-28 18:43:22.231 Setting [GENERAL] inputAudioDevice -> /dev/null

M: 2019-11-28 18:43:22.231 Setting [GENERAL] useMicrophone -> false

M: 2019-11-28 18:43:22.231 Setting [GENERAL] useVox -> false

M: 2019-11-28 18:43:22.231 Setting [GENERAL] voxDecay -> 2

M: 2019-11-28 18:43:22.231 Setting [GENERAL] voxTrigger -> 200

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] server -> 127.0.0.1

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] fromDMRPort -> 31100

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] toDMRPort -> 31103

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] ambeMode -> DMR

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] minTxTimeMS -> 2000

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] gatewayDmrId -> 3151317

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] repeaterID -> 315131703

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] txTg -> 315136

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] txTs -> 2

M: 2019-11-28 18:43:22.231 Setting [AMBE_AUDIO] colorCode -> 1

M: 2019-11-28 18:43:22.231 Setting [USRP] server -> 127.0.0.1

M: 2019-11-28 18:43:22.231 Setting [USRP] toASLPort -> 32001

M: 2019-11-28 18:43:22.231 Setting [USRP] fromASLPort -> 34001

M: 2019-11-28 18:43:22.232 Setting [USRP] aslAudio -> AUDIO_UNITY

M: 2019-11-28 18:43:22.232 Setting [USRP] agcGain -> -20

M: 2019-11-28 18:43:22.232 Setting [USRP] dmrAudio -> AUDIO_UNITY

M: 2019-11-28 18:43:22.232 Setting [USRP] dmrGain -> 0.37

M: 2019-11-28 18:43:22.232 Setting [DV3000] server -> 127.0.0.1

M: 2019-11-28 18:43:22.232 Setting [DV3000] port -> 2460

W: 2019-11-28 18:43:22.232 ioctl reset error 

W: 2019-11-28 18:43:22.232 ioctl speed error 

W: 2019-11-28 18:43:22.232 ioctl stereo error 

W: 2019-11-28 18:43:22.232 ioctl setfmt error 

M: 2019-11-28 18:43:22.232 Audio In/Out Device: /dev/null

I: 2019-11-28 18:43:22.232 Open UDP listener on 127.0.0.1:31100

I: 2019-11-28 18:43:22.232 Open USRP on 127.0.0.1:32001

M: 2019-11-28 18:43:22.232 Connecting to DV3000 hardware......

W: 2019-11-28 18:43:23.241 DV3000 not found at 127.0.0.1:2460


Thanks,
Ted
KD4EG


Re: Switch Between BM and TGIF

Steve N4IRS
 

I'm glad to see the macro system is allowing you to do what you want to do. As Mike and I answer questions in the threads we find more about what people want to do. The best example of this is dvswitch.sh and the updated mvsm.macro.

Have fun guys.
Steve N4IRS


Re: ASL to DMR Bridge how to on Raspberry Pi #best_practices

Steve N4IRS
 

Ted,
This is how ASL rpt.conf is as "shipped"

; Enable the selected channel driver in modules.conf !!!
rxchannel = dahdi/pseudo            ; No radio (hub)
; rxchannel = SimpleUSB/usb_1999    ; SimpleUSB
; rxchannel = Pi/1                      ; Raspberry Pi PiTA
; rxchannel = Radio/usb_1999        ; USBRadio (DSP)
; rxchannel = Dahdi/1            ; PCI Quad card
; rxchannel = Beagle/1            ; BeagleBoard
; rxchannel = USRP/127.0.0.1:34001:32001; GNU Radio interface USRP 


On 11/27/19 7:47 PM, Ted Lawrence via Groups.Io wrote:
Thanks for responding Steve! Very good on the  [1999] Parameters.   All is good with [1999] parameters.  All is working and passing audio to and from DMR.  Just not sure about the my node 505501. It's not connected to any hardware.    


Re: ASL to DMR Bridge how to on Raspberry Pi #best_practices

Ted Lawrence
 

Thanks for responding Steve! Very good on the  [1999] Parameters.   All is good with [1999] parameters.  All is working and passing audio to and from DMR.  Just not sure about the my node 505501. It's not connected to any hardware.    


Re: ASL to DMR Bridge how to on Raspberry Pi #best_practices

Steve N4IRS
 

On 11/27/19 7:32 PM, Ted Lawrence via Groups.Io wrote:
Greetings folks!

I have a Raspberry pi node configured ASL to DMR Bridge.  I do not have any radio on this node 505501.   The node is stand alone, used to connect to other remote base nodes to our DMR Local TG 315136.  As such, I am not clear on the best practice for the node parameters.  For example, should the rxchannel = SimpleUSB/usb_505501 be commented out.  As if so, what other recommended parameters should be made.

Thanks!
Ted
KD4EG 


ASL to DMR Bridge how to on Raspberry Pi #best_practices

Ted Lawrence
 

Greetings folks!

I have a Raspberry pi node configured ASL to DMR Bridge.  I do not have any radio on this node 505501.   The node is stand alone, used to connect to other remote base nodes to our DMR Local TG 315136.  As such, I am not clear on the best practice for the node parameters.  For example, should the rxchannel = SimpleUSB/usb_505501 be commented out.  As if so, what other recommended parameters should be made.

Thanks!
Ted
KD4EG 


Re: Switch Between BM and TGIF

Tom Corcoran
 

Switching macros working great. Also enabled switch to the QRM network. Tnx for collective efforts.
--
Tom VE3NY


Re: Switch Between BM and TGIF

Eddie
 

Wow fantastic work gentlemen, will look for everyone on TGIF soon.

Vy 73-Eddie, KQ6K 

On Tue, Nov 26, 2019 at 9:16 PM Ke4tlc <ke4tlc@...> wrote:

 

Thanks for the efforts of Jeff Lehman N8ACL, Dion Brown KE4TLC, and Jim Lathan W4JLP

 

Files located in /opt/MMDVM_Bridge

MMDVM_Bridge.ini

MMDVM_Bridge_BM.ini ß Brand Meister (copy of original MMDVM_Bridge.ini)

MMDVM_Bridge_TGIF.ini ß TGIF (copy of original MMDVM_Bridge.ini and change under section [DMR Network] Address=84.232.5.113 to Address=tgif.network, save file and close.

 

Scripts: Create these file in the /opt/Analog_Bridge

BM_chng.sh ß Changes MMDVM Bridge to Brand Meister

TGIF_chng.shß Changes MMDVM Bridge to TGIF

 

BM_chng.sh

#! /bin/bash

cp /opt/MMDVM_Bridge/MMDVM_Bridge_BM.ini  /opt/MMDVM_Bridge/MMDVM_Bridge.ini

service mmdvmb restart

 

TGIF_Chng.sh

#! /bin/bash

cp /opt/MMDVM_Bridge/MMDVM_Bridge_TGIF.ini  /opt/MMDVM_Bridge/MMDVM_Bridge.ini

service mmdvmb restart

 

Change Mod of BM_chng.sh and TGIF_chng.sh

                chmod 755 /opt/MMDVM_Bridge/BM_chng.sh

chmod 755 /opt/MMDVM_Bridge/TGIF_chng.sh

 

Edit /opt/Analog_Bridge/dvsm.ini and add the following macros, see example below:

Note: If you cannot access a keyboard on your device screen, use keypad numbers, i.e. *72.

AB=/opt/Analog_Bridge/BM_chng.sh dmr.ini

AC=/opt/Analog_Bridge/TGIF_chng.sh dmr.ini

 

So to ensure all is applied, restart Raspberry Pi.


Re: DMRlink.cfg #dmrlink #best_practices

ai6bx
 

Sorry covered your schematic and see oh do have the dmrlink as a master too. Is your dmrlink.cfg a single file with one master and multiple peers pointing to that master or are you running multiple instances as I have seen others describe? The text explanations would read as I can do the former however my file fails to execute when I do so.


Re: DMRlink.cfg #dmrlink #best_practices

ai6bx
 

Interesting, so you are allowing all traffic from the Moto repeaters to flow through to HBlink3 and using that as the single master and tg filter? Essentially each Moto repeater one of the peer seats your HBlink.cfg file?

4481 - 4500 of 9814