Date   

Re: Starting MMDVM_Bridge #mmdvm_bridge

Heiko DL1BZ
 

An address with value of 0 in this case means binding to *all* available network devices. An address of 127.0.0.1 can be never work to "outside" - only on the same system for internal communication - also if no real network device like network card exists.
That's basic knowledge of tcp/ip networking :)

73 Heiko, DL1BZ


Re: Just Moved server from Digital Ocean and now server won't run

N9UMJ
 

Mike

Your one several that has suggested Vultr , Allstar maybe an option later for linking our 9 analog repeaters to the digital network, I know doug has done that on the Alabama link

I wasn't trying to be unique , Believe it or not I was trying to make it as simple as possible by moving the the files over just as they were on DO.
I have a theory for the issues with the transfer , but will require further investigation to confirm the problem, but not sure if it's worth the effort at this point?

So your thinking it's best to load DVSwitch and the ysf reflector fresh and just copy the ini files?

I'll look at Vultr tonight and Debian is fine , I run Debian on other projects for work. Ubuntu was selected because I use it on my windows 10 machine for ham and personal, not an issue to load Debian to Windows too.Prefer not to use Windows , but some things just won't run without it.

Thanks again for your help, may have more questions later..

Rick



On Tue, Jun 18, 2019 at 5:55 PM Mike KB8JNM <groupio@...> wrote:

If I might suggest using VUTR.com

Cheap reliable and no custom headers and you can load your own ISO

But I suggest you use DEBIAN especially if you are running or think you might run allstar/app_rpt

ASL  on vultr VPS http://29999.link/asl-vps.html

Try to stay on the beaten path until you know more. But I'm not suggesting that you don't try new things but wait till you understand how it all works. Easier to get help when there is nothing unique in your set-up.

On 6/18/2019 8:41 AM, N9UMJ wrote:
Thanks Steve and Mike
I'm going to wipe out Dv_Switch and all of the files completely from the new PS and try again

I've made the directories and they exist in the files,on the new VPS running is the issue??  all of the DV_Switch files and YSFReflector files are working on DO.

Something has been lost of corrupted when brought over from Digital Ocean

It's unfortunate that the snapshot image from DO cannot be moved outside of DO .

I may look at at creating a stand alone on a pi and putting it at the fiber hub for now and start building a standalone instance for the fiber hub and not use the vps. I have 4 multi channel trans coders sitting on the bench as a fall project, Time restraints in the summer is the problem.

The urgency is moving oit away from DO and having it running as it was before the DO fiasco , until the long term changes can be made


Since I'm starting over again is there a better iso option that Ubuntu 18.04

Thanks to both of you , I'll give the move another try any tips would be appreciated.

Rick n9umj


On Tue, Jun 18, 2019 at 7:39 AM Steve KC1AWV <smiller@...> wrote:
It looks to me that you're having procedural problems, and not issues with the programs themselves. You've got folders missing apparently. Here's the important part of what you've sent over:

chown: cannot access '/var/log/YSFReflector': No such file or directory

Make sure the directory exists first before changing owner. mkdir -p /var/log/YSFReflector

Also, it looks like you're already logged in as root, so no need to use sudo on those commands.

While I'm sure nobody here really minds providing help where it's needed, we're getting into support of an operating system, and programs that are not specifically part of DVSwitch. Remember, the support for the DVSwitch programs that this group is intended for are the ones that are maintained in the DVSwitch github repo. All other support is a courtesy.

Steve KC1AWV

On Tue, Jun 18, 2019 at 1:48 AM N9UMJ <n9umj2@...> wrote:
Mike

I tried to reload the YSFReflecor and can't get it to reinstall over whats already there.

Analog_Bridge  NXDNClients  P25Clients  Quantar_Bridge  YSFParrot
DMRGateway     NXDNGateway  P25Gateway  YSFClients      md380-emu
MMDVM_Bridge   NXDNParrot   P25Parrot   YSFGateway      opt
root@hwsrv-499225:/opt# sudo chown mmdvm /var/log/YSFReflector
chown: cannot access '/var/log/YSFReflector': No such file or directory
root@hwsrv-499225:/opt# cd YSFClients
root@hwsrv-499225:/opt/YSFClients# ls
LICENCE    YSFClients      YSFGateway  YSFReflector
README.md  YSFClients.sln  YSFParrot
root@hwsrv-499225:/opt/YSFClients# cd YSFReflector
root@hwsrv-499225:/opt/YSFClients/YSFReflector# sudo nano YSFreflector.ini
root@hwsrv-499225:/opt/YSFClients/YSFReflector# udo nano YSFReflector.ini

root@hwsrv-499225:/opt/YSFClients/YSFReflector# sudo nano YSFReflector.ini
root@hwsrv-499225:/opt/YSFClients/YSFReflector# sudo useradd mmdvm -g mmdvm -s /                                                                             sbin/nologin
useradd: user 'mmdvm' already exists
root@hwsrv-499225:/opt/YSFClients/YSFReflector# sudo chown mmdvm /var/log/YSFRef                                                                             lector
chown: cannot access '/var/log/YSFReflector': No such file or directory
root@hwsrv-499225:/opt/YSFClients/YSFReflector#

What Think??

On Mon, Jun 17, 2019 at 10:52 PM Mike KB8JNM <groupio@...> wrote:

http://manpages.ubuntu.com/manpages/bionic/man1/uname.1.html

On 6/17/2019 10:28 PM, N9UMJ wrote:
Mike

I recovered uname -r with sudo apt-get --reinstall install linux-headers-`uname -r`


Now it shows 4.15.0-15 generic for uname-r 




On Sun, Jun 16, 2019, 9:04 PM Mike KB8JNM <groupio@...> wrote:

Not sure if there is anything specific to Ubuntu but Just a thought... Your packaging might be missing something needed. Someone else may be able to chime in on that.

What does it say when you type   '  uname -r   ' from cmd line ?

Not familiar with Dig Oc but

Did you use one of their stock images ?  or - Can/did you load your own iso ?


On 6/16/2019 7:40 PM, N9UMJ wrote:
Hi Mike

Ubuntu 18.04

On Sun, Jun 16, 2019 at 12:20 PM Mike KB8JNM <groupio@...> wrote:

What OS and kernel version ?

On 6/16/2019 12:03 PM, N9UMJ wrote:
I just moved all of the DvSwitch files and server configurations away from Digital Ocean to a new VPS and can't get it to run, All of the ports have been configut=red on the firewall as the working version of DO, I was wondering if someone could give me some tips on what it might be or would be will to take a look see and see if I may have missed something

Thanks
Rick n9umj


--
Steve Miller
KC1AWV


Re: Starting MMDVM_Bridge #mmdvm_bridge

Dexter Harroo
 

OK Guys thanks for all the help, problem has been solved, it was in the MMDVM_Bridge.ini

[System Fusion Network]
Enable=1
LocalAddress=127.0.0.1  <--------------------------------this doesn't work
LocalPort=3200
GatewayAddress=ysfreflector.dvswitch.org
GatewayPort=42166
Debug=0
  

[System Fusion Network]
Enable=1
LocalAddress=0 <------------------------------ this works
LocalPort=3200
GatewayAddress=ysfreflector.dvswitch.org
GatewayPort=42166
Debug=0
  

Made the Mistake of changing LocalAddress from 0 to 127.0.0.1
again thanks for all the help, you guys are an awesome bunch

On Tue, Jun 18, 2019 at 6:26 PM Steve N4IRS <szingman@...> wrote:
You can ignore that.

On 6/18/19 6:24 PM, Dexter Harroo wrote:
When MMDVM_Bridge is starting up I see error cannot open RSSI Data file

On Tue, Jun 18, 2019, 18:01 Steve N4IRS <szingman@...> wrote:
Then the problem is in the [System Fusion Network] stanza. Again, this should help <https://dvswitch.groups.io/g/main/message/4133>

Steve N4IRS

On 6/18/19 5:30 PM, Dexter Harroo wrote:
Disabled DMR problem persists

On Tue, Jun 18, 2019, 16:14 Steve N4IRS <szingman@...> wrote:
Disable DMR network and retest

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Dexter Harroo <dex.9y4c@...>
Sent: Tuesday, June 18, 2019 4:10:23 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Starting MMDVM_Bridge #mmdvm_bridge
 
Yes i can ping tgif.network successfully




--
73
9Y4C
Dexter Harroo


Re: Starting MMDVM_Bridge #mmdvm_bridge

Steve N4IRS
 

You can ignore that.

On 6/18/19 6:24 PM, Dexter Harroo wrote:
When MMDVM_Bridge is starting up I see error cannot open RSSI Data file

On Tue, Jun 18, 2019, 18:01 Steve N4IRS <szingman@...> wrote:
Then the problem is in the [System Fusion Network] stanza. Again, this should help <https://dvswitch.groups.io/g/main/message/4133>

Steve N4IRS

On 6/18/19 5:30 PM, Dexter Harroo wrote:
Disabled DMR problem persists

On Tue, Jun 18, 2019, 16:14 Steve N4IRS <szingman@...> wrote:
Disable DMR network and retest

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Dexter Harroo <dex.9y4c@...>
Sent: Tuesday, June 18, 2019 4:10:23 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Starting MMDVM_Bridge #mmdvm_bridge
 
Yes i can ping tgif.network successfully



Re: Starting MMDVM_Bridge #mmdvm_bridge

Dexter Harroo
 

When MMDVM_Bridge is starting up I see error cannot open RSSI Data file


On Tue, Jun 18, 2019, 18:01 Steve N4IRS <szingman@...> wrote:
Then the problem is in the [System Fusion Network] stanza. Again, this should help <https://dvswitch.groups.io/g/main/message/4133>

Steve N4IRS

On 6/18/19 5:30 PM, Dexter Harroo wrote:
Disabled DMR problem persists

On Tue, Jun 18, 2019, 16:14 Steve N4IRS <szingman@...> wrote:
Disable DMR network and retest

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Dexter Harroo <dex.9y4c@...>
Sent: Tuesday, June 18, 2019 4:10:23 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Starting MMDVM_Bridge #mmdvm_bridge
 
Yes i can ping tgif.network successfully


Re: Starting MMDVM_Bridge #mmdvm_bridge

Steve N4IRS
 

Then the problem is in the [System Fusion Network] stanza. Again, this should help <https://dvswitch.groups.io/g/main/message/4133>

Steve N4IRS

On 6/18/19 5:30 PM, Dexter Harroo wrote:
Disabled DMR problem persists

On Tue, Jun 18, 2019, 16:14 Steve N4IRS <szingman@...> wrote:
Disable DMR network and retest

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Dexter Harroo <dex.9y4c@...>
Sent: Tuesday, June 18, 2019 4:10:23 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Starting MMDVM_Bridge #mmdvm_bridge
 
Yes i can ping tgif.network successfully


Re: Just Moved server from Digital Ocean and now server won't run

Mike KB8JNM
 

If I might suggest using VUTR.com

Cheap reliable and no custom headers and you can load your own ISO

But I suggest you use DEBIAN especially if you are running or think you might run allstar/app_rpt

ASL  on vultr VPS http://29999.link/asl-vps.html

Try to stay on the beaten path until you know more. But I'm not suggesting that you don't try new things but wait till you understand how it all works. Easier to get help when there is nothing unique in your set-up.

On 6/18/2019 8:41 AM, N9UMJ wrote:
Thanks Steve and Mike
I'm going to wipe out Dv_Switch and all of the files completely from the new PS and try again

I've made the directories and they exist in the files,on the new VPS running is the issue??  all of the DV_Switch files and YSFReflector files are working on DO.

Something has been lost of corrupted when brought over from Digital Ocean

It's unfortunate that the snapshot image from DO cannot be moved outside of DO .

I may look at at creating a stand alone on a pi and putting it at the fiber hub for now and start building a standalone instance for the fiber hub and not use the vps. I have 4 multi channel trans coders sitting on the bench as a fall project, Time restraints in the summer is the problem.

The urgency is moving oit away from DO and having it running as it was before the DO fiasco , until the long term changes can be made


Since I'm starting over again is there a better iso option that Ubuntu 18.04

Thanks to both of you , I'll give the move another try any tips would be appreciated.

Rick n9umj


On Tue, Jun 18, 2019 at 7:39 AM Steve KC1AWV <smiller@...> wrote:
It looks to me that you're having procedural problems, and not issues with the programs themselves. You've got folders missing apparently. Here's the important part of what you've sent over:

chown: cannot access '/var/log/YSFReflector': No such file or directory

Make sure the directory exists first before changing owner. mkdir -p /var/log/YSFReflector

Also, it looks like you're already logged in as root, so no need to use sudo on those commands.

While I'm sure nobody here really minds providing help where it's needed, we're getting into support of an operating system, and programs that are not specifically part of DVSwitch. Remember, the support for the DVSwitch programs that this group is intended for are the ones that are maintained in the DVSwitch github repo. All other support is a courtesy.

Steve KC1AWV

On Tue, Jun 18, 2019 at 1:48 AM N9UMJ <n9umj2@...> wrote:
Mike

I tried to reload the YSFReflecor and can't get it to reinstall over whats already there.

Analog_Bridge  NXDNClients  P25Clients  Quantar_Bridge  YSFParrot
DMRGateway     NXDNGateway  P25Gateway  YSFClients      md380-emu
MMDVM_Bridge   NXDNParrot   P25Parrot   YSFGateway      opt
root@hwsrv-499225:/opt# sudo chown mmdvm /var/log/YSFReflector
chown: cannot access '/var/log/YSFReflector': No such file or directory
root@hwsrv-499225:/opt# cd YSFClients
root@hwsrv-499225:/opt/YSFClients# ls
LICENCE    YSFClients      YSFGateway  YSFReflector
README.md  YSFClients.sln  YSFParrot
root@hwsrv-499225:/opt/YSFClients# cd YSFReflector
root@hwsrv-499225:/opt/YSFClients/YSFReflector# sudo nano YSFreflector.ini
root@hwsrv-499225:/opt/YSFClients/YSFReflector# udo nano YSFReflector.ini

root@hwsrv-499225:/opt/YSFClients/YSFReflector# sudo nano YSFReflector.ini
root@hwsrv-499225:/opt/YSFClients/YSFReflector# sudo useradd mmdvm -g mmdvm -s /                                                                             sbin/nologin
useradd: user 'mmdvm' already exists
root@hwsrv-499225:/opt/YSFClients/YSFReflector# sudo chown mmdvm /var/log/YSFRef                                                                             lector
chown: cannot access '/var/log/YSFReflector': No such file or directory
root@hwsrv-499225:/opt/YSFClients/YSFReflector#

What Think??

On Mon, Jun 17, 2019 at 10:52 PM Mike KB8JNM <groupio@...> wrote:

http://manpages.ubuntu.com/manpages/bionic/man1/uname.1.html

On 6/17/2019 10:28 PM, N9UMJ wrote:
Mike

I recovered uname -r with sudo apt-get --reinstall install linux-headers-`uname -r`


Now it shows 4.15.0-15 generic for uname-r 




On Sun, Jun 16, 2019, 9:04 PM Mike KB8JNM <groupio@...> wrote:

Not sure if there is anything specific to Ubuntu but Just a thought... Your packaging might be missing something needed. Someone else may be able to chime in on that.

What does it say when you type   '  uname -r   ' from cmd line ?

Not familiar with Dig Oc but

Did you use one of their stock images ?  or - Can/did you load your own iso ?


On 6/16/2019 7:40 PM, N9UMJ wrote:
Hi Mike

Ubuntu 18.04

On Sun, Jun 16, 2019 at 12:20 PM Mike KB8JNM <groupio@...> wrote:

What OS and kernel version ?

On 6/16/2019 12:03 PM, N9UMJ wrote:
I just moved all of the DvSwitch files and server configurations away from Digital Ocean to a new VPS and can't get it to run, All of the ports have been configut=red on the firewall as the working version of DO, I was wondering if someone could give me some tips on what it might be or would be will to take a look see and see if I may have missed something

Thanks
Rick n9umj


--
Steve Miller
KC1AWV


Re: Starting MMDVM_Bridge #mmdvm_bridge

Steve KC1AWV
 

Ok, I think we need to see a full copy of all the config files, the command executed and all the logs that you're getting. I mean, we're getting the results piecemeal here and I'm trying to follow along but I'm having a hard time understanding what's going on.

Copy and paste everything from your terminal from the command executed all the way down to the end of the console output of the program you're executing. Copy and paste the config files here too.

I know, I know... Medice, cura te ipsum but I think a more comprehensive view of what you're getting will help out immensely.

Steve KC1AWV


On Tue, Jun 18, 2019 at 5:31 PM Dexter Harroo <dex.9y4c@...> wrote:
Disabled DMR problem persists

On Tue, Jun 18, 2019, 16:14 Steve N4IRS <szingman@...> wrote:
Disable DMR network and retest

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Dexter Harroo <dex.9y4c@...>
Sent: Tuesday, June 18, 2019 4:10:23 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Starting MMDVM_Bridge #mmdvm_bridge
 
Yes i can ping tgif.network successfully



--
Steve Miller
KC1AWV


Re: Starting MMDVM_Bridge #mmdvm_bridge

Dexter Harroo
 

Disabled DMR problem persists


On Tue, Jun 18, 2019, 16:14 Steve N4IRS <szingman@...> wrote:
Disable DMR network and retest

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Dexter Harroo <dex.9y4c@...>
Sent: Tuesday, June 18, 2019 4:10:23 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Starting MMDVM_Bridge #mmdvm_bridge
 
Yes i can ping tgif.network successfully


Re: Starting MMDVM_Bridge #mmdvm_bridge

Steve N4IRS
 

So,
The question is, what network is causing the issue. By disabling one network at a time you can narrow it down. I also suggest you read <https://dvswitch.groups.io/g/main/message/4133>

Steve N4IRS

On 6/18/19 4:10 PM, Dexter Harroo wrote:
Yes i can ping tgif.network successfully


Re: Starting MMDVM_Bridge #mmdvm_bridge

Steve N4IRS
 

Disable DMR network and retest

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Dexter Harroo <dex.9y4c@...>
Sent: Tuesday, June 18, 2019 4:10:23 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Starting MMDVM_Bridge #mmdvm_bridge
 
Yes i can ping tgif.network successfully


Re: Starting MMDVM_Bridge #mmdvm_bridge

Dexter Harroo
 

Yes i can ping tgif.network successfully


Re: Starting MMDVM_Bridge #mmdvm_bridge

Dexter Harroo
 

Ok I changed from domain name to IP but the issue is still there


Re: Starting MMDVM_Bridge #mmdvm_bridge

Steve N4IRS
 

Can you ping TGIF network?

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Dexter Harroo <dex.9y4c@...>
Sent: Tuesday, June 18, 2019 3:45:39 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Starting MMDVM_Bridge #mmdvm_bridge
 
[DMR Network] Enable=1
Address=tgif.network
Port=62031 Jitter=360
Local=62032
Password=passw0rd
Slot1=1
Slot2=1
Debug=0


Re: Starting MMDVM_Bridge #mmdvm_bridge

Dexter Harroo
 

[DMR Network] Enable=1
Address=tgif.network
Port=62031 Jitter=360
Local=62032
Password=passw0rd
Slot1=1
Slot2=1
Debug=0


Re: Starting MMDVM_Bridge #mmdvm_bridge

Jeff Lehman, N8ACL
 

Also, if you are connecting to the TGIF network, the address is tgif.network make sure that is correct as well.


On Tue, Jun 18, 2019 at 3:18 PM Steve KC1AWV <smiller@...> wrote:
Check your MMDVM_Bridge.ini to see if you used a domain name for DMRNetwork instead of the IP. If true, switch to IP address and try again.

On Tue, Jun 18, 2019 at 3:15 PM Dexter Harroo <dex.9y4c@...> wrote:
I dont want to be a pain but this is what happens when i run MMDVM_Bridge

: 2019-06-18 19:10:16.804 Error returned from sendto, err: 22
2019-06-18 19:10:21.811 Error returned from sendto, err: 22
2019-06-18 19:10:26.822 Error returned from sendto, err: 22
2019-06-18 19:10:31.833 Error returned from sendto, err: 22



--
Steve Miller
KC1AWV



--
Jeff Lehman, KC8QCH
E-mail: kc8qch@...
Hamshack Hotline: 4218

Webmaster
Hamilton County ARPSC
http://www.hamcoarpsc.org
E-mail: hamcoarpsc@...
Phone: 513-452-6480

Technical Director/ Multimode System Administrator
World Wide Amateur Radio Guild
https://hamradiohub.com/
E-Mail: kc8qch@...


Re: Starting MMDVM_Bridge #mmdvm_bridge

Steve KC1AWV
 

Check your MMDVM_Bridge.ini to see if you used a domain name for DMRNetwork instead of the IP. If true, switch to IP address and try again.

On Tue, Jun 18, 2019 at 3:15 PM Dexter Harroo <dex.9y4c@...> wrote:
I dont want to be a pain but this is what happens when i run MMDVM_Bridge

: 2019-06-18 19:10:16.804 Error returned from sendto, err: 22
2019-06-18 19:10:21.811 Error returned from sendto, err: 22
2019-06-18 19:10:26.822 Error returned from sendto, err: 22
2019-06-18 19:10:31.833 Error returned from sendto, err: 22



--
Steve Miller
KC1AWV


Re: Starting MMDVM_Bridge #mmdvm_bridge

Steve N4IRS
 

That is a IP error. Please post your [DMR Network] stanza from MMDVM_Bridge.ini

On 6/18/2019 3:15 PM, Dexter Harroo wrote:
I dont want to be a pain but this is what happens when i run MMDVM_Bridge

: 2019-06-18 19:10:16.804 Error returned from sendto, err: 22
2019-06-18 19:10:21.811 Error returned from sendto, err: 22
2019-06-18 19:10:26.822 Error returned from sendto, err: 22
2019-06-18 19:10:31.833 Error returned from sendto, err: 22


Re: Starting MMDVM_Bridge #mmdvm_bridge

Dexter Harroo
 

I dont want to be a pain but this is what happens when i run MMDVM_Bridge

: 2019-06-18 19:10:16.804 Error returned from sendto, err: 22
2019-06-18 19:10:21.811 Error returned from sendto, err: 22
2019-06-18 19:10:26.822 Error returned from sendto, err: 22
2019-06-18 19:10:31.833 Error returned from sendto, err: 22


Re: Starting MMDVM_Bridge #mmdvm_bridge

Steve N4IRS
 

On 6/18/2019 2:53 PM, Dexter Harroo wrote:
and where do i put the TG number ?
Does that go in the DVSwitch.ini 

5641 - 5660 of 9814