Date   

Re: Error, DVSwitch.ini file not found.. But it's right there?!

Mike KB8JNM
 

Are you sure you did not mean DVSwitch.ini 'not found' ?

If so set path and check permissions and ownership of the .ini file

On 7/9/2020 9:31 PM, w2jon@... wrote:
Crazy... Still no worky..
parseIniFile "$DVSWITCH_INI" "$_MODE" "TXPort"
++ parseIniFile ./opt/MMDVM_Bridge/DVSwitch.ini DSTAR TXPort
++ python -
+ _MBTX=
parseIniFile "$DVSWITCH_INI" "$_MODE" "RXPort"
++ parseIniFile ./opt/MMDVM_Bridge/DVSwitch.ini DSTAR RXPort
++ python -
+ _MBRX=
+ '[' '!' -z ']'
+ echo 'Error, DVSwitch.ini file not found'
Error, DVSwitch.ini file not found
+ _ERRORCODE=-1
exit $_ERRORCODE
 


Re: Error, DVSwitch.ini file not found.. But it's right there?!

sigmazgfx@...
 
Edited

Crazy... Still no worky.. ( ./Analog_Bridge/dvswitch.sh mode DSTAR )
 

parseIniFile "$DVSWITCH_INI" "$_MODE" "TXPort"
++ parseIniFile /opt/MMDVM_Bridge/DVSwitch.ini DSTAR TXPort
++ python -
+ _MBTX=
parseIniFile "$DVSWITCH_INI" "$_MODE" "RXPort"
++ parseIniFile /opt/MMDVM_Bridge/DVSwitch.ini DSTAR RXPort
++ python -
+ _MBRX=
+ '[' '!' -z ']'
+ echo 'Error, DVSwitch.ini file not found'
Error, DVSwitch.ini file not found
+ _ERRORCODE=-1
exit $_ERRORCODE
+ exit -1
 


Re: Error, DVSwitch.ini file not found.. But it's right there?!

Mike KB8JNM
 

typo ?

perhaps try to back out of the current director of it and specify the path to it ./dir/sub/xxx.sh

after that I am out of guesses.

On 7/9/2020 9:17 PM, w2jon@... wrote:

[Edited Message Follows]

Yep I'm root and the files are owned by root as well.\
all processes except for some started by systemd+ (none related to this) are running under root


Re: Error, DVSwitch.ini file not found.. But it's right there?!

sigmazgfx@...
 
Edited

Yep I'm root and the files are owned by root as well.\
all processes except for some started by systemd+ (none related to this) are running under root


Re: Error, DVSwitch.ini file not found.. But it's right there?!

Mike KB8JNM
 

are you root ?

check ownership

On 7/9/2020 9:12 PM, w2jon@... wrote:
Hey Guys/Gals, 
I'm having a strange error.. I have DVSwitch up and running on an ASL deployment and I had configured ASL NODE 1999 for use as a bridge to DMR.
It works just dandy, So I figured it was time to move forward and see about lighting up DStar and maybe another mode.. but for now DStar was the one I was going to start with.

I when I manually invoke a ./dvswitch.sh mode DSTAR the script comes back with the error that the DVSwitch.ini cant be found?
I checked the script and the DVSWITCH_INI variable points to /opt/MMDVM_Bridge/DVSwitch.ini and after checking several if not tens of times, YES the file lives in there along with MMDVM_Bridge and MMDVM_Bridge.ini

What gives? what did I mess up?
I think that in the dvswitch.sh file, I can see that it it's supposed to parse the file and if it cant find the values it assumes its because the file isn't available?
The file permissions are 755 but I have also tried at 777 and it still fails. 

Oh , and YES the [DSTAR] schema is present in the DVSwitch.ini as well as it's associated TXPort and RXPort values this process is looking for.
And the [D-Star] Enable=1 is set in the MMDVM_Bridge.ini..

Thanks, any insight is appreciated.  

-jon W2JON


  


Error, DVSwitch.ini file not found.. But it's right there?!

sigmazgfx@...
 

Hey Guys/Gals, 
I'm having a strange error.. I have DVSwitch up and running on an ASL deployment and I had configured ASL NODE 1999 for use as a bridge to DMR.
It works just dandy, So I figured it was time to move forward and see about lighting up DStar and maybe another mode.. but for now DStar was the one I was going to start with.

I when I manually invoke a ./dvswitch.sh mode DSTAR the script comes back with the error that the DVSwitch.ini cant be found?
I checked the script and the DVSWITCH_INI variable points to /opt/MMDVM_Bridge/DVSwitch.ini and after checking several if not tens of times, YES the file lives in there along with MMDVM_Bridge and MMDVM_Bridge.ini

What gives? what did I mess up?
I think that in the dvswitch.sh file, I can see that it it's supposed to parse the file and if it cant find the values it assumes its because the file isn't available?
The file permissions are 755 but I have also tried at 777 and it still fails. 

Oh , and YES the [DSTAR] schema is present in the DVSwitch.ini as well as it's associated TXPort and RXPort values this process is looking for.
And the [D-Star] Enable=1 is set in the MMDVM_Bridge.ini..

Thanks, any insight is appreciated.  

-jon W2JON


  


Re: Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

ct1hdc@...
 

Hi,
yes I updated dvswitch.sh

thanks 73

ct1hdc, Paulo

A quarta, 8/07/2020, 15:13, <lz1gsp.george@...> escreveu:

Change the ID update address from http://www.radioid to http://database.radioid


Re: Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

George Palikarsky
 

Change the ID update address from http://www.radioid to http://database.radioid


Re: Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

Steve N4IRS
 

How did you do your install?

On 7/7/2020 9:15 AM, ik1zvk@... wrote:
Raspbian buster.


Re: Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

Amedeo
 

Raspbian buster.


Re: Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

Steve N4IRS
 

How did you do your install?

On 7/6/20 8:47 PM, ct1hdc@... wrote:
Hi Steve,
is Raspbian,

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian


Re: Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

ct1hdc@...
 

Hi Steve,
is Raspbian,

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"


Re: Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

ct1hdc@...
 

  Hi,
I have the same problem, my installation is buster.

Linux raspberrypi 4.19.97-v7+ #1294 SMP Thu Jan 30 13:15:58 GMT 2020 armv7l GNU/Linux

Error, DMR ID file does not seem to be valid
dpkg: error processing package mmdvm-bridge (--configure):
 installed mmdvm-bridge package post-installation script subprocess returned error exit status 251


Running hooks in /etc/ca-certificates/update.d...
done.
Errors were encountered while processing:
 mmdvm-bridge
E: Sub-process /usr/bin/dpkg returned an error code (1)

Best Regards, 73

Paulo,ct1hdc





paulo pereira Pereira <ct1hdc@...> escreveu no dia terça, 7/07/2020 à(s) 01:35:

Hi,
I have the same problem, my installation is buster.

Linux raspberrypi 4.19.97-v7+ #1294 SMP Thu Jan 30 13:15:58 GMT 2020 armv7l GNU/Linux

Best Regards, 73

Paulo,ct1hdc

Steve N4IRS <szingman@...> escreveu no dia segunda, 6/07/2020 à(s) 18:43:
How did you do your install? is this RPIOS or Raspbian?
cat /etc/os-release?
uname -a

Steve N4IRS

On 7/6/20 1:07 PM, ik1zvk@... wrote:
Hi everyone,

Fresh Raspian installatiom,
on RPI 4 4 GB,
i have installed dvswitch but i obtain this error:


Configurazione di mmdvm-bridge (1.5-20200427-23)...
Error, DMR ID file does not seem to be valid
dpkg: errore nell'elaborare il pacchetto mmdvm-bridge (--configure):
 il sottoprocesso installato pacchetto mmdvm-bridge script post-installation ha restituito lo stato di errore 251
Si sono verificati degli errori nell'elaborazione:
 mmdvm-bridge
E: Sub-process /usr/bin/dpkg returned an error code (1


I can not find In /usr/local/sbin
/usr/local/sbin/DMRIDUpdate.sh

Anyone can help me?

Thanks in advance Amedeo IK1ZVK


Re: Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

Steve N4IRS
 

How did you do your install? is this RPIOS or Raspbian?
cat /etc/os-release?

On 7/6/20 8:35 PM, ct1hdc@... wrote:
Hi,
I have the same problem, my installation is buster.

Linux raspberrypi 4.19.97-v7+ #1294 SMP Thu Jan 30 13:15:58 GMT 2020 armv7l GNU/Linux

Best Regards, 73

Paulo,ct1hdc

Steve N4IRS <szingman@...> escreveu no dia segunda, 6/07/2020 à(s) 18:43:
How did you do your install? is this RPIOS or Raspbian?
cat /etc/os-release?
uname -a

Steve N4IRS

On 7/6/20 1:07 PM, ik1zvk@... wrote:
Hi everyone,

Fresh Raspian installatiom,
on RPI 4 4 GB,
i have installed dvswitch but i obtain this error:


Configurazione di mmdvm-bridge (1.5-20200427-23)...
Error, DMR ID file does not seem to be valid
dpkg: errore nell'elaborare il pacchetto mmdvm-bridge (--configure):
 il sottoprocesso installato pacchetto mmdvm-bridge script post-installation ha restituito lo stato di errore 251
Si sono verificati degli errori nell'elaborazione:
 mmdvm-bridge
E: Sub-process /usr/bin/dpkg returned an error code (1


I can not find In /usr/local/sbin
/usr/local/sbin/DMRIDUpdate.sh

Anyone can help me?

Thanks in advance Amedeo IK1ZVK



Re: enabling an AMBE dongle

Steve N4IRS
 

It's all about power.

On 7/6/20 1:43 PM, Aerodan wrote:
I'm using the ThumbDV without issue. The solution for me, not skipping any of these steps:

1_ Make sure that the Pi4 works with DMR and the default audio driver. If not, ThumbDV isn't the issue.

2_ I picked up a "Nekteck 72W 4 port USB C wall charger station" from Amazon.

3_ Plugged my entire Raspberry Pi4 into it the Nekteck. I have two Pi4's running off of it without issue, one with ThumbDV one without. That's all that I have powered.

4_ Plugged ThumbDV in one of the Pi4's USB 2.0 ports. Run AMBEtest4 a couple of times to be sure it's working.

5_ Run AMBEtest4 a couple of times and verify that the ThumbDV passes.




Re: enabling an AMBE dongle

Aerodan
 

I'm using the ThumbDV without issue. The solution for me, not skipping any of these steps:

1_ Make sure that the Pi4 works with DMR and the default audio driver. If not, ThumbDV isn't the issue.

2_ I picked up a "Nekteck 72W 4 port USB C wall charger station" from Amazon.

3_ Plugged my entire Raspberry Pi4 into it the Nekteck. I have two Pi4's running off of it without issue, one with ThumbDV one without. That's all that I have powered.

4_ Plugged ThumbDV in one of the Pi4's USB 2.0 ports. Run AMBEtest4 a couple of times to be sure it's working.

5_ Run AMBEtest4 a couple of times and verify that the ThumbDV passes.



Re: Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

Steve N4IRS
 

How did you do your install? is this RPIOS or Raspbian?
cat /etc/os-release?
uname -a

Steve N4IRS

On 7/6/20 1:07 PM, ik1zvk@... wrote:
Hi everyone,

Fresh Raspian installatiom,
on RPI 4 4 GB,
i have installed dvswitch but i obtain this error:


Configurazione di mmdvm-bridge (1.5-20200427-23)...
Error, DMR ID file does not seem to be valid
dpkg: errore nell'elaborare il pacchetto mmdvm-bridge (--configure):
 il sottoprocesso installato pacchetto mmdvm-bridge script post-installation ha restituito lo stato di errore 251
Si sono verificati degli errori nell'elaborazione:
 mmdvm-bridge
E: Sub-process /usr/bin/dpkg returned an error code (1


I can not find In /usr/local/sbin
/usr/local/sbin/DMRIDUpdate.sh

Anyone can help me?

Thanks in advance Amedeo IK1ZVK


Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

Amedeo
 

Hi everyone,

Fresh Raspian installatiom,
on RPI 4 4 GB,
i have installed dvswitch but i obtain this error:


Configurazione di mmdvm-bridge (1.5-20200427-23)...
Error, DMR ID file does not seem to be valid
dpkg: errore nell'elaborare il pacchetto mmdvm-bridge (--configure):
 il sottoprocesso installato pacchetto mmdvm-bridge script post-installation ha restituito lo stato di errore 251
Si sono verificati degli errori nell'elaborazione:
 mmdvm-bridge
E: Sub-process /usr/bin/dpkg returned an error code (1


I can not find In /usr/local/sbin
/usr/local/sbin/DMRIDUpdate.sh

Anyone can help me?

Thanks in advance Amedeo IK1ZVK


Re: enabling an AMBE dongle

Steve N4IRS
 

2 channels for WHAT to work? Analog_Bridge does not need 2 hardware vocoders to work.

On 7/6/20 12:15 PM, Curt Hart via groups.io wrote:
Because you need at least 2 channels for it to work.

On Monday, July 6, 2020, 10:40:02 AM CDT, Steve N4IRS <szingman@...> wrote:


Why a pair?

On 7/6/20 11:39 AM, Curt Hart via groups.io wrote:
Thumb DV works great, Northwest Digital, but you need at least a pair.

73,
Curtis - N9INK

On Monday, July 6, 2020, 10:36:33 AM CDT, Steve N4IRS <szingman@...> wrote:


Hard to say, not seeing much info. I THINK the DV stick30 will work with AMBEserver  <https://github.com/marrold/AMBEServer>

On 7/6/20 11:29 AM, Derek William Haden wrote:

I am clearly fighting a losing battle here.

I assume the DVmega version works OK?





Re: enabling an AMBE dongle

Curt Hart <curtg49@...>
 

Because you need at least 2 channels for it to work.

On Monday, July 6, 2020, 10:40:02 AM CDT, Steve N4IRS <szingman@...> wrote:


Why a pair?

On 7/6/20 11:39 AM, Curt Hart via groups.io wrote:
Thumb DV works great, Northwest Digital, but you need at least a pair.

73,
Curtis - N9INK

On Monday, July 6, 2020, 10:36:33 AM CDT, Steve N4IRS <szingman@...> wrote:


Hard to say, not seeing much info. I THINK the DV stick30 will work with AMBEserver  <https://github.com/marrold/AMBEServer>

On 7/6/20 11:29 AM, Derek William Haden wrote:

I am clearly fighting a losing battle here.

I assume the DVmega version works OK?



2341 - 2360 of 9087