Date   

Re: Stacato audio on DVSM

Derek William Haden <facebook@...>
 

yes, the ambeserver is started by a systemd unit file.

I am out most of day tomorrow, but will give it a try before the weekend.

again thanks for all the help.


Re: 2 DMR networks

pewpewpew000@...
 

Perhaps not on opposing time slots BUT interchangeably (one or the other).

AFAIK the limitation to operating one network versus having two simultatiously is more complex of an issue.


Re: Stacato audio on DVSM

Steve N4IRS
 

I don't know if you use a systemd unit file to start/stop/restart your AMBEServer.
If you do, You could add:
ExecStartPre = /bin/sh -c 'echo "1" >> /sys/bus/usb-serial/devices/ttyUSB0/latency_timer'

to the [SERVICE] stanza in the unit file that controls AMBEServer

On 9/2/2020 10:34 AM, Derek William Haden wrote:

OK if I restart everything, from fresh reboot, with AB configured for ambe server, but ambe server not yet started.
stop AB
do echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer

start amber server and restart AB

all seems to work correctly I do not get the stacato audio.

So I am guessing that somehow the command echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
Needs to to part of the ambe server start up? which I have no idea how to do.



Re: Stacato audio on DVSM

Derek William Haden <facebook@...>
 

OK if I restart everything, from fresh reboot, with AB configured for ambe server, but ambe server not yet started.
stop AB
do echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer

start amber server and restart AB

all seems to work correctly I do not get the stacato audio.

So I am guessing that somehow the command echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
Needs to to part of the ambe server start up? which I have no idea how to do.


Re: Cloud hosting

Tom Corcoran
 

W8DSB ... does this mean you have all apps running in cloud. How do you access ASL node? DVSM -> DVS -> ASL?
--
Tnx Tom VE3NY


Re: Multiple private nodes one cloud server using DVSwitch Mobile - Audio Issues. #mmdvm_bridge #analog_bridge #brandmeister

Willie Sandin
 

So I copied from another location and replaced the DVSwitch.ini file and edited the two ports.  And it is working now.  No clue what caused the issue, but it is working again!


Re: Multiple private nodes one cloud server using DVSwitch Mobile - Audio Issues. #mmdvm_bridge #analog_bridge #brandmeister

Willie Sandin
 

It is. That is what is weird.

M: 2020-09-01 22:52:07.350 DMR, Opening INI file: DVSwitch.ini
...
E: 2020-09-01 22:52:07.350 DMR, ini file "DVSwitch.ini" was not found.  Fatal error exiting



Re: Multiple private nodes one cloud server using DVSwitch Mobile - Audio Issues. #mmdvm_bridge #analog_bridge #brandmeister

Steve N4IRS
 

It says it can't find the file are you sure it's in the same directory?


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Willie Sandin <dwsandin@...>
Sent: Tuesday, September 1, 2020 7:10:16 PM
To: main@DVSwitch.groups.io <main@DVSwitch.groups.io>
Subject: Re: [DVSwitch] Multiple private nodes one cloud server using DVSwitch Mobile - Audio Issues. #mmdvm_bridge #analog_bridge #brandmeister
 
Thanks for the clarification.  

Now it seems that another issue has developed.  I had everything working.  Saved copies, etc.  Then rebooted the server.  One of the 3 now has an error that I am trying to track down..

The MMDVM Bridge will not load.  Somehow it starts to load DVSwitch.ini, then loses it.

● mmdvm_bridge-n0mgj.service - MMDVM_Bridge Service
   Loaded: loaded (/lib/systemd/system/mmdvm_bridge-n0mgj.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2020-09-01 17:52:07 CDT; 5min ago
  Process: 2578 ExecStart=/opt/MMDVM_Bridge-n0mgj/MMDVM_Bridge /opt/MMDVM_Bridge-n0mgj/MMDVM_Bridge.ini (code=exited, status=1/FAILURE)
 Main PID: 2578 (code=exited, status=1/FAILURE)

Partial Log

I: 2020-09-01 22:52:07.135 DMR Id Lookups
I: 2020-09-01 22:52:07.135     File: /var/lib/mmdvm/DMRIds.dat
I: 2020-09-01 22:52:07.136     Reload: 24 hours
I: 2020-09-01 22:52:07.349 Loaded 171196 Ids to the DMR callsign lookup table
I: 2020-09-01 22:52:07.349 DMR RF Parameters
I: 2020-09-01 22:52:07.349     Id: 316747902
I: 2020-09-01 22:52:07.350     Color Code: 1
I: 2020-09-01 22:52:07.350     Self Only: no
I: 2020-09-01 22:52:07.350     Embedded LC Only: yes
I: 2020-09-01 22:52:07.350     Dump Talker Alias Data: no
I: 2020-09-01 22:52:07.350     Prefixes: 0
I: 2020-09-01 22:52:07.350     Call Hang: 3s
I: 2020-09-01 22:52:07.350     TX Hang: 3s
I: 2020-09-01 22:52:07.350     Mode Hang: 10s
M: 2020-09-01 22:52:07.350 DMR, Opening INI file: DVSwitch.ini
M: 2020-09-01 22:52:07.350 DMR, Setting [DMR] Address -> 127.0.0.1
M: 2020-09-01 22:52:07.350 DMR, Setting [DMR] TXPort -> 31140
M: 2020-09-01 22:52:07.350 DMR, Setting [DMR] RXPort -> 31143
M: 2020-09-01 22:52:07.350 DMR, Setting [DMR] Slot -> 2
E: 2020-09-01 22:52:07.350 DMR, ini file "DVSwitch.ini" was not found.  Fatal error exiting

Nothing was edited in the MMDVM_Bridge.ini or DVSwitch.ini   This occurred after a reboot.

Thanks,


Re: Multiple private nodes one cloud server using DVSwitch Mobile - Audio Issues. #mmdvm_bridge #analog_bridge #brandmeister

Willie Sandin
 

Thanks for the clarification.  

Now it seems that another issue has developed.  I had everything working.  Saved copies, etc.  Then rebooted the server.  One of the 3 now has an error that I am trying to track down..

The MMDVM Bridge will not load.  Somehow it starts to load DVSwitch.ini, then loses it.

● mmdvm_bridge-n0mgj.service - MMDVM_Bridge Service
   Loaded: loaded (/lib/systemd/system/mmdvm_bridge-n0mgj.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2020-09-01 17:52:07 CDT; 5min ago
  Process: 2578 ExecStart=/opt/MMDVM_Bridge-n0mgj/MMDVM_Bridge /opt/MMDVM_Bridge-n0mgj/MMDVM_Bridge.ini (code=exited, status=1/FAILURE)
 Main PID: 2578 (code=exited, status=1/FAILURE)

Partial Log

I: 2020-09-01 22:52:07.135 DMR Id Lookups
I: 2020-09-01 22:52:07.135     File: /var/lib/mmdvm/DMRIds.dat
I: 2020-09-01 22:52:07.136     Reload: 24 hours
I: 2020-09-01 22:52:07.349 Loaded 171196 Ids to the DMR callsign lookup table
I: 2020-09-01 22:52:07.349 DMR RF Parameters
I: 2020-09-01 22:52:07.349     Id: 316747902
I: 2020-09-01 22:52:07.350     Color Code: 1
I: 2020-09-01 22:52:07.350     Self Only: no
I: 2020-09-01 22:52:07.350     Embedded LC Only: yes
I: 2020-09-01 22:52:07.350     Dump Talker Alias Data: no
I: 2020-09-01 22:52:07.350     Prefixes: 0
I: 2020-09-01 22:52:07.350     Call Hang: 3s
I: 2020-09-01 22:52:07.350     TX Hang: 3s
I: 2020-09-01 22:52:07.350     Mode Hang: 10s
M: 2020-09-01 22:52:07.350 DMR, Opening INI file: DVSwitch.ini
M: 2020-09-01 22:52:07.350 DMR, Setting [DMR] Address -> 127.0.0.1
M: 2020-09-01 22:52:07.350 DMR, Setting [DMR] TXPort -> 31140
M: 2020-09-01 22:52:07.350 DMR, Setting [DMR] RXPort -> 31143
M: 2020-09-01 22:52:07.350 DMR, Setting [DMR] Slot -> 2
E: 2020-09-01 22:52:07.350 DMR, ini file "DVSwitch.ini" was not found.  Fatal error exiting

Nothing was edited in the MMDVM_Bridge.ini or DVSwitch.ini   This occurred after a reboot.

Thanks,


Re: hblink.service

Steve N4IRS
 

Show us your hblink.service file and the result of systemctl status hblink.service

Sent by smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of p47thunderbolt@... <p47thunderbolt@...>
Sent: Tuesday, September 1, 2020 3:28:15 PM
To: main@DVSwitch.groups.io <main@DVSwitch.groups.io>
Subject: [DVSwitch] hblink.service
 
I have been running HBLINK on a raspberry Pi 4 for 7 months.  It has worked just fine.  I decided to put it on a server after my ISP provider kept changing my ISP address.  That's a story for another day.
I installed everything on my server and so far it appears to be working.  The only problem I am having is auto start up if the server reboots for some reason.
When on my raspberry HBLINK will automatically start upon boot up.  I cant for the life of me figure out how to do it now that it is on the server. I am sure it has to do with the hblink.service file.
I do have the systemctl working as expected.

Any help or info would be greatly appreciated.

I am fairly new at this so please take it easy on me.


hblink.service

p47thunderbolt@...
 

I have been running HBLINK on a raspberry Pi 4 for 7 months.  It has worked just fine.  I decided to put it on a server after my ISP provider kept changing my ISP address.  That's a story for another day.
I installed everything on my server and so far it appears to be working.  The only problem I am having is auto start up if the server reboots for some reason.
When on my raspberry HBLINK will automatically start upon boot up.  I cant for the life of me figure out how to do it now that it is on the server. I am sure it has to do with the hblink.service file.
I do have the systemctl working as expected.

Any help or info would be greatly appreciated.

I am fairly new at this so please take it easy on me.


Re: Multiple private nodes one cloud server using DVSwitch Mobile - Audio Issues. #mmdvm_bridge #analog_bridge #brandmeister

Steve N4IRS
 

If all yuo want is ASL access, then use IAX protocol.
Analog_Bridge uses USRP to connect to an analog client. That client can be ASL or DVS but not both. If you wanted to connect ASL to Digital Voice, you connect ASL via USRP to AB. If you want to add DVSM, you can connect to ASL via IAX.

Steve N4IRS

On 9/1/2020 2:30 PM, Willie Sandin wrote:
Ahh.. So a bridge from DVSwitch thru USRP to ASL is not possible?  Is this where DVSeitch uses the IAXClient?


Re: Multiple private nodes one cloud server using DVSwitch Mobile - Audio Issues. #mmdvm_bridge #analog_bridge #brandmeister

Willie Sandin
 

Ahh.. So a bridge from DVSwitch thru USRP to ASL is not possible?  Is this where DVSeitch uses the IAXClient?


Re: Updated DVSwitch repository available

Joe Azzara
 

hi I had wanted to know why the mac osx version does not work I had found the steps on GitHub and still it does not work


Re: Analog_Bridge and Mumble server

Paul on6dp
 

Waldek,

I have installed a mumble on my Debian, where HBLINK, Analog_Bridge and MMDVM_Bridge are also installed

73 Paul, ON6DP

 

De : main@DVSwitch.groups.io <main@DVSwitch.groups.io> De la part de SP2ONG Waldek
Envoyé : mardi 1 septembre 2020 18:04
À : main@DVSwitch.groups.io
Objet : [DVSwitch] Analog_Bridge and Mumble server

 

I like various radio amateur experiments. Currently running a test Mumble server which I connected via the python3 script from Analog_Bridge. Generally, the transmission works both ways, although I think that the script is very "raw" and requires work on it to work optimally. For end users exist client application for PC/MacOS or Android.

The local Mumble server uses the authorization based on the CERT key generated by the user and only the server admin can allow joining the channel where there is access only, for example, listening to audio from a DMR or a channel that allows you to transmit and hear via the Mumble <> AB / MB> DV bridge

Has anyone tried or is having a working connection from the Mumble server to Analog_Bridge?

73 Waldek


Garanti sans virus. www.avg.com


Analog_Bridge and Mumble server

SP2ONG Waldek
 

I like various radio amateur experiments. Currently running a test Mumble server which I connected via the python3 script from Analog_Bridge. Generally, the transmission works both ways, although I think that the script is very "raw" and requires work on it to work optimally. For end users exist client application for PC/MacOS or Android.

The local Mumble server uses the authorization based on the CERT key generated by the user and only the server admin can allow joining the channel where there is access only, for example, listening to audio from a DMR or a channel that allows you to transmit and hear via the Mumble <> AB / MB> DV bridge

Has anyone tried or is having a working connection from the Mumble server to Analog_Bridge?

73 Waldek


Re: Multiple private nodes one cloud server using DVSwitch Mobile - Audio Issues. #mmdvm_bridge #analog_bridge #brandmeister

Steve N4IRS
 

Maybe I'm not being clear, you are showing 2 USRP connections to AB. It's either / or. Either DVSM or ASL not both.


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Willie Sandin <dwsandin@...>
Sent: Tuesday, September 1, 2020 10:41:38 AM
To: main@DVSwitch.groups.io <main@DVSwitch.groups.io>
Subject: Re: [DVSwitch] Multiple private nodes one cloud server using DVSwitch Mobile - Audio Issues. #mmdvm_bridge #analog_bridge #brandmeister
 
Hopefully this one clears up the issues.  I am guessing that most people now use USRP to access and not the IAX Client direct to Asterisk.  I plan on adding the links and ports to other modes as we add them, but I have not attempted that yet.  


Re: Multiple private nodes one cloud server using DVSwitch Mobile - Audio Issues. #mmdvm_bridge #analog_bridge #brandmeister

Willie Sandin
 

Hopefully this one clears up the issues.  I am guessing that most people now use USRP to access and not the IAX Client direct to Asterisk.  I plan on adding the links and ports to other modes as we add them, but I have not attempted that yet.  


Re: Multiple private nodes one cloud server using DVSwitch Mobile - Audio Issues. #mmdvm_bridge #analog_bridge #brandmeister

Steve N4IRS
 

Correct. The problem I have with the diagram is it is showing both connections to AB. That may confuse someone trying to connect both DVSM and ASL at the same time.

On 9/1/2020 9:58 AM, Willie Sandin wrote:
So for clarification, Asterisk (ASL) uses ports 32001 and 34001 back to USRP to bridge correct?  

I showed DVSwitch at both points as one is using USRP (with port #'s), the other is using (iaxclient) as entrance points. (OPTIONS)  For what I am doing now, I am using only the USRP direct into the Analog Bridge.

  


Re: Multiple private nodes one cloud server using DVSwitch Mobile - Audio Issues. #mmdvm_bridge #analog_bridge #brandmeister

Willie Sandin
 

So for clarification, Asterisk (ASL) uses ports 32001 and 34001 back to USRP to bridge correct?  

I showed DVSwitch at both points as one is using USRP (with port #'s), the other is using (iaxclient) as entrance points. (OPTIONS)  For what I am doing now, I am using only the USRP direct into the Analog Bridge.

  

2361 - 2380 of 9518