Date   

Re: Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

ct1hdc@...
 

  Hi,
I have the same problem, my installation is buster.

Linux raspberrypi 4.19.97-v7+ #1294 SMP Thu Jan 30 13:15:58 GMT 2020 armv7l GNU/Linux

Error, DMR ID file does not seem to be valid
dpkg: error processing package mmdvm-bridge (--configure):
 installed mmdvm-bridge package post-installation script subprocess returned error exit status 251


Running hooks in /etc/ca-certificates/update.d...
done.
Errors were encountered while processing:
 mmdvm-bridge
E: Sub-process /usr/bin/dpkg returned an error code (1)

Best Regards, 73

Paulo,ct1hdc





paulo pereira Pereira <ct1hdc@...> escreveu no dia terça, 7/07/2020 à(s) 01:35:

Hi,
I have the same problem, my installation is buster.

Linux raspberrypi 4.19.97-v7+ #1294 SMP Thu Jan 30 13:15:58 GMT 2020 armv7l GNU/Linux

Best Regards, 73

Paulo,ct1hdc

Steve N4IRS <szingman@...> escreveu no dia segunda, 6/07/2020 à(s) 18:43:
How did you do your install? is this RPIOS or Raspbian?
cat /etc/os-release?
uname -a

Steve N4IRS

On 7/6/20 1:07 PM, ik1zvk@... wrote:
Hi everyone,

Fresh Raspian installatiom,
on RPI 4 4 GB,
i have installed dvswitch but i obtain this error:


Configurazione di mmdvm-bridge (1.5-20200427-23)...
Error, DMR ID file does not seem to be valid
dpkg: errore nell'elaborare il pacchetto mmdvm-bridge (--configure):
 il sottoprocesso installato pacchetto mmdvm-bridge script post-installation ha restituito lo stato di errore 251
Si sono verificati degli errori nell'elaborazione:
 mmdvm-bridge
E: Sub-process /usr/bin/dpkg returned an error code (1


I can not find In /usr/local/sbin
/usr/local/sbin/DMRIDUpdate.sh

Anyone can help me?

Thanks in advance Amedeo IK1ZVK


Re: Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

Steve N4IRS
 

How did you do your install? is this RPIOS or Raspbian?
cat /etc/os-release?

On 7/6/20 8:35 PM, ct1hdc@... wrote:
Hi,
I have the same problem, my installation is buster.

Linux raspberrypi 4.19.97-v7+ #1294 SMP Thu Jan 30 13:15:58 GMT 2020 armv7l GNU/Linux

Best Regards, 73

Paulo,ct1hdc

Steve N4IRS <szingman@...> escreveu no dia segunda, 6/07/2020 à(s) 18:43:
How did you do your install? is this RPIOS or Raspbian?
cat /etc/os-release?
uname -a

Steve N4IRS

On 7/6/20 1:07 PM, ik1zvk@... wrote:
Hi everyone,

Fresh Raspian installatiom,
on RPI 4 4 GB,
i have installed dvswitch but i obtain this error:


Configurazione di mmdvm-bridge (1.5-20200427-23)...
Error, DMR ID file does not seem to be valid
dpkg: errore nell'elaborare il pacchetto mmdvm-bridge (--configure):
 il sottoprocesso installato pacchetto mmdvm-bridge script post-installation ha restituito lo stato di errore 251
Si sono verificati degli errori nell'elaborazione:
 mmdvm-bridge
E: Sub-process /usr/bin/dpkg returned an error code (1


I can not find In /usr/local/sbin
/usr/local/sbin/DMRIDUpdate.sh

Anyone can help me?

Thanks in advance Amedeo IK1ZVK



Re: enabling an AMBE dongle

Steve N4IRS
 

It's all about power.

On 7/6/20 1:43 PM, Aerodan wrote:
I'm using the ThumbDV without issue. The solution for me, not skipping any of these steps:

1_ Make sure that the Pi4 works with DMR and the default audio driver. If not, ThumbDV isn't the issue.

2_ I picked up a "Nekteck 72W 4 port USB C wall charger station" from Amazon.

3_ Plugged my entire Raspberry Pi4 into it the Nekteck. I have two Pi4's running off of it without issue, one with ThumbDV one without. That's all that I have powered.

4_ Plugged ThumbDV in one of the Pi4's USB 2.0 ports. Run AMBEtest4 a couple of times to be sure it's working.

5_ Run AMBEtest4 a couple of times and verify that the ThumbDV passes.




Re: enabling an AMBE dongle

Aerodan
 

I'm using the ThumbDV without issue. The solution for me, not skipping any of these steps:

1_ Make sure that the Pi4 works with DMR and the default audio driver. If not, ThumbDV isn't the issue.

2_ I picked up a "Nekteck 72W 4 port USB C wall charger station" from Amazon.

3_ Plugged my entire Raspberry Pi4 into it the Nekteck. I have two Pi4's running off of it without issue, one with ThumbDV one without. That's all that I have powered.

4_ Plugged ThumbDV in one of the Pi4's USB 2.0 ports. Run AMBEtest4 a couple of times to be sure it's working.

5_ Run AMBEtest4 a couple of times and verify that the ThumbDV passes.



Re: Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

Steve N4IRS
 

How did you do your install? is this RPIOS or Raspbian?
cat /etc/os-release?
uname -a

Steve N4IRS

On 7/6/20 1:07 PM, ik1zvk@... wrote:
Hi everyone,

Fresh Raspian installatiom,
on RPI 4 4 GB,
i have installed dvswitch but i obtain this error:


Configurazione di mmdvm-bridge (1.5-20200427-23)...
Error, DMR ID file does not seem to be valid
dpkg: errore nell'elaborare il pacchetto mmdvm-bridge (--configure):
 il sottoprocesso installato pacchetto mmdvm-bridge script post-installation ha restituito lo stato di errore 251
Si sono verificati degli errori nell'elaborazione:
 mmdvm-bridge
E: Sub-process /usr/bin/dpkg returned an error code (1


I can not find In /usr/local/sbin
/usr/local/sbin/DMRIDUpdate.sh

Anyone can help me?

Thanks in advance Amedeo IK1ZVK


Error mmdvm_bridge after new installation; not find DMRDMRIDUpdate.sh #mmdvm_bridge #dmrlink

Amedeo
 

Hi everyone,

Fresh Raspian installatiom,
on RPI 4 4 GB,
i have installed dvswitch but i obtain this error:


Configurazione di mmdvm-bridge (1.5-20200427-23)...
Error, DMR ID file does not seem to be valid
dpkg: errore nell'elaborare il pacchetto mmdvm-bridge (--configure):
 il sottoprocesso installato pacchetto mmdvm-bridge script post-installation ha restituito lo stato di errore 251
Si sono verificati degli errori nell'elaborazione:
 mmdvm-bridge
E: Sub-process /usr/bin/dpkg returned an error code (1


I can not find In /usr/local/sbin
/usr/local/sbin/DMRIDUpdate.sh

Anyone can help me?

Thanks in advance Amedeo IK1ZVK


Re: enabling an AMBE dongle

Steve N4IRS
 

2 channels for WHAT to work? Analog_Bridge does not need 2 hardware vocoders to work.

On 7/6/20 12:15 PM, Curt Hart via groups.io wrote:
Because you need at least 2 channels for it to work.

On Monday, July 6, 2020, 10:40:02 AM CDT, Steve N4IRS <szingman@...> wrote:


Why a pair?

On 7/6/20 11:39 AM, Curt Hart via groups.io wrote:
Thumb DV works great, Northwest Digital, but you need at least a pair.

73,
Curtis - N9INK

On Monday, July 6, 2020, 10:36:33 AM CDT, Steve N4IRS <szingman@...> wrote:


Hard to say, not seeing much info. I THINK the DV stick30 will work with AMBEserver  <https://github.com/marrold/AMBEServer>

On 7/6/20 11:29 AM, Derek William Haden wrote:

I am clearly fighting a losing battle here.

I assume the DVmega version works OK?





Re: enabling an AMBE dongle

Curt Hart
 

Because you need at least 2 channels for it to work.

On Monday, July 6, 2020, 10:40:02 AM CDT, Steve N4IRS <szingman@...> wrote:


Why a pair?

On 7/6/20 11:39 AM, Curt Hart via groups.io wrote:
Thumb DV works great, Northwest Digital, but you need at least a pair.

73,
Curtis - N9INK

On Monday, July 6, 2020, 10:36:33 AM CDT, Steve N4IRS <szingman@...> wrote:


Hard to say, not seeing much info. I THINK the DV stick30 will work with AMBEserver  <https://github.com/marrold/AMBEServer>

On 7/6/20 11:29 AM, Derek William Haden wrote:

I am clearly fighting a losing battle here.

I assume the DVmega version works OK?




Re: enabling an AMBE dongle

Steve N4IRS
 

Why a pair?

On 7/6/20 11:39 AM, Curt Hart via groups.io wrote:
Thumb DV works great, Northwest Digital, but you need at least a pair.

73,
Curtis - N9INK

On Monday, July 6, 2020, 10:36:33 AM CDT, Steve N4IRS <szingman@...> wrote:


Hard to say, not seeing much info. I THINK the DV stick30 will work with AMBEserver  <https://github.com/marrold/AMBEServer>

On 7/6/20 11:29 AM, Derek William Haden wrote:

I am clearly fighting a losing battle here.

I assume the DVmega version works OK?




Re: enabling an AMBE dongle

Curt Hart
 

Thumb DV works great, Northwest Digital, but you need at least a pair.

73,
Curtis - N9INK

On Monday, July 6, 2020, 10:36:33 AM CDT, Steve N4IRS <szingman@...> wrote:


Hard to say, not seeing much info. I THINK the DV stick30 will work with AMBEserver  <https://github.com/marrold/AMBEServer>

On 7/6/20 11:29 AM, Derek William Haden wrote:

I am clearly fighting a losing battle here.

I assume the DVmega version works OK?



Re: enabling an AMBE dongle

Steve N4IRS
 

Hard to say, not seeing much info. I THINK the DV stick30 will work with AMBEserver  <https://github.com/marrold/AMBEServer>

On 7/6/20 11:29 AM, Derek William Haden wrote:

I am clearly fighting a losing battle here.

I assume the DVmega version works OK?



Re: enabling an AMBE dongle

Derek William Haden <facebook@...>
 

I am clearly fighting a losing battle here.

I assume the DVmega version works OK?


Re: enabling an AMBE dongle

Steve N4IRS
 

It may, AMBEtest4 is your friend. Try it.

On 7/5/20 12:55 PM, Derek William Haden wrote:
Thanks for all your help. I could not have got this far on my own.

Would a powered USB hub help?


Re: enabling an AMBE dongle

Derek William Haden <facebook@...>
 

Thanks for all your help. I could not have got this far on my own.

Would a powered USB hub help?


Re: enabling an AMBE dongle

Steve N4IRS
 

My guess it's on the edge for power. I would keep an eye on the log.

On 7/5/20 12:30 PM, Derek William Haden wrote:
systemctl status analog_bridge
tells me it's running, however it's not accessing the dongle.
systemctl stop analog_bridge
remove and reinsert dongle
systemctl start analog_bridge

Bingo! works, just not an ideal startup procedure.


Re: enabling an AMBE dongle

Derek William Haden <facebook@...>
 

systemctl status analog_bridge
tells me it's running, however it's not accessing the dongle.
systemctl stop analog_bridge
remove and reinsert dongle
systemctl start analog_bridge

Bingo! works, just not an ideal startup procedure.


Re: enabling an AMBE dongle

Steve N4IRS
 

How are you deciding it's running?
My bet is on power. The better gauge of wire, the better chance if the DV3000 running on a Pi.
See this:
https://dvswitch.groups.io/g/main/message/315?p=,,,20,0,0,0::relevance,,DV3000+reset,20,2,0,5521534

On 7/5/20 11:56 AM, Derek William Haden wrote:

Thanks Steve and John.

I can get it working, it's a faff but it's working.

I restart the Rpi, once it's all settled. Check the status of the AB which says it's running.
Stop the AB
remove dongle and then reinsert
Start AB

done job, works.

So I'm guessing it's a timing issue?
any thoughts?



Re: enabling an AMBE dongle

Derek William Haden <facebook@...>
 

Thanks Steve and John.

I can get it working, it's a faff but it's working.

I restart the Rpi, once it's all settled. Check the status of the AB which says it's running.
Stop the AB
remove dongle and then reinsert
Start AB

done job, works.

So I'm guessing it's a timing issue?
any thoughts?


Re: enabling an AMBE dongle

Steve N4IRS
 

This is not good:
M: 2020-07-05 15:22:15.584 Connecting to DV3000 hardware......
E: 2020-07-05 15:22:15.651 DV3000 header is short.  byte count=-1
W: 2020-07-05 15:22:15.692 DV3000 did not reset at /dev/ttyUSB0:2460
W: 2020-07-05 15:22:15.692 DV3000 not found at /dev/ttyUSB0:2460 (Reset failed

You can try what John suggests. If not, I suggest you talk to DVlink support, I don't know how they are using the DVSwitch components.

Steve N4IRS

On 7/5/20 11:30 AM, John D Hays - K7VE wrote:

Sometimes when you run the test script and it opens the USB port at a different baud rate, you need to remove and reinsert the device and run again at the right baud rate.

 

What brand and model of AMBE-3000 device are you using?



Re: enabling an AMBE dongle

Derek William Haden <facebook@...>
 

NWDigital 

3041 - 3060 of 9775