Date   

Re: Analog Bridge Binds to the same port

 

If you are running the ambeserver on the same device.

address = 127.0.0.1                   ; IP address of AMBEServer
rxPort = 2460                         ; Port of AMBEServer
address = /dev/ttyUSB0              ; Device of DV3000U on this machine
baud = 460800                       ; Baud rate of the dongle (230400 or 460800)
serial = false                       ; Use serial=true for direct connect or serial=false for AMBEServer
I found that I needed the bottom three lines as well.


Re: Analog Bridge Binds to the same port

Matthew 2E0SIP
 

Cheers Steve. In the short term I've shifted AMBEServer to another Pi. In the medium term I might experiment with running it in Docker, but I'm not an expert on that front. 


Re: Analog Bridge Binds to the same port

Steve N4IRS
 

You are correct. The change that was made recently had to do with the emulator. Mike is looking at making the same type of change for AMBE_Server. I'll keep you informed.

Steve

On 6/1/2020 9:23 AM, Matthew 2E0SIP wrote:

Hi Steve,

I pulled the latest and had the same issue. If I start AMBEServer and it binds to 2460, then start Analog_Bridge, AB tries to bind to the same port and can't.

Thanks



Re: Analog Bridge Binds to the same port

Matthew 2E0SIP
 

Hi Steve,

I pulled the latest and had the same issue. If I start AMBEServer and it binds to 2460, then start Analog_Bridge, AB tries to bind to the same port and can't.

Thanks


Re: Analog Bridge Binds to the same port

Steve N4IRS
 

Yes, grab the latest from github and re-test

On 6/1/2020 8:35 AM, Matthew 2E0SIP wrote:
Architecture is armhf

I'm using the latest version from the repo. Should I be pulling from Github? 

Thanks


Re: Analog Bridge Binds to the same port

Matthew 2E0SIP
 

Architecture is armhf

I'm using the latest version from the repo. Should I be pulling from Github? 

Thanks


Re: Analog Bridge Binds to the same port

Steve N4IRS
 

Matt,
Are you running the most current version from github? What architecture are you running on?

73, Steve N4IRS

On 6/1/20 5:22 AM, Matthew 2E0SIP wrote:

Hi All, 

I am attempting to use a modified version of AMBESever in order to use a DVMega AMBE 3000 board that's not supported by Analog_Bridge (Github Issue).

However, Analog_Bridge binds to the rxPort itself, so it won't start if AMBEServer is running on the same host. 

[DV3000]
address = 127.0.0.1                ; IP address of AMBEServer
rxPort = 2461                      ; Port of AMBEServer

In a future version of Analog Bridge would it be possible to define a local port, or bind to a random port? I appreciate this is an unusual use case.

Thanks!


Analog Bridge Binds to the same port

Matthew 2E0SIP
 

Hi All, 

I am attempting to use a modified version of AMBESever in order to use a DVMega AMBE 3000 board that's not supported by Analog_Bridge (Github Issue).

However, Analog_Bridge binds to the rxPort itself, so it won't start if AMBEServer is running on the same host. 

[DV3000]
address = 127.0.0.1                ; IP address of AMBEServer
rxPort = 2461                      ; Port of AMBEServer

In a future version of Analog Bridge would it be possible to define a local port, or bind to a random port? I appreciate this is an unusual use case.

Thanks!


Re: ASL_node_list.txt

Tom Corcoran
 

Followed your directions and the nodes_list.txt file uploads to the android device. However, when I initiate the IAX2 ASL profile, select Macro on the Dialer page, select Nodes, select an Allstar node, the command that is issued is a *2 command (i.e. monitor only). How do I change this so it is a *3 command initiating connection?

--
Tom VE3NY


Re: Will Nextion Screen work with dvswitch?

Steve N4IRS
 

On 5/31/20 4:34 PM, Andre VE3SP 🇨🇦 wrote:

thanks for the very useful information within.


--

73s,   Warmest wishes to you and blessings to your family.
Andre 
Toronto, CANADA 🇨🇦 
🌐 website VE3SP.com

VE3SP.com 


Re: Will Nextion Screen work with dvswitch?

 

thanks for the very useful information within.


--

73s,   Warmest wishes to you and blessings to your family.
Andre 
Toronto, CANADA 🇨🇦 
🌐 website VE3SP.com

VE3SP.com 


Re: MMDVM_Bridge doesn't appear to be connecting to ircddbgateway

Matthew 2E0SIP
 

Ah, that solved it. I think at some point subscriber_ids.csv was in the wrong format. I've updated it, restarted everything, and now its working, hopefully.


Re: MMDVM_Bridge doesn't appear to be connecting to ircddbgateway

Matthew 2E0SIP
 

Hi Steve,

I'll see if I can schedule something with another Amateur on a DCS reflector.

I noticed in a packet capture I'm sending a DMR ID in place of a Call Sign in the packet to XLX:


This is what it looks like from a D-Star user:


On the DMR side of Analog_Bridge I see this:

I: 2020-05-31 19:43:37.056 Begin TX: src=2343265 rpt=0 dst=2348479 slot=2 cc=0 call=2343265

I wonder if this is causing the issue. Do you know why this would happen? subscriber_ids.csv is up to date and includes my DMR ID, so I'd expect to see my callsign

Thanks

 

 


Re: MMDVM_Bridge doesn't appear to be connecting to ircddbgateway

Steve N4IRS
 

I was wondering if you could connect to a "real" DCS reflector. I wanted to talk XLX out of the mix for the test.

On 5/31/20 12:02 PM, Matthew 2E0SIP wrote:

Ok, is the Talk Group significant? I tried connecting to another XLX server via DCS but same issue, I appear as connected, I see a stream of packets to the server when I Tx, but nothing appears on the XLX Server. I can receive DStar transmissions on the DMR side without any issues.


Does anyone have a known good Analog_Bridge.ini, MMDVM_Bridge.ini and DVSwitch.ini for a link to XLX / DStar ?  

And for what it's worth, I know in theory I could connect directly to XLX with DMR, but this server doesn't have any transcoding capability at present.

Cheers



Re: MMDVM_Bridge doesn't appear to be connecting to ircddbgateway

Matthew 2E0SIP
 

Ok, is the Talk Group significant? I tried connecting to another XLX server via DCS but same issue, I appear as connected, I see a stream of packets to the server when I Tx, but nothing appears on the XLX Server. I can receive DStar transmissions on the DMR side without any issues.


Does anyone have a known good Analog_Bridge.ini, MMDVM_Bridge.ini and DVSwitch.ini for a link to XLX / DStar ?  

And for what it's worth, I know in theory I could connect directly to XLX with DMR, but this server doesn't have any transcoding capability at present.

Cheers


Re: MMDVM_Bridge doesn't appear to be connecting to ircddbgateway

Steve N4IRS
 

As far as IDs go, I don't THINK there is any validation for XLX. the DMR instance of AB will try to lookup a DMRID to callsign and pass that on through the bridge. Check the D-Star MB log and make sure the callsigns are being sent on to XLX.

On 5/31/20 11:43 AM, Matthew 2E0SIP wrote:
Hi Steve,

Good Idea, I'll give it a go. 

I don't see much in the ircddblog, other than Gateway and User updates. This seems to be only relevant line:

M: 2020-05-31 15:32:43: From RF
M: 2020-05-31 15:32:43: 0000:  32 36 42 30 30 43 33 20 20                         *26B00C3  *

A few things spring to mind, is there any validation on the IDs used? They're registered as DMR IDs but I don't know if something special is required for D-Star.
 
Secondly, for the DStar instance of Analog_Bridge, does the following work? Should I be using a specific TG etc to get into XLX? 

; The metadata below is used when ASL is the source since it does not have any concept of digital modes
gatewayDmrId = 2348479                  ; ID to use when transmitting from Analog_Bridge 7 digit ID
repeaterID = 234847911                  ; ID of source repeater 7 digit ID plus 2 digit SSID
txTg = 4003                          ; TG to use for all frames sent from Analog_Bridge -> xx_Bridge
txTs = 2                                ; Slot to use for frames sent from Analog_Bridge -> xx_Bridge
colorCode = 1                           ; Color Code to assign DMR frames

Thanks
Matthew


Re: MMDVM_Bridge doesn't appear to be connecting to ircddbgateway

Matthew 2E0SIP
 

Hi Steve,

Good Idea, I'll give it a go. 

I don't see much in the ircddblog, other than Gateway and User updates. This seems to be only relevant line:

M: 2020-05-31 15:32:43: From RF
M: 2020-05-31 15:32:43: 0000:  32 36 42 30 30 43 33 20 20                         *26B00C3  *

A few things spring to mind, is there any validation on the IDs used? They're registered as DMR IDs but I don't know if something special is required for D-Star.
 
Secondly, for the DStar instance of Analog_Bridge, does the following work? Should I be using a specific TG etc to get into XLX? 

; The metadata below is used when ASL is the source since it does not have any concept of digital modes
gatewayDmrId = 2348479                  ; ID to use when transmitting from Analog_Bridge 7 digit ID
repeaterID = 234847911                  ; ID of source repeater 7 digit ID plus 2 digit SSID
txTg = 4003                          ; TG to use for all frames sent from Analog_Bridge -> xx_Bridge
txTs = 2                                ; Slot to use for frames sent from Analog_Bridge -> xx_Bridge
colorCode = 1                           ; Color Code to assign DMR frames

Thanks
Matthew


Re: MMDVM_Bridge doesn't appear to be connecting to ircddbgateway

Steve N4IRS
 

Matt,
Have you tried connecting to a DCS reflector as a test? Anything in the ircDDBGateway log?

Steve

On 5/31/20 10:05 AM, Matthew 2E0SIP wrote:

[Edited Message Follows]

Thanks both! I think it was just a case of not seeing the logs, but it was working in the background.
 
Mike - I've updated the Modules to match.

I've got a bit further and I'm now running :
 
DMR <-> MMDVM_Bridge <-> Analog Bridge <-> Analog Bridge <-> MMDVM_Bridge <-> ircddbgateway <-> DStar XLX

I can DStar to DMR is working, but DMR to DStar is not. Transcoding seems to be working, both Analog Bridge instances are showing Ptt Up etc, and AMBE frames are reaching both dongles.

I see packets get as far as XLX, but nothing is showing in the Dashboard. Am I missing something? - ircddbgateway is showing as logged in on the dashboard.
 
Thanks again
 
Edited: ( I can actually see packets reaching XLX, but nothing on the Dash, and DStar users don't receive anything) 


Re: MMDVM_Bridge doesn't appear to be connecting to ircddbgateway

Matthew 2E0SIP
 
Edited

Thanks both! I think it was just a case of not seeing the logs, but it was working in the background.
 
Mike - I've updated the Modules to match.

I've got a bit further and I'm now running :
 
DMR <-> MMDVM_Bridge <-> Analog Bridge <-> Analog Bridge <-> MMDVM_Bridge <-> ircddbgateway <-> DStar XLX

I can DStar to DMR is working, but DMR to DStar is not. Transcoding seems to be working, both Analog Bridge instances are showing Ptt Up etc, and AMBE frames are reaching both dongles.

I see packets get as far as XLX, but nothing is showing in the Dashboard. Am I missing something? - ircddbgateway is showing as logged in on the dashboard.
 
Thanks again
 
Edited: ( I can actually see packets reaching XLX, but nothing on the Dash, and DStar users don't receive anything) 


attenuating USRP gain post-AGC processing

Patrick Perdue
 

Hi:

I have a bridge set up using AGC with the following parameters:

usrpAudio = AUDIO_USE_AGC                 ; Digital -> Analog (AUDIO_UNITY, AUDIO_USE_GAIN, AUDIO_USE_AGC)
usrpGain = 0.50                         ; Gain factor when usrpAudio = AUDIO_USE_GAIN (0.0 to 5.0) (1.0 = AUDIO_UNITY)
usrpAgc = -19,10,200                    ; Set the agc threshold (db), slope (db) and decay (ms)
This sounds great, but I want to reduce the output of the processed audio by just a couple DB going into ASL. It doesn't appear that the usrpGain value does anything when set to usrpAudio = AUDIO_USE_AGC, which, I believe, is expected behavior.

Yes, I could raise the threshold to something closer to 0, but I want the processing as-is, just with a trim on the output. Actually, I would like to possibly make the processing even more aggressive (lower threshold and longer release) to comp for some lower levels and keep higher ones in check), but then reduce that output by, say, 3 to 6 db coming into ASL's USRP driver. Is this at all possible with one instance of A_B, or can I use a second instance of A_B just as an attenuater? With older versions of A_B, this could be done, but the AGC algorithm was practically useless.

3261 - 3280 of 9753