Date   

Re: Emulator timed out on encode!

Steve N4IRS
 

When you say, "known good image" ???

On 3/12/21 2:34 PM, G4WXN@... wrote:
Made a fresh SD card from a known good image, still same problem.

Could there be a hardware error with the Rpi?

I'm really clutching at straws now.

--
Derek

G4WXN


Re: YSF<>Echolink - can someone explain if it's possible and what I need to install on my linux server? #analog_bridge

 

On 13/3/21 4:54 am, hello@hamzah.net wrote:
I run a YSF Reflector for the community on a linux machine and would
like to bridge it to echolink. 
I am so confused about all the different software packages,
mmdvmbridge, analogbridge, allstarlink etc.. 

Please can someone tell me what I need to set up and connect what to
what in order to make it work?
Would be much appreciated. 73
Yes it's possible (I'm doing it as a subset of a much bigger system). 
Easiest path is to use an AllStar node with Echolink capability
configured linked to Analog_Bridge and MMDVM_Bridge, talking to your YSF
Reflector.

It is possible to use SvxLink with svxbridge, instead of AllStar, but
this is a significantly more difficult path, I'd go with ASL..

--
73 de Tony VK3JED/VK3IRL
http://vkradio.com


Re: M17 to ASL

 

On 13/3/21 1:34 am, Steve KC1AWV wrote:
Tony, my thoughts exactly. A path between two points should be made as
simple as possible.
Yes, I have a principle of doing as little as possible with the audio,
and that principle goes back to the early days of EchoIRLP (way back in
2002-2003), where I theorised that it should be possible to pass traffic
from Echolink to IRLP without decompressing the audio, which others were
able to implement in code.  This became a feature of EchoIRLP and the
shared IRLP/Echolink conferences in use today.

I was unaware of the Codec2 server. This should make things a whole
lot easier. M17Gateway exists as a 'beta', in the sense that it's not
completely tested.
Yep, why reinvent the wheel, when all you need to do is bolt an existing
wheel onto your new axle? :)

https://github.com/g4klx/M17Gateway

I think we have the parts, we just need a plan to put them together.
I have a feeling you're right.

--
73 de Tony VK3JED/VK3IRL
http://vkradio.com


Re: Emulator timed out on encode!

G4WXN@...
 

Made a fresh SD card from a known good image, still same problem.

Could there be a hardware error with the Rpi?

I'm really clutching at straws now.

--
Derek

G4WXN


Re: Decoder error

G4WXN@...
 

Did you ever resolve this?

I am having exactly the same problem, and have been unable to resolve.

--
Derek

G4WXN


YSF<>Echolink - can someone explain if it's possible and what I need to install on my linux server? #analog_bridge

@hamzahradio
 

I run a YSF Reflector for the community on a linux machine and would like to bridge it to echolink. 
I am so confused about all the different software packages, mmdvmbridge, analogbridge, allstarlink etc.. 

Please can someone tell me what I need to set up and connect what to what in order to make it work?
Would be much appreciated. 73


Re: M17 to ASL

Steve KC1AWV
 

Tony, my thoughts exactly. A path between two points should be made as simple as possible.

I was unaware of the Codec2 server. This should make things a whole lot easier. M17Gateway exists as a 'beta', in the sense that it's not completely tested.

https://github.com/g4klx/M17Gateway

I think we have the parts, we just need a plan to put them together.

Steve KC1AWV


Re: Emulator timed out on encode!

Steve N4IRS
 

Yes,
Only one copy running. Start over

On 3/12/21 7:08 AM, G4WXN@... wrote:
I assumed you meant ps and not pa

ps ax | grep md380-emu

974 pts/0    S+     0:00 grep --color=auto md380-emu
 
--
Derek

G4WXN


Re: Emulator timed out on encode!

G4WXN@...
 

I assumed you meant ps and not pa

ps ax | grep md380-emu

974 pts/0    S+     0:00 grep --color=auto md380-emu
 
--
Derek

G4WXN


Re: Emulator timed out on encode!

Steve N4IRS
 

Stop the emulator:
systemctl stop md380-emu

Check for another instance running:
pa ax | grep md380-emu



On 3/12/21 6:58 AM, G4WXN@... wrote:
All looks good in the AB log until I press PTT and then the error 

Emulator timed out on encode!

I have another install of DVS on a netbook which I normally use for DMR+ and FreeDMR, I switched that over to Brandmeister and all worked fine.

Anything else I can do to test, before I wipe the card and start again?

--
Derek

G4WXN


Re: Emulator timed out on encode!

G4WXN@...
 

All looks good in the AB log until I press PTT and then the error 

Emulator timed out on encode!

I have another install of DVS on a netbook which I normally use for DMR+ and FreeDMR, I switched that over to Brandmeister and all worked fine.

Anything else I can do to test, before I wipe the card and start again?

--
Derek

G4WXN


Re: Emulator timed out on encode!

Steve N4IRS
 

Yes it is.

On 3/12/21 6:44 AM, G4WXN@... wrote:
Here's the output from that.
Looks like the emulator is running.
---------------------
● md380-emu.service - MD-380 Emulator Service
   Loaded: loaded (/lib/systemd/system/md380-emu.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2021-03-12 11:07:12 GMT; 36min ago
 Main PID: 875 (md380-emu)
    Tasks: 1 (limit: 2062)
   CGroup: /system.slice/md380-emu.service
           └─875 /opt/md380-emu/md380-emu -S 2470
 
Mar 12 11:07:12 DVSwitch4 systemd[1]: Started MD-380 Emulator Service.
 
--
Derek

G4WXN


Re: Emulator timed out on encode!

G4WXN@...
 

Here's the output from that.
Looks like the emulator is running.
---------------------
● md380-emu.service - MD-380 Emulator Service
   Loaded: loaded (/lib/systemd/system/md380-emu.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2021-03-12 11:07:12 GMT; 36min ago
 Main PID: 875 (md380-emu)
    Tasks: 1 (limit: 2062)
   CGroup: /system.slice/md380-emu.service
           └─875 /opt/md380-emu/md380-emu -S 2470
 
Mar 12 11:07:12 DVSwitch4 systemd[1]: Started MD-380 Emulator Service.
 
--
Derek

G4WXN


Re: Emulator timed out on encode!

Steve N4IRS
 

OK, that's clean.
to verify emulator is running:
systemctl status md380-emu

On 3/12/21 6:35 AM, G4WXN@... wrote:

Sorry, posted the AB.ini from the Rpi I use for DStar

The correct one is now attached.

All was working fine early yesterday, the only problem I had at the time was that i was only seeing DMR ids on the client.

I ran DVSM_update after that this issue started.

--
Derek

G4WXN



Re: Emulator timed out on encode!

G4WXN@...
 

Sorry, posted the AB.ini from the Rpi I use for DStar

The correct one is now attached.

All was working fine early yesterday, the only problem I had at the time was that i was only seeing DMR ids on the client.

I ran DVSM_update after that this issue started.

--
Derek

G4WXN


Re: Emulator timed out on encode!

Steve N4IRS
 

These are the settings for you to look at:

[GENERAL]

; General vocoder setup information
decoderFallBack = false            ; Allow software AMBE decoding if a hardware decoder is not found
useEmulator = false                ; Use the MD380 AMBE emulator for AMBE72 (DMR/YSFN/NXDN)
emulatorAddress = 127.0.0.1:2470   ; IP address and port of the md380 server

[DV3000]
;address = 127.0.0.1               ; IP address of AMBEServer
;rxPort = 2471                     ; Port of AMBEServer
address = /dev/ttyUSB0             ; Device of DV3000U on this machine
baud = 460800                      ; Baud rate of the dongle (230400 or 460800)
serial = true                      ; Use serial=true for direct connect or serial=false for AMBEServer


You are not set to use the emulator or fall back to the vocoder built into Analog_Bridge
You are setup to use a hardware vocoder plugged into the USB port

If this is not what you want, fix the settings above.

Steve N4IRS

On 3/12/21 4:55 AM, G4WXN@... wrote:
I was seeing activity on the android device, but no audio.

How can I test to see if the emulator is running?

AB.ini file attached.

Thanks for your time.
--
Derek

G4WXN


Re: Emulator timed out on encode!

G4WXN@...
 

I was seeing activity on the android device, but no audio.

How can I test to see if the emulator is running?

AB.ini file attached.

Thanks for your time.
--
Derek

G4WXN


Re: M17 to ASL

 

Yep, that sounds reasonable.  The Codec2 server already exists, might as well make use of what's already out there.

On 12/3/21 6:14 pm, SP2ONG Waldek wrote:
The Codec2 server is used in DMRStation project:

https://github.com/ea3ihi/DMRStation/blob/master/DMRStation.ini

# md380-emu
[ambe]
ambeServerHost=127.0.0.1
ambeServerPort=2460
 

#Codec2 server

[codec2]
codec2ServerHost=127.0.0.1
codec2ServerPort=2470
enabled=0
 

So it looks like similar in Analog_Bridge


-- 
73 de Tony VK3JED/VK3IRL
http://vkradio.com


Re: M17 to ASL

 

This sounds like a really good way to do it.

On 12/3/21 6:10 pm, SP2ONG Waldek wrote:
Perhaps this would require adding Codec2 support and an M17 mode to Analog_Bridge similar to use md380-emu.
The Codec2 server version is available

https://github.com/ea3ihi/codec2

and it can be used in a similar way as md380-emu via UDP port


-- 
73 de Tony VK3JED/VK3IRL
http://vkradio.com


Re: M17 to ASL

SP2ONG Waldek
 

The Codec2 server is used in DMRStation project:

https://github.com/ea3ihi/DMRStation/blob/master/DMRStation.ini

# md380-emu
[ambe]
ambeServerHost=127.0.0.1
ambeServerPort=2460
 

#Codec2 server

[codec2]
codec2ServerHost=127.0.0.1
codec2ServerPort=2470
enabled=0
 

So it looks like similar in Analog_Bridge

421 - 440 of 9203