Date   

Re: Error running Analog_bridge

Jeff Scoville
 

Result from cat /etc/*-release:

AME="cpe:/o:amazon:linux:2018.03:ga"
HOME_URL="http://aws.amazon.com/amazon-linux-ami/"
Amazon Linux AMI release 2018.03

As I stated in my post, I am running a AWS Linux.  Looks like it's time to spin up a Debian machine on AWS if there is no way to get the appropriate shared libraries loaded to run.

--Jeff AE5ME


Re: Error running Analog_bridge

Mike KB8JNM
 

What full version of linux are you running.

cat /etc/*-release

It appears you are using 'centos'

You should be using 'Debian v9' to be par with the program.

Best advise is to stay on the beaten path, especially till you understand the software and setup.


On 4/7/2019 12:10 AM, Jeff Scoville via Groups.Io wrote:
Running Analog_Bridge AMD64 version, on AWS Linux, I get an error "error while loading shared libraries: libsndfile..........

Can't find libsndfile in yum for installing.  Is there a way to install the required library?

--Jeff AE5ME




Error running Analog_bridge

Jeff Scoville
 

Running Analog_Bridge AMD64 version, on AWS Linux, I get an error "error while loading shared libraries: libsndfile..........

Can't find libsndfile in yum for installing.  Is there a way to install the required library?

--Jeff AE5ME




Re: Bridging a P25Reflector and a YSFReflector?

Alec-N1AJW
 

that's an excellent idea.   Love it.  cant wait to see it work.   Thanks.

Alec
N1AJW


Re: Bridging a P25Reflector and a YSFReflector?

Steve N4IRS
 

Jeff,
Are you trying to Bridge YSF Wide to P25? If so, you will not need Analog_Bridge at all.

On 4/6/19 7:30 AM, Jeff Scoville via Groups.Io wrote:
To use the built-in encoder, just comment out the references to the DV3000 hardware and tell it to fallback to software decoder?


Like this?


General vocoder setup information

decoderFallBack = true                  ; Allow software AMBE decoding if a hardware decoder is not found

useEmulator = true                     ; Use the MD380 AMBE emulator for AMBE72 (DMR/YSFN/NXDN)

emulatorAddress = 127.0.0.1:2472        ; IP address and port of the server

;   There are two configuration modes: IP (AMBEServer) and serial (direct connect hardware)

;   Use top server and port if using AMBEServer

;   Use bottom server/port and serial = true if using the DV3000u (thumbdv)

;   Did you run AMBETest4.py before using this?

[DV3000]

; server = 127.0.0.1                    ; IP address of AMBEServer

; port = 2460                           ; Port of AMBEServer

;server = /dev/ttyUSB0                 ; Device of DV3000U on this machine

;port = 460800                         ; Baud rate of the dongle

;serial = true                         ; Use serial (DV3000U) or IP

 







Re: Bridging a P25Reflector and a YSFReflector?

Jeff Scoville
 

To use the built-in encoder, just comment out the references to the DV3000 hardware and tell it to fallback to software decoder?


Like this?


General vocoder setup information

decoderFallBack = true                  ; Allow software AMBE decoding if a hardware decoder is not found

useEmulator = true                     ; Use the MD380 AMBE emulator for AMBE72 (DMR/YSFN/NXDN)

emulatorAddress = 127.0.0.1:2472        ; IP address and port of the server

;   There are two configuration modes: IP (AMBEServer) and serial (direct connect hardware)

;   Use top server and port if using AMBEServer

;   Use bottom server/port and serial = true if using the DV3000u (thumbdv)

;   Did you run AMBETest4.py before using this?

[DV3000]

; server = 127.0.0.1                    ; IP address of AMBEServer

; port = 2460                           ; Port of AMBEServer

;server = /dev/ttyUSB0                 ; Device of DV3000U on this machine

;port = 460800                         ; Baud rate of the dongle

;serial = true                         ; Use serial (DV3000U) or IP

 






Re: Bridging a P25Reflector and a YSFReflector?

Steve N4IRS
 

With Analog_Bridge you have the following software only choices, in order of quality:
IMBE: OP25 IMBE Vocoder built-in
AMBE: md380-emu, OP25 AMBE Vocoder built-in

On 4/5/19 11:45 PM, Jeff Scoville via Groups.Io wrote:
What are the choices for software AMBE and IMBE encoders/decoders? Preference is to run on an AWS cloud server, so hardware would be last choice.

--Jeff AE5ME


Re: Bridging a P25Reflector and a YSFReflector?

Scott Martin
 

On 4/5/19 10:45 PM, Jeff Scoville via Groups.Io wrote:
What are the choices for software AMBE and IMBE encoders/decoders? Preference is to run on an AWS cloud server, so hardware would be last choice.

--Jeff AE5ME
This is about the only one I know of, good luck!

https://github.com/f4exb/dsdcc


--
Be well,
Scott

...
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?


Re: Bridging a P25Reflector and a YSFReflector?

Jeff Scoville
 

What are the choices for software AMBE and IMBE encoders/decoders? Preference is to run on an AWS cloud server, so hardware would be last choice.

--Jeff AE5ME


Re: Bridging a P25Reflector and a YSFReflector?

Mike Zingman - N4IRR
 
Edited

Jeff,

Yes, if you are doing a "like mode" bridge (IMBE to IMBE or AMBE to AMBE) then you never have to go through an analog conversion.  But if the modes are different, there is no choice.

Now, the following is to all watching this thread:
There is a problem with YSF (it is a good kind of problem to have); the reflector accepts both YSFN (narrow) and YSFW (wide) transmissions.  When MB gets these streams, it does know the data type of the audio but it only has one "transmit" port that sends that stream to the other partner.  So, in the case of:
YSFW <--> P25 the ports should point at each other and no conversion needs to take place
YSFN <--> P25 the audio must be converted (transcoded) and needs to go through AB.

I am proposing adding a new transmit port definition to the DVSwitch.ini for YSFN and YSFW.  You would then be able to point the Wide ports at each other and the Narrow ports to a transcoder.  Also, note that this is only needed for YSFN -> P25 because a Fusion radio even in narrow mode can receive Wide transmissions, so the P25 -> YSFW will decode perfectly and does not need to be transcoded for the conversation to succeed.

So TXPort would be deprecated and TXPortN and TXPortW would be created for the [YSF] stanza

P25 -> YSFW would point the P25 TXPort at the YSF RXPort
YSFW -> P25 would point the YSF TXPortW at the P25 RXPort
YSFN -> P25 would point the YSF TXPortN at an AB transcoder (which would transcode AMBE to IMBE) and send it back to MB on the P25 RXPort

Thoughts?
Mike


Re: Bridging a P25Reflector and a YSFReflector?

Jeff Scoville
 

Steve-- do you have to be running in VW mode on the YSFReflector side for it to be passed to the P25 Reflector side without analog conversion between?  I have a bridge set up as explained above, but I keep getting a message "got AMBE/DSAMBE (TAG=7) and expected IMBE (change to 88 bits).  No audio is coming out on the P25 Reflector side.

Thanks!

--Jeff AE5ME


Re: DV Switch Mobile

Steve N4IRS
 

Mark,
Both DVSwitch Mobile and Zopier connect to a existing AllStar Network node. You can not just connect to the network like Echolink does. The AllStar node does not have to be connected to a radio. This can be built on a Raspberry Pi or in the "cloud".

Hope this helps,
73, Steve N4IRS

On 4/3/2019 5:21 PM, Mark Carroll wrote:
Hi Guys.

Please be patient with me. I have seen this app mentioned on the International Radio Guild website. 

I have downloaded it and tried to get my head around it. Ivwould really like to try it out . However after watching a you tube video on this app and another called Zoiper. I am no further forward.

All i want to try is getting onto the AllStar network. I have been registered on this network for about 5 years. But never done anything about it. Can someone give me some advice?

Thanks for your help 
Mark G1BOP. 


Re: DV Switch Mobile

Pierre Martel
 

I would not go that way as this web site recommand software distributed illegally based on the GPL licence.


Garanti sans virus. www.avast.com


Le mer. 3 avr. 2019 à 19:01, Jason Turning <cturning1@...> a écrit :
Hello Mark,

I'm guessing you haven't setup your own Allstar node yet, which you would connect DVSwitch to. If so you'll first need to setup your own personal node, unless you have someone that will let you access their node. A good place to start for a simple personal node is: 


He has how to build your own cheaply, and where you can buy different audio/radio interface options. He'll even sell you one already modified for a good price. After you have the node working you'll need to setup the iaxrpt access for DVSwitch. Hamvoip.com has a guide on how to set that part up along with setting up their hamvoip software which I run and recommend for its OS base and enhancements to make setup easy.  

Jason - N6WBL


Re: DV Switch Mobile

Jason - WY7JT
 

Hello Mark,

I'm guessing you haven't setup your own Allstar node yet, which you would connect DVSwitch to. If so you'll first need to setup your own personal node, unless you have someone that will let you access their node. A good place to start for a simple personal node is: 


He has how to build your own cheaply, and where you can buy different audio/radio interface options. He'll even sell you one already modified for a good price. After you have the node working you'll need to setup the iaxrpt access for DVSwitch. Hamvoip.com has a guide on how to set that part up along with setting up their hamvoip software which I run and recommend for its OS base and enhancements to make setup easy.  

Jason - N6WBL


Re: DV Switch Mobile

K4VL
 

From what you said you are registered and trying to connect t alistar. You have build an altar node or know someone willing to  allow you access through their node. DV Switch isn't like Echolink. You can't just pick a node and connect to it. 


On Wed, Apr 3, 2019, 4:34 PM Mark Carroll <markcarroll9@...> wrote:
Hi Guys.

Please be patient with me. I have seen this app mentioned on the International Radio Guild website. 

I have downloaded it and tried to get my head around it. Ivwould really like to try it out . However after watching a you tube video on this app and another called Zoiper. I am no further forward.

All i want to try is getting onto the AllStar network. I have been registered on this network for about 5 years. But never done anything about it. Can someone give me some advice?

Thanks for your help 
Mark G1BOP. 


Re: DV Switch Mobile

Steve KC1AWV
 

Hi Mark,

I guess the question is, what is it that you're trying to do? Allstar is VERY different from Zoiper.

What's your end goal?

Steve KC1AWV


On Wed, Apr 3, 2019 at 5:34 PM Mark Carroll <markcarroll9@...> wrote:
Hi Guys.

Please be patient with me. I have seen this app mentioned on the International Radio Guild website. 

I have downloaded it and tried to get my head around it. Ivwould really like to try it out . However after watching a you tube video on this app and another called Zoiper. I am no further forward.

All i want to try is getting onto the AllStar network. I have been registered on this network for about 5 years. But never done anything about it. Can someone give me some advice?

Thanks for your help 
Mark G1BOP. 



--
Steve Miller
KC1AWV


DV Switch Mobile

Mark Carroll
 

Hi Guys.

Please be patient with me. I have seen this app mentioned on the International Radio Guild website. 

I have downloaded it and tried to get my head around it. Ivwould really like to try it out . However after watching a you tube video on this app and another called Zoiper. I am no further forward.

All i want to try is getting onto the AllStar network. I have been registered on this network for about 5 years. But never done anything about it. Can someone give me some advice?

Thanks for your help 
Mark G1BOP. 


Re: ASL <> DMR

Steve KC1AWV
 

Doug,

Is this running on a Raspberry Pi (ARM) or an x86 machine? Try running this .ini file that N4IRS provided in a thread similar to the issue you're having, changing the settings to match your setup.


Steve KC1AWV

On Tue, Apr 2, 2019 at 11:52 PM Doug - W4DBG <douggooden@...> wrote:
Ok, working on a DMR <> ASL setup and it isn't working but I think I know why.... but I don't know how to fix it. I have put what I think the problem is in bold below. Any guidance would be appreciated.

I: 2019-04-03 03:25:25.407 Analog Bridge is starting
M: 2019-04-03 03:25:25.407 Setting [GENERAL] logLevel -> 2
M: 2019-04-03 03:25:25.408 Setting [GENERAL] subscriberFile -> ./subscriber_ids.csv
M: 2019-04-03 03:25:25.408 Setting [GENERAL] exportMetadata -> true
M: 2019-04-03 03:25:25.408 Setting [GENERAL] decoderFallBack -> true
M: 2019-04-03 03:25:25.408 Setting [GENERAL] useEmulator -> true
M: 2019-04-03 03:25:25.408 Setting [GENERAL] emulatorAddress -> 127.0.0.1:2470
W: 2019-04-03 03:25:25.408 Unknown section/name in .ini file: AMBE_AUDIO/address
W: 2019-04-03 03:25:25.408 Unknown section/name in .ini file: AMBE_AUDIO/txPort
W: 2019-04-03 03:25:25.408 Unknown section/name in .ini file: AMBE_AUDIO/rxPort
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] ambeMode -> DMR
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] minTxTimeMS -> 2000
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] gatewayDmrId -> 3101044
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] repeaterID -> 310104405
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] txTg -> 31017
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] txTs -> 2
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] colorCode -> 1
W: 2019-04-03 03:25:25.408 Unknown section/name in .ini file: USRP/address
W: 2019-04-03 03:25:25.409 Unknown section/name in .ini file: USRP/txPort
W: 2019-04-03 03:25:25.409 Unknown section/name in .ini file: USRP/rxPort
M: 2019-04-03 03:25:25.409 Setting [USRP] aslAudio -> AUDIO_USE_GAIN
M: 2019-04-03 03:25:25.409 Setting [USRP] agcGain -> 5
M: 2019-04-03 03:25:25.409 Setting [USRP] dmrAudio -> AUDIO_UUSE_GAIN
M: 2019-04-03 03:25:25.409 Setting [USRP] dmrGain -> 0.50
W: 2019-04-03 03:25:25.409 Unknown section/name in .ini file: DV3000/address
W: 2019-04-03 03:25:25.409 Unknown section/name in .ini file: DV3000/rxPort
W: 2019-04-03 03:25:25.409 ioctl reset error
W: 2019-04-03 03:25:25.409 ioctl speed error
W: 2019-04-03 03:25:25.409 ioctl stereo error
W: 2019-04-03 03:25:25.409 ioctl setfmt error
M: 2019-04-03 03:25:25.409 Audio In/Out Device: /dev/null
I: 2019-04-03 03:25:25.409 Open UDP listener on 127.0.0.1:31000
I: 2019-04-03 03:25:25.409 Open USRP on 127.0.0.1:32001
M: 2019-04-03 03:25:25.409 Connecting to DV3000 hardware......
W: 2019-04-03 03:25:26.417 DV3000 not found at 127.0.0.1:2460
Project 25 IMBE Encoder/Decoder Fixed-Point implementation
Developed by Pavel Yazev E-mail: pyazev@...
Version 1.0 (c) Copyright 2009
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file ``LICENSE'' for details.
I: 2019-04-03 03:25:26.418 Subscriber IDs file not found.
I: 2019-04-03 03:25:26.418 Default extended metadata <3101044>
I: 2019-04-03 03:25:26.418 Connecting to emulator on host 127.0.0.1:2470
W: 2019-04-03 03:25:26.418 Using software MBE decoder version 1.2.3
W: 2019-04-03 03:25:26.419 Using software OP25 IMBE/AMBE vocoder
I: 2019-04-03 03:25:26.419 Starting Analog_Bridge --> USRP thread
I: 2019-04-03 03:25:26.419 Open UDP listener on 127.0.0.1:34001
I: 2019-04-03 03:25:26.419 Starting USRP --> HB_Bridge thread



--
Steve Miller
KC1AWV


ASL <> DMR

Doug - W4DBG
 

Ok, working on a DMR <> ASL setup and it isn't working but I think I know why.... but I don't know how to fix it. I have put what I think the problem is in bold below. Any guidance would be appreciated.

I: 2019-04-03 03:25:25.407 Analog Bridge is starting
M: 2019-04-03 03:25:25.407 Setting [GENERAL] logLevel -> 2
M: 2019-04-03 03:25:25.408 Setting [GENERAL] subscriberFile -> ./subscriber_ids.csv
M: 2019-04-03 03:25:25.408 Setting [GENERAL] exportMetadata -> true
M: 2019-04-03 03:25:25.408 Setting [GENERAL] decoderFallBack -> true
M: 2019-04-03 03:25:25.408 Setting [GENERAL] useEmulator -> true
M: 2019-04-03 03:25:25.408 Setting [GENERAL] emulatorAddress -> 127.0.0.1:2470
W: 2019-04-03 03:25:25.408 Unknown section/name in .ini file: AMBE_AUDIO/address
W: 2019-04-03 03:25:25.408 Unknown section/name in .ini file: AMBE_AUDIO/txPort
W: 2019-04-03 03:25:25.408 Unknown section/name in .ini file: AMBE_AUDIO/rxPort
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] ambeMode -> DMR
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] minTxTimeMS -> 2000
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] gatewayDmrId -> 3101044
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] repeaterID -> 310104405
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] txTg -> 31017
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] txTs -> 2
M: 2019-04-03 03:25:25.408 Setting [AMBE_AUDIO] colorCode -> 1
W: 2019-04-03 03:25:25.408 Unknown section/name in .ini file: USRP/address
W: 2019-04-03 03:25:25.409 Unknown section/name in .ini file: USRP/txPort
W: 2019-04-03 03:25:25.409 Unknown section/name in .ini file: USRP/rxPort
M: 2019-04-03 03:25:25.409 Setting [USRP] aslAudio -> AUDIO_USE_GAIN
M: 2019-04-03 03:25:25.409 Setting [USRP] agcGain -> 5
M: 2019-04-03 03:25:25.409 Setting [USRP] dmrAudio -> AUDIO_UUSE_GAIN
M: 2019-04-03 03:25:25.409 Setting [USRP] dmrGain -> 0.50
W: 2019-04-03 03:25:25.409 Unknown section/name in .ini file: DV3000/address
W: 2019-04-03 03:25:25.409 Unknown section/name in .ini file: DV3000/rxPort
W: 2019-04-03 03:25:25.409 ioctl reset error
W: 2019-04-03 03:25:25.409 ioctl speed error
W: 2019-04-03 03:25:25.409 ioctl stereo error
W: 2019-04-03 03:25:25.409 ioctl setfmt error
M: 2019-04-03 03:25:25.409 Audio In/Out Device: /dev/null
I: 2019-04-03 03:25:25.409 Open UDP listener on 127.0.0.1:31000
I: 2019-04-03 03:25:25.409 Open USRP on 127.0.0.1:32001
M: 2019-04-03 03:25:25.409 Connecting to DV3000 hardware......
W: 2019-04-03 03:25:26.417 DV3000 not found at 127.0.0.1:2460
Project 25 IMBE Encoder/Decoder Fixed-Point implementation
Developed by Pavel Yazev E-mail: pyazev@...
Version 1.0 (c) Copyright 2009
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file ``LICENSE'' for details.
I: 2019-04-03 03:25:26.418 Subscriber IDs file not found.
I: 2019-04-03 03:25:26.418 Default extended metadata <3101044>
I: 2019-04-03 03:25:26.418 Connecting to emulator on host 127.0.0.1:2470
W: 2019-04-03 03:25:26.418 Using software MBE decoder version 1.2.3
W: 2019-04-03 03:25:26.419 Using software OP25 IMBE/AMBE vocoder
I: 2019-04-03 03:25:26.419 Starting Analog_Bridge --> USRP thread
I: 2019-04-03 03:25:26.419 Open UDP listener on 127.0.0.1:34001
I: 2019-04-03 03:25:26.419 Starting USRP --> HB_Bridge thread


Re: BrandMeister to XLX

Steve KC1AWV
 

What does XLX show for the BM user talking? Are users connected to XLX able to talk to other XLX users fine?

On Tue, Apr 2, 2019 at 11:08 AM Kevin Halton <KA1MXL@...> wrote:
Andre

Keep me in the loop on this. I was experiencing the same exact issue. Worked fine for well over a year then one morning just a quick keyup of a second or two. Audio passes from analog to dstar but nothing from dstar across. 


On Apr 2, 2019, at 9:39 AM, André Franco <andre.francoo@...> wrote:

Hi Steve. Great tutorial. However, im getting some problems regarding audio. The audio from XLX to BM works fine, however, when someone talks from the BM side it's just like it was a key up.. it doesn't hang during the whole session. I can see who is talking because the callsign does appear on dashboard. As i said, it's like a key up even if the session is > 20s and someone is talking, it only shows 0.1s. Any help would be appreciated.Thanks



--
Steve Miller
KC1AWV

5901 - 5920 of 9589