Date   

HB Bridge <-> MMDVM_Bridge <-> P25gateway

Michael KD5DFB
 

If I have HB_Bridge connected to MMDVM_bridge and P25gateway shouldn't traffic flow both ways? So if I key up on P25 it should go thru MMDVM_bridge and to HB_Bridge and vise versus 

HB Bridge <-> MMDVM_Bridge <-> P25gateway

Or does it just go out the ports defined in the dvswitch.ini??


Re: MMDVM_Bridge.ini

Steve N4IRS
 

yep

On 1/5/19 9:51 PM, KD5DFB wrote:
Okay, I see it now. It is like the txport and rxport in the dvswitch.ini

On Sat, Jan 5, 2019 at 8:48 PM Steve N4IRS <szingman@...> wrote:
In P25 it is used to communicate with P25Gateway. In DMR it is used if you are using DMRGateway to communicate. Otherwise it is not used for DMR.

On 1/5/19 9:44 PM, KD5DFB wrote:
What is the purpose of the local ports in the MMDVM_Bridge.ini

[DMR Network]
Enable=1
Address=127.0.0.1
Port=54000
Jitter=360
#Local=62032
Password=s3cr37w0rd
Slot1=0
Slot2=1
Debug=1

[P25 Network]
Enable=1
GatewayAddress=127.0.0.1
GatewayPort=42020
LocalPort=32010
Debug=0
 



Re: MMDVM_Bridge.ini

Michael KD5DFB
 

Okay, I see it now. It is like the txport and rxport in the dvswitch.ini

On Sat, Jan 5, 2019 at 8:48 PM Steve N4IRS <szingman@...> wrote:
In P25 it is used to communicate with P25Gateway. In DMR it is used if you are using DMRGateway to communicate. Otherwise it is not used for DMR.

On 1/5/19 9:44 PM, KD5DFB wrote:
What is the purpose of the local ports in the MMDVM_Bridge.ini

[DMR Network]
Enable=1
Address=127.0.0.1
Port=54000
Jitter=360
#Local=62032
Password=s3cr37w0rd
Slot1=0
Slot2=1
Debug=1

[P25 Network]
Enable=1
GatewayAddress=127.0.0.1
GatewayPort=42020
LocalPort=32010
Debug=0
 


Re: MMDVM_Bridge.ini

Steve N4IRS
 

In P25 it is used to communicate with P25Gateway. In DMR it is used if you are using DMRGateway to communicate. Otherwise it is not used for DMR.

On 1/5/19 9:44 PM, KD5DFB wrote:
What is the purpose of the local ports in the MMDVM_Bridge.ini

[DMR Network]
Enable=1
Address=127.0.0.1
Port=54000
Jitter=360
#Local=62032
Password=s3cr37w0rd
Slot1=0
Slot2=1
Debug=1

[P25 Network]
Enable=1
GatewayAddress=127.0.0.1
GatewayPort=42020
LocalPort=32010
Debug=0
 


MMDVM_Bridge.ini

Michael KD5DFB
 

What is the purpose of the local ports in the MMDVM_Bridge.ini

[DMR Network]
Enable=1
Address=127.0.0.1
Port=54000
Jitter=360
#Local=62032
Password=s3cr37w0rd
Slot1=0
Slot2=1
Debug=1

[P25 Network]
Enable=1
GatewayAddress=127.0.0.1
GatewayPort=42020
LocalPort=32010
Debug=0
 


Re: Allstarlink to Echolink showing an error??

Corey Dean N3FE <n3fe@...>
 

I understand but this issue is with allstar and not dvswitch.  I have the same problem and was not able to get it resolved either.  As stated before it is a question for the allstar group, not dvswitch.

On Sat, Jan 5, 2019 at 8:31 AM <jeff@...> wrote:
I can make and receive all Echolink connects inbound and outbound from the node, i continually see this error each time an outbound connection is attempted.
I was just wondering what it is and how to  fix it, it gives an error code of (467) I am guessing it is a IP Address for node number not found error but again it connects..


Re: Allstarlink to Echolink showing an error??

Mike KB8JNM
 

Check your Db servers in the conf file

These work well for me

server1=naeast.echolink.org
server2=nasouth.echolink.org
server3=servers.echolink.org

...mike/kb8jnm

On 1/5/2019 8:31 AM, jeff@... wrote:
I can make and receive all Echolink connects inbound and outbound from the node, i continually see this error each time an outbound connection is attempted.
I was just wondering what it is and how to  fix it, it gives an error code of (467) I am guessing it is a IP Address for node number not found error but again it connects..


Re: Allstarlink to Echolink showing an error??

Jeff Wood
 

I can make and receive all Echolink connects inbound and outbound from the node, i continually see this error each time an outbound connection is attempted.
I was just wondering what it is and how to  fix it, it gives an error code of (467) I am guessing it is a IP Address for node number not found error but again it connects..


Re: DMR<-->P25 Now only one way Audio

Steve N4IRS
 

Put the gateway in debug and verify it is getting data from the reflector

Also I think there is a debug setting in p25 network of mmdvm_bridge.

Sent via smoke signal (Verizon)

On Jan 4, 2019 6:07 PM, Ian Tulley <ian@...> wrote:
Not that I can see Steve, 

Here is the startup,

I: 2019-01-04 23:04:19.346 MMDVM_Bridge:
I: 2019-01-04 23:04:19.346 Portions Copyright (C) 2018 DVSwitch, INAD.
I: 2019-01-04 23:04:19.346 Hacks by Mike N4IRR and Steve N4IRS
I: 2019-01-04 23:04:19.346 =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
I: 2019-01-04 23:04:19.346 This software is for use on amateur radio networks only,
I: 2019-01-04 23:04:19.346 it is to be used for educational purposes only. Its use on
I: 2019-01-04 23:04:19.346 commercial networks is strictly prohibited.
I: 2019-01-04 23:04:19.346 Copyright(C) 2015-2018 by Jonathan Naylor, G4KLX and others
M: 2019-01-04 23:04:19.346 MMDVM_Bridge-20180423 is starting
M: 2019-01-04 23:04:19.346 Built 15:47:01 May 30 2018 (GitID #9cdea41)
I: 2019-01-04 23:04:19.346 General Parameters
I: 2019-01-04 23:04:19.347     Callsign: VK2RHK
I: 2019-01-04 23:04:19.347     Id: 505204
I: 2019-01-04 23:04:19.347     Duplex: no
I: 2019-01-04 23:04:19.347     Timeout: 180s
I: 2019-01-04 23:04:19.347     D-Star: disabled
I: 2019-01-04 23:04:19.347     DMR: enabled
I: 2019-01-04 23:04:19.347     YSF: disabled
I: 2019-01-04 23:04:19.347     P25: enabled
I: 2019-01-04 23:04:19.347     NXDN: disabled
I: 2019-01-04 23:04:19.347 Modem Parameters
I: 2019-01-04 23:04:19.347     Port: /dev/null
I: 2019-01-04 23:04:19.347     RX Invert: no
I: 2019-01-04 23:04:19.347     TX Invert: no
I: 2019-01-04 23:04:19.347     PTT Invert: no
I: 2019-01-04 23:04:19.347     TX Delay: 100ms
I: 2019-01-04 23:04:19.347     RX Offset: 0Hz
I: 2019-01-04 23:04:19.347     TX Offset: 0Hz
I: 2019-01-04 23:04:19.347     RX DC Offset: 0
I: 2019-01-04 23:04:19.347     TX DC Offset: 0
I: 2019-01-04 23:04:19.347     RF Level: 100.0%
I: 2019-01-04 23:04:19.347     DMR Delay: 0 (0.0ms)
I: 2019-01-04 23:04:19.347     RX Level: 50.0%
I: 2019-01-04 23:04:19.348     CW Id TX Level: 50.0%
I: 2019-01-04 23:04:19.348     D-Star TX Level: 50.0%
I: 2019-01-04 23:04:19.348     DMR TX Level: 50.0%
I: 2019-01-04 23:04:19.348     YSF TX Level: 50.0%
I: 2019-01-04 23:04:19.348     P25 TX Level: 50.0%
I: 2019-01-04 23:04:19.348     NXDN TX Level: 50.0%
I: 2019-01-04 23:04:19.348     RX Frequency: 222340000Hz (222340000Hz)
I: 2019-01-04 23:04:19.348     TX Frequency: 224940000Hz (224940000Hz)
M: 2019-01-04 23:04:19.348 Opening the MMDVM
I: 2019-01-04 23:04:19.348 Display Parameters
I: 2019-01-04 23:04:19.348     Type:
I: 2019-01-04 23:04:19.348 DMR Network Parameters
I: 2019-01-04 23:04:19.348     Address: vkbm.repeaters.info
I: 2019-01-04 23:04:19.348     Port: 62031
I: 2019-01-04 23:04:19.348     Local: 62032
I: 2019-01-04 23:04:19.348     Jitter: 360ms
I: 2019-01-04 23:04:19.348     Slot 1: enabled
I: 2019-01-04 23:04:19.348     Slot 2: enabled
I: 2019-01-04 23:04:19.348     Mode Hang: 3s
I: 2019-01-04 23:04:19.350 Info Parameters
I: 2019-01-04 23:04:19.350     Callsign: VK2RHK
I: 2019-01-04 23:04:19.350     RX Frequency: 222340000Hz
I: 2019-01-04 23:04:19.350     TX Frequency: 224940000Hz
I: 2019-01-04 23:04:19.350     Power: 1W
I: 2019-01-04 23:04:19.350     Latitude: -33.182800deg N
I: 2019-01-04 23:04:19.350     Longitude: -151.494095deg E
I: 2019-01-04 23:04:19.350     Height: 0m
I: 2019-01-04 23:04:19.350     Location: "Central Coast, NSW-AU"
I: 2019-01-04 23:04:19.350     Description: "50525 MMDVM_Bridge"
I: 2019-01-04 23:04:19.350     URL: "http:tg50525.repeaters.info"
M: 2019-01-04 23:04:19.350 DMR, Opening DMR Network
I: 2019-01-04 23:04:19.350 P25 Network Parameters
I: 2019-01-04 23:04:19.350     Gateway Address: 127.0.0.1
I: 2019-01-04 23:04:19.351     Gateway Port: 42020
I: 2019-01-04 23:04:19.351     Local Port: 32010
I: 2019-01-04 23:04:19.351     Mode Hang: 3s
M: 2019-01-04 23:04:19.351 P25, Opening INI file: DVSwitch.ini
M: 2019-01-04 23:04:19.351 P25, Setting [P25] Address -> 127.0.0.1
M: 2019-01-04 23:04:19.351 P25, Setting [P25] TXPort -> 34100
M: 2019-01-04 23:04:19.351 P25, Setting [P25] RXPort -> 34103
M: 2019-01-04 23:04:19.351 P25, Setting [P25] Slot -> 2
M: 2019-01-04 23:04:19.351 P25, Transmitting on 127.0.0.1:34100 and listening on port 34103.  Result = 1
M: 2019-01-04 23:04:19.351 Opening P25 network connection
I: 2019-01-04 23:04:19.351 RSSI
I: 2019-01-04 23:04:19.351     Mapping File: RSSI.dat
W: 2019-01-04 23:04:19.352 Cannot open the RSSI data file - RSSI.dat
I: 2019-01-04 23:04:19.352 DMR Id Lookups
I: 2019-01-04 23:04:19.352     File: /var/lib/mmdvm/DMRIds.dat
I: 2019-01-04 23:04:19.352     Reload: 24 hours
I: 2019-01-04 23:04:19.486 Loaded 120478 Ids to the DMR callsign lookup table
I: 2019-01-04 23:04:19.486 DMR RF Parameters
I: 2019-01-04 23:04:19.486     Id: 505204
I: 2019-01-04 23:04:19.486     Color Code: 1
I: 2019-01-04 23:04:19.487     Self Only: no
I: 2019-01-04 23:04:19.487     Embedded LC Only: yes
I: 2019-01-04 23:04:19.487     Dump Talker Alias Data: no
I: 2019-01-04 23:04:19.487     Prefixes: 0
I: 2019-01-04 23:04:19.487     Call Hang: 3s
I: 2019-01-04 23:04:19.487     TX Hang: 3s
I: 2019-01-04 23:04:19.487     Mode Hang: 10s
M: 2019-01-04 23:04:19.487 DMR, Opening INI file: DVSwitch.ini
M: 2019-01-04 23:04:19.487 DMR, Setting [DMR] Address -> 127.0.0.1
M: 2019-01-04 23:04:19.487 DMR, Setting [DMR] TXPort -> 31100
M: 2019-01-04 23:04:19.487 DMR, Setting [DMR] RXPort -> 31103
M: 2019-01-04 23:04:19.487 DMR, Setting [DMR] Slot -> 2
M: 2019-01-04 23:04:19.487 DMR, Transmitting on 127.0.0.1:31100 and listening on port 31103.  Result = 1
I: 2019-01-04 23:04:19.487 P25 RF Parameters
I: 2019-01-04 23:04:19.487     Id: 505204
I: 2019-01-04 23:04:19.488     NAC: $293
I: 2019-01-04 23:04:19.488     UID Override: no
I: 2019-01-04 23:04:19.488     Self Only: no
I: 2019-01-04 23:04:19.488     Remote Gateway: no
I: 2019-01-04 23:04:19.488     Mode Hang: 10s
M: 2019-01-04 23:04:19.488 MMDVM_Bridge-20180423 is running
I: 2019-01-04 23:04:19.488 Started the DMR Id lookup reload thread
D: 2019-01-04 23:04:29.495 DMR, Sending authorisation
D: 2019-01-04 23:04:29.501 DMR, Sending configuration
M: 2019-01-04 23:04:29.506 DMR, Logged into the master successfully

And I did a PTT after this so as you can see nothing showing up for P25 but after that I did a PTT from DMR and this is what I get.

M: 2019-01-04 23:06:34.130 DMR Slot 2, received network voice header from VK2HK to TG 50525
M: 2019-01-04 23:06:34.636 P25, TX state = ON
I: 2019-01-04 23:06:34.636 P25, Begin TX: src=5052110 rpt=505204 dst=50525 slot=2 cc=1

M: 2019-01-04 23:06:34.805 DMR Talker Alias (Data Format 1, Received 6/22 char): 'VK2HK '
M: 2019-01-04 23:06:35.288 DMR Slot 2, received network end of voice transmission, 1.2 seconds, 0% packet loss, BER: 0.2%
M: 2019-01-04 23:06:35.293 P25, TX state = OFF



------------------
Regards
Ian (VK2HK)




On 5 Jan 2019, at 9:49 am, Steve N4IRS <szingman@...> wrote:

Then the problem is at MMDVM_Bridge. Absolutely nothing in the MMDVM_Bridge log when you TX on P25 through the reflector? Nothing strange in the startup of MMDVM_Bridge?

On 1/4/19 5:43 PM, Ian Tulley wrote:
Hi Steve, well that’s the problem, when I PTT of P25, I can see myself on the Reflector, but nothing on mmdvm_bridge log or and of the analog_bridge logs ??

------------------
Regards
Ian (VK2HK)




On 5 Jan 2019, at 9:20 am, Steve N4IRS <szingman@...> wrote:

Follow the data in the logs from program to program. Do you see the data in the log for MMDVM_Bridge? if yes, move on to analog_bridge. Same question. rinse repeat.

On 1/4/19 4:52 PM, Ian Tulley wrote:
Hi all, I recently had active a DMR <--> P25 Bridge with the help of Steve. There was an issue with setting up the audio due to some problem associated with md380-emu, but it was fixed and the bridge worked great and after some tweaking the audio and audio levels in both directions just worked. I have been monitoring for a couple of days and found last night that I only had audio from DMR to P25 but not in the reverse direction. This morning I have been trying hard to solve this issue but just cannot find out why.
This is on a VPS and I am running the P25Reflector/Gateway/Bridge plus NXDN Reflector and YSF Reflector all off the same server, but when the bridge was working all of this was running at the same time.
This is what I have done so far, so any further suggestions would be welcome.

Checked status of all services to make sure all running and yes all OK
Set both P25Reflector and P25Gateway into Debug mode and monitored the output but nothing found.
restarted all services but again no difference.
stoped md30-emu
stopped mmdvm_bridge
stopped analog_bridge_p25 and analog_bridge_dmr
restarted all services manually in seperate windows so I could monitor the output to the screen.

Results I am getting, 
If I key up on the P25 radio, I get nothing coming to any of the screen outputs, but can hear myself via another connected P25 Hotspot so I know the reflector is working OK
If I key up on DMR I can see all 3 screen outputs and can hear myself out of the P25 Radio.

Anyone have any idea where to start to look for this issue.

Ian (VK2HK)
 




Re: DMR<-->P25 Now only one way Audio

Ian Tulley
 

Not that I can see Steve, 

Here is the startup,

I: 2019-01-04 23:04:19.346 MMDVM_Bridge:
I: 2019-01-04 23:04:19.346 Portions Copyright (C) 2018 DVSwitch, INAD.
I: 2019-01-04 23:04:19.346 Hacks by Mike N4IRR and Steve N4IRS
I: 2019-01-04 23:04:19.346 =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
I: 2019-01-04 23:04:19.346 This software is for use on amateur radio networks only,
I: 2019-01-04 23:04:19.346 it is to be used for educational purposes only. Its use on
I: 2019-01-04 23:04:19.346 commercial networks is strictly prohibited.
I: 2019-01-04 23:04:19.346 Copyright(C) 2015-2018 by Jonathan Naylor, G4KLX and others
M: 2019-01-04 23:04:19.346 MMDVM_Bridge-20180423 is starting
M: 2019-01-04 23:04:19.346 Built 15:47:01 May 30 2018 (GitID #9cdea41)
I: 2019-01-04 23:04:19.346 General Parameters
I: 2019-01-04 23:04:19.347     Callsign: VK2RHK
I: 2019-01-04 23:04:19.347     Id: 505204
I: 2019-01-04 23:04:19.347     Duplex: no
I: 2019-01-04 23:04:19.347     Timeout: 180s
I: 2019-01-04 23:04:19.347     D-Star: disabled
I: 2019-01-04 23:04:19.347     DMR: enabled
I: 2019-01-04 23:04:19.347     YSF: disabled
I: 2019-01-04 23:04:19.347     P25: enabled
I: 2019-01-04 23:04:19.347     NXDN: disabled
I: 2019-01-04 23:04:19.347 Modem Parameters
I: 2019-01-04 23:04:19.347     Port: /dev/null
I: 2019-01-04 23:04:19.347     RX Invert: no
I: 2019-01-04 23:04:19.347     TX Invert: no
I: 2019-01-04 23:04:19.347     PTT Invert: no
I: 2019-01-04 23:04:19.347     TX Delay: 100ms
I: 2019-01-04 23:04:19.347     RX Offset: 0Hz
I: 2019-01-04 23:04:19.347     TX Offset: 0Hz
I: 2019-01-04 23:04:19.347     RX DC Offset: 0
I: 2019-01-04 23:04:19.347     TX DC Offset: 0
I: 2019-01-04 23:04:19.347     RF Level: 100.0%
I: 2019-01-04 23:04:19.347     DMR Delay: 0 (0.0ms)
I: 2019-01-04 23:04:19.347     RX Level: 50.0%
I: 2019-01-04 23:04:19.348     CW Id TX Level: 50.0%
I: 2019-01-04 23:04:19.348     D-Star TX Level: 50.0%
I: 2019-01-04 23:04:19.348     DMR TX Level: 50.0%
I: 2019-01-04 23:04:19.348     YSF TX Level: 50.0%
I: 2019-01-04 23:04:19.348     P25 TX Level: 50.0%
I: 2019-01-04 23:04:19.348     NXDN TX Level: 50.0%
I: 2019-01-04 23:04:19.348     RX Frequency: 222340000Hz (222340000Hz)
I: 2019-01-04 23:04:19.348     TX Frequency: 224940000Hz (224940000Hz)
M: 2019-01-04 23:04:19.348 Opening the MMDVM
I: 2019-01-04 23:04:19.348 Display Parameters
I: 2019-01-04 23:04:19.348     Type:
I: 2019-01-04 23:04:19.348 DMR Network Parameters
I: 2019-01-04 23:04:19.348     Address: vkbm.repeaters.info
I: 2019-01-04 23:04:19.348     Port: 62031
I: 2019-01-04 23:04:19.348     Local: 62032
I: 2019-01-04 23:04:19.348     Jitter: 360ms
I: 2019-01-04 23:04:19.348     Slot 1: enabled
I: 2019-01-04 23:04:19.348     Slot 2: enabled
I: 2019-01-04 23:04:19.348     Mode Hang: 3s
I: 2019-01-04 23:04:19.350 Info Parameters
I: 2019-01-04 23:04:19.350     Callsign: VK2RHK
I: 2019-01-04 23:04:19.350     RX Frequency: 222340000Hz
I: 2019-01-04 23:04:19.350     TX Frequency: 224940000Hz
I: 2019-01-04 23:04:19.350     Power: 1W
I: 2019-01-04 23:04:19.350     Latitude: -33.182800deg N
I: 2019-01-04 23:04:19.350     Longitude: -151.494095deg E
I: 2019-01-04 23:04:19.350     Height: 0m
I: 2019-01-04 23:04:19.350     Location: "Central Coast, NSW-AU"
I: 2019-01-04 23:04:19.350     Description: "50525 MMDVM_Bridge"
I: 2019-01-04 23:04:19.350     URL: "http:tg50525.repeaters.info"
M: 2019-01-04 23:04:19.350 DMR, Opening DMR Network
I: 2019-01-04 23:04:19.350 P25 Network Parameters
I: 2019-01-04 23:04:19.350     Gateway Address: 127.0.0.1
I: 2019-01-04 23:04:19.351     Gateway Port: 42020
I: 2019-01-04 23:04:19.351     Local Port: 32010
I: 2019-01-04 23:04:19.351     Mode Hang: 3s
M: 2019-01-04 23:04:19.351 P25, Opening INI file: DVSwitch.ini
M: 2019-01-04 23:04:19.351 P25, Setting [P25] Address -> 127.0.0.1
M: 2019-01-04 23:04:19.351 P25, Setting [P25] TXPort -> 34100
M: 2019-01-04 23:04:19.351 P25, Setting [P25] RXPort -> 34103
M: 2019-01-04 23:04:19.351 P25, Setting [P25] Slot -> 2
M: 2019-01-04 23:04:19.351 P25, Transmitting on 127.0.0.1:34100 and listening on port 34103.  Result = 1
M: 2019-01-04 23:04:19.351 Opening P25 network connection
I: 2019-01-04 23:04:19.351 RSSI
I: 2019-01-04 23:04:19.351     Mapping File: RSSI.dat
W: 2019-01-04 23:04:19.352 Cannot open the RSSI data file - RSSI.dat
I: 2019-01-04 23:04:19.352 DMR Id Lookups
I: 2019-01-04 23:04:19.352     File: /var/lib/mmdvm/DMRIds.dat
I: 2019-01-04 23:04:19.352     Reload: 24 hours
I: 2019-01-04 23:04:19.486 Loaded 120478 Ids to the DMR callsign lookup table
I: 2019-01-04 23:04:19.486 DMR RF Parameters
I: 2019-01-04 23:04:19.486     Id: 505204
I: 2019-01-04 23:04:19.486     Color Code: 1
I: 2019-01-04 23:04:19.487     Self Only: no
I: 2019-01-04 23:04:19.487     Embedded LC Only: yes
I: 2019-01-04 23:04:19.487     Dump Talker Alias Data: no
I: 2019-01-04 23:04:19.487     Prefixes: 0
I: 2019-01-04 23:04:19.487     Call Hang: 3s
I: 2019-01-04 23:04:19.487     TX Hang: 3s
I: 2019-01-04 23:04:19.487     Mode Hang: 10s
M: 2019-01-04 23:04:19.487 DMR, Opening INI file: DVSwitch.ini
M: 2019-01-04 23:04:19.487 DMR, Setting [DMR] Address -> 127.0.0.1
M: 2019-01-04 23:04:19.487 DMR, Setting [DMR] TXPort -> 31100
M: 2019-01-04 23:04:19.487 DMR, Setting [DMR] RXPort -> 31103
M: 2019-01-04 23:04:19.487 DMR, Setting [DMR] Slot -> 2
M: 2019-01-04 23:04:19.487 DMR, Transmitting on 127.0.0.1:31100 and listening on port 31103.  Result = 1
I: 2019-01-04 23:04:19.487 P25 RF Parameters
I: 2019-01-04 23:04:19.487     Id: 505204
I: 2019-01-04 23:04:19.488     NAC: $293
I: 2019-01-04 23:04:19.488     UID Override: no
I: 2019-01-04 23:04:19.488     Self Only: no
I: 2019-01-04 23:04:19.488     Remote Gateway: no
I: 2019-01-04 23:04:19.488     Mode Hang: 10s
M: 2019-01-04 23:04:19.488 MMDVM_Bridge-20180423 is running
I: 2019-01-04 23:04:19.488 Started the DMR Id lookup reload thread
D: 2019-01-04 23:04:29.495 DMR, Sending authorisation
D: 2019-01-04 23:04:29.501 DMR, Sending configuration
M: 2019-01-04 23:04:29.506 DMR, Logged into the master successfully

And I did a PTT after this so as you can see nothing showing up for P25 but after that I did a PTT from DMR and this is what I get.

M: 2019-01-04 23:06:34.130 DMR Slot 2, received network voice header from VK2HK to TG 50525
M: 2019-01-04 23:06:34.636 P25, TX state = ON
I: 2019-01-04 23:06:34.636 P25, Begin TX: src=5052110 rpt=505204 dst=50525 slot=2 cc=1

M: 2019-01-04 23:06:34.805 DMR Talker Alias (Data Format 1, Received 6/22 char): 'VK2HK '
M: 2019-01-04 23:06:35.288 DMR Slot 2, received network end of voice transmission, 1.2 seconds, 0% packet loss, BER: 0.2%
M: 2019-01-04 23:06:35.293 P25, TX state = OFF



------------------
Regards
Ian (VK2HK)




On 5 Jan 2019, at 9:49 am, Steve N4IRS <szingman@...> wrote:

Then the problem is at MMDVM_Bridge. Absolutely nothing in the MMDVM_Bridge log when you TX on P25 through the reflector? Nothing strange in the startup of MMDVM_Bridge?

On 1/4/19 5:43 PM, Ian Tulley wrote:
Hi Steve, well that’s the problem, when I PTT of P25, I can see myself on the Reflector, but nothing on mmdvm_bridge log or and of the analog_bridge logs ??

------------------
Regards
Ian (VK2HK)




On 5 Jan 2019, at 9:20 am, Steve N4IRS <szingman@...> wrote:

Follow the data in the logs from program to program. Do you see the data in the log for MMDVM_Bridge? if yes, move on to analog_bridge. Same question. rinse repeat.

On 1/4/19 4:52 PM, Ian Tulley wrote:
Hi all, I recently had active a DMR <--> P25 Bridge with the help of Steve. There was an issue with setting up the audio due to some problem associated with md380-emu, but it was fixed and the bridge worked great and after some tweaking the audio and audio levels in both directions just worked. I have been monitoring for a couple of days and found last night that I only had audio from DMR to P25 but not in the reverse direction. This morning I have been trying hard to solve this issue but just cannot find out why.
This is on a VPS and I am running the P25Reflector/Gateway/Bridge plus NXDN Reflector and YSF Reflector all off the same server, but when the bridge was working all of this was running at the same time.
This is what I have done so far, so any further suggestions would be welcome.

Checked status of all services to make sure all running and yes all OK
Set both P25Reflector and P25Gateway into Debug mode and monitored the output but nothing found.
restarted all services but again no difference.
stoped md30-emu
stopped mmdvm_bridge
stopped analog_bridge_p25 and analog_bridge_dmr
restarted all services manually in seperate windows so I could monitor the output to the screen.

Results I am getting, 
If I key up on the P25 radio, I get nothing coming to any of the screen outputs, but can hear myself via another connected P25 Hotspot so I know the reflector is working OK
If I key up on DMR I can see all 3 screen outputs and can hear myself out of the P25 Radio.

Anyone have any idea where to start to look for this issue.

Ian (VK2HK)
 





Re: DMR<-->P25 Now only one way Audio

Steve N4IRS
 

Then the problem is at MMDVM_Bridge. Absolutely nothing in the MMDVM_Bridge log when you TX on P25 through the reflector? Nothing strange in the startup of MMDVM_Bridge?

On 1/4/19 5:43 PM, Ian Tulley wrote:
Hi Steve, well that’s the problem, when I PTT of P25, I can see myself on the Reflector, but nothing on mmdvm_bridge log or and of the analog_bridge logs ??

------------------
Regards
Ian (VK2HK)




On 5 Jan 2019, at 9:20 am, Steve N4IRS <szingman@...> wrote:

Follow the data in the logs from program to program. Do you see the data in the log for MMDVM_Bridge? if yes, move on to analog_bridge. Same question. rinse repeat.

On 1/4/19 4:52 PM, Ian Tulley wrote:
Hi all, I recently had active a DMR <--> P25 Bridge with the help of Steve. There was an issue with setting up the audio due to some problem associated with md380-emu, but it was fixed and the bridge worked great and after some tweaking the audio and audio levels in both directions just worked. I have been monitoring for a couple of days and found last night that I only had audio from DMR to P25 but not in the reverse direction. This morning I have been trying hard to solve this issue but just cannot find out why.
This is on a VPS and I am running the P25Reflector/Gateway/Bridge plus NXDN Reflector and YSF Reflector all off the same server, but when the bridge was working all of this was running at the same time.
This is what I have done so far, so any further suggestions would be welcome.

Checked status of all services to make sure all running and yes all OK
Set both P25Reflector and P25Gateway into Debug mode and monitored the output but nothing found.
restarted all services but again no difference.
stoped md30-emu
stopped mmdvm_bridge
stopped analog_bridge_p25 and analog_bridge_dmr
restarted all services manually in seperate windows so I could monitor the output to the screen.

Results I am getting, 
If I key up on the P25 radio, I get nothing coming to any of the screen outputs, but can hear myself via another connected P25 Hotspot so I know the reflector is working OK
If I key up on DMR I can see all 3 screen outputs and can hear myself out of the P25 Radio.

Anyone have any idea where to start to look for this issue.

Ian (VK2HK)
 




Re: DMR<-->P25 Now only one way Audio

Ian Tulley
 

Hi Steve, well that’s the problem, when I PTT of P25, I can see myself on the Reflector, but nothing on mmdvm_bridge log or and of the analog_bridge logs ??

------------------
Regards
Ian (VK2HK)




On 5 Jan 2019, at 9:20 am, Steve N4IRS <szingman@...> wrote:

Follow the data in the logs from program to program. Do you see the data in the log for MMDVM_Bridge? if yes, move on to analog_bridge. Same question. rinse repeat.

On 1/4/19 4:52 PM, Ian Tulley wrote:
Hi all, I recently had active a DMR <--> P25 Bridge with the help of Steve. There was an issue with setting up the audio due to some problem associated with md380-emu, but it was fixed and the bridge worked great and after some tweaking the audio and audio levels in both directions just worked. I have been monitoring for a couple of days and found last night that I only had audio from DMR to P25 but not in the reverse direction. This morning I have been trying hard to solve this issue but just cannot find out why.
This is on a VPS and I am running the P25Reflector/Gateway/Bridge plus NXDN Reflector and YSF Reflector all off the same server, but when the bridge was working all of this was running at the same time.
This is what I have done so far, so any further suggestions would be welcome.

Checked status of all services to make sure all running and yes all OK
Set both P25Reflector and P25Gateway into Debug mode and monitored the output but nothing found.
restarted all services but again no difference.
stoped md30-emu
stopped mmdvm_bridge
stopped analog_bridge_p25 and analog_bridge_dmr
restarted all services manually in seperate windows so I could monitor the output to the screen.

Results I am getting, 
If I key up on the P25 radio, I get nothing coming to any of the screen outputs, but can hear myself via another connected P25 Hotspot so I know the reflector is working OK
If I key up on DMR I can see all 3 screen outputs and can hear myself out of the P25 Radio.

Anyone have any idea where to start to look for this issue.

Ian (VK2HK)
 



Re: DMR<-->P25 Now only one way Audio

Steve N4IRS
 

Follow the data in the logs from program to program. Do you see the data in the log for MMDVM_Bridge? if yes, move on to analog_bridge. Same question. rinse repeat.

On 1/4/19 4:52 PM, Ian Tulley wrote:
Hi all, I recently had active a DMR <--> P25 Bridge with the help of Steve. There was an issue with setting up the audio due to some problem associated with md380-emu, but it was fixed and the bridge worked great and after some tweaking the audio and audio levels in both directions just worked. I have been monitoring for a couple of days and found last night that I only had audio from DMR to P25 but not in the reverse direction. This morning I have been trying hard to solve this issue but just cannot find out why.
This is on a VPS and I am running the P25Reflector/Gateway/Bridge plus NXDN Reflector and YSF Reflector all off the same server, but when the bridge was working all of this was running at the same time.
This is what I have done so far, so any further suggestions would be welcome.

Checked status of all services to make sure all running and yes all OK
Set both P25Reflector and P25Gateway into Debug mode and monitored the output but nothing found.
restarted all services but again no difference.
stoped md30-emu
stopped mmdvm_bridge
stopped analog_bridge_p25 and analog_bridge_dmr
restarted all services manually in seperate windows so I could monitor the output to the screen.

Results I am getting, 
If I key up on the P25 radio, I get nothing coming to any of the screen outputs, but can hear myself via another connected P25 Hotspot so I know the reflector is working OK
If I key up on DMR I can see all 3 screen outputs and can hear myself out of the P25 Radio.

Anyone have any idea where to start to look for this issue.

Ian (VK2HK)
 


Re: Setting up DMRLink <-> KBLink #best_practices #dmrlink #hblink

Jason Johnston
 

I *think* I have everything setup.  But when I run "python IPSC_Bridge.py" it doesn't login to my cbridge... that is, I don't see it on my Peer Watch or admin Netwatch screen.  But it does seem to be logging in...somewhere... and working.  Here are the results of running that script

<snip>
root@DMRlink1:/opt/DMRlink# python IPSC_Bridge.py
INFO 2019-01-04 15:55:47,493 DMRlink 'IPSC_Bridge.py' (c) 2015 N0MJS & the K0USY Group - SYSTEM STARTING...
INFO 2019-01-04 15:55:47,493 Version 20170620
INFO 2019-01-04 15:55:47,591 ID ALIAS MAPPER: 'peer_ids.csv' could not be downloaded
INFO 2019-01-04 15:55:47,886 ID ALIAS MAPPER: 'subscriber_ids.csv' could not be downloaded
INFO 2019-01-04 15:55:47,886 (SAMPLE_PEER) IPSC Instance Created: 114810, 0.0.0.0:50000
INFO 2019-01-04 15:55:47,887 section = SAMPLE_PEER
INFO 2019-01-04 15:55:47,887 Section SAMPLE_PEER was not found, using DEFAULTS
INFO 2019-01-04 15:55:47,888 gateway = 127.0.0.1
INFO 2019-01-04 15:55:47,888 toGatewayPort = 31003
INFO 2019-01-04 15:55:47,888 fromGatewayPort = 31000
INFO 2019-01-04 15:55:47,888 DMRLink IPSC Bridge
INFO 2019-01-04 15:55:47,892 (SAMPLE_PEER) Registering with the Master: ##########
WARNING 2019-01-04 15:55:48,960 (SAMPLE_PEER) Registration response (we requested reg) from the Master: 1114810, ######### (0 peers)
</snip>

Once it is ready to go... what is the command to launch everything in the background, and how can I make sure it autostarts when the system is rebooted?


DMR<-->P25 Now only one way Audio

Ian Tulley
 

Hi all, I recently had active a DMR <--> P25 Bridge with the help of Steve. There was an issue with setting up the audio due to some problem associated with md380-emu, but it was fixed and the bridge worked great and after some tweaking the audio and audio levels in both directions just worked. I have been monitoring for a couple of days and found last night that I only had audio from DMR to P25 but not in the reverse direction. This morning I have been trying hard to solve this issue but just cannot find out why.
This is on a VPS and I am running the P25Reflector/Gateway/Bridge plus NXDN Reflector and YSF Reflector all off the same server, but when the bridge was working all of this was running at the same time.
This is what I have done so far, so any further suggestions would be welcome.

Checked status of all services to make sure all running and yes all OK
Set both P25Reflector and P25Gateway into Debug mode and monitored the output but nothing found.
restarted all services but again no difference.
stoped md30-emu
stopped mmdvm_bridge
stopped analog_bridge_p25 and analog_bridge_dmr
restarted all services manually in seperate windows so I could monitor the output to the screen.

Results I am getting, 
If I key up on the P25 radio, I get nothing coming to any of the screen outputs, but can hear myself via another connected P25 Hotspot so I know the reflector is working OK
If I key up on DMR I can see all 3 screen outputs and can hear myself out of the P25 Radio.

Anyone have any idea where to start to look for this issue.

Ian (VK2HK)
 


Re: Allstarlink to Echolink showing an error??

Mike KB8JNM
 

Could you say a bit more on the conditions when you get this error?

Is it you connecting to your own node behind/inside  your nat ?

...mike/kb8jnm

On 1/4/2019 11:17 AM, jeff@... wrote:
When Connecting to an Echolink Node Number I receive this message on the console., But the echolink node "does" connect...
any idea what this error is and how to correct it??


Re: Dvswitch bridge help

Steve N4IRS
 

Where does it stop. That page has you look in several places. It's follow the data through the system.

On 1/4/2019 11:31 AM, Ke4tlc wrote:
The part where I key the radio to produce trafitr. 


Re: Dvswitch bridge help

Ke4tlc
 

The part where I key the radio to produce trafitr. 


Re: Dvswitch bridge help

Steve N4IRS
 

What is not working? Where does it stop?

On 1/4/2019 11:27 AM, Ke4tlc wrote:
Yes I used that document .  I did the checks and it looked to me it was correct.  I think it is something  I am missing. 


Re: Dvswitch bridge help

Ke4tlc
 

Yes I used that document .  I did the checks and it looked to me it was correct.  I think it is something  I am missing. 

7021 - 7040 of 9775