Date   

Re: AllStarLink/ASL-Install

Mike KB8JNM
 

Very good Stephen,

I should have taken my time and looked at it all and not looked for the short answer.

As I said, I don't use the asl-menu,

but I guess I should find out why it's not  in /usr/loacal/sbin or /usr/sbin/  on my Pi when I get a chance.


The best fix would be to come back at this with a new instance of putty and just run the commands from there.

Makes little sense to run the menu to run a command. But, No harm.

...mike/kb8jnm

On 12/12/2018 10:05 AM, Stephen Miller wrote:
Mike,

The $ASTERISK is a variable set earlier in the script, on line 68. The do_asterisk_cli takes that variable and makes it into a full line that the shell expects. The variable in this case allows for the asterisk executable to be placed anywhere on the system, and each time the variable is called the shell will replace the variable name with the actual value. Since the asterisk program is called in many functions in the script, creating a variable makes it easier to change one line rather than many in the script, in case the location of the program changes.

So line 68 creates the variable:

ASTERISK=/usr/sbin/asterisk

which turns $ASTERISK -rvvv into

/usr/sbin/asterisk -rvvv

in do_asterisk_cli


On Wed, Dec 12, 2018 at 9:57 AM Mike KB8JNM <groupio@...> wrote:

Funny,

I went looking at my install. I don't use the asl-menu, but it is not installed on my Pi.

So, I went to the PC and took a look at the asl-menu shell script.

5 is the menu item for ast cmd line

do_asl_cli() {
echo "do_asl_cli" >> $logfile
clear
$ASTERISK -rvvv        <--------------------------------
}


This needs to be changed to lower case.

$asterisk -rvvv


...mike/kb8jnm


On 12/12/2018 6:25 AM, ea3eiz@... wrote:
I am using a raspberry pi B + with the raspbian Stretch installed.
if I throw the command like:
asl-menu (error5)
sudo asl.menu (error5)


--
Steve Miller
KC1AWV


Re: AllStarLink/ASL-Install

Steve KC1AWV
 

Mike,

The $ASTERISK is a variable set earlier in the script, on line 68. The do_asterisk_cli takes that variable and makes it into a full line that the shell expects. The variable in this case allows for the asterisk executable to be placed anywhere on the system, and each time the variable is called the shell will replace the variable name with the actual value. Since the asterisk program is called in many functions in the script, creating a variable makes it easier to change one line rather than many in the script, in case the location of the program changes.

So line 68 creates the variable:

ASTERISK=/usr/sbin/asterisk

which turns $ASTERISK -rvvv into

/usr/sbin/asterisk -rvvv

in do_asterisk_cli


On Wed, Dec 12, 2018 at 9:57 AM Mike KB8JNM <groupio@...> wrote:

Funny,

I went looking at my install. I don't use the asl-menu, but it is not installed on my Pi.

So, I went to the PC and took a look at the asl-menu shell script.

5 is the menu item for ast cmd line

do_asl_cli() {
echo "do_asl_cli" >> $logfile
clear
$ASTERISK -rvvv        <--------------------------------
}


This needs to be changed to lower case.

$asterisk -rvvv


...mike/kb8jnm


On 12/12/2018 6:25 AM, ea3eiz@... wrote:
I am using a raspberry pi B + with the raspbian Stretch installed.
if I throw the command like:
asl-menu (error5)
sudo asl.menu (error5)



--
Steve Miller
KC1AWV


Re: AllStarLink/ASL-Install

Mike KB8JNM
 

Funny,

I went looking at my install. I don't use the asl-menu, but it is not installed on my Pi.

So, I went to the PC and took a look at the asl-menu shell script.

5 is the menu item for ast cmd line

do_asl_cli() {
echo "do_asl_cli" >> $logfile
clear
$ASTERISK -rvvv        <--------------------------------
}


This needs to be changed to lower case.

$asterisk -rvvv


...mike/kb8jnm


On 12/12/2018 6:25 AM, ea3eiz@... wrote:
I am using a raspberry pi B + with the raspbian Stretch installed.
if I throw the command like:
asl-menu (error5)
sudo asl.menu (error5)


Re: AllStarLink/ASL-Install

Manuel Díaz
 

I am using a raspberry pi B + with the raspbian Stretch installed.
if I throw the command like:
asl-menu (error5)
sudo asl.menu (error5)


Re: AllStarLink/ASL-Install

Steve KC1AWV
 

I assume that with the graphical interface being used, you installed ASL on top of an existing Linux install? If I recall correctly, the ASL image is based on ALArm, not Debian/Raspbian. 

When running the asl-menu script, are you elevating to superuser by using sudo asl-menu?


Re: AllStarLink/ASL-Install

Manuel Díaz
 




so I have it and it gives me the error 5




Re: AllStarLink/ASL-Install

Steve KC1AWV
 

Long story short, if running the command asterisk -rvvv on the terminal works, this is the reason why.

The asl-menu script looks for the asterisk executable in /usr/sbin. If your instance of asterisk is installed or located elsewhere, you will need to change line 68 in the asl-menu script to reflect the correct location of the executable. So, for instance, if it's located in /usr/local/sbin the line should be changed to ASTERISK=/usr/local/sbin/asterisk. To find where the executable is, you can run which asterisk on the terminal to show where the file is located in your PATH.

Of course, flashing the maintained image for the RPi onto your card would work too, and I've had no issues running a mobile ASL node from it.

- Steve KC1AWV


Re: AllStarLink/ASL-Install

Steve KC1AWV
 

If you exit back to the terminal and run asterisk -rvvv does the asterisk cli come up?

- Steve KC1AWV


AllStarLink/ASL-Install

Manuel Díaz
 

Hi.
Who knows why I get this error when I give option 5 of the asl-menu?
I have the system installed in a raspberry pi 3B





Re: Problem with hb_parrot.py with actual github version of hblink...

Heiko DL1BZ
 

Great work Cort. Thanks a lot for the very fast fixing.

73 Heiko, DL1BZ


Re: Problem with hb_parrot.py with actual github version of hblink...

Cort N0MJS <n0mjs@...>
 

I fixed parrot. Stupid typo. Thanks, Heiko for finding my mistake!

On Dec 11, 2018, at 8:35 AM, Heiko DL1BZ <dg2dra@...> wrote:

If I use the master branch of hblink (with openbridge now) the included hb_parrot.py don't work anymore. I don't see no connect from hb_confbridge. BUT, if I use the old hb_parrot.py as an own instance, the hb_parrot works - it connects and playback all correctly. The newer in actual master branch do nothing. I'm running a master instance of hb_confbridge und an instance of hb_parrot, all is bridged (here with a talkgroup 79990).

What was changed between old and new ?

73 Heiko, DL1BZ

Cort Buffington
785-865-7206


Problem with hb_parrot.py with actual github version of hblink...

Heiko DL1BZ
 

If I use the master branch of hblink (with openbridge now) the included hb_parrot.py don't work anymore. I don't see no connect from hb_confbridge. BUT, if I use the old hb_parrot.py as an own instance, the hb_parrot works - it connects and playback all correctly. The newer in actual master branch do nothing. I'm running a master instance of hb_confbridge und an instance of hb_parrot, all is bridged (here with a talkgroup 79990).

What was changed between old and new ?

73 Heiko, DL1BZ


Re: ASL <-> XLX No analog audio?

Steve KC1AWV
 

Unfortunately, not yet. I am using the md380 software codec right now, and I would like to test a hardware AMBE dongle. I will have to purchase another pair and send the audio over to the transcoding server, as the ASL and XLX servers are housed in a colo data center that I do not have physical access to. I intended to do this anyway, to see if I can get DStar, DMR and YSF all on one module talking to each other.

Please let me know if you make any progress. I do want to keep this topic open to see if anyone else has input, as well as providing my own status updates with this project.

If there are people interested in testing the system I have in place, please do. The inbound connections available are:

ASL node 46550
Echolink KC1AWV-L
XLX740 Module B (Transcoding)

Thanks!
-Steve KC1AWV

On Sat, Dec 8, 2018, 8:39 PM adshar64 via Groups.Io <adshar64=yahoo.com@groups.io wrote:
Steve, Did you find a fix for this issue, i have the same here ?

Murray.


Re: Link DMR <==> FCSXXX

Bruno
 

Hi,

Super thank you very much for the developments. Congratulations for your work.

73's

F1PTL Bruno


Le ven. 7 déc. 2018 à 15:03, Steve N4IRS <szingman@...> a écrit :
We have identified a bug. It is being worked on now. I will post when you can update.

Steve N4IRS

On 12/4/2018 4:41 PM, Bruno wrote:
Starting logging, please wait...
M: 2018-12-04 21:39:55.381 YSF, network watchdog has expired, 152.4 seconds, 0% packet loss, BER: 0.0%
M: 2018-12-04 21:39:58.946 YSF, received network data from N4IRR to ALL at FCS001-33 


Re: Link DMR <==> FCSXXX

Steve N4IRS
 

We have identified a bug. It is being worked on now. I will post when you can update.

Steve N4IRS

On 12/4/2018 4:41 PM, Bruno wrote:
Starting logging, please wait...
M: 2018-12-04 21:39:55.381 YSF, network watchdog has expired, 152.4 seconds, 0% packet loss, BER: 0.0%
M: 2018-12-04 21:39:58.946 YSF, received network data from N4IRR to ALL at FCS001-33 


Re: NXDN to YSF

Steve N4IRS
 

In testing another issue with YSF we have identified a bug. It is being looked at to resolve both problems.  I'll post when it is resolved and you can do a update.

Steve N4IRS

On 12/7/2018 8:39 AM, andrew_12ph via Groups.Io wrote:
I have similar issues the DN switch to VW using my yaesu ftm100 but it seems to be okay when im using my portable ft2d.
any suggestions to fix this?


Re: NXDN to YSF

andrew delgado
 

I have similar issues the DN switch to VW using my yaesu ftm100 but it seems to be okay when im using my portable ft2d.
any suggestions to fix this?


Re: ASL playback and morse distorted when bridge is running

Corey Dean N3FE <n3fe@...>
 

I pulled the email address you used to register with in bm and sent the email from my personal address.

Corey


On Dec 5, 2018, at 8:33 PM, va3dxv <va3dxv@...> wrote:

Corey, could you please tell me what email address you used and where you got it? I'm concerned that I didn't receive the email. If there's an incorrect address published somewhere I'd like to rectify it so that i can be contacted in the event something is malfunctioning.

My apologies for the noise and annoyance, I disconnected from all TG's when I saw what was happening. After returning to that device just a few minutes ago, I've found out what caused it (https://dvswitch.groups.io/g/allstarlink/topic/dmr_on_the_fly_shell_script/28137868)


Re: ASL playback and morse distorted when bridge is running

va3dxv
 

Corey, could you please tell me what email address you used and where you got it? I'm concerned that I didn't receive the email. If there's an incorrect address published somewhere I'd like to rectify it so that i can be contacted in the event something is malfunctioning.

My apologies for the noise and annoyance, I disconnected from all TG's when I saw what was happening. After returning to that device just a few minutes ago, I've found out what caused it (https://dvswitch.groups.io/g/allstarlink/topic/dmr_on_the_fly_shell_script/28137868)


Re: Link DMR <==> FCSXXX

Steve N4IRS
 

I need to see the log from MMDVM_Bridge during a transmission from DMR I have a hotspot at home and I'm listening to FCS001 33

On 12/5/2018 2:13 PM, Bruno wrote:
Hi,

Here are the files used to set up this configuration.
YSFGateway Local that connects FCS001 33
MMDVM_Bridge making DMR connection BM <=> YSF
Port 35100 and 35103
The MMDVM logs are good with the good indicative
This is found at the PI-Star interface which is connected to the FCS001 33 on the receiving OM that arrives from the DMR BM.
 
73's
F1PTL Bruno

7061 - 7080 of 9595