Date   

Re: Registration of Dv Switch

Steve N4IRS
 

OK,
Thank you.

On 3/15/2021 10:33 AM, g6luu alan wrote:
Using DvSwitch.img on my own Rpi2 , on own Network


Re: Registration of Dv Switch

g6luu alan
 

Using DvSwitch.img on my own Rpi2 , on own Network


Re: Registration of Dv Switch

Steve N4IRS
 

Are you using your own server or someone else?

On 3/15/2021 10:02 AM, g6luu alan wrote:
DVSwitch Server (USRP) 

Been 'resetting' and working now, not sure what 'changed' but all good now
Fantastic Network ! Like it a lot . 73 alan


Re: Registration of Dv Switch

g6luu alan
 
Edited

DVSwitch Server (USRP) 

Been 'resetting' and working now, not sure what 'changed' but all good now
Got a lot of RX Data coming down from , i guess, the Network ?
Fantastic Network ! Like it a lot . 73 alan


Re: Emulator timed out on encode!

G4WXN@...
 

I have decided I am flogging a dead horse here, so have decided to start again, and use the Rpi image 2020-10-31-DVSwitch-Server-lite.img
I am assuming that is the most up to date version?
--
Derek

G4WXN


P25 to DMR bridge using DVSwitch Server

David Young
 

Trying to understand how to use the new DVSwitch-Server to bridge from P25 to DMR.  Using the old DVSwitch bridging, two instances of Analog_Bridge were required, which I assume is still necessary but DVSwitch-Server seems to only auto-start one instance of Analog_Bridge.  The second I have been starting manually.  I think I am missing something here.  How do I setup DVSwitch-Server to auto start two instances of Analog_Bridge?  I have been using the primary Analog_Bridge with it's .ini file (Analog_Bridge.ini) setup for the P25 side and then I add another instance of Analog_Bridge in the same default folder named Analog_Bridge_DMR with it's associated .ini file (Analog_Bridge_DMR.ini).  The DMR side Analog_Bridge I have been manually starting which is where I think I am missing the correct procedure.  Doing the P25 to DMR bridge this way works, but I do run into problems usually after it runs for some time (sometimes afew hours and some times a day or so), then either it stops running or the audio gets distorted with very long latency.  When I look at the server stats I see a very large amount of disk IO operations and the CPU usage goes upward over 50% which seems excessive as I am only running two bridges on the server, P25 and NXDN, both to DMR.  I also noted that the Analog_Bridge_DMR.log generating messages which say MMDVM success constantly which is causing the log file to grow quite large.  I have changed the logging from the default of 2 (message) to 0 (None) which stops these messages.  The primary Analog_Bridge.log file does not do this.

I am sure I must not be following the correct setup to bridge P25 to DMR with DVSwitch-Server, help?

--
Dave WB6DTB


Re: Connection Issue to BM

N4UPC - Scott
 

Fixed.  I must have misunderstood about the DUPLEX=1.

Thanks!

73
Scott,
N4UPC



On 3/14/2021 6:50 PM, Steve N4IRS wrote:
Set Duplex = 0

On 3/14/21 7:41 PM, N4UPC - Scott via groups.io wrote:

---

[General]
Callsign=N4UPC
#Id=316235620
Id=3162356
Timeout=180
Duplex=1

[Info]
RXFrequency=222340000
TXFrequency=222340000
Power=1
Latitude=41.7333
Longitude=-50.3999
Height=0
Location=USA
Description=Bridge
URL=https://www.dodropin.net

[Log]
# Logging levels, 0=No logging, 1=Debug, 2=Message, 3=Info, 4=Warning, 5=Error, 6=Fatal
DisplayLevel=1
FileLevel=2
FilePath=/var/log/mmdvm
FileRoot=MMDVM_Bridge

[DMR Id Lookup]
File=/var/lib/mmdvm/DMRIds.dat
Time=24

[NXDN Id Lookup]
File=/var/lib/mmdvm/NXDN.csv
Time=24

[Modem]
Port=/dev/null
RSSIMappingFile=/dev/null
Trace=0
Debug=0

[D-Star]
Enable=1
Module=B

[DMR]
Enable=1
ColorCode=1
EmbeddedLCOnly=1
DumpTAData=0

[System Fusion]
Enable=0

[P25]
Enable=0
NAC=293

[NXDN]
Enable=0
RAN=1
Id=

[D-Star Network]
Enable=0
GatewayAddress=127.0.0.1
GatewayPort=20010
LocalPort=20011
Debug=0

[DMR Network]
Enable=1
Address=3102.repeater.net
Port=62031
Jitter=360
Local=62032
Password=xxxxxxx
# for DMR+ see https://github.com/DVSwitch/MMDVM_Bridge/blob/master/DOC/DMRplus_startup_options.md
# for XLX the syntax is: Options=XLX:4009
# Options=
Slot1=0
Slot2=1
Debug=0

[System Fusion Network]
Enable=0
LocalAddress=0
LocalPort=3200
GatewayAddress=127.0.0.1
GatewayPort=4200
Debug=0

[P25 Network]
Enable=0
GatewayAddress=127.0.0.1
GatewayPort=42020
LocalPort=32010
Debug=0

[NXDN Network]
Enable=0
#LocalAddress=127.0.0.1
Debug=0
LocalPort=14021
GatewayAddress=127.0.0.1
GatewayPort=14020


---



73
Scott,
N4UPC



On 3/14/2021 6:37 PM, Steve N4IRS wrote:
Show MMDVM_Bridge.ini

On 3/14/21 7:36 PM, N4UPC - Scott via groups.io wrote:
Also RX/TX freq is the same.

73,
Scott
N4UPC



On Sun, Mar 14, 2021 at 18:33, N4UPC - Scott via groups.io <n4upc@...> wrote:
All,

My DVSwitch system as suddenly stopped connecting to BM.  I've made the changes to the MMDVM_Bridge file as previously noted:

[General]
Callsign=N4UPC
#Id=316235620
Id=3162356
Timeout=180
Duplex=1

Still no joy.  All I get in the MMDVM_Bridge.log is:

E: 2021-03-14 23:31:05.954 DMR, Master is closing down
M: 2021-03-14 23:31:05.954 DMR, Closing DMR Network
M: 2021-03-14 23:31:05.954 DMR, Opening DMR Network
E: 2021-03-14 23:31:16.167 DMR, Master is closing down
M: 2021-03-14 23:31:16.167 DMR, Closing DMR Network
M: 2021-03-14 23:31:16.167 DMR, Opening DMR Network
E: 2021-03-14 23:31:26.373 DMR, Master is closing down
M: 2021-03-14 23:31:26.373 DMR, Closing DMR Network
M: 2021-03-14 23:31:26.373 DMR, Opening DMR Network

I also did an upgrade and rebooted the system afterward.  Stumped!

--
73
Scott,
N4UPC










Re: Connection Issue to BM

Steve N4IRS
 

Set Duplex = 0

On 3/14/21 7:41 PM, N4UPC - Scott via groups.io wrote:

---

[General]
Callsign=N4UPC
#Id=316235620
Id=3162356
Timeout=180
Duplex=1

[Info]
RXFrequency=222340000
TXFrequency=222340000
Power=1
Latitude=41.7333
Longitude=-50.3999
Height=0
Location=USA
Description=Bridge
URL=https://www.dodropin.net

[Log]
# Logging levels, 0=No logging, 1=Debug, 2=Message, 3=Info, 4=Warning, 5=Error, 6=Fatal
DisplayLevel=1
FileLevel=2
FilePath=/var/log/mmdvm
FileRoot=MMDVM_Bridge

[DMR Id Lookup]
File=/var/lib/mmdvm/DMRIds.dat
Time=24

[NXDN Id Lookup]
File=/var/lib/mmdvm/NXDN.csv
Time=24

[Modem]
Port=/dev/null
RSSIMappingFile=/dev/null
Trace=0
Debug=0

[D-Star]
Enable=1
Module=B

[DMR]
Enable=1
ColorCode=1
EmbeddedLCOnly=1
DumpTAData=0

[System Fusion]
Enable=0

[P25]
Enable=0
NAC=293

[NXDN]
Enable=0
RAN=1
Id=

[D-Star Network]
Enable=0
GatewayAddress=127.0.0.1
GatewayPort=20010
LocalPort=20011
Debug=0

[DMR Network]
Enable=1
Address=3102.repeater.net
Port=62031
Jitter=360
Local=62032
Password=xxxxxxx
# for DMR+ see https://github.com/DVSwitch/MMDVM_Bridge/blob/master/DOC/DMRplus_startup_options.md
# for XLX the syntax is: Options=XLX:4009
# Options=
Slot1=0
Slot2=1
Debug=0

[System Fusion Network]
Enable=0
LocalAddress=0
LocalPort=3200
GatewayAddress=127.0.0.1
GatewayPort=4200
Debug=0

[P25 Network]
Enable=0
GatewayAddress=127.0.0.1
GatewayPort=42020
LocalPort=32010
Debug=0

[NXDN Network]
Enable=0
#LocalAddress=127.0.0.1
Debug=0
LocalPort=14021
GatewayAddress=127.0.0.1
GatewayPort=14020


---



73
Scott,
N4UPC



On 3/14/2021 6:37 PM, Steve N4IRS wrote:
Show MMDVM_Bridge.ini

On 3/14/21 7:36 PM, N4UPC - Scott via groups.io wrote:
Also RX/TX freq is the same.

73,
Scott
N4UPC



On Sun, Mar 14, 2021 at 18:33, N4UPC - Scott via groups.io <n4upc@...> wrote:
All,

My DVSwitch system as suddenly stopped connecting to BM.  I've made the changes to the MMDVM_Bridge file as previously noted:

[General]
Callsign=N4UPC
#Id=316235620
Id=3162356
Timeout=180
Duplex=1

Still no joy.  All I get in the MMDVM_Bridge.log is:

E: 2021-03-14 23:31:05.954 DMR, Master is closing down
M: 2021-03-14 23:31:05.954 DMR, Closing DMR Network
M: 2021-03-14 23:31:05.954 DMR, Opening DMR Network
E: 2021-03-14 23:31:16.167 DMR, Master is closing down
M: 2021-03-14 23:31:16.167 DMR, Closing DMR Network
M: 2021-03-14 23:31:16.167 DMR, Opening DMR Network
E: 2021-03-14 23:31:26.373 DMR, Master is closing down
M: 2021-03-14 23:31:26.373 DMR, Closing DMR Network
M: 2021-03-14 23:31:26.373 DMR, Opening DMR Network

I also did an upgrade and rebooted the system afterward.  Stumped!

--
73
Scott,
N4UPC









Re: Connection Issue to BM

N4UPC - Scott
 


---

[General]
Callsign=N4UPC
#Id=316235620
Id=3162356
Timeout=180
Duplex=1

[Info]
RXFrequency=222340000
TXFrequency=222340000
Power=1
Latitude=41.7333
Longitude=-50.3999
Height=0
Location=USA
Description=Bridge
URL=https://www.dodropin.net

[Log]
# Logging levels, 0=No logging, 1=Debug, 2=Message, 3=Info, 4=Warning, 5=Error, 6=Fatal
DisplayLevel=1
FileLevel=2
FilePath=/var/log/mmdvm
FileRoot=MMDVM_Bridge

[DMR Id Lookup]
File=/var/lib/mmdvm/DMRIds.dat
Time=24

[NXDN Id Lookup]
File=/var/lib/mmdvm/NXDN.csv
Time=24

[Modem]
Port=/dev/null
RSSIMappingFile=/dev/null
Trace=0
Debug=0

[D-Star]
Enable=1
Module=B

[DMR]
Enable=1
ColorCode=1
EmbeddedLCOnly=1
DumpTAData=0

[System Fusion]
Enable=0

[P25]
Enable=0
NAC=293

[NXDN]
Enable=0
RAN=1
Id=

[D-Star Network]
Enable=0
GatewayAddress=127.0.0.1
GatewayPort=20010
LocalPort=20011
Debug=0

[DMR Network]
Enable=1
Address=3102.repeater.net
Port=62031
Jitter=360
Local=62032
Password=xxxxxxx
# for DMR+ see https://github.com/DVSwitch/MMDVM_Bridge/blob/master/DOC/DMRplus_startup_options.md
# for XLX the syntax is: Options=XLX:4009
# Options=
Slot1=0
Slot2=1
Debug=0

[System Fusion Network]
Enable=0
LocalAddress=0
LocalPort=3200
GatewayAddress=127.0.0.1
GatewayPort=4200
Debug=0

[P25 Network]
Enable=0
GatewayAddress=127.0.0.1
GatewayPort=42020
LocalPort=32010
Debug=0

[NXDN Network]
Enable=0
#LocalAddress=127.0.0.1
Debug=0
LocalPort=14021
GatewayAddress=127.0.0.1
GatewayPort=14020


---



73
Scott,
N4UPC



On 3/14/2021 6:37 PM, Steve N4IRS wrote:
Show MMDVM_Bridge.ini

On 3/14/21 7:36 PM, N4UPC - Scott via groups.io wrote:
Also RX/TX freq is the same.

73,
Scott
N4UPC



On Sun, Mar 14, 2021 at 18:33, N4UPC - Scott via groups.io <n4upc@...> wrote:
All,

My DVSwitch system as suddenly stopped connecting to BM.  I've made the changes to the MMDVM_Bridge file as previously noted:

[General]
Callsign=N4UPC
#Id=316235620
Id=3162356
Timeout=180
Duplex=1

Still no joy.  All I get in the MMDVM_Bridge.log is:

E: 2021-03-14 23:31:05.954 DMR, Master is closing down
M: 2021-03-14 23:31:05.954 DMR, Closing DMR Network
M: 2021-03-14 23:31:05.954 DMR, Opening DMR Network
E: 2021-03-14 23:31:16.167 DMR, Master is closing down
M: 2021-03-14 23:31:16.167 DMR, Closing DMR Network
M: 2021-03-14 23:31:16.167 DMR, Opening DMR Network
E: 2021-03-14 23:31:26.373 DMR, Master is closing down
M: 2021-03-14 23:31:26.373 DMR, Closing DMR Network
M: 2021-03-14 23:31:26.373 DMR, Opening DMR Network

I also did an upgrade and rebooted the system afterward.  Stumped!

--
73
Scott,
N4UPC








Re: Connection Issue to BM

Steve N4IRS
 

Show MMDVM_Bridge.ini

On 3/14/21 7:36 PM, N4UPC - Scott via groups.io wrote:
Also RX/TX freq is the same.

73,
Scott
N4UPC



On Sun, Mar 14, 2021 at 18:33, N4UPC - Scott via groups.io <n4upc@...> wrote:
All,

My DVSwitch system as suddenly stopped connecting to BM.  I've made the changes to the MMDVM_Bridge file as previously noted:

[General]
Callsign=N4UPC
#Id=316235620
Id=3162356
Timeout=180
Duplex=1

Still no joy.  All I get in the MMDVM_Bridge.log is:

E: 2021-03-14 23:31:05.954 DMR, Master is closing down
M: 2021-03-14 23:31:05.954 DMR, Closing DMR Network
M: 2021-03-14 23:31:05.954 DMR, Opening DMR Network
E: 2021-03-14 23:31:16.167 DMR, Master is closing down
M: 2021-03-14 23:31:16.167 DMR, Closing DMR Network
M: 2021-03-14 23:31:16.167 DMR, Opening DMR Network
E: 2021-03-14 23:31:26.373 DMR, Master is closing down
M: 2021-03-14 23:31:26.373 DMR, Closing DMR Network
M: 2021-03-14 23:31:26.373 DMR, Opening DMR Network

I also did an upgrade and rebooted the system afterward.  Stumped!

--
73
Scott,
N4UPC







Re: Connection Issue to BM

N4UPC - Scott
 

Also RX/TX freq is the same.

73,
Scott
N4UPC



On Sun, Mar 14, 2021 at 18:33, N4UPC - Scott via groups.io <n4upc@...> wrote:
All,

My DVSwitch system as suddenly stopped connecting to BM.  I've made the changes to the MMDVM_Bridge file as previously noted:

[General]
Callsign=N4UPC
#Id=316235620
Id=3162356
Timeout=180
Duplex=1

Still no joy.  All I get in the MMDVM_Bridge.log is:

E: 2021-03-14 23:31:05.954 DMR, Master is closing down
M: 2021-03-14 23:31:05.954 DMR, Closing DMR Network
M: 2021-03-14 23:31:05.954 DMR, Opening DMR Network
E: 2021-03-14 23:31:16.167 DMR, Master is closing down
M: 2021-03-14 23:31:16.167 DMR, Closing DMR Network
M: 2021-03-14 23:31:16.167 DMR, Opening DMR Network
E: 2021-03-14 23:31:26.373 DMR, Master is closing down
M: 2021-03-14 23:31:26.373 DMR, Closing DMR Network
M: 2021-03-14 23:31:26.373 DMR, Opening DMR Network

I also did an upgrade and rebooted the system afterward.  Stumped!

--
73
Scott,
N4UPC






Re: Connection Issue to BM

Steve N4IRS
 

On 3/14/21 7:33 PM, N4UPC - Scott via groups.io wrote:
All,

My DVSwitch system as suddenly stopped connecting to BM.  I've made the changes to the MMDVM_Bridge file as previously noted:

[General]
Callsign=N4UPC
#Id=316235620
Id=3162356
Timeout=180
Duplex=1

Still no joy.  All I get in the MMDVM_Bridge.log is:

E: 2021-03-14 23:31:05.954 DMR, Master is closing down
M: 2021-03-14 23:31:05.954 DMR, Closing DMR Network
M: 2021-03-14 23:31:05.954 DMR, Opening DMR Network
E: 2021-03-14 23:31:16.167 DMR, Master is closing down
M: 2021-03-14 23:31:16.167 DMR, Closing DMR Network
M: 2021-03-14 23:31:16.167 DMR, Opening DMR Network
E: 2021-03-14 23:31:26.373 DMR, Master is closing down
M: 2021-03-14 23:31:26.373 DMR, Closing DMR Network
M: 2021-03-14 23:31:26.373 DMR, Opening DMR Network

I also did an upgrade and rebooted the system afterward.  Stumped!

--
73
Scott,
N4UPC





Connection Issue to BM

N4UPC - Scott
 

All,

My DVSwitch system as suddenly stopped connecting to BM.  I've made the changes to the MMDVM_Bridge file as previously noted:

[General]
Callsign=N4UPC
#Id=316235620
Id=3162356
Timeout=180
Duplex=1

Still no joy.  All I get in the MMDVM_Bridge.log is:

E: 2021-03-14 23:31:05.954 DMR, Master is closing down
M: 2021-03-14 23:31:05.954 DMR, Closing DMR Network
M: 2021-03-14 23:31:05.954 DMR, Opening DMR Network
E: 2021-03-14 23:31:16.167 DMR, Master is closing down
M: 2021-03-14 23:31:16.167 DMR, Closing DMR Network
M: 2021-03-14 23:31:16.167 DMR, Opening DMR Network
E: 2021-03-14 23:31:26.373 DMR, Master is closing down
M: 2021-03-14 23:31:26.373 DMR, Closing DMR Network
M: 2021-03-14 23:31:26.373 DMR, Opening DMR Network

I also did an upgrade and rebooted the system afterward.  Stumped!

--
73
Scott,
N4UPC




Re: Registration of Dv Switch

Steve N4IRS
 

What are you connecting to? AllStar (IAX) or DVSwitch Server (USRP)

Steve N4IRS

On 3/14/21 6:01 PM, g6luu alan wrote:
Hi de G6LUU

Have installed Dv Switch on a second android device 
Which is a T320 nd I have a problem.
It says on Status 'Not registered' . I cannot work out away round this problem , Tried the "Register button with no success
Any help would be appreciated

Regards
alan G6LUU


Registration of Dv Switch

g6luu alan
 

Hi de G6LUU

Have installed Dv Switch on a second android device 
Which is a T320 nd I have a problem.
It says on Status 'Not registered' . I cannot work out away round this problem , Tried the "Register button with no success
Any help would be appreciated

Regards
alan G6LUU


Re: M17 to ASL

Steve KC1AWV
 

Ok, so the only issue I see at this point is with Analog_Bridge. It's not aware of M17 as a digital mode and does not know how to send frames to M17Gateway.

I suppose we'll have to wait until Analog_Bridge supports M17.

Steve KC1AWV


Re: Emulator timed out on encode!

G4WXN@...
 

Terrible audio apparently, so I think a reinstall.
--
Derek

G4WXN


Re: Emulator timed out on encode!

G4WXN@...
 

I've figured it out, I had to add the repository manually.

I think I may have an old version or install, I used the brute force install, it's probably nearly a year old.

Anyway it's working, not sure if it's worth a complete setup from scratch, as I have a lot of work with scripts and macros invested.


--
Derek

G4WXN


Re: Emulator timed out on encode!

Steve N4IRS
 

Show me the output of apt update


On 3/14/21 2:19 PM, G4WXN@... wrote:
Rpi 3 Raspbian buster

--
Derek

G4WXN


Re: Emulator timed out on encode!

G4WXN@...
 

Rpi 3 Raspbian buster

--
Derek

G4WXN

761 - 780 of 9595