Date   

Re: Using DVSwitch to access DMR+/Phoenix

G4WXN@...
 

That works, but when I drop the transmission, the voice announcement "Linked to 4440" repeats, cutting off the first few seconds of incoming signals.

--
Derek

G4WXN


DVSwitch Server Multi Access

IZ1XBB - Pier Paolo
 

Hi everybody!

May I have some infos and instructions to develope a multi access function on my DVSwitch Server?

Thank You for help!



Re: digital transmit overtime

Patrick Perdue
 

Hi Steve:

Thanks. Yeah, I thought it should work the same as any other channel driver, so I changed it to a ridiculously low number (10000), and transmissions over 10 seconds across the bridge still passed after rpt reload, at least from digital to analog. I didn't test in the other direction.


Re: digital transmit overtime

Steve N4IRS
 

Patrick,
AllStar should treat traffic coming from AB just like any other channel driver. I will try to test when I get a chance. I'm on the road for the next few day, so it will be the weekend before I can play.

Steve N4IRS

On 12/9/20 5:38 AM, Patrick Perdue wrote:
Hi:
I'm trying to find a way to limit transmission time from digital to analog. Lately, I've had users experimenting with Peanut and BlueDV continuously transmitting for long periods of time without realizing it. totime in rpt.conf on the node's stanza seems to have no effect, and I can't find a way to do this from DVSwitch itself. What am I missing?




digital transmit overtime

Patrick Perdue
 

Hi:
I'm trying to find a way to limit transmission time from digital to analog. Lately, I've had users experimenting with Peanut and BlueDV continuously transmitting for long periods of time without realizing it. totime in rpt.conf on the node's stanza seems to have no effect, and I can't find a way to do this from DVSwitch itself. What am I missing?


Re: DVSwitch Dashboard Web Port

IZ1XBB - Pier Paolo
 

All done! Now is all OK! Thank you for the help!!!


Re: Adding P25 to existing YSF and DMR bridge

Gary, KE8O
 

Steve,

Last night when I tested the P25Gateway was one of the services I forgot to start. In all of my previous attempts it was running. It is set to startup on 27715 my P25 reflector #. I'm using privateP25Host.txt to define my P25Reflector (attached).

Tonight I tested again with the GW started and I'm seeing activity in my terminal windows for MB, AB, and AB2. I've attached the logs from each of those terminal windows.  I also included my P25Reflector log, and my P25GW ini.

There has to be something I'm overlooking. 

Thank you !



Re: DVSwitch Dashboard Web Port

Steve N4IRS
 

What port did you move the dashboard to? RX Monitor uses port 8080.

Steve N4IRS

On 12/8/20 7:07 PM, Joe, WB3IHY wrote:
Would changing the port have any repercussions, such as causing the RX Monitor button to malfunction?

I have three DVSwitch installations running on three different Linux computers.  Two of the three have the Dashboard running on the standard lighttpd port and the RX Monitor works fine.

I had to change the port on the third to something else since I already have a webserver occupying the standard one.  The RX Monitor on that one does not work.  It goes red, green, red, blue, etc. and no audio comes through.

Everything else behaves properly.

Thoughts?


Re: DVSwitch Dashboard Web Port

Joe, WB3IHY
 

Would changing the port have any repercussions, such as causing the RX Monitor button to malfunction?

I have three DVSwitch installations running on three different Linux computers.  Two of the three have the Dashboard running on the standard lighttpd port and the RX Monitor works fine.

I had to change the port on the third to something else since I already have a webserver occupying the standard one.  The RX Monitor on that one does not work.  It goes red, green, red, blue, etc. and no audio comes through.

Everything else behaves properly.

Thoughts?


Re: DVSwitch Dashboard Web Port

Steve N4IRS
 

/etc/lighttpd/lighttpd.conf

On 12/8/20 6:37 AM, IZ1XBB - Pier Paolo wrote:

Hello Everybody!

How i can do to change the default web port (80) of my DVSwitch Server with another port? Where i can find the program file to change this port?



DVSwitch Dashboard Web Port

IZ1XBB - Pier Paolo
 

Hello Everybody!

How i can do to change the default web port (80) of my DVSwitch Server with another port? Where i can find the program file to change this port?


Re: Adding P25 to existing YSF and DMR bridge

Steve N4IRS
 

Do you have P25Gateway running? Is the startup set to connect to your p25 Reflector?

On 12/7/20 9:59 PM, Gary, KE8O wrote:
Steve, 

As suggested I stopped all services except my P25Reflector and then started MB2 (P25/DMR instance) in the foreground. I confirmed that it logged into the DMR master server (see attached). I then started the P25 AB instance in the foreground (see attached). When coming in on  P25 I showed no activity in the P25 AB or MB2 terminal windows. I know you said to stop all services but without my P25Reflector running I don't have anyway to test unless I can point to one of the DVS P25 test reflector?  If yes which one. 


While I had all of the services stopped and before I restarted all of the services. I did start up the DMR AB instances in the foreground and observer activity in the MB2, DMR AB, and P25 AB terminal windows when coming in on DMR. (see attached). So it appears my P25 side is broken. 


Re: Adding P25 to existing YSF and DMR bridge

Gary, KE8O
 

Steve, 

As suggested I stopped all services except my P25Reflector and then started MB2 (P25/DMR instance) in the foreground. I confirmed that it logged into the DMR master server (see attached). I then started the P25 AB instance in the foreground (see attached). When coming in on  P25 I showed no activity in the P25 AB or MB2 terminal windows. I know you said to stop all services but without my P25Reflector running I don't have anyway to test unless I can point to one of the DVS P25 test reflector?  If yes which one. 


While I had all of the services stopped and before I restarted all of the services. I did start up the DMR AB instances in the foreground and observer activity in the MB2, DMR AB, and P25 AB terminal windows when coming in on DMR. (see attached). So it appears my P25 side is broken. 


Re: Adding P25 to existing YSF and DMR bridge

k7wby@...
 

I think the clue here is when Steve said, "Is it logging into the master". If DMR is logging into Bradmeister as it's master then your repeater id is probably your DMR id + 01. Your P25 Gateway has no clue what to do with that. Go to RadioID.net and get yourself a second DMR Id. In the AB.ini for P25 set the DMR ID to your normal DMRid and the Gateway DMRid to your new DMRid.


Re: Using DVSwitch to access DMR+/Phoenix

Steve N4IRS
 

Append !9 to your tune string.

On 12/7/2020 10:14 AM, G4WXN@... wrote:

Is there anyone who could explain to me how to use DMR+/Phoenix?

I can link to a reflector such as 4440, which should then go out on TG 840, however when I monitor the ipsc phoenixf site I see my callsign and I see my transmission, but it doesn't go anywhere.

However if I now type 840 into the dialer string press send, then change the dialer string to 9 it transmits out on the TG.

So is there a way of putting all the above into one dvswitch tune string?

Appreciate any help.
--
Derek

G4WXN



Using DVSwitch to access DMR+/Phoenix

G4WXN@...
 

Is there anyone who could explain to me how to use DMR+/Phoenix?

I can link to a reflector such as 4440, which should then go out on TG 840, however when I monitor the ipsc phoenixf site I see my callsign and I see my transmission, but it doesn't go anywhere.

However if I now type 840 into the dialer string press send, then change the dialer string to 9 it transmits out on the TG.

So is there a way of putting all the above into one dvswitch tune string?

Appreciate any help.
--
Derek

G4WXN


Re: Unable to connect to Brandmeister using HBlink #hblink

ve6gcd@...
 

What really changed was the frequency requirement. As soon as I changed it to the repeater frequency pair in HBlink I was able to get in. Thanks guys 73.


Re: Unable to connect to Brandmeister using HBlink #hblink

ve6gcd@...
 

I already did that, changed password via Self Care and after changing the connection password I obtained the same result. Pretty sure the updated password is correct (otherwise I get an MSTNAK Received message).


Re: Adding P25 to existing YSF and DMR bridge

Steve N4IRS
 

Gary,
To get the bridge working, forget all the extra stuff to start. Tun off the reflectors, turn off the dashboards. Stop all DVswitch services starting at boot.
Start at one end of the bridge and work to the middle. If you don't see the traffic, stop and fix before moving on.

Start MB in the foreground. Is it logging into the master? Do you see traffic?
While MB is running, start the connected AB. Do you see the traffic?
Once you have this working, go from P25 in. Same thing, do you see inbound P25 traffic? Does the traffic transfer to the connected AB?
When that all works, cross connect the instances of AB.

When you post logs or config files for someone to look at, post them as separate files. That way we can open both files side by side, having to scroll up and down make it hard to troubleshoot. Same for the log files.

 Steve N4IRS

On 12/6/20 8:57 PM, Gary, KE8O wrote:
A little more background on my setup. I built this bridge using the DVSwitch-Server-RPI image as an experiment. However, I never ran the DVS script to configure for use with DVSM. I installed YSFReflector and P25Reflector on the same system. I'm using the original MB for my YSF to DMR bridge which works fine. I then added a second instance of MB for my P25 to DMR bridge. My original AB is configure for P25, and my second AB instance is configured for DMR. 

Everything is set to start at boot, and I recently added the new logs into the nightly logrotate process. I'm also planning to add the new instances to monit.

I just can't get the P25 to DMR bridge working and it is driving me crazy. I'm spending every free moment thinking about this and rechecking my settings.

Below are the log files for one transmission on the P25/DMR bridge side with my YSF/DMR bridge stopped..


MMDVM DMR / P25 Instance

M: 2020-12-07 00:31:35.940 DMR Slot 2, received network voice header from KE8O to TG 27715

M: 2020-12-07 00:31:36.456 P25, TX state = ON

I: 2020-12-07 00:31:36.456 P25, Begin TX: src=1139360 rpt=113936033 dst=9 slot=2 cc=1 metadata=KE8O

M: 2020-12-07 00:31:36.528 DMR Talker Alias (Data Format 1, Received 6/27 char): 'KE8O D'

M: 2020-12-07 00:31:37.255 DMR Talker Alias (Data Format 1, Received 13/27 char): 'KE8O Delaware'

M: 2020-12-07 00:31:37.971 DMR Talker Alias (Data Format 1, Received 20/27 char): 'KE8O Delaware, OH US'

M: 2020-12-07 00:31:38.691 DMR Talker Alias (Data Format 1, Received 27/27 char): 'KE8O Delaware, OH USA MMDVM'

M: 2020-12-07 00:31:40.341 DMR Slot 2, received network end of voice transmission, 4.8 seconds, 0% packet loss, BER: 0.0%

M: 2020-12-07 00:31:40.424 P25, TX state = OFF

 

P25Reflector log

M: 2020-12-07 00:31:36.464 Transmission started from KE8O     

M: 2020-12-07 00:31:36.500 Transmission from KE8O at KE8O       to TG 27715

M: 2020-12-07 00:31:40.430 Received end of transmission

 

AB P25 Log

I: 2020-12-07 00:31:35.941 USRP packet type: USRP_TYPE_TEXT (KE8O) -> 1139360

M: 2020-12-07 00:31:36.451 PTT on

M: 2020-12-07 00:31:40.419 PTT off (keyed for 3968 ms)

 

AB DMR Log

I: 2020-12-07 00:31:35.941 Begin TX: src=1139360 rpt=113936022 dst=27715 slot=2 cc=0 call=KE8O



Re: Adding P25 to existing YSF and DMR bridge

Gary, KE8O
 

A little more background on my setup. I built this bridge using the DVSwitch-Server-RPI image as an experiment. However, I never ran the DVS script to configure for use with DVSM. I installed YSFReflector and P25Reflector on the same system. I'm using the original MB for my YSF to DMR bridge which works fine. I then added a second instance of MB for my P25 to DMR bridge. My original AB is configure for P25, and my second AB instance is configured for DMR. 

Everything is set to start at boot, and I recently added the new logs into the nightly logrotate process. I'm also planning to add the new instances to monit.

I just can't get the P25 to DMR bridge working and it is driving me crazy. I'm spending every free moment thinking about this and rechecking my settings.

Below are the log files for one transmission on the P25/DMR bridge side with my YSF/DMR bridge stopped..


MMDVM DMR / P25 Instance

M: 2020-12-07 00:31:35.940 DMR Slot 2, received network voice header from KE8O to TG 27715

M: 2020-12-07 00:31:36.456 P25, TX state = ON

I: 2020-12-07 00:31:36.456 P25, Begin TX: src=1139360 rpt=113936033 dst=9 slot=2 cc=1 metadata=KE8O

M: 2020-12-07 00:31:36.528 DMR Talker Alias (Data Format 1, Received 6/27 char): 'KE8O D'

M: 2020-12-07 00:31:37.255 DMR Talker Alias (Data Format 1, Received 13/27 char): 'KE8O Delaware'

M: 2020-12-07 00:31:37.971 DMR Talker Alias (Data Format 1, Received 20/27 char): 'KE8O Delaware, OH US'

M: 2020-12-07 00:31:38.691 DMR Talker Alias (Data Format 1, Received 27/27 char): 'KE8O Delaware, OH USA MMDVM'

M: 2020-12-07 00:31:40.341 DMR Slot 2, received network end of voice transmission, 4.8 seconds, 0% packet loss, BER: 0.0%

M: 2020-12-07 00:31:40.424 P25, TX state = OFF

 

P25Reflector log

M: 2020-12-07 00:31:36.464 Transmission started from KE8O     

M: 2020-12-07 00:31:36.500 Transmission from KE8O at KE8O       to TG 27715

M: 2020-12-07 00:31:40.430 Received end of transmission

 

AB P25 Log

I: 2020-12-07 00:31:35.941 USRP packet type: USRP_TYPE_TEXT (KE8O) -> 1139360

M: 2020-12-07 00:31:36.451 PTT on

M: 2020-12-07 00:31:40.419 PTT off (keyed for 3968 ms)

 

AB DMR Log

I: 2020-12-07 00:31:35.941 Begin TX: src=1139360 rpt=113936022 dst=27715 slot=2 cc=0 call=KE8O

1921 - 1940 of 9589